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When you have achieved a reasonable
working knowledge in drawing electro-
technical diagrams - as described in
“The 10 basic rules for drawing Wiring
and Power control circuit diagrams on
PC” - there are some extra facilities
which might come in handy when docu-
menting PLCs.
This will enable you to handle larger
numbers of PLC data in the documenta-
tion, and will give you a fast and effi-
cient exchange of data with the PLC pro-
gram you use.
To phrase it in a popular way, you can
say that there are 5 things you need to
know, in order to achieve a fast and effi-
cient workflow when documenting PLCs
in an electro-technical documentation
program as PCschematic ELautomation.

1. Get familiar with the options
for applying PLC symbols
When documenting PLCs, you need to
know, that it is optional whether you
apply large symbols for representing
entire PLC modules, or a number of small
I/O symbols for representing the indi-
vidual inputs and outputs on the PLC.
If you select the PLC from a database,
you can get a symbol pickmenu, from
which you can select whether to use
the one type of symbols or the other.
For those of the PLCs, where this makes
sense, they can already be addressed
from the database. This can be done
directly in the component vendor data-
bases, or you can type in these data in
your database once and for all.

2. Importing/Exporting PLC I/O
data
You can also save time by becoming
familiar with how you can easily load
PLC I/O files from different PLC pro-
grams. When you do so, the program

will guide you through which conse-
quences this will have. If you answer
“Yes” to the import, the changes are
transferred to all relevant places in the
documentation.
Correspondingly, you can export PLC
I/O data from PCschematic to the nec-
essary PLC programs.

3. Reference symbols for PLCs
Especially when working with larger
PLCs, there can be a considerable
amount of data attached to each indi-
vidual PLC. Therefore you should know,
that when placing PLCs, a so-called PLC
reference symbol is filled out, contain-
ing all data for this PLC. When changes
are made on the individual I/O symbols
for the inputs and outputs on the PLC,
these changes are also displayed in the
PLC reference symbol.
When you make changes in the data

via the PLC reference symbol, these
changes are also automatically trans-
ferred to the implied  I/O symbols in the
documentation.
When the address of an I/O symbol is
changed, the other texts for this con-
nection point is changed according to
the information for this address in the
PLC reference symbol.
When a PLC I/O list is loaded, the sur-
vey symbols for the implied PLC sym-
bols are updated.

4. Changing data for PLCs
Beyond how you apply PLC reference
symbols and import PLC I/O data, it is
good to have a survey of the other op-
tions for changing PLC data in the pro-
gram. This includes the so-called Ob-
ject Lister, from which you can edit data
for any type of objects in the documen-
tation, including PLC I/O data.

The 5 basic rules for working with PLCs
in electro-technical documentation

projects
This article describes the 5 things you need to know in order to work with PLCs

 quickly and effectively - in an advanced electro-technical CAD-program as
PCschematic ELautomation

You can save a lot of time by becoming familiar with the basic rules for work-
ing with PLCs in PCschematic ELautomation



You can also use the import/export func-
tions in the program for editing PLC I/O
data via Microsoft Excel. Or you can
save time by becoming familiar with the
functions for automatic counting on
project texts, e.g. connection names and
addresses on PLCs.

5. Text links and Text wrap
A final thing which makes importing PLC
I/O data considerably easier, is getting
familiar with how to insert the so-called
text links. When you during import
change a PLC information, which also
occurs elsewhere in the project than
next to the PLC symbol, it is important
that these texts are also updated
throughout the project.
You can make sure that this happens by
linking these texts with text links. When

one of these texts are changed, the other
linked texts are changed accordingly.
Furthermore, it is practical to know how
to specify that a text shall continue on a
new line, when a specified text length is
exceeded. When importing PLC I/O data
this can be important for the appearance
of the documentation, because too long
text lines will result in that you will have
to clear up the mess in the documenta-
tion.

It is learned quickly
Learning these options does not nec-
essarily require much of an effort on
your part.
A fast short-cut for also mastering this
aspect of electro-technical documenta-
tion, could for instance be attending a
course in the program, where you will

also learn a lot of other program func-
tions. The time spent in these courses,
will pay back quickly in your daily work
with the program.

Further information
You may read more in the following arti-
cles:
• The 10 basic rules for drawing Wiring

and Power control circuit diagrams on
PC

• The 5 basic rules for working with elec-
tro-technical documentation projects

• The 5 basic rules for working with Da-
tabase and Lists in electro-technical
documentation
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SURVEY OF PLC FUNCTIONS

When working with PLCs in PCschematic ELautomation you have the following 
options:

1) Working with PLC’s: See “Working with PLC’s” on page 446.

2) Exporting/Importing PLC I/O data: See “PLC I/O addressing via Excel” 
on page 463.

3) Controlling PLC related texts for other symbols: See “Text links” on 
page 153, especially “Text links and importing PLC I/O lists” on page 157.

4) Editing PLC I/O data via the Object Lister: See “Typing in PLC I/O data 
via the Object Lister” on page 454 and “Editing PLC I/O data via the Object 
Lister” on page 321.

5) PLC I/O addressing via Excel: “PLC I/O addressing via Excel” on 
page 463.

6) Addressing PLC symbols via the database: See “Addressing PLC symbols 
via the database” on page 584.

7) Applying alternative PLC symbols: See “Alternative symbols for PLC´s” 
on page 578.

8) Connection symbol for signal buses: See “Connection symbol for signal 
buses” on page 465.

THIS CHAPTER DESCRIBES

THIS CHAPTER GIVES A SURVEY OF WHICH OPTIONS YOU HAVE WHEN WORKING WITH PLCS 
IN PCschematic ELautomation.

http://www.dps.dk/english/Video/Product_videos.htm
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— Please also refer to “PLC I/O addressing via Excel” on page 463, in particular 
“Export of PLC I/O data to Excel” on page 463.

ON PLC REFERENCE SYMBOLS

When working with PLC’s in PCschematic ELautoma-
tion, you should — as your first action — place a PLC 
reference symbol, which carries the data for the PLC, 
and functions as a kind of control center for the PLC.

When you have placed the PLC reference symbol, you 
will then typically load the I/O list for the PLC, or type 
in I/O data manually in the program. Not until then will 
you start placing the PLC I/O symbols in PCschematic 
ELautomation.

— Read more about the workflow in “Workflow for 
PLC’s from the database” on page 449.

THIS CHAPTER DESCRIBES

— ON PLC REFERENCE SYMBOLS...........................................................................(P. 446)

— MORE THAN ONE PLC REFERENCE SYMBOL FOR THE SAME PLC COMPONENT.(P. 447)

— ASSIGNING ADDRESSES TO PLC’S VIA THE DATABASE...................................... (P. 448)

— WORKFLOW IN PCSCHEMATIC FOR PLC’S VIA THE DATABASE .........................(P. 449)

— RE-ADDRESSING PLC’S ......................................................................................(P. 451)

— PLC DATA ON THE CONNECTION POINTS OF THE I/O SYMBOLS.........................(P. 453)

— TYPING IN PLC I/O DATA VIA THE OBJECT LISTER ........................................... (P. 454)

— JUMPING BETWEEN PLC REFERENCE SYMBOLS AND PLC I/O SYMBOLS...........(P. 455)

— WORKFLOW FOR PLC’S NOT IN THE DATABASE................................................. (P. 456)

— SYNCHRINIZING PLC DATA WHEN COPYING BETWEEN PROJECTS ..................... (P. 458)

— UPDATING PLC PROJECTS FROM PREVIOUS VERSIONS.......................................(P. 458)

PLC reference symbol

http://www.dps.dk/english/Video/Product_videos.htm
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Each line in the PLC reference symbol represents a node
In each individual line in the PLC reference symbol, you can see information about 
one individual node (input/output) on the PLC:

Each of these nodes on the PLC can be represented as individual PLC I/O symbols 
in the project drawings. You can also apply PLC symbols representing e.g. eight 
nodes.

All re-addressing is performed via the PLC reference symbol
All general re-addressing of PLC’s / PLC modules, takes place via the PLC refer-
ence symbols, as described in “Re-addressing PLC’s” on page 451.

Creating PLC reference symbols
See how to create PLC reference symbols in “Creating Symbols” on page 670, in 
particular “Creating PLC reference symbols” on page 700.

MORE PLC REFERENCE SYMBOLS FOR THE SAME PLC COMPONENT

You can also control PLC I/O data for a PLC component by using more than one 
PLC reference symbol for the component.

— Please also refer to “Re-addressing when more PLC ref. symbols for a compo-
nent” on page 451.

I/O address
for the node

Connection name on
the PLC (connect-
point on the PLC)

Another connection
name (Here for the
supply)

Reference to the I/O symbol in the project
(Double-click to jump to the I/O symbol)
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ASSIGNING PLC ADDRESSES DIRECTLY FROM THE DATABASE

All PLC components can be assigned addresses 
directly from the database. This saves time, and 
reduces the risk for errors when typing in data.

Read more about this in “Creating components in 
the database” on page 572, especially “Address-
ing PLC symbols via the database” on page 584.

As an example on this, you can refer to the PLC 
with EAN number 4536854815720 in the 
Eldemo database.

Base addressing of PLC’s recommended
It is recommended that all PLC’s in the database 
has a base addressing, so that they are assigned 
the addresses they would have, if they were 
placed in position 0 (lowest address).

This also applies for PLC’s — e.g. PLC modules — which does not have fixed 
addresses.

This is because the base addressing tells the program which addressing principle 
should be applied for this particular PLC during subsequent re-addressing in 
PCschematic ELautomation.

Examples on PLC’s in the Eldemo database
In the Eldemo database, you can find the PLC’s in the folder Electronic systems, 
where they are placed in the subfolder PLC control systems.

Example on a PLC
addressed directly
from the database



PCschematic ELautomation 10.0 PAGE 449

WORKING WITH PLC’S

WORKFLOW FOR PLC’S FROM THE DATABASE

When you are using PLC’s which have been posted in your database for PCsche-
matic ELautomation — see “Creating components in the database” on page 572 
and “Addressing PLC symbols via the database” on page 584 —, the following 
workflow is recommended:

1. Select a PLC and place the PLC reference symbol
1a) Select the PLC in the database, or choose a PLC which has been placed in 

the program pickmenu with data from the database. — Select for instance the 
PLC with EAN number 4536854716201 in the Eldemo database.
You now get a pickmenu for the component:

1b) Choose the PLC reference symbol, place it on a project page, and assign a 
name to the component in the dialog box Component data.
The reference symbol is now placed on the project page:

1c) From the PLC reference symbol, you can now control all data for the PLC in 
the project. In each individual line in the PLC reference symbol, you can see 
information about an individual node in the PLC, represented by I/O symbols 
for the PLC in the project — see “Each line in the PLC reference symbol rep-
resents a node” on page 447.

2. Loading the PLC I/O list
2a) Now add labels and descriptions to the PLC in one of the two following 

ways:
— Load an I/O list for the PLC, as described in “Reading PLC I/O lists” on 
page 460. Load e.g. the file Plc_ref.xls in the Lists folder (apply the format 

The PLC reference symbol
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file ExcelIO.plc), which matches the selected PLC with EAN number 
4536854716201 in the Eldemo database. Or:
— Type in labels and descriptions for the PLC via the Object Lister, as 
described in “Typing in PLC I/O data via the Object Lister” on page 454. 
(Please also read “Re-addressing PLC’s” on page 451).

3. Placing PLC I/O symbols in projects
3a) You can now place the I/O symbols for the PLC in the project: Right-click 

on the PLC reference symbol, choose Show available — see “The function 
Show available” on page 245 —, and the pickmenu for the PLC appears. Pick 
an I/O symbol, and place it in the project.

3b) Now place the remaining PLC I/O symbols. It can be a good idea to choose 
View => Show available window, which gives you direct access to choose 
the pickmenu for the PLC — and makes it easier to keep the survey, while 
working with several PLC’s at a time.

— See “The function Show available window” on page 247.

See also:

— “More PLC reference symbols for the same PLC component” on page 447.

— “Re-addressing PLC’s” on page 451.

— “PLC data on the I/O symbol connection points” on page 453.

— “On PLC reference symbols” on page 446.

ADDRESSES ON I/O SYMBOLS ARE 
DISPLAYED IN THE PLC PICKMENU

IN THE PICKMENU FOR THE PLC, THE 
ADDRESS FOR EACH I/O SYMBOL 
APPEARS IN RED WRITING.
CONNECTION NAMES ARE DIS-
PLAYED AS FOR OTHER SYMBOLS. Address

Names on input/output

Double-click here
and the pickmenu
for the PLC is dis-
played
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RE-ADDRESSING PLC’S
All re-addressing of PLC modules in PCschematic ELautomation takes place via 
the PLC reference symbols.

To re-address, do the following:

1) Right-click on the PLC reference symbol, choose Component data, and click 
on the tab I/O address:

2) Type in a new start address for the PLC in the left-hand side, click on From 
left/high — or pick another corner to start numbering from —, choose 
Number system, and click OK. (See “Options on the tab I/O address in the 
Component data dialog box” on page 451).

Options on the tab I/O address in the Component data dialog box
On the tab I/O address in the Component data dialog box, you have the following 
options:

Specify start address
In the left-hand side you type in the start address in the field Input and/or Output.

Mode
Under Mode you can specify from which corner of the PLC reference symbol the 
numbering shall begin. Here From left/upper will be selected by default, which 
will cover most situations.

RE-ADDRESSING WHEN MORE PLC REF. SYMBOLS FOR A COMPONENT

ONLY INPUTS/OUTPUTS ATTACHED TO THE PLC REFERENCE SYMBOL IS RE-
ADDRESSED. WHEN FOR INSTANCE TWO PLC REFERENCE SYMBOLS ARE 
ATTACHED TO A COMPONENT, ONLY THE INPUTS/OUTPUTS REPRESENTED IN 
THE SELECTED PLC REFERENCE SYMBOL ARE RE-ADDRESSED.
WHEN YOU WISH TO RE-ADDRESS INPUTS/OUTPUTS FOR MORE PLC REFER-
ENCE SYMBOLS FOR THE COMPONENT, CHOOSE ALL RELEVANT PLC REFER-
ENCE SYMBOLS BEFORE ENTERING THE COMPONENT DATA DIALOG BOX AND 
RE-ADDRESS.



PAGE 452 PCschematic ELautomation 10.0

WORKING WITH PLC’S

Choosing a numbering system
In the field Num. System you can choose whether to number according to the 
binary, the octal, the decimal or the hexadecimal numbering system.

Applying the addresses
To apply the addresses, Apply addresses must be activated. Apply addresses is 
deactivated each time you enter the dialog box. This ensures you that you do not 
activate a re-numbering by clicking OK after making changes in the upper part of 
the dialog box. When you make changes on the tab I/O address, Apply addresses is 
activated automatically.

Changing addresses on PLC I/O symbols
When you change the address on a PLC I/O symbol, this has the effect that all data 
for this address in the PLC reference symbol, is transferred to the PLC I/O symbol.

It is not recommended to change the address for a PLC I/O symbol to an address 
which does not exist in the PLC reference symbol. The only thing you should do in 
this context, is to specify that the PLC I/O symbol now represents another input/
output for the same PLC.

— Read more about this in “PLC data on the I/O symbol connection points” on 
page 453.

Exporting PLC I/O data
Read “Export of PLC I/O data to Excel” on page 463 for information about how to 
export PLC I/O data from PCschematic ELautomation.

RENUMBERING PLC ADDRESSES WITH COMPOUND NUMBERING SYSTEMS

WHEN RENUMBERING OF PLC ADDRESSES, PCschematic ELautoma-
tion ALSO HANDLES RENUMBERING FOR MIXED NUMBERING SYSTEMS 
— E.G. DECIMAL NUMBERING BEFORE THE PERIOD COMBINED WITH 
OCTAL NUMBERING AFTER. FOR INSTANCE CAN I17.0-I17.7 BE RENUM-
BERED TO I18.0-18.7.
IN THE FIELD NUM. SYSTEM YOU MUST SPECIFY THE NUMBERING SYS-
TEM APPLIED AFTER THE PERIOD.
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PLC DATA ON THE I/O SYMBOL CONNECTION POINTS

When working with PLC I/O symbols, data for the PLC inputs/outputs are attached 
to the connection points on the PLC I/O symbols. This makes it possible to either 
document PLC’s using PLC I/O symbols representing e.g. eight inputs/outputs, or 
by PLC I/O symbols representing a single input/output in each symbol.

The I/O address determines the other texts in the dialog box
It is the address of the PLC I/O symbol connection point, that determines the con-
tents in the other fields for the connection point. When you double-click on the con-
nection point and enter the dialog box Connection data, this address is specified in 
the I/O addr. field.

When you change the I/O address to another I/O address for the PLC — e.g. to the 
address 00.06 in the figure above — and click OK, Name, Label and Description 
for the node / connection point is updated with the data specified for the address 
00.06 in the reference symbol for the PLC.

Changes in Label and Description are updated in the PLC ref. symbol
When you change Label or Description in the dialog box Connection data, this 
information is updated in the reference symbol for the PLC. — Please note that you 
also can edit the Label and Description texts via the Object Lister, as described in 
“Typing in PLC I/O data via the Object Lister” on page 454.

RE-ADDRESSING PLC’S ONLY POSSIBLE FROM PLC REFERENCE SYMBOLS

ALL GENERAL RE-ADDRESSING OF PLC’S TAKES PLACE VIA THE PLC REFER-
ENCE SYMBOLS. — SEE “RE-ADDRESSING PLC’S” ON PAGE 451.

Double-click on the connection point,
and see PLC data for the node

Or: Right-click on the symbol, and
choose PLC I/O data ...

... and edit data via
the Object Lister
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When you change Label and/or Description and at the same time change the I/O 
address in the dialog box, the changes in Label/Description will be overwritten by 
the new data, which are fetched — via the address — from the PLC reference sym-
bol.

TYPING IN PLC I/O DATA VIA THE OBJECT LISTER

When you wish to type in / edit PLC I/O 
data manually in PCschematic ELauto-
mation, do the following:

1) Right-click on the reference sym-
bol for the PLC, and click on PLC 
I/O data.

2) You now enter the Object Lister, 
where PLC I/O data are displayed 
for the selected PLC reference 
symbol.
If the data for the PLC is spread over more than one PLC reference symbol, 
only I/O data for the inputs/outputs represented by the selected PLC reference 
symbol is displayed.

3) In the Object Lister: Click on the Pencil, double-click on the relevant fields 
(or click and press <F2> / <Enter>), and type in the new data.

RE-ADDRESSING PLC’S
IF YOU WISH TO RE-ADDRESS A PLC, PLEASE READ “RE-ADDRESSING PLC’S” 
ON PAGE 451.



PCschematic ELautomation 10.0 PAGE 455

WORKING WITH PLC’S

4) Click OK, and the change(s) are transferred to the PLC.

Read more about the Object Lister in “The Object Lister” on page 314. Here you 
can read about the options for applying automatic counting functions, and the pos-
sibilities for saving data in various file formats.

— Please read “Reading PLC I/O lists” on page 460 also.

JUMPING BETWEEN PLC REF. SYMBOLS AND PLC I/O SYMBOLS

When you have placed an I/O symbol, you can — in the PLC reference symbol — 
double-click on the reference to the I/O symbol, and you jump to the I/O symbol.

On the PLC I/O symbol you can double-click on the reference to the PLC reference 
symbol, and you jump to the line for the selected I/O symbol in the PLC reference 
symbol:

— Read more about references in “Automatically updated references” on page 373.

EDITS ONLY I/O DATA ATTACHED TO THE SELECTED PLC REF. SYMBOL

WHEN YOU RIGHT-CLICK AND CHOOSE PLC I/O DATA, YOU CAN ONLY EDIT 
THE I/O DATA ATTACHED TO THIS REFERENCE SYMBOL.
THIS MAKES IT EASIER TO MAINTAIN THE SURVEY WHEN WORKING WITH 
LARGE PLC’S WITH MORE THAN ONE ATTACHED PLC REFERENCE SYMBOL.

PLC reference symbol

PLC I/O symbol

http://www.dps.dk/english/Video/Product_videos.htm
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WORKFLOW FOR PLC’S NOT REPRESENTED IN THE DATABASE

When you choose to work with PLC’s, which does not exist in your database for 
PCschematic ELautomation, you should do the following:

1. Select PLC reference symbol(s) for the component
1a) Select an appropriate PLC reference symbol, and place it in the project. You 

can for instance choose one of the two PLC reference symbols placed to the 
right in the pickmenu:

— If you need another already created PLC reference symbol, these can be 
found via the Symbol menu in the folder PLC346, where the PLC reference 
symbol names starts with PLCRef.

1b) Click to place the PLC reference symbol, and name it in the dialog box 
Component data. If you need more than one PLC reference symbol for the 
same PLC component, just click to place these also, and assign the same 
name to these symbols.

1c) Then address the PLC reference symbol(s) as described in “Re-addressing 
PLC’s” on page 451, so that the addresses matches this PLC.

2. Type in data for the PLC
2a) Type in data for the PLC, as described in “Typing in PLC I/O data via the 

Object Lister” on page 454.

3. Place the PLC I/O symbols and choose PLC I/O data
3a) Place the PLC I/O symbols for the PLC by selecting them in the pickmenu at 

the upper part of the screen:

Select the symbol, and click to place it on the project page.

IT IS RECOMMENDED TO ADD THE APPLIED PLC’S TO THE DATABASE

IT IS STRONGLY RECOMMENDED TO ADD THE APPLIED PLC’S TO THE DATA-
BASE. THIS CAN SAVE YOU A LOT OF TIME IN THE FUTURE, AND REDUCE THE 
RISK FOR ERRORS. — PLEASE ALSO SEE “ASSIGNING PLC ADDRESSES 
DIRECTLY FROM THE DATABASE” ON PAGE 448.

PLC reference symbol for inputs

PLC reference symbol for outputs

PLC I/O symbol for input

PLC I/O symbol for output
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— If you need another already created PLC I/O symbol, these can be found 
via the Symbol menu in the folder PLC346.

3b) When you enter the dialog box Component data, you type in a component 
name in the Name field and click on the I/O addr button in the lower-right 
corner of the dialog box:

3c) You now enter the dialog box Inputs (or Outputs), where you click on the 
relevant input/output, and click OK.
Please note that used inputs/outputs are marked by a preceding +.

3d) When returning to the Component data dialog box, you will see that it now 
carries data for the component, and when you click OK, you will subse-
quently see that the PLC symbol now carries the selected I/O data:

CHOOSE INPUTS/OUTPUTS FOR ALL PLC’S IN THE PROJECT

IF FOR INSTANCE YOU ONLY TYPE IN -K IN THE NAME FIELD, INPUTS/
OUTPUTS FOR ALL PLC’S IN THE PROJECT WITH NAMES BEGINNING WITH 
-K ARE DISPLAYED.

Click here Choose input/output

Used are marked by a +
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3e) Continue like this, until you have placed the relevant symbols.

See also:

— “Workflow for PLC’s from the database” on page 449.

— “Re-addressing PLC’s” on page 451.

— “PLC data on the I/O symbol connection points” on page 453.

SYNCHRONIZING PLC DATA WHEN COPYING BETWEEN PROJECTS

If you merge project pages from different projects, so that the pages containing the 
PLC symbols come from one project, while the pages with the PLC reference sym-
bols come from another, no synchronization are made between the PLC symbols 
and the PLC reference symbols.

This is because the program does not know whether to transfer the values from the 
PLC reference symbols to the PLC symbols — or the reverse.
You specify this yourself, by using one of the following functions:

•Functions => Special Functions => Transfer data from PLC reference sym-
bols to PLC symbols, or

•Functions => Special Functions => Transfer data from PLC symbols to 
PLC reference symbols.

UPDATING PLC PROJECTS FROM PREVIOUS VERSIONS

When you wish to update a PLC project from an earlier version of PCschematic 
ELautomation than version 7.0, to get the full benefit of applying PLC reference 
symbols, do the following:

1) Enter the Symbol menu, click on Project symbols and update the symbol 
definition on the applied PLC I/O symbols, so that they follow the guidelines 
described in “Creating PLC I/O symbols” on page 697.

2) In the project: Replace the applied PLC I/O symbols with the new versions of 
the symbols. Even though you save the updated PLC I/O symbols under the 
same names as before, the symbols in the project must still be replaced with 
the updated versions. — See “Replacing symbols” on page 209.

3) Create PLC reference symbols for all PLC’s in the project. — See “Creating 
PLC reference symbols” on page 700.
(You might use the predefined PLC reference symbols in the PLC346 folder).

4) Update the PLC’s in the database, so that they now have PLC reference sym-
bols and connection names for the PLC reference symbols. — See “Creating 
PLC components in the database” on page 589.
Because the PLC’s most likely are already addressed in the existing project, it 
is not strictly necessary to address the PLC’s in the database, though it is rec-
ommended because of the subsequent use of the PLC’s in other projects.
— See “Assigning PLC addresses directly from the database” on page 448.
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5) Right-click on one of the PLC I/O symbols in the project, and choose Show 
available.

6) In the pickmenu for the selected PLC: Click on the PLC reference symbol, 
and place it an appropriate place in the project. Please note that the PLC refer-
ence symbol is automatically filled out with data from the placed PLC I/O 
symbols.

7) Repeat the two steps above for all PLC’s in the project.

The project is now updated.
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READING PLC I/O LISTS

In PCschematic ELautomation you can read PLC I/O lists from PLC programming 
tools, and have the changes transferred directly to your diagrams.

The reading procedure is build up step by step, so that you only make one decision 
in each dialog box. This is to avoid errors, because errors under the reading could 
be crucial.

CHOOSING FORMAT FILE

To start reading a PLC I/O list, choose List => 
Read PLC I/O List.

In the first dialog box, you choose which format file 
to use, when you read the PLC I/O list.

This format file contains 
information about how the 
contents of the PLC I/O file 
shall be interpreted.

Here you choose a format 
file from the displayed list, 
or click on Browse and 
choose another format file.

As you can see, you have 
the option of converting 
description texts on PLC 
connections to upper case 
characters during the import, by selecting Convert Description to Uppercase. You 
can also specify to keep line breaks in the imported data by selecting Keep Line 
Breaks in imported Data.

Click Next.

— For further information about format files, please refer to “The format file” on 
page 626.

THIS CHAPTER DESCRIBES

— CHOOSING THE FORMAT FILE ............................................................................. (P. 460)

— SPECIFYING THE FILE NAME ...............................................................................(P. 461)

— DISPLAYING THE CONTENTS OF THE FILE ..........................................................(P. 461)

— IF MORE THAN ONE PLC IN THE PROJECT ..........................................................(P. 462)

— DISPLAYING THE CHANGES IN THE PROJECT ......................................................(P. 462)
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SPECIFYING THE FILE NAME

You are then asked about 
the name of the PLC I/O file 
itself.

To keep the survey of the 
project file names, it is rec-
ommended to let the file 
have the same name as the 
project — but off course 
having another extension 
(such as .txt for text files, or 
.xls for Excel files).

Click on Browse if you 
need to locate another file, and then click Next.

THE CONTENTS OF THE FILE

You can then see the con-
tents of the file you are 
going to read, in order to 
make sure, that you have 
chosen the correct file.

The contents of the file will 
be displayed in columns, for 
clarity — even though it 
might actually be a comma 
separated file. If the column 
width is incorrect, this can 
also be detected here.

Apply the elevator in the right-hand side of the dialog box, to see the entire contents 
of the file.

Please notice, that it is not possible to make changes in the file here.

Click Next if no errors are found in the file.

If you find an error, click Cancel, and the file will not be read.

CONNECTION NAMES AS PART OF PLC NAMES

DURING LOAD OF PLC I/O LISTS, THE CONNECTION NAMES OF THE PLC I/O’S 
CAN BE A PART OF THE PLC NAME, SO THAT YOU DO NOT NEED A SEPARATE 
COLUMN FOR CONNECTION NAMES IN THE PLC I/O FILE. (E.G. K1:1).
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IF MORE THAN ONE PLC EXISTS IN THE PROJECT

If no name has been specified for the PLC in the file, and there are more than one 
PLC in the project, you must now select which PLC the file contents matches:

Click on the PLC, and click OK.

DISPLAYING THE CHANGES IN RELATION TO THE PROJECT

It is then displayed which 
changes the PLC program-
mer have made, compared to 
the information in the 
project.

If the sign ^ already is 
applied to signify line 
breaks, the program esti-
mates which column width 
the use of this sign corre-
sponds to. In the following, 
the program places ^ signs 
in the new texts, in order to 
make them follow a similar column width.

If you need to, click on Print to print out the changes for documentation purposes, 
or to pass it on to the PLC programmer.

If everything is in order, then click on Execute. It is not until you click here, that 
the program reads the PLC I/O list.
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PLC I/O ADDRESSING VIA EXCEL

In PCschematic ELautomation it is possible to export PLC I/O data to an Excel 
file, which can be opened in Excel automatically.

For further details about the options in the individual dialog boxes, please refer to 
“Reading PLC I/O lists” on page 460.

EXPORT OF PLC I/O DATA TO EXCEL

In a project containing PLCs — such as Plcdemo.pro —, exporting PLC I/O data 
can be done like this:

1) Choose Lists => PLC List File:

THIS CHAPTER DESCRIBES

— EXPORTING PLC I/O DATA TO EXCEL................................................................(P. 463)

— IMPORTING PLC I/O DATA FROM EXCEL ...........................................................(P. 464)

EXCEL MUST BE INSTALLED

IT IS ONLY POSSIBLE TO SAVE AND OPEN FILES IN EXCEL FORMAT IF EXCEL IS 
INSTALLED ON THE PC.
READ MORE ABOUT THIS IN “EXCEL MUST BE INSTALLED TO PERFORM EXCEL 
IMPORT/EXPORT” ON PAGE 641.
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2) Click on Open — to open a format file specifying which information to 
include in the generated file. (You can also specify this information in the dia-
log box manually).

3) In the dialog box Open: Select the format file ExcelIO.plc in the folder Pcsel-
cad — or another suitable format file for the export — and click OK.

4) The settings are now as displayed in the dialog box above. Please note that the 
file format is set to Microsoft Excel(R), and that Run Microsoft Excel(R) is 
selected.

5) Select Field Header in the dialog box, so that you get a header in the Excel 
sheet, that informs you about the contents of the columns.

6) Click OK.

7) When there is more than one PLC in the project, you must select which 
PLC(s) to export PLC I/O data for, or whether to export PLC I/O data for:

Select a PLC, or select multiple PLC’s — e.g. by pressing <Ctrl> and click-
ing on them — or select all by clicking on All.

8) Click OK.

9) Excel is now started, and the created PLC I/O file is displayed in Excel.

IMPORTING PLC I/O DATA FROM EXCEL

In PCschematic ELautomation you can update I/O addresses having a PLC name 
and connection number in the PLC I/O list file.

See how to import a PLC I/O list in Excel format in “Reading PLC I/O lists” on 
page 460.
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CONNECTION SYMBOL FOR SIGNAL BUSES

When you want to display a signal bus on the drawing, you do this by drawing a 
wide non conducting line.

— Please refer to “Creating Join symbols” on page 714 to see how to create join 
symbols.

To specify a signal bus as displayed above, do this:

1) Find a symbol for an IC or a PLC and place it on the drawing.

2) Activate the Pencil and click the Lines button, select a wide line type — for 
instance like the one above — and set the line width (A:) to an appropriate 
size. On the drawing above it is set to 2.5 mm.

3) Draw a line like the left-most line on the drawing.

4) Then draw a line like the one on the right side of the symbol. The lines must 
not be conducting (which they also can not be when you are using a wide line 
type).

5) You have now drawn the two signal buses: Deactivate the Pencil (press 
<Esc>), select a thin line type, and click on the line to the left of the circuit. 
Thus the line is selected.

6) Then choose Edit => Join signal.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO WORK WITH CONNECTION SYMBOLS FOR SIGNAL BUSES.
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7) A rubber band now emerge starting from the selected line and ending up in 
the cross hairs. Mark up a window that includes all the connection points on 
the left side of the circuit.

8) The following dialog box appears:

9) Below Signal name you either type in a name, or specify the name using the 
buttons under the Signal name field, as described in “Specify Signal name” 
on page 220.
If you click on the up- or down-arrow in the right hand side of the dialog box, 
you can choose between the signal symbols, that are defined in the system. 
The symbol itself will also be shown in the window inside the dialog box.
In the upper-left corner you state whether the number in the signal names 
shall be assigned from Top to bottom or from Bottom to top.
Click OK when you are satisfied with the settings.

10) Press <Esc>, and the line is no longer selected.

11) If you just want to connect one connection point to the signal symbol, you 
can try to click on the thick line at the right-hand side of the circuit. Thus the 
line is selected.

12) Then choose Edit => Join signal.

13) A rubber band now appears starting from the line and ending up in the cross 
hairs. Now click on the connection point on the circuit you wish to connect to 
the bus.

14) A dialog box, like the one above, now appears on the screen, and you con-
tinue as described above.

15) When you have connected the first connection point to the signal bus, you 
will see that there is still a rubber band radiating from the signal bus to the 
cross hairs. If you want to connect more legs to the bus, you can now carry on 
connecting their connection points individually.
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16) If you want to determine yourself where on the line the signal symbol shall 
be located, just select Point at position in the dialog box. When you click OK 
after doing this, the next thing to do is to click between the signal bus and the 
connection point, where you want the signal symbol to be placed.

The program keeps full control over where the signals enters and leaves the signal 
bus via the signal names. When for instance the signal name A0 is connected some-
where to the signal bus, the signal continue the next place A0 is connected to the 
signal bus.
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This section deals with the additional drawing 

functions in PCschematic ELautomation.

Following topics are elaborated:

- Layers, Elevation and Scaling .............(p. 471)

- Single Line Diagrams ..........................(p. 477)

- Inserting Images...................................(p. 479)
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LAYERS, ELEVATION AND SCALING

In PCschematic ELautomation you can work in different layers on the same 
project page. You can also apply scaling, and work in different elevations.

ABOUT LAYERS

If you on a drawing want to be able to display how for instance a switchboard 
would look with and without a switchboard front, you have the option of doing this 
by placing the switchboard, the switchboard front and the components on individ-
ual layers on the drawing. You can determine what you want displayed by turning 
the different layers on and off.

You can copy or move elements of drawings from one layer to another, and by 
working on layers, you can also determine which layers/parts of the drawing you 
want to be included when you print out the drawing.

You can also determine to place eventual corrections on independent layers on the 
drawing.

The layer you are working on will always be visible, but apart from this, you can 
determine yourself which layers you want displayed on the screen. On each page in 
the project you have the option of working on 255 different layers.

Layer information saved in the project file
Information about which layer is active, as well as which layers are visible, are 
saved in each project file individually.

THIS CHAPTER DESCRIBES

— ABOUT LAYERS...................................................................................................(P. 471)

— THE LAYER MENU...............................................................................................(P. 472)

— DRAWING HEADERS AND LAYERS.......................................................................(P. 473)

— CHANGING BETWEEN LAYERS WITH THE MOUSE ...............................................(P. 473)

— MOVING OR COPYING BETWEEN LAYERS ...........................................................(P. 473)

— SELECTING OBJECTS ON LAYERS ........................................................................(P. 474)

— PRINTING OUT A PAGE WITH LAYERS .................................................................(P. 474)

— DRAWING WITH ELEVATION...............................................................................(P. 475)

— SETTING THE SCALE OF AN ENTIRE PAGE ...........................................................(P. 476)

— SCALING AN AREA ..............................................................................................(P. 476)

LAYERS ARE ALSO APPLIED FOR CREATING SYMBOLS WITH STATES

LAYERS ARE ALSO APPLIED WHEN CREATING SYMBOLS WITH STATES, AS 
DESCRIBED IN “CREATING SYMBOLS WITH STATES” ON PAGE 686.
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THE LAYER MENU

To see or change the layer settings, you first have to enter the Layer menu, which 
is done by clicking on the Layer button on the left tool bar. Clicking on 
Layer=1:Lay 1 at the bottom of the screen will have the same effect:

The pencil displayed against 1:Lay1 states that layer 1 is the active layer. When a 
layer is active, this means you can draw and make changes on this specific layer, 
while you cannot make changes on the inactive layers on the drawing.

If you see a + in front of a layer, this means something has been placed on this 
layer.

Visible layers
The eye you see in front of all the other layers, tells you that these layers are visible. 
When you, like you do here, work on layer number one, you will see the other lay-
ers in the background drawn with the color grey on the diagrams.

If you want to work on layer three, you click on it, and then click on Active. You 
will now see that the pencil has moved to layer three.

Selecting more than one layer
If you want to make for instance layer four and six invisible, you click on layer 
four, press down [Ctrl] and click on layer six. Then you click on Invisible, and the 
eyes in front of the two names disappear.

If you then click on No visible, all the eyes disappear, and if you click on All visi-
ble, all layers have become visible again.

In order to select for instance all layers from eight to twelve, click first on layer 8, 
then keep the <Shift> key pressed down when clicking on layer 12.
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Naming layers
If you want to insert a name or a description for a layer, first click on the layer, and 
then click on Rename. A new dialog box appears, you type in the new name and 
click OK. It is a good idea to assign names to the layers, so that you always use the 
same layers to the same purpose.

Saving layer changes in the project
If you regret the changes you have made, you click Cancel, otherwise you click 
OK to save them.

Saving layer settings as Default
If you have a specific use for the various layers, then save the settings as default by 
clicking on Save as default.

DRAWING HEADERS AND LAYERS

Please note, that drawing headers are always placed on layer number zero, which is 
always displayed. If a drawing header is placed on a page, you will always see it, no 
matter which settings you choose in the layer menu.

CHANGING BETWEEN LAYERS USING THE MOUSE

If you press down <Alt> and click on an object which is located on another layer, 
you will be asked whether to change to this layer.

Answer Yes, and you will change layer.

Of course the object you click on have to be of the object type you are working with 
for the moment. If Symbols is active, you can change to symbols on other layers — 
and so on.

MOVING OR COPYING BETWEEN LAYERS

When you want to move or copy objects from one layer to another, do this:

1) Enter the Layer menu and choose the layer you want to fetch something from

2) Select what you want to move/copy, right-click and choose Move or Copy

3) Change layer
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4) Place the selected objects

SELECTING OBJECTS ON DIFFERENT LAYERS

The chapter “Selecting objects” on page 77 describes how to select objects in 
PCschematic ELautomation. Below you can see the options of selecting objects in 
different layers.

Selecting everything on a layer
You can select everything on a layer by choosing Edit => Select all => All on 
layer. If the Area button is active, all objects on the page will be selected. If Lines 
is active, all lines on the layer will be selected.

Selecting an object on a different layer
If you wish to select an object located in another layer than the active, you can press 
down the <Alt> key while clicking on the object. You will then be told on which 
layer the object is located, and will get the option to change to this layer.

Selecting an area in all layers
It is possible to select everything in all layers within an area of your drawing. Select 
for instance Area and mark up an area within the page. Then right-click anywhere 
on the page and choose Select in all layers. All objects on all layers within the area 
are now selected.

If for instance you had selected Symbols in stead of Areas, only the symbols within 
the area would have been selected.

PRINTING PAGES WITH LAYERS

When you want to print out a drawing consisting of several layers, you choose File 
=> Print => Select pages => Show layer settings. Hereby you enter a dialog box 
similar to the one you entered before, but these settings only apply to what you print 
out.

Following the same guidelines as above, you now determine which layers should 
be visible, and then click OK. In the lower part of the dialog box, you see how the 
drawing would look on print.

If you do not wish to print out the entire project, please make sure that you have 
only checked off Actual page in the lower-left part of the dialog box, and then click 
on Print in the upper-right corner.

The drawing will now be printed out on your printer. Read more about printing in 
PCschematic ELautomation in “Printing” on page 332.
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DRAWING WITH ELEVATION

The Elevation window is used when you want to place objects 
in different elevations on ground plan pages, and enables you to 
work in three dimensions.

The Elevation window is only visible when you are working on 
a Ground plan page in the project.

You either determine an elevation by pressing [F11] and then 
type in the elevation, or by clicking inside the Elevation window and then type in 
the elevation. The five latest elevations are remembered, and can be chosen by 
clicking on the down-arrow in the window.

The Elevation window can be docked as described in “Docking Windows and 
Toolbars” on page 49.

Selecting elevated objects
You can only select objects that are located in the elevation you see in the Eleva-
tion window. If you press down <Shift> while clicking on an object, you automati-
cally change to the elevation in which the selected object is placed.

Displaying the elevation of symbols as a hint
When a symbol is not placed in the elevation 0, the elevation is displayed as an 
InfoTip when the cross hairs is above the symbol.

Lines changing elevation
If you want to draw a line that changes elevation while drawing, you start by click-
ing where you want the line to start, then click in the Elevation window, type in the 
elevation for the next point of the line, and click where the line shall end.
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SETTING THE SCALE OF THE PAGE

The scaling on the page is set in Settings => Page setup. 
Here you determine the scale you want to apply on the page. 
On diagram drawings the scale will typically be 1:1, while it 
will typically be 1:50 on ground plan drawings.

There is no reason to scale on diagram pages, because you can choose to draw on a 
page with the A3 page size, and make the program scale automatically to fit the 
paper size when printing out the diagram. This kind of settings are set in the 
Printer dialog box, and you can read more about automatic scaling in “Setup” on 
page 335.

The scaling on the page has great influence on the objects you place on the page. In 
the following list, you will see some examples on what to keep in mind when you 
work on scaled pages.

SCALING AREAS

It is also possible to scale an area — both on diagrams and when editing symbols. 
Read more about this in “Scaling areas” on page 263.

EXAMPLE PLEASE NOTE

DRAWING BY MEASURES WHEN YOU CHANGE THE SCALING OF THE PAGE FROM 1:1 TO 1:50, 
ALL COORDINATES ON THE PAGE BECOMES 50 TIMES LARGER — 
EVEN THOUGH THE REPRESENTATION ON THE PAGE WILL REMAIN 
THE SAME. A PAGE OF THE A4 FORMAT OF 21.0CM X 29.7CM, WILL 
IN THIS CASE CORRESPOND TO 10.5M X 14.85M.

GRID/SNAP YOUR GRID AND SNAP WILL ALSO BECOME 50 TIMES LARGER. THIS 
MEANS THAT A GRID ON 10MM WILL NOW CORRESPOND TO 50CM, 
AND A SNAP OF 2.500MM WILL CORRESPOND TO 12.5CM.

SYMBOLS THE INFLUENCE OF THE SCALING ON A SYMBOL, DEPENDS ON 
WHETHER THE SYMBOL HAS AUTO SCALE OR NO SCALE ADJUST-
MENT. TYPICALLY, A SYMBOL WILL HAVE SCALE ADJUSTMENT, BUT 
NO AUTO SCALE. READ MORE ABOUT THIS IN “SYMBOL SETTINGS: 
ADVANCED” ON PAGE 682.

LINE DISTANCE WHEN YOU DRAW LINES HAVING A SPECIFIC LINE DISTANCE, IT IS 
IMPORTANT TO BEAR IN MIND THE SCALE OF THE PAGE. FOR 
INSTANCE, IF YOU DRAW A WALL OF 30CM ON A PAGE HAVING THE 
SCALE 1:50, YOU HAVE TO SET THE LINE DISTANCE (A) TO 30CM. 
THE PROGRAM WILL PERFORM THE SCALING BY ITSELF, SO THAT 
THE LINE IS DRAWN AS A 6MM LINE ON THE PAGE.

SCALING
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SINGLE LINE DIAGRAMS

PCschematic ELautomation supports single line diagrams — except for PLCs.

This means that you can draw lines that represents several connections. Corre-
spondingly, you can place symbols, representing several symbols of the same kind.

There are three places where you can specify that a line or a symbol represents 
more lines or components. This is in the signal names, the connection names and 
the symbol names.

Single line diagrams and lists
These lines and symbols are automatically unpacked in the lists of the project. 
When it comes to lists, it therefore makes no difference whether you have created 
single line diagrams or ordinary diagrams.

SIGNAL NAMES IN SINGLE LINE DIAGRAMS

As an example, you can draw the signals L1, 
L2 and L3 with just single line.

The only thing you need to do, is to assign 
the signal name L1,L2,L3 to the signal, as 
displayed on figure 2.

On the symbol K1, the connection name of 
the contact to the left is set to 1, which speci-
fies it is connected to L1.

The connection name of the contact in the 
middle gets the name ,3. This specifies that it 
is connected to L2, because L2 is specified 
as the second signal in the signal name.

Correspondingly, the name ,,5 tells you that 
the contact to the right is connected to the 
signal L3.

THIS CHAPTER DESCRIBES

— SIGNAL NAMES IN SINGLE LINE DIAGRAMS........................................................(P. 477)

— CONNECTION NAMES IN SINGLE LINE DIAGRAMS...............................................(P. 478)

— SYMBOL NAMES IN SINGLE LINE DIAGRAMS ......................................................(P. 478)

— ELDEMO AS SINGLE LINE DIAGRAM....................................................................(P. 478)

— SYMBOLS FOR SINGLE LINE DIAGRAMS IN PICKMENU........................................(P. 478)

— SYMBOLS WITH STATES FOR SINGLE LINE DIAGRAMS........................................(P. 478)

Figure 1

Figure 2
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CONNECTION NAMES IN SINGLE LINE DIAGRAMS

On figure 3, the symbol for K1 has 
been replaced by a symbol, which 
only displays one contact.

However, the three names in the con-
nection points of K1, specify that the 
symbol represents a component hav-
ing three contacts.

Therefore the connection names still 
specify the same connections as on 
the other figures.

SYMBOL NAMES IN SINGLE LINE DIAGRAMS

By assigning the names Q1,Q2,Q3 to a symbol, 
you can in a similar way let a symbol represent 
three — or more — symbols of the same type.

These two figures represent two different ways 
of drawing the same connection.

EXAMPLE

By using single line drawing, the power con-
trol circuit in the example eldemo, could look 
like this:

SYMBOLS FOR SINGLE LINE
DIAGRAMS IN PICKMENU

See how to place symbols for single line dia-
grams in the pickmenu for a component from 
the database in “Specifying alternative electri-
cal symbols via the database” on page 577.

SYMBOLS WITH STATES FOR
SINGLE LINE DIAGRAMS

Symbols can be created with different states, so that the symbols changes appear-
ance when their state number is changed.

Hereby the same symbol can be applied for single line diagrams, where e.g. lines 
across the symbol indicates the number of phases used.

— See how to apply symbols with states in “Symbols with states” on page 187.

— See how to create symbols with states in “Creating symbols with states” on 
page 686.

Figure 3
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If you want to insert an image on a page in your project, you choose Functions => 
Insert Picture. You can choose this function independent from which type of draw-
ing objects you are working with.

You now enter the dialog box Open, where you determine which file to insert into 
the project, and click Open. — You can read more about how to open files in 
“Opening files/projects” on page 41.

Here you can choose between inserting the image with or without a link. — Se 
more about this on the figure above.

The file types you can open from here are 
either .bmp files, .jpg files or metafiles.

If you need to insert other file types/
image formats, it is possible that you can 
insert the image as an OLE object, which 
is described in “Inserting files from other programs / OLE” on page 642.

When you have opened the image, it is placed in the cross hairs, and you click 
where you want to place it on the page.

Inserting images with link
When you insert an image with a link, please note that the image is not copied into 
the project file. The program just adds a link/reference to where the file containing 
the image is placed on your PC.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO INSERT AN IMAGE IN A PROJECT.

Click here if a copy of the image
shall be placed in the project file

Click here if a link shall be made
to the original image in stead
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When you insert a linked image on a page in a project, it is therefore required that 
you do not move the image file from its position on your PC (or on the network).

Move, delete, copy or rotate inserted image
If you want to select an image, you click the Area but-
ton, and then click on the reference point of the image 
— or, alternatively, drag a window around the refer-
ence point.

If you right-click on the selected image, this menu 
appear:

Here you determine to either move, copy, delete or 
rotate the selected image.

Images can not be rotated.

Scaling an image
When you want to change the size of an image, do 
like this:

1) Double-click on the image

2) Point on one of the corners of the image, so 
that the mouse pointer changes to a two-way 
arrow

3) Press the mouse button, drag the image to the 
desired size, and release the mouse button

4) Click somewhere outside the image, to dese-
lect the image

You can also scale an image by choosing Edit => 
Scale, as described in “Scaling areas” on page 263.

Point at the corner, and
drag until the desired
size is achieved



In this part you can see how to work with 

projects in PCschematic ELautomation.

It contains following topics:

- On projects...........................................(p. 485)

- Pages and Chapters ..............................(p. 487)

- Template and Standard projects ...........(p. 505)

- Copying full projects into projects.......(p. 507)

- Working with More than one Project...(p. 510)

- Inserting logos in projects....................(p. 518)

Please also refer to the Project Generator man-

ual to see how to merge projects via Excel.

READ THE SURVEY ARTICLE

READ THE SURVEY ARTICLE ABOUT WORKING 
WITH PROJECTS ON THE FOLLOWING PAGE.

W
orking w

ith Projects





The 5 basic rules for working with
electro-technical documentation

projects
This article describes the five things you should know to create projects effectively - in an
advanced electro-technical documentation CAD-program as PCschematic ELautomation

When having achieved reasonable skills
in drawing wiring and power control cir-
cuit diagrams, you can save a lot of time
by getting familiar with how to work with
projects.
To phrase it in a popular way, you might
say that there are 5 things you should
know, in order to work with projects ef-
fectively - in an advanced electro-tech-
nical documentation program as PC-
schematic ELautomation.

1. What does “Project oriented”
mean
To be able to work with projects, you
must first understand what it means that
PCschematic is project oriented.
The fact that PCschematic is project ori-
ented means that all parts of the elec-
tro-technical documentation is included
in the same file.  This file can therefore
contain project and chapter front pages,
project and chapter tables of contents,
wiring and power control circuit dia-
grams, PLC diagrams and other types
of diagrams, all types of lists (e.g. com-
ponents, parts, cables, terminals and
PLC lists), pages for printing labels, and
graphical cables, terminals and connec-
tions plans.
This has the consequence that you can
easily update project lists, and do not need
to spend time gathering all the files for the
project you are working on - because
there is only this single file, covering it all.

2. How to create new Projects
and new Project pages
- using templates
When you wish to create a new project,
you can really save a lot of time using
project templates.
When you start by opening a project
template, you never start from scratch.
A such template contains all the pages
you need, when creating a project of
this specific type, that you are about to
create. - E.g. front pages, tables of con-
tents, diagram pages with drawing head-

ers and list pages. You can therefore
start drawing the electrical diagrams
right away.
Opening the project templates is as easy
as in Microsoft Word. You can corre-
spondingly open template pages for all
of the different page types, that you will
need in the project.

3. How to keep the survey over
a project
As the project starts growing, it is im-
portant to know how to keep the sur-
vey over the project.
In this context, you should know how to
change project page, how to name project
pages, and how to move and copy pages.

Having a survey of your electro-technical documentation, you can be much
more precise and accurate in your daily work



It is also nice to know how easy it is to
structure the project in chapters.
Furthermore, it is practical to know how
to quickly click you way to any symbol
in the project, as well as how to search
for symbols and texts.

4. How to attach Information to
project pages, and to the full
project
You should also know how to attach
information to each individual page in
the project (e.g. page revision time), and
how to attach in information about the
full project (e.g. customer name).

5. How to Design symbols,
drawing headers and lists
In order to follow the standards, it is an
advantage to know how to design your
own symbols - in case you need other
symbols, than the more than 1000 stand-
ard symbols, which are included in the
program package.
Also, you could benefit from knowing
how to design your own drawing head-
ers and lists - or at least how to adapt
the drawing headers / lists that are in-
cluded in the program package.

Quite easy to learn
The first four issues can be learned
quite quickly. The fifth requires a little
more effort on your part. However, the
manuals for the program includes de-
scriptions, in which you can see how to
do - so this is definitely possible.
Some companies choose a person re-
sponsible for creating symbols and
drawing headers / lists.

Many other options
Beyond the points mentioned, there are
naturally many other options, worth
getting familiar with. These could for
instance be:

• How to insert sub drawings, e.g. with
attached article data, into diagram
pages

• How logos can be placed/replaced on
drawing headers / lists automatically

• How to edit all types of project texts
easily from the so-called Object Lister

• How to be supported in using refer-
ence designations automatically

• How to perform a revision control
• How to make a design check
• How to use passwords in projects

• How to merge projects
• How the program can automatically

insert sub drawings (already drawn
sub diagrams)

• How the program can generate
projects automatically

... and much more.

Further information
You can read more in the these articles:
• The 10 basic rules for drawing Wiring

and Power control circuit diagrams on
PC

• The 5 basic rules for working with
Database and Lists in electro-techni-
cal documentation

• The 5 basic rules for working with
PLCs in electro-technical documen-
tation projects
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PCschematic ELautomation is a project oriented program. This means, that all 
information you need when working on a project, is gathered in just one file.

Therefore you do not need to change program to e.g. create parts lists or unit draw-
ings, because they are located along with your diagrams inside the project file.

THE ELEMENTS OF A PROJECT

A project typically consists of a front page, a table of contents, pages with dia-
grams, and pages containing various kinds of lists. Also, pages containing mechan-
ical symbols for the applied components, can be part of the project. All these parts 
are placed on their individual page(s) inside the project. A project can contain sev-
eral thousand pages. 

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES THE PROJECT ORIENTED CONCEPT OF 
PCschematic ELautomation.

Front page

Table of Contents

Project diagrams

Parts list

Components list
Terminals list

Cables list

Mechanical symbols

Chapter dividers

PLC list

Chapter Table of Contents

http://www.dps.dk/english/Video/Product_videos.htm
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Project diagrams
The basis of your projects are the project diagrams. Here you draw your diagrams 
by placing symbols, texts and lines on one or more pages in the project. And here 
you assign the article data to the symbols, that will be transferred to the project lists 
automatically.

How to draw diagrams, are described in the two previous sections “Basic Drawing 
facilities” on page 71 and “Additional Drawing Facilities” on page 469.

This section
This section covers the topics you need to know something about when you want to 
create projects, containing different types of pages:

How to work with lists in projects is covered in the section “Lists” on page 521. In 
the Project Generator manual, you can furthermore see how to merge projects and 
control project data via Excel.

Practical examples
If you want to see practical examples on how to create projects, please refer to the 
PCschematic Tutorial.

THIS CAN ALSO BE CREATED AUTOMATICALLY

— GRAPHICAL TERMINAL PLANS

— GRAPHICAL CABLE PLANS

— GRAPHICAL CONNECTION PLANS

— SYMBOL DOCUMENTATION

THIS IS DESCRIBED IN THE PCschematic Tools MANUAL. THERE YOU CAN 
ALSO SEE HOW TO TRANSLATE PROJECT TEXTS USING THE PROGRAM PCsche-
matic Translator, AND SPECIFY PARAMETERS FOR DWG/DXF IMPORT/
EXPORT.

CHAPTER CONTENTS PAGE

"PAGES AND CHAP-
TERS"

HOW TO CREATE NEW PAGES IN A PROJECT, HOW TO FIND 
PAGES, AND WHICH TYPES OF PAGES YOU CAN CREATE.
CREATING CHAPTERS.

487

"PROJECT TEM-
PLATES AND STAND-
ARD PROJECTS"

HOW TO APPLY TEMPLATE PROJECTS, CONTAINING JUST THE 
PAGES YOU NEED EACH TIME YOU START A NEW PROJECT.

505

"COPYING FULL 
PROJECTS INTO 
OTHER PROJECTS"

HOW TO COPY FULL PROJECT INTO OTHER PROJECTS. 507

"SEVERAL PROJECTS 
SIMULTANEOUSLY"

HOW TO DRAG PAGES FROM PROJECT TO PROJECT, HOW TO 
COPY AREAS FROM PROJECT TO PROJECT, OR COPY TO OTHER 
PROGRAMS.

510

"INSERTING LOGOS 
IN PROJECTS"

HOW TO INSERT A LOGO FOR THE FULL PROJECT. 518

SUMMARY OF THE CHAPTERS IN THIS SECTION
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When you wish to add or delete pages, and specify the type and function of a page, 
you typically do this in the Page menu. You can also drag pages into the active 
project from the SubDrawings tab in the Explorer window.

From the Page menu you can also divide projects into chapters, and from here you 
can copy several pages at a time, for insertion into other projects. You can also copy 
pages or projects between the open projects, just by dragging page or chapter tabs 
from one project to another.

CHOOSING PAGES OUTSIDE THE PAGE MENU

When you are not in the Page menu, you can change back and forth 
between the project pages by clicking on the tabs on the lower part of the 
page, or by clicking the Previous/Next page button.

Or you can use the [Page Up] and the [Page Down] keys to jump back and 
forth between the project pages. Another option is clicking the Page his-
tory buttons, as described in “The Page history buttons” on page 488.

Also, you can choose View => Go to page, and type in a page number.

When you click the chapter tabs on the right-hand side of the screen, the 
first page of the chosen chapter is displayed. These chapter tabs are only 
displayed when the project is divided into chapters. — Read more about 
this in “Chapters” on page 499.

Collapsed chapter tabs
When chapter tabs appears among the page tabs at the bottom of the screen, 
you can choose between seeing:

THIS CHAPTER DESCRIBES

— CHOOSING PAGES OUTSIDE THE PAGE MENU .....................................................(P. 487)

— THE PAGE MENU.................................................................................................(P. 489)

— INSERTING A NEW PAGE......................................................................................(P. 491)

— COPYING, CUTTING AND PASTING MORE THAN ONE PAGE.................................(P. 495)

— PASTING COPIED PAGES IN OTHER PROJECTS......................................................(P. 496)

— MOVE, COPY AND DELETE PAGES AND CHAPTERS BY USING PAGE TABS ........(P. 498)

— CHAPTERS ...........................................................................................................(P. 499)

— NAMING PAGE TABS............................................................................................(P. 500)

— SPECIFYING PAGE TYPE......................................................................................(P. 502)

— SPECIFYING PAPER SIZE .....................................................................................(P. 503)

— GROUND PLAN DRAWING....................................................................................(P. 503)

— ISOMETRIC DRAWING..........................................................................................(P. 504)
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a) Both the chapter tab and page tabs 
for all pages in the chapter:

b) Only the chapter tab:

You can change back and forth between 
the two views by clicking on the chapter icon on the tabs, as illustrated in the figure 
above.

When the active page is placed in a chapter, which is collapsed, the page number is 
displayed in square brackets on the chapter tab — as you can see in the figure 
above. — See more about chapters in “Chapters” on page 499.

The Page history buttons
By clicking the Page history buttons to the left of the page tabs at the bottom of the 
screen, you can jump back and forth between the pages you have been working on 
in the project. This function can also be activated by choosing View => Page his-
tory back and View => Page history forward.

You could say that these buttons function like the Back and Forward buttons in 
Microsoft Internet Explorer, with the only difference that in PCschematic ELauto-
mation these are only active within the active project.

The Select page button
When you click the little down-arrow between these two buttons, you get a survey 
of the most recently active project pages:

When you click on one of these, you jump to this page in the project. This way you 
can jump to the 10 most recently active pages in the project.

— Please note that it can be an advantage also to have activated the function Keep 
page zoom — see “Keep page zoom” on page 65.

Default short-cut keys for the Page history functions
The default short-cut keys for the three functions are:

FUNCTIONS DEFAULT SHORT-CUT KEYS

PAGE HISTORY BACK <ALT+LEFTARROW>

PAGE HISTORY FORWARD <ALT+RIGHTARROW>

SELECT PAGE <ALT+DOWNARROW>

DEFAULT SHORT-CUT KEYS FOR PAGE HISTORY BUTTONS

Click here to change
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Using the Explorer window for Survey
Just to get a survey of the project pages — or for instance find a specific symbol in 
the project — you can also use the Explorer window, as described in “The 
Explorer window: The Projects tab” on page 309.

THE PAGE MENU

Choose the Page menu by clicking on the Page menu button, or by choosing View 
=> Select page.

You use the Page menu to insert new pages into the project, copy or delete pages, 
or to change the settings for the pages you have created. Or you can use it to choose 
which page in the project you want to work on. Besides, the Page menu is the place 
to keep the survey of a huge project, because you will find the titles of all the pages 
listed here.

From the Page menu you can also load other projects into the existing project. 
Read how to do this in “Project templates and Standard projects” on page 505.

Options in the Page menu
The Page menu for a project could for instance appear like this:

In front of each page an icon indicates whether the page ahs a horizontal or a verti-
cal page format. After this you see the page function, which is described in “Creat-
ing a new page” on page 491. Folders in front of pages marks the beginning of a 
new chapter.

Pages marked with a +, have been changed since the project was last saved.

Pages marked with a !, have been changed since the project was opened.

If there are pages marked with an R, this means that these pages have been changed 
since the start of a revision check. — See “Revision control” on page 788.
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In the Page menu you have the following options:

CHOOSE FUNCTION/USE

ADD NEW ADDS A NEW PAGE IN THE END OF THE PROJECT. — SEE “CREATING A NEW 
PAGE” ON PAGE 491.

INSERT NEW INSERTS A NEW PAGE IN FRONT OF THE SELECTED PAGE. IF THE FIRST PAGE IN 
THE PROJECT IS SELECTED, THE PAGE WILL BE INSERTED AS A NEW FIRST PAGE 
IN THE PROJECT. — SEE “CREATING A NEW PAGE” ON PAGE 491.

CUT CLICK ON THE PAGE(S) YOU WISH TO CUT, CLICK ON CUT, AND CLICK OK TO 
CUT. THE PAGE(S) CAN THEN BE INSERTED WHERE YOU WANT TO, BY USING THE 
INSERT FUNCTION. (SHORT CUT KEY: [CTRL+X]).
— SEE “COPYING, CUTTING AND PASTING MORE THAN ONE PAGE” ON 
PAGE 495.

COPY SELECT THE PAGE(S) YOU WISH TO COPY, CLICK ON COPY, CLICK WHERE YOU 
WISH TO INSERT THE COPIED PAGES, AND CLICK ON INSERT, AS DESCRIBED 
BELOW. THE COPIED PAGES ARE THEN INSERTED. (SHORT CUT KEY: [CTRL+C]).
THE COPIED PAGES CAN ALSO BE INSERTED INTO OTHER PROJECTS.
— SEE “PAGE NAMES WHEN COPYING PAGES IN THE PAGE MENU” ON PAGE 495 
AND “COPYING, CUTTING AND PASTING MORE THAN ONE PAGE” ON PAGE 495.

INSERT IS USED AFTER CUT OR COPY.
CLICK WHERE YOU WISH TO INSERT THE PAGE(S), CLICK ON INSERT, AND CLICK 
OK TO INSERT. (SHORT CUT KEY: [CTRL+I]).

DELETE CLICK ON THE PAGE YOU WISH TO DELETE, CLICK ON DELETE, AND CLICK OK.
— SEE HOW TO SELECT MORE THAN ONE PAGE IN “COPYING, CUTTING AND 
PASTING MORE THAN ONE PAGE” ON PAGE 495.

ARTICLE 
DATA

WHEN YOU CLICK HERE, YOU CAN EDIT THE ARTICLE DATA AND/OR REFERENCE 
DESIGNATIONS FOR THE PAGE.
IF YOU HAVE SELECTED MORE THAN ONE PAGE, YOU EDIT ARTICLE DATA/REF-
ERENCE DATA FOR ALL OF THE SELECTED PAGES IN ONE OPERATION. — SEE 
“EDIT REFERENCE DESIGNATIONS FOR MORE THAN ONE PAGE” ON PAGE 363.

PAGE 
NUMBER

CLICK ON THE PAGE IN THE MENU YOU WISH TO CHANGE PAGE NUMBER FOR, 
CLICK ON PAGE NUMBER, TYPE IN THE NEW PAGE NUMBER, AND CLICK OK. 
THE PAGE NUMBER IS NOW CHANGED.
WHEN YOU HAVE SELECTED MORE THAN ONE PAGE, YOU ARE ASKED TO TYPE 
IN THE NUMBER OF THE FIRST OF THE CHOSEN PAGES. THE SUBSEQUENT PAGES 
ARE INCREMENTED AUTOMATICALLY.
WHEN YOU DOUBLE-CLICK ON A PAGE TAB IN A PROJECT, YOU ARE ALSO 
ALLOWED TO CHANGE THE PAGE NUMBER.

GO TO PAGE TYPE IN A PAGE NUMBER AND PRESS <ENTER>. THIS DISPLAYS THE CHOSEN 
PAGE IN THE PAGE MENU.

PAGE SETUP.. WHEN YOU CLICK HERE, YOU ENTER SETTINGS => PAGE SETUP FOR THE 
SELECTED PAGE IN THE PAGE MENU. IN THIS MENU YOU SPECIFY THE PAGE 
TYPE, SIZE, SCALE AND SO ON.
— READ MORE ABOUT THIS IN “PAGE TYPE” ON PAGE 502, “PAGE SETUP - AND 
TRANSFERRING THIS TO OTHER PAGES” ON PAGE 501 AND “PAGE SETUP” ON 
PAGE 823.

PAGE DATA CLICKING HERE BRINGS YOU INTO THE DIALOG BOX SETTINGS => PAGE DATA 
FOR THE SELECTED PAGE IN THE PAGE MENU. HERE YOU CAN ASSIGN A TITLE 
TO THE PAGE, TYPE IN INFORMATION ATTACHED TO THIS SPECIFIC PAGE, AND 
PLACE A DRAWING HEADER ON THE PAGE. YOU CAN ALSO SET UP CURRENT 
PATH NUMBERING / A REFERENCE SYSTEM FOR THE PAGE.
— SEE “INSERT DRAWING HEADERS/FORMULAS” ON PAGE 525 AND “PAGE 
DATA” ON PAGE 813.

OPTIONS IN THE PAGE MENU
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The Page menu and current path numbers
If you name project symbols according to their location on page/current path, you 
may read more about which influence it has on these symbol names, when you 
make changes in the project like the ones mentioned above. Please refer to “Nam-
ing due to changes in the Page menu” on page 391.

CREATING A NEW PAGE

You can create new pages in the project in two different ways:

•By dragging a page into the project via the Explorer window — see “Drag a 
new page into the project - via the Explorer window” on page 491.

•Via the Page menu — see “Creating a new project page - via the Page menu” 
on page 492.

Drag a new page into the project - via the Explorer window
In order to drag a new page into the project from the Explorer window, this 
requires:

a) A page of the desired type already is created in the Explorer window on the 
SubDrawings tab (see “Sub drawings” on page 266), or

b) A template page of the desired type has been created (see “Creating Tem-
plates” on page 748).

Dragging a page into the project
To drag an existing template page into the project via 
the SubDrawings tab in the Explorer window, do 
this:

1) Select the page in the project, that you wish to 
place the new page after in the project — e.g. 
by clicking on a page tab at the bottom of the 
screen.

2) In the Explorer window, on the SubDrawings 
tab: Open the folder STANDARD/Template — 
which contains the folders with all program 
templates — and open e.g. the folder Normal, 
as displayed in the figure to the right.

3) Then click on one of the templates in the folder — e.g. A4_L1-L3.STD — and 
drag it over to the project page in the drawing area on the screen.

4) When you release the mouse button, the new page is placed after the active 
page in the project.

Correspondingly, you can drag other pages directly into the project from the Sub-
Drawings tab.
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Creating a new project page - via the Page menu
When you want to create a new page via 
the Page menu, you first enter the Page 
menu, and click on Add new or Insert 
new — as described in “The Page 
menu” on page 489.

If you are not in the Page menu, you 
can add a new page by going to the last 
page of the project, and press [Page 
Down].

You then enter the Page function dialog 
box, where you specify what you are 
going to use the page for.

Selecting a Page function

Choose one of the following options and click OK:

PAGE FUNCTION NORMAL FOR SYMBOLS WITH ARTICLE DATA

WHEN YOU WISH TO INCLUDE ARTICLE DATA FOR THE COMPONENTS/SYMBOLS 
IN FOR INSTANCE PARTS LISTS, IT IS IMPORTANT THAT DIAGRAM PAGES HAS 
THE PAGE FUNCTION NORMAL, BEFORE PLACING SYMBOLS ON THE DIAGRAM 
PAGES.

PAGE 
FUNCTION

DESCRIPTION
NAME IN

PAGE MENU

NORMAL THE PAGE IS USED FOR DIAGRAM- OR MECHANICAL/GROUND 
PLAN DRAWINGS. SYMBOLS/COMPONENTS WITH COMPONENT 
DATA FROM PAGES OF THIS TYPE, CAN BE FILLED INTO FOR 
INSTANCE PARTS LISTS.

DIA (DIA-
GRAMS), OR 
GRP 
(GROUND 
PLANS)

IGNORED THE PAGE WILL BE USED TO ENTER INFORMATION THAT SHALL 
NOT BE INCLUDED IN LISTS. COULD FOR INSTANCE BE MOUNT-
ING INSTRUCTIONS, OR A FRONT PAGE FOR THE PROJECT.

IGN

UNIT DRAW-
ING

THE PAGE IS USED FOR UNIT DRAWINGS, AND CAN FOR 
INSTANCE BE ASSIGNED ARTICLE DATA. YOU WILL BE ASKED TO 
SELECT AN EXISTING UNIT DRAWING (A .STD FILE). — READ 
MORE ABOUT THIS IN “INSERTING UNIT DRAWINGS” ON 
PAGE 555.

UNT

TABLE OF 
CONTENTS

THE PAGE IS USED AS A TABLE OF CONTENTS. ON PAGES OF THIS 
TYPE YOU CAN INSERT DATAFIELDS OF THE TYPE TABLE OF 
CONTENTS.
PAGES OF THE TYPE TABLE OF CONTENTS CAN BE PLACED 
FREELY IN THE PROJECT. WHICH PART OF THE PROJECT THIS 
PAGE IS A TABLE OF CONTENTS FOR, IS SPECIFIED IN LISTS => 
LIST SETTINGS. — READ MORE ABOUT THIS IN “LIST SETTINGS 
FOR TABLES OF CONTENTS” ON PAGE 548.
THE TABLE OF CONTENTS IS UPDATED WHEN YOU CHOOSE LISTS 
=> UPDATE TABLE OF CONTENTS.

TOC

PAGE FUNCTIONS IN PCschematic ELautomation
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OTHER PAGE FUNCTIONS

Furthermore, there are page functions for graphical terminal plans (TEP), graphical 
cable plans (CAP) and for graphical connection plans (CNP) and symbol documen-
tation (SYM). Pages of this type are created in the modules for creating graphical 
lists / symbol documentation.

— Read more about this in the PCschematic Tools manual.

You can see the page function of a page when you choose Settings => Page setup. 
— See “Page setup” on page 823.

PARTS LIST THE PAGE WILL BE USED AS A PARTS LIST PAGE. DATAFIELDS 
RELATED TO PARTS LISTS CAN BE INSERTED. 

PAR

COMPO-
NENTS LIST

THE PAGE WILL BE USED AS A COMPONENTS LIST PAGE. 
DATAFIELDS RELATED TO COMPONENTS LISTS CAN BE 
INSERTED. 

COM

TERMINALS 
LIST

THE PAGE WILL BE USED AS A TERMINALS LIST PAGE. 
DATAFIELDS RELATED TO TERMINALS LISTS CAN BE INSERTED.

TER

CABLE LIST THE PAGE WILL BE USED AS A CABLES LIST PAGE. DATAFIELDS 
RELATED TO CABLES LISTS CAN BE INSERTED.

CAB

PLC LIST THE PAGE WILL BE USED AS A PLC LIST PAGE. DATAFIELDS 
RELATED TO PLC LISTS CAN BE INSERTED. 

PLC

DIVIDER THE PAGE IS USED TO MARK THE START OF A NEW CHAPTER. 
THE TITLE OF THIS PAGE WILL BE DISPLAYED ON THE RIGHT-
HAND SIDE OF THE SCREEN WHILE WORKING IN THE PROJECT, 
ALONG WITH THE OTHER DIVIDER TABS.
A FOLDER WILL BE DISPLAYED IN FRONT OF THE PAGE TITLE IN 
THE EXPLORER WINDOW.

A FOLDER IS 
DISPLAYED

STANDARD/
PROJECT 
FILE

APPLIED WHEN YOU WANT TO LOAD ANOTHER EXISTING 
PROJECT INTO THE PROJECT. THIS CAN EITHER BE AN ORDINARY 
PROJECT, OR A SO-CALLED STANDARD PROJECT/STANDARD DRAW-
ING. — READ MORE ABOUT THIS IN “PROJECT TEMPLATES AND 
STANDARD PROJECTS” ON PAGE 505.
IS ALSO USED FOR IMPORT OF DWG AND DXF DRAWINGS — 
SEE “DWG AND DXF FILES” ON PAGE 635.

NONE

CHANGING THE PAGE FUNCTION

AS A GENERAL RULE, IT IS NOT POSSIBLE TO CHANGE THE PAGE FUNCTION FOR 
A PAGE AFTER THE PAGE HAS BEEN CREATED.
HOWEVER, IT IS POSSIBLE TO CHANGE A PAGE FUNCTION TO NORMAL, BY 
CHOOSING THE RELEVANT PAGE IN THE PROJECT, AND THEN CHOOSE FUNC-
TIONS => SPECIAL FUNCTIONS => SET PAGE FUNCTION TO NORMAL.

PAGE 
FUNCTION

DESCRIPTION
NAME IN

PAGE MENU

PAGE FUNCTIONS IN PCschematic ELautomation
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Selecting a page template
When you have selected a Page function, you enter the dialog box New, from 
which you can choose between the created page templates, that matches the Page 
function, you selected:

Click on the desired template page, and click OK.

If you select the template Blank page, you get an empty project page with the 
selected page type.

— See how to create your own templates in “Creating Templates” on page 748, 
specially “Creating Page templates — via the Template editor” on page 749.

Click OK in the Page menu
You have now inserted the desired page, and are still in the Page menu.

When you click OK to leave the Page menu, you jump to the inserted project page.

TEMPLATE PAGES FOR LISTS

WHEN YOU HAVE SELECTED A PAGE FUNCTION FOR A LIST, YOU CAN, CORRE-
SPONDINGLY, SELECT TO INSERT PAGES CONTAINING LIST DRAWING HEADERS.
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COPYING, CUTTING AND PASTING MORE THAN ONE PAGE

To copy/cut and then paste more than one page in the Page menu, do this:

1) Click on the first page you wish to cut/copy.

2) Press down <Shift> and click on the last of the pages you wish to cut/copy.

3) Deselect/select further pages by pressing the <Ctrl> key when clicking on the 
pages.

4) Click on Cut / Copy.

5) When cutting: Click OK to cut the pages.

6) Click where you wish to paste the pages, and click Paste.

7) Click OK to paste the pages.

8) In the dialog box Rename symbols: Specify whether/how to rename the sym-
bols on the pasted pages — see the options for this in “Intelligent copying of 
areas” on page 255.

The copied pages can also be pasted after the last page in the project, if you click 
below the last page in the Page menu and choose Paste.

— See also “Pasting copied pages in other projects” on page 496.

PAGE NAMES WHEN COPYING PAGES IN THE PAGE MENU

WHEN COPYING PAGES IN THE PAGE MENU, THE EXISTING PAGE NUMBERS 
ARE NOT CHANGED. THE COPIED PAGES KEEPS THEIR ORIGINAL PAGE NUM-
BERS, WITH AN ADDITIONAL COPY NUMBER INCLUDED IN BRACKETS. IF FOR 
INSTANCE PAGE 2 IS COPIED, THE COPIED PAGE IS ASSIGNED PAGE NUMBER

2 (1).

1) Click here 2) Press down <Shift>
and click here
(Choosing page I3-4)

Example on choices
in the Page menu:

4) Click on Copy
and paste
the pages

3) Press <Ctrl>
and click here
(Deselect DIV)
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PASTING COPIED PAGES IN OTHER PROJECTS

To cut/copy pages from a project, and then paste these pages in another project, do 
the following:

1) Copy the pages in the Page menu according to the common Windows guide-
lines, as described in “Copying, Cutting and Pasting more than one page” on 
page 495.

2) Open the other project.

3) Paste the pages via the Page menu, or by right-clicking on a project page, and 
then choose Paste.

4) Click OK to paste the pages:

5) Specify how to renumber symbols, terminals etc. and click OK — see “Intel-
ligent copying of areas” on page 255:
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6) The pages are now pasted into the other project, and the symbol names etc. 
have been updated for the pasted pages.

— See “Copying full Projects into other Projects” on page 507, “Drag pages 
between projects” on page 511 and “Copying an area from one project to another” 
on page 512.

COPYING CHAPTERS

YOU CAN ALSO COPY FULL CHAPTERS USING DRAG AND DROP, AS DESCRIBED 
IN “MOVE, COPY AND DELETE PAGES AND CHAPTERS VIA PAGE TABS” ON 
PAGE 498.
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MOVE, COPY AND DELETE PAGES AND CHAPTERS VIA PAGE TABS

By using the page tabs, you can also move or copy project pages and chapters.

Moving pages by using the Page tabs
To move a single page in the project by using the page tabs, do this:

1) Select the page you wish to move, so that it becomes the active page in the 
project — e.g. by clicking its page tab at the bottom of the screen.

2) Click on the page tab, keep the mouse key pressed down, and drag the page to 
the page tab for the page in the project, where you wish to place the moved 
page. Release the mouse button.

3) Click OK to move the page.

The moved page is placed before the page, whose page tab you clicked on.
The moved page can also be inserted after the last page in the project.

You can also move individual pages by right-clicking on the page tab, then choose 
Cut, and right-click on another page tab and choose Insert. You can also copy a 
single page by clicking on its page tab, and then choose Copy.

Move chapters using the page tabs
To move a chapter in the project using 
the page tabs, you just move the page 
tab for the Divider page, that indicates 
the start of the chapter.

When you answer OK to move the 
Divider page, just select Include pages 
in chapter:

Hereby all pages in the chapter are also moved.

Copy pages and chapters using the page tabs
You copy pages and chapters just like described above; the only difference is that 
you press the <Ctrl> key while doing it. When you copy pages/chapters, a small + 
is displayed in the cursor.

When you copy pages, you are asked whether/how to rename the symbols on the 
page — and change reference designations (if any) —, as described in “Intelligent 
copying of areas” on page 255.

Delete pages via the page tabs
You can delete an individual page by right-
clicking on the page tab for the page, and 
choose Delete.
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CHAPTERS

In PCschematic ELautomation you can divide projects in chapters, which 
gives a better survey. When a project is divided in chapters, the divider/chap-
ter tabs are displayed on the right-hand side of the screen. When you click on 
one of these divider tabs, the first project page in the chosen chapter is dis-
played.

For chapters, it is possible to:

1) Create separate tables of contents for each individual chapter in the 
project — se “List settings for Tables of Contents” on page 548.

2) To change reference designations on chapter level — see “Editing refer-
ence designations for chapters” on page 363.

3) To move/copy all pages in the chapter in a single operation — see 
“Move, Copy and Delete Pages and Chapters via Page tabs” on page 498.

Creating a new chapter
The only thing you have to do to create a new chapter, is to insert a divider page, 
which indicates the start of a new chapter.

The contents of the chapter is the pages between this divider tab and the next 
divider tab.

To insert a divider tab, do this:

1) Enter the Page menu, click on the page 
in the menu where you want the chapter 
to start, and click Insert.

2) In the dialog box Page function: Click 
on Divider and click OK.

3) In the dialog box New: Click on a page 
template, and click OK.

4) In the dialog box Divider: Type in the name of the divider/chapter:

5) Click OK.

You have now created a new chapter.
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Inserting chapter drawing headers
You can now insert a drawing 
header on the page, as 
described in “Insert drawing 
headers/formulas” on 
page 525.

Here you can either choose to 
use the included chapter 
divider drawing header 
Divider in the folder Misc, or 
you can design your own 
drawing header as described 
in “Creating Drawing Head-
ers” on page 715.

Datafields on chapter level
For the datafields First used page, Last used 
page and Used pages, you can select whether 
these shall cover the full project, or just the 
chapter pages.

— Read more about inserting datafields in 
“Datafields” on page 134.

NAMING PAGE TABS

You are free to name all page tabs in a project as 
you please. However, you are not allowed to 
assign the same name to two different page tabs.

When you want to edit the name of a 
page tab or a divider tab, just double-
click on the tab. You can then edit 
the name of the tab:

Type in the new name and click OK.

You can also rename one or more of the pages by selecting the page/pages in the 
Page menu and click on Page number, as described in “The Page menu” on 
page 489.

You can also rename a page by right-clicking on the page tab, and choose Page 
number.

DRAG IN A CHAPTER DIVIDER PAGE FROM THE EXPLORER WINDOW

YOU CAN ALSO DRAG A CHAPTER DIVIDER PAGE INTO THE PROJECT FROM THE 
EXPLORER WINDOW — AS DESCRIBED IN “DRAG A NEW PAGE INTO THE 
PROJECT - VIA THE EXPLORER WINDOW” ON PAGE 491.

Click here to see
the first page
in the chapter

Click here to see
the Divider tab
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PAGE SETUP - AND TRANSFERRING THIS TO OTHER PAGES

When you select Settings => 
Page setup, you enter the dia-
log box Page setup.

You can also enter this dialog 
box by right-clicking on the 
active project page, and choose 
Page setup.

In the dialog box Page setup 
you can for instance specify the 
page type and the paper size, as 
described in “Page type” on 
page 502 and in “Paper size” on 
page 503. — See more options in “Page setup” on page 823.

Transferring the Page setup to other project pages
To transfer a page setup from a project page to other project pages, you can right-
click on some of the settings in the Page setup dialog box — for instance Reading 
direction as illustrated below —, which gives you the option of transferring this 
setting to other project pages:

If you choose Select pages to transfer setting to, you enter a special version of the 
Page menu, where you select which pages to transfer the setting to:

Here the green icons indicate which pages the setting can be transferred to. If the 
icon is dimmed, the page already has this setting — or the setting is not possible for 
the page. The settings for the other pages are displayed in the Value column.

Choose the pages to transfer the setting to, and click OK.
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Page settings that can be transferred to other pages
It is possible to transfer the following Page settings to other project pages, accord-
ing to the procedure described above:

PAGE TYPE

The type of a page is determined in Settings => Page 
setup and in the lower part of the left tool bar.

— See “Direct access to menus and Tabs” on page 69.

The Page type can be changed any time.

In the list below you can see what the various page 
types are used for:

PAGE SETUP REMARKS

READING DIRECTION SEE THE DESCRIPTION ABOVE.

PAGE FUNCTION PAGES, WHICH ARE NOT OF THE TYPE NORMAL, CAN HERE BE 
ASSIGNED THE TYPE NORMAL. THE FUNCTION IS ONLY AVAILABLE VIA 
THE RIGHT-CLICK MENU, WHEN A PAGE HAVE BEEN CHANGED TO THE 
TYPE NORMAL.

LISTTYPE THIS FUNCTION IS ONLY AVAILABLE VIA A RIGHT-CLICK MENU, WHEN 
A LIST PAGE HAS BEEN CHANGED TO THE TYPE NORMAL.

CONTAINS A LIST THE SETTING, THAT A DIAGRAM PAGE ALSO CONTAINS A LIST, CAN 
ALSO BE TRANSFERRED TO OTHER DIAGRAM PAGES. — SEE “DIAGRAM 
PAGES - CONTAINING A PARTS OR COMPONENTS LIST” ON PAGE 738,

PAGE SETTINGS THAT CAN BE TRANSFERRED TO OTHER PAGES

PAGE TYPE DESCRIPTION

DIAGRAM THE PAGE IS A STANDARD DIAGRAM FOR DRAWING IN TWO DIMEN-
SIONS. USED FOR ALL TYPES OF LISTS AS WELL.

GROUND PLAN/
MECHANICAL

THE PAGE IS USED FOR GROUND PLAN- AND MECHANICAL DRAW-
INGS, WHERE WORKING IN DIFFERENT ELEVATIONS, AND THEREBY 
WORK IN THREE DIMENSIONS, IS POSSIBLE.

ISOMETRIC THE PAGE CAN BE USED FOR ISOMETRICALLY DRAWINGS, OR DIS-
PLAY IN X, Y OR Z.

SEMI ISOMETRIC THE PAGE IS A KIND OF ISOMETRIC PAGE, WITHOUT PURELY ISOMET-
RIC ANGLES.

PAGE TYPES IN PCschematic ELautomation
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PAPER SIZE

Under Settings => Page setup you can also choose the size of the page:

Basically, you can choose between User defined, where you type in the measures of 
the page, and Standard size, where you select a norm, and a paper size in this norm.

All pages can be either horizontal or vertical. To get a vertical page, you must select 
Vertical format.

On choosing norms for page formats
As it is, you can choose between the page format norms ANSI (American stand-
ard), ISO and JIS (Japanese standard). However, it is easy to add new page format 
norms to the list. Please contact DpS CAD-center, or your local hot-line, for further 
information.

Standard page sizes for List and Chapter tabs
If you are on a list page, and select Settings => Page setup, and choose Save as 
default, the size of this list page becomes the default page size for list pages.

The same is the case for chapter tabs and diagram pages.

GROUND PLAN DRAWING

— See a practical example on how to create ground plan drawings in the PCsche-
matic tutorial manual.

Select size

Select norm

Choose between
User defined
and Standard size

Click here for
Vertical format
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ISOMETRIC DRAWING

Beyond drawing on an isometric page, you can also use this page type to see 
whether a ground plan page, where three dimensions are used, seems reasonably 
drawn.

If you have drawn a three dimensional ground plan, and wish to check it isometri-
cally, you choose Settings => Page setup. Here you click on Isometric instead of 
Ground plan, and click OK.

When you choose Isometric you can also specify an ISO 
angle. Click on the up- and down arrows to change the ISO 
angle.

If you choose Semi isometric you can specify another angle 
accordingly.

Click OK.

Centre drawing
If your drawing hereby disappear completely or is halfway out of sight, you choose 
Functions => Centre drawing and get the isometric drawing placed on the middle 
of the screen. You can now check out whether it looks reasonable or not.

To carry on drawing on your ground plan, you choose Ground plan again in the 
Page settings.

If you are working on a Ground plan page and choose Functions => Generate 
isometry, an isometric drawing will be generated, and added to the end of the 
project.
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PROJECT TEMPLATES AND STANDARD PROJECTS

This chapter shows you how to start a new project using an already created standard 
project.

WHAT IS A TEMPLATE PROJECT?
To get started as quickly as possible when you create new projects, you can create a 
so-called template project, which contains all the pages you need every time you 
start up a new project.

This way you can build a library of different project templates, which can be used 
when starting different types of projects, or for instance for projects for different 
customers.

THIS CHAPTER DESCRIBES

— WHAT IS A TEMPLATE PROJECT..........................................................................(P. 505)

— USING TEMPLATE PROJECTS ...............................................................................(P. 506)

— ADDING LISTS TO A PROJECT USING TEMPLATE PROJECTS ................................(P. 506)

Front page

Table of Contents

Parts list
Components list

Terminals list

Cables list

Pages for project drawings

Template project

PLC list

Chapter Table of Contents

Chapter tab

Chapter tab
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USING PROJECT TEMPLATES

To create a new project based on a project template, do this:

1) Choose File => New.

2) In the dialog box New: Click on the tab for Projects, click on a project on the 
tab, and click OK.

3) You can now start working on the new based on the project template.

— See how to create project templates in “Creating Templates” on page 748.

ADDING LISTS TO PROJECTS USING STANDARD PROJECTS

When you know that there are a collection of pages — for instance a set of different 
types of lists — which you need to insert frequently in active projects, you can cre-
ate a project containing these pages.

Such a project is called a standard project in PCschematic ELautomation.

This standard project can be copied into the active project from the Page menu, as 
described in “Copying full Projects into other Projects” on page 507.

Click here
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COPYING FULL PROJECTS INTO OTHER PROJECTS

When you are working on a project, you can load another project into this project 
via the Page menu.

You may wish to read:

- “Project templates and Standard projects” on page 505, for information about 
Template projects and Standard projects, which can contain the pages you need 
when you start new projects.

- “Merging projects via Excel” on page 625, to see how to merge PCschematic 
ELautomation projects via Microsoft Excel.

- “Drag pages between projects” on page 511, to see how to drag pages from one 
project to another.

HOW TO COPY ONE PROJECT INTO ANOTHER

In PCschematic ELautomation you can load any project into an existing project as 
a Standard/Project file, and then adapt the loaded project pages according to your 
needs in the active project.

As an example you can open the project eldemo.pro — or any of your own projects 
— and then enter the Page menu.

THIS CHAPTER DESCRIBES

— HOW TO COPY ONE PROJECT INTO ANOTHER......................................................(P. 507)

— PROJECT DATA WHEN COPYING PROJECTS..........................................................(P. 509)
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Here you click Add new — to add a new project/page in the end of this project — 
and then click on Standard/Project file and click OK.

— Instead of Add new you could also click on for instance page four and then click 
Insert new. The project would then be inserted starting on page four.

You now enter the dialog box Open dialog box, and have to type in which project 
you wish to insert. In this case you could open the folder Project, select 
plcdemo.pro, and click OK.

Defining new datafields when inserting projects
If the new project contains datafields, which have not been defined in the active 
project, you are asked what to do about this:

Click Yes to define the datafields in the project file.
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Renaming symbol names and Page numbers when inserting projects
You will now be asked whether you wish to rename the copied symbols:

Select Rename symbols, Rename terminals, and select Keep page numbers, if you 
wish to keep the original page numbers from the inserted project. Click OK.

The project plcdemo.pro is now being inserted into the project you opened:

You have now loaded an entire project into another project.

If you now wish to rearrange the pages in the project, delete pages and so on, you 
can do this as described in “The Page menu” on page 489.

— If you have followed the example using the projects eldemo.pro and 
plcdemo.pro, you should now close the project choosing File => Close, and 
answer No to save the changes, in order not to change the project eldemo.pro.

PROJECT DATA WHEN COPYING PAGES

When you load a new project into the original project, these pages will have exactly 
the same Project data as the original project. This is because the Project data only is 
specified in one place for the entire project.

In the example above, this means that the pages which came from plcdemo.pro, 
now has the same project data as all the other pages in eldemo.pro.

Read more about Project data in “Project data” on page 811.

Click here not to change
page numbers in the
inserted project
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SEVERAL PROJECTS SIMULTANEOUSLY

In PCschematic ELautomation you have got the option of working on several 
projects at the same time. In practice you should not meet any limitations on how 
many projects you can open; even if the projects consist of several thousand pages 
each.

If you are interested in how to copy an entire project into another, please read “Cop-
ying full Projects into other Projects” on page 507.

— See “Pasting copied pages in other projects” on page 496 also.

DISPLAYING MORE THAN ONE PROJECT AT A TIME

When you wish to see more than one project on 
the screen, first choose the menu point Win-
dow.

You can then choose between:

a) Cascade,

b) Tile vertical and

c) Tile horizontal.

When you choose Window => Close All, all projects in the program are closed. If 
you have made changes, which have not been saved, you will get the option of sav-
ing these.

If you have minimized projects displayed on the screen, and choose Window => 
Arrange Icons, all minimized projects are gathered at the bottom of the screen.

THIS CHAPTER DESCRIBES

— DISPLAYING MORE THAN ONE PROJECT AT A TIME ............................................(P. 510)

— DRAGGING PAGES/CHAPTERS BETWEEN PROJECTS............................................. (P. 511)

— COPYING AN AREA FROM ONE PROJECT TO ANOTHER .......................................(P. 512)

— DRAWING HEADERS AND COPYING ....................................................................(P. 515)

— OPENING A NEW PROJECT BY CLICKING ON A SYMBOL...................................... (P. 515)

— OPENING A UNIT DRAWING................................................................................(P. 516)

— WORKING WITH THE SAME PROJECT IN TWO VERSIONS .....................................(P. 517)

— COPYING TO OTHER PROGRAMS .........................................................................(P. 517)
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DRAG PAGES BETWEEN PROJECTS

To drag a page from one project to another, you open both projects and choose 
Window => Tile, which places the projects side by side.

Then click on the page you want to copy, keep the mouse button 
pressed down, and drag the page over to the other project. You 
first release the mouse button when you are pointing on the tab, 
for the page in the project, where you want the copied page to be 
placed. (A small + is displayed in the cursor when you copy pages).

Then answer Yes to copy the page, and answer the emerging question whether — 
and how — to rename the symbols copied. The page copied is placed immediately 
before the page you clicked on in the project.

The copied pages can also be inserted after the last page in the project.

If necessary you can then rearrange the order of the pages in the Page menu. — 
See “The Page menu” on page 489.

For information on how to change back and forth between open projects, please 
refer to “Switching between windows” on page 37.

— See also “Pasting copied pages in other projects” on page 496.

COPYING FULL CHAPTERS BETWEEN PROJECTS

YOU CAN ALSO DRAG FULL CHAPTERS FROM ONE PROJECT TO ANOTHER, BY 
DRAGGING THE PAGE TAB FOR THE CHAPTER DIVIDER PAGE TO ANOTHER 
PROJECT — OR BY USING THE SAME PROCEDURE AS DESCRIBED ABOVE.
— SEE ALSO “MOVE, COPY AND DELETE PAGES AND CHAPTERS VIA PAGE 
TABS” ON PAGE 498.

Click here And release here
Drag the page
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COPYING AN AREA FROM ONE PROJECT TO ANOTHER

This chapter describes how to copy a drawing — or parts of a drawing — from one 
project to another. In this example, you copy from the project Demo5 to a new 
project. If you will rather use your own projects, please do so.

If you want to follow the example, it is a good idea to close the project you are 
working on for the moment, choosing File => Close.

Then do the following:

1) Choose File => New, click on the project template Demostart, and click OK.

2) In the dialog box Settings: Click OK.

3) Choose File => Open, open the project Demo5.pro in the Project folder, and 
click OK. You now have two projects open.

4) Select Window => Tile horizontal to see the projects side by side.

5) Now first click on one of the windows, and click on the page tab for the page 
you wish to copy from — in this case page 2 in the project Demo5.

6) Then click on the other window, and click on the page tab for the page you 
wish to copy to — here page 1 in the new project. (When there is no page to 
copy to in your project, you can insert a new page as described in “Pages and 
Chapters” on page 487).

CHANGING FROM PROJECT TO PROJECT

TO CHANGE BACK AND FORTH BETWEEN THE PROJECTS, JUST CLICK SOME-
WHERE WITHIN THE WINDOW YOU WANT TO WORK ON. THE BAR AT THE TOP 
OF THE ACTIVE WINDOW WILL THEN BECOME HIGHLIGHTED. YOU CAN ALSO 
CHANGE BACK AND FORTH BETWEEN THE WINDOWS BY PRESSING DOWN 
<CTRL> WHILE PRESSING <TAB>.
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7) Before copying the diagram in the Demo5 project, you can, if you wish to, 
Zoom in on the area you wish to copy — see “Zoom” on page 63 if neces-
sary.

8) Click on the Area button, and use the mouse pointer to select up the area you 
wish to copy — see “Selecting objects” on page 77 if necessary.
— If you zoom in on the area you wish to copy, this will not effect the size of 
the area you insert in the other project. This is because zoom only has to do 
with what is displayed on the screen in the actual project, and does not change 
the measures/scaling of the objects.

9) Click the Copy button.

10) Now click inside the other window, and click the Paste button (short-cut key 
[Ctrl+v]). You now have the selected area in the cross hairs in the project you 
wish to copy to. Click where you wish to insert the area on the page.

11) You are now asked whether you want to rename the copied symbols. Specify 
how you wish to rename the symbols — see “Intelligent copying of areas” on 
page 255 — and click OK.
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12) The selected area is now copied from the one project into the other.

13) Press <Esc> not to place the drawing once again.

14) When you return to the project you copied from, you will have the selected 
area in the cross hairs once again. Therefore, not to place the selected area in 
this project, it is a good idea to change windows by clicking on the title bar of 
the window, and then press <Esc>.

SETTINGS ARE MEMORIZED FOR THE DIFFERENT PROJECTS

PLEASE NOTE THAT THE PROGRAM REMEMBERS ALL SETTINGS CONCERNING 
THE INDIVIDUAL PROJECTS AS YOU CHANGE BACK AND FORTH BETWEEN THE 
VARIOUS PROJECTS. WHEN FOR INSTANCE YOU ARE WORKING WITH SYMBOLS 
IN ONE WINDOW, AND TEXTS IN ANOTHER, THE PROGRAM WILL REMEMBER 
THIS. THUS WHEN YOU CLICK ON THE FIRST WINDOW YOU WILL SEE THE SYM-
BOLS BUTTON ACTIVE, AND WHEN YOU CLICK ON THE OTHER YOU WILL SEE 
THE TEXTS BUTTON ACTIVE.
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DRAWING HEADERS AND COPYING AREAS

When you copy areas, you cannot copy the drawing headers on the page you copy 
from. But you can choose Settings => Page data any time, and determine which 
drawing header you want to insert on the page you copy to.

Read more about how to insert drawing headers in “Insert drawing headers/formu-
las” on page 525.

If you copy/insert an entire project into another, drawing headers will also be 
inserted/copied. Read more about this in “Copying full Projects into other Projects” 
on page 507.

OPENING NEW PROJECTS BY CLICKING ON SYMBOLS

If for instance you use a distribution panel, and already have an existing project 
where the distribution panel is documented, it is possible to open this project by 
clicking on the symbol.

To achieve this, you do the following:

Place a symbol for the distribution panel on the drawing. — If you do not have a 
suitable symbol, you can see how to create one in “Creating Symbols” on page 670.
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Right-click on the symbol, and choose Component data.

In the Article no field you type in the full path to the project in which the switch-
board is documented. If the project is documented in the folder specified for 
projects in Settings => Directories, you only have to type in the name of the 
project file itself. Therefore it only says distpan.pro in the dialog box above. Read 
more about this in “Directories” on page 819.

Click OK.

You have now established a connection between the symbol for the distribution 
panel, and the project in which it is documented.

If you then wish to open the project, in which the distribution panel is documented, 
you just have to right-click on the symbol, and then choose Open.

Survey of your projects
You can also use this function to create a project, which you only use to get a sur-
vey of your projects. Each symbol you place in this survey, then represents an indi-
vidual project.

If you attach a project to each symbol — as described above — you can then start 
the projects directly from this survey.

OPENING UNIT DRAWINGS

If you wish to open one of the unit drawings in your projects when you choose 
Open, then click on Detail in the dialog box Component data, and select the rele-
vant drawing.

Read more about this in “Attach a symbol on a diagram to the unit drawing” on 
page 555.
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WORKING WITH THE SAME PROJECT IN TWO VERSIONS

It is possible to have a project file open in several versions at the same time. If the 
project for instance is called demo.pro, the first version of the project will be 
named demo.pro:1, the second will be named demo.pro:2 and so on.

The program will give you a warning if you open the same project twice.

COPYING TO OTHER PROGRAMS

If you want to copy an area of the active project into another program, then click on 
the Area button, drag a window around the area, and choose Edit => Copy to Clip-
board.

If you want to use the area you copied in for instance Word, you just click on the 
Paste button in Word, and the copied area will be inserted as an image.

By clicking on for instance the Symbols button, you only copy the symbols in the 
area you mark up.

If you want to copy areas — or files — from other computer programs to PCsche-
matic ELautomation, please refer to “Inserting files from other programs / OLE” 
on page 642.

KEEP TRACK OF WHICH IS THE ORIGINAL PROJECT

PLEASE NOTE, THAT IT IS VERY IMPORTANT TO KEEP TRACK OF WHICH PROJECT 
IS THE ORIGINAL, IN ORDER NOT TO SAVE THE WRONG PROJECT IN STEAD OF 
THE ORIGINAL.
IF YOU CLICK ON SAVE FOR VERSION :2 (OR LATER) OF A PROJECT, YOU ENTER 
THE DIALOG BOX SAVE AS.

ELECTRICAL INFORMATION IS NOT TRANSFERRED

PLEASE NOTE, THAT ELECTRICAL INFORMATION AND ARTICLE DATA IS NOT 
TRANSFERRED THIS WAY. YOU ONLY TRANSFER THE DRAWING ITSELF.
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INSERTING LOGOS IN PROJECTS

ON PLACING LOGOS IN PROJECTS

When you wish to apply a logo in a PCschematic ELautomation project, you spec-
ify which logo you wish to apply for all of the project. This way the logo only takes 
up file space once in the project file. The logo will be saved together with the 
project file.

The logo must be a *.bmp file, a .jpg file, an *.emf file or a *.wmf file.

INSERTING A LOGO IN A PROJECT

To insert logos in projects in PCschematic ELautomation do the following:

Specifying the logo file
1) Place the logo in an appropriate folder using the Windows Explorer.

2) Click the Project data button.

3) In the dialog box Project data: Click on the 
Select logo button under Logo in the right-hand 
side of the dialog box.

4) In the dialog box Open: Find the logo, specify 
whether to insert it directly in the project 
(Insert) or whether to create a link to the logo 
(Link to file), and click OK. (When you have 
selected the logo — and before clicking OK — 
you can click on the Preview button in the 
upper right-hand corner in the Open dialog box 
to see an enlarged version of the logo).

Place the logo using a Datafield on a project page
5) Choose Functions => Insert Datafield.

6) In the dialog box Datafield: Click on Project Data, choose the datafield 
Logo, and click OK.

7) You get the logo in the cross hairs: Click where you wish to place the logo. 
Press <Esc> to remove the logo from the cross hairs.

THIS CHAPTER DESCRIBES

— ON PLACING LOGOS IN PROJECTS .......................................................................(P. 518)

— INSERTING A LOGO IN A PROJECT .......................................................................(P. 518)

Select logo Delete logo

Save logo
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Adapting the size of the logo
8) The logo can be very small, and its size must now be adapted: Select the logo 

datafield, and click on the Text properties button.

9) In the dialog box Text properties: Type in the size of 
the logo in the field Height — the width is set auto-
matically — and click OK.

10) Press <Esc> — to deselect the logo.
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In this section you can see how to use lists in 

PCschematic ELautomation.

You can read about:

- Inserting drawing headers/formulas.....(p. 525)

- Specifying list settings .........................(p. 534)

- Component Grouping ..........................(p. 549)

- Inserting unit drawings ........................(p. 555)

See also “Exporting List Files” on page 625.

READ THE SURVEY ARTICLE

READ THE SURVEY ARTICLE ON WORKING WITH 
DATABASES AND LISTS ON THE SUBSEQUENT 
PAGES.

L
ists





The 5 basic rules for working with
Database and Lists

in electro-technical documentation
This article describes the 5 things you need to know in order to work with

databases and lists quickly and effectively
- in an advanced electro-technical CAD-program as PCschematic ELautomation

When having achieved reasonable skills
in drawing PLC, wiring and power con-
trol circuit diagrams, you can save a lot
of time by getting familiar with how to
work with databases and lists.
To phrase it in a popular way, you might
say that there are 5 things you should
know, in order to work with databases
and lists effectively - in an advanced
electro-technical documentation pro-
gram as PCschematic ELautomation.

1. How to let PCschematic fill
out lists automatically
When creating electro-technical docu-
mentation projects, the applied compo-
nents are represented by one or more
electrical symbols - one symbol for each
of the functions in the component.
All of these symbols can have attached
article data - e.g. an EAN13 number or a
type description. This makes it possi-
ble for the program to fetch further data
for the symbol/component in the at-
tached database.
When the project lists are to be filled
out, the program therefore fetches in-
formation about which components that
are used, directly from the drawn circuit
diagrams. Based on this information the
program fetches further information in
the database, and the lists are filled out
automatically.

2. How to create your own
database
To make this function the best, it is an
advantage to be able to create your own
database. This could for instance be
done by just importing parts of the ex-
isting component vendor databases for
the program. Data, which you already
have electronically, can also easily be
added to the database.
Some companies choose to select a sin-
gle person as responsible for handling
the PCschemaitc database.

3. How to perform database
maintenance
When you wish to perform database
maintenance, you should also know
how to edit database information, up-
date information from the applied com-
ponent vendor databases, and how to
add new components to the database.
Here you can save time by learning how
to create new components to the data-
base graphically, as well as by learning
how to design your own symbols.

4. How to Create, Insert and
Update project Lists
If you do not use the pre-defined list
pages, which are included in the pro-
gram package, it is a good idea to get

familiar with how to create lists in PC-
schematic ELautomation. - Or at least
to learn how to easily adapt these lists
to meet your own demands.
You should then know how to easily
insert these lists in the project, as well
as how to quickly specify which com-
ponents to include when generating the
lists.
Finally, you should know which com-
mand to apply, in order to have the lists
filled out.

5. How to Export list files
All list types in the program can be cre-
ated as list files. When you e.g. wish to
export a parts list to a storage manage-
ment system, send an ordering file, a

When you click on a component from one of the component databases, you
automatically get a menu containing electrical symbols for all functions in the
component. When placing these symbols, you simultaneously transfer data to
the diagrams, which enables PCschematic to fill out ordering lists and to
generate ordering files automatically



wirenumber file, or a PLC I/O list to a
PLC program, you should know how to
create list files in few minutes.

This takes a little effort from
your side
If you wish to learn how to do this on
your own, this takes a little effort.  How-
ever, the manuals for the program in-
cludes descriptions, in which you can
see how to do - so this is definitely pos-
sible.

A short-cut to also master this side of
electro-technical documentation, is tak-
ing a course in the program. The time
spent on such a course, will be regained
quickly in your  daily work.

Further information
You may read more in the following arti-
cles:
• The 10 basic rules for drawing Wiring

and Power control circuit diagrams on
PC

• The 5 basic rules for working with elec-
tro-technical documentation projects

• The 5 basic rules for working with
PLCs in electro-technical documen-
tation projects
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INSERT DRAWING HEADERS/FORMULAS

Drawing headers are a kind of formulas consisting of text and graphics, which you 
can insert on the pages in your projects.

In the chapter “Creating Drawing Headers” on page 715 you can see how to create 
your own drawing headers.

This chapter describes how to place a drawing header on a project page.

THIS CHAPTER DESCRIBES

— WHAT A DRAWING HEADER CAN CONSIST OF.................................................... (P. 526)

— PLACING A DRAWING HEADER ON A PAGE ......................................................... (P. 526)

— ADDING A NEW PAGE CONTAINING A DRAWING HEADER .................................. (P. 529)

— REPLACING DRAWING HEADERS......................................................................... (P. 529)

— INSERTING LISTS ................................................................................................ (P. 531)

— UPDATING LISTS ................................................................................................. (P. 532)

— CONTENTS OF LISTS WHEN NO DATABASE IS ATTACHED ................................... (P. 533)

TEMPLATE CONTAINING ALREADY INSERTED DRAWING HEADERS

AS AN ALTERNATIVE TO MANUALLY INSERTING A DRAWING HEADER, YOU 
CAN ALSO OPEN A TEMPLATE PAGE, ON WHICH THERE IS ALREADY PLACED A 
DRAWING HEADER.
— READ MORE ABOUT THIS IN “PAGES AND CHAPTERS” ON PAGE 487; SPE-
CIALLY IN “CREATING A NEW PAGE” ON PAGE 491.



PAGE 526 PCschematic ELautomation 10.0

INSERT DRAWING HEADERS/FORMULAS

THE CONTENTS OF A DRAWING HEADER

A drawing header is a kind of formula containing 
text and graphics, which you can choose to insert 
on project pages.

A drawing header can for instance consist of a 
frame drawn around the entire page, with your 
company name and logo in the lower-left corner of 
the frame. Apart from this, the name and number 
of the individual pages, which customer the project 
is carried out for — and much more — can be 
stated in the drawing header.

When you have placed the drawing header on a 
page in the project, you can make the program fill 
in this information for you automatically.

You will typically apply different drawing headers 
on the pages in the project — depending on the use 
of the pages.

You can read more about what a drawing header is in “Dictionary” on page 850.

INSERTING A DRAWING HEADER ON A PAGE IN A PROJECT

To insert a drawing header on the page you are located on in the project, you first 
click on the Page data button on the program tool bar on the top of the screen. This 
makes you enter the dialog box Page data. You can also enter this dialog box by 
choosing Settings => Page data.

Click here to select
drawing header

The title of the
drawing header
is displayed here

Click to select a dra-
wing header form
the Symbol menu
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Choosing a drawing header
To specify which drawing header is to be placed on the page, click on the down-
arrow in the field below the With drawing header check box.

In the list that appears, you click on the name of the desired drawing header. As you 
scroll down the list of drawing headers, the titles of the drawing headers are dis-
played.

When you choose a drawing header the list disappears, and the name of the drawing 
header is placed in the field.

At the same time With drawing header is automatically selected.

You have now chosen a drawing header for the current project page.

Adding a drawing header to the list of drawing headers
If you want to add a drawing header to the list of drawing headers, please refer to 
“Adding drawing headers to the List Of Drawing Headers” on page 723.

Choosing a drawing header not on the list
If you want to use a drawing header that is not in the list of drawing headers in 
PCschematic ELautomation, click on the Browse button next to the drawing 
header field. You then enter the Symbol menu, where you select the desired draw-
ing header, and click OK.

Drawing headers with States
When a drawing header has different states, you can choose the drawing header 
state in the lower-right corner of the dialog box:

NOT ADDED TO THE LIST OF DRAWING HEADERS

THE CHOSEN DRAWING HEADER IS NOT ADDED TO THE LIST OF STANDARD 
DRAWING HEADERS IN PCschematic ELautomation.

HOWEVER, WHEN YOU HAVE USED A DRAWING HEADER IN A PAGE IN A 
PROJECT THIS WAY, YOU WILL SEE THE DRAWING HEADER ON THE LIST OF 
DRAWING HEADERS.
THIS IS BECAUSE THE LIST ALWAYS DISPLAYS THE LIST OF STANDARD DRAW-
ING HEADERS IN PCschematic ELautomation AND THE USED DRAWING 
HEADERS IN THE ACTIVE PROJECT. WHEN YOU START WORKING IN ANOTHER 
PROJECT, YOU WILL THEREFORE NO LONGER SEE THE DRAWING HEADER IN 
THE LIST.
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If you wish to transfer the selected state to 
the other pages in the project, you can right-
click on the State field, and specify which 
pages in the project to transfer the state to.

Page title
If you at the same time want to assign a title to the page, you click inside the field 
Page title. Here you for instance type in the text Drawing. You can also fill out the 
other fields with information about this particular page in the project.

Missing datafields
When you have chosen a 
drawing header, click OK on 
the tab Page data.

If a drawing header contains 
some datafields, which have 
not been created in the cur-
rent project, you will get a 
message about this, as you 
can see in the figure to the 
right.

Click Yes to create them in 
your project. As you will see, the drawing header has now been placed on the page.

Active links from Datafields in Drawing headers to the Settings dialog box
When you double-click on a datafield, which comes from the dialog box Settings, 
the dialog box Settings is opened on the tab, from which the datafield collects its 
value. — For instance Customer or Project title in Project data:
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ADD NEW PROJECT PAGE, AND ASSIGN A DRAWING HEADER TO IT

If you have not created the page you want to place the drawing header on, you do 
this by entering the Page menu:

1) In the Page menu: Click on Add.

2) In the dialog box Page function: Click on Normal and click OK.

3) In the dialog box New: Click on the template Blank page and click OK.

If you want to know more about the Page menu and the various types of pages you 
can apply, you may read “Pages and Chapters” on page 487.

If you want to place a drawing header on the page you have selected in the Page 
menu, click on Page data, and then continue as described in “Inserting a drawing 
header on a page in a project” on page 526.

When you have inserted the drawing header, you return to the Page menu, and here 
you click OK.

REPLACING DRAWING HEADERS

If your company for instance has changed its phone number, you can enter Design 
symbol, correct the phone number in the drawing header, and save the new drawing 
header under the same name. — See how to change drawing headers in “Placing a 
Company Logo on a drawing header” on page 725.

Checking if a drawing header has been replaced
You can see whether the definition of a drawing header has been changed by enter-
ing Page data on one of the pages where the drawing header is used in your 
project.

If for instance you have changed the drawing header A4VDPS, this drawing header 
has now changed its name to A4VDPS?1. This informs you that a new version of 
the drawing header exists under the name A4VDPS, but the project has maintained 
— and renamed — the old drawing header to A4VDPS?1.

EDITED DRAWING HEADERS ARE NOT REPLACED AUTOMATICALLY

WHEN YOU CHANGE THE DEFINITION OF A DRAWING HEADER, WHICH IS USED 
IN A PROJECT, THE DRAWING HEADER IN THE PROJECT WILL NOT BE REPLACED 
BY THE NEW VERSION OF THE DRAWING HEADER, UNTIL YOU YOURSELF STATE 
THAT IT SHALL BE REPLACED.
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To change to the new drawing header, you click on the down-arrow and choose the 
drawing header with the name A4VDPS.

If you select On this page, the new version of the drawing header will be inserted 
on this page in the project.

If you select On all pages instead, all pages in the project using the old version of 
the drawing header, will have their drawing headers replaced by the new version. If 
you choose this, A4VDPS?1 disappear from the list of drawing headers at the same 
time.

Of course you can also replace a drawing header with any other drawing header 
form the list of drawing headers.

DRAWING HEADERS AND PAGE FORMATS

DRAWING HEADERS CAN ALWAYS BE REPLACED — ALSO WHEN THEY ARE 
ORIGINALLY INSERTED VIA A TEMPLATE PAGE.
WHEN A DRAWING HEADER WITH A NEW PAGE FORMAT IS SELECTED, THE 
PAGE FORMAT IS CHANGED AUTOMATICALLY.
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INSERTING A LIST

Lists are a special type of drawing headers, 
which you can place in your projects.

There are several types of lists in PCschematic 
ELautomation. These are for instance parts 
lists, components lists, terminals lists, cables 
lists, PLC lists and tables of contents.

The parts lists collect information from the 
symbols/components which have been placed 
on the project drawings, while the table of con-
tents pages collect information about the vari-
ous project pages.

Because lists are a special kind of drawing 
headers, they have to be updated to have all 
information filled out correctly.

To tell the program which type of information 
have to be filled into a list, you have to make sure that the page, on which the list is 
placed, is set to the right page function.

If you want to insert a parts list, the page function has to be Parts list, and if you 
want to insert a table of contents, the page function must be Table of Contents — as 
opposed to above, where the page function was set to Normal.

Apart form the page function, lists are placed as described above. — Read more 
about page function in “Creating a new page” on page 491.

Diagram pages can also contain lists
Diagram pages can also contain parts or components lists. Read more about this in 
“Diagram pages - containing a Parts or Components list” on page 738.

You can also place a list as a symbol on a diagram page, without letting the list 
become part of the drawing header — see “Creating a List symbol” on page 739.

THE CORRECT PAGE FUNCTION MUST BE SELECTED FOR LISTS

IF YOU DO NOT CHOOSE THE CORRECT PAGE FUNCTION FOR A LIST, THE LIST 
WILL NOT BE FILLED OUT WHEN UPDATED.
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Active links in lists and in tables of contents
When you double-click on 
datafields in lists and in tables 
of contents, you jump to the 
place in the project, from 
where the datafield fetched its 
contents — e.g. a page, a 
symbol or a connection point. 
This is the case for quite a 
few datafields, but not for all 
types.

When the cursor is above a datafield containing an active link, the datafield is 
underlined, and the appearence of the cursor changes to a pointing hand. However, 
this is only the case if View => Show object below cursor is selected.

When you double-click on e.g. an article number, you jump to the first symbol for 
the component in the project.

Please note that this makes it possible to use the tables of contents in the project as 
a kind of page menus.

Jumping back to the list / table of contents
When for instance you have jumped from an article number in a list to a symbol on 
a project page, you can return to the list by clicking the Page history back button 
to return to the list. The button is placed to the left of the page tabs at the bottom of 
the screen. — See “Choosing pages outside the Page menu” on page 487.

UPDATING LISTS

When for instance you have inserted a parts list on a project 
page, it will not be filled out with information from the project 
drawings right away.

Choose Lists => Update Parts Lists to update the parts lists 
in the project.

The list is now updated with information from the present 
project.

Updating all lists
If you want to update all the lists in the project, choose Lists 
=> Update All Lists.

UPDATE ALL LISTS

IN PROJECTS ORIGINALLY CREATED IN PCschematic ELautomation VER-
SION 8.0 OR PREVIOUS, YOU MUST FIRST CHOOSE LISTS => UPDATE ALL 
LISTS TO ACTIVATE ALL LINKS IN LISTS AND IN TABLES OF CONTENTS IN THE 
PROJECT.
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Updating lists by right-clicking
When the active project page contains a list or a table of contents, you can also 
right-click and choose Update the List.

If a diagram page contains a components or parts list, this list can also be updated 
with this function.

CONTENTS OF LISTS WHEN NO DATABASE IS ATTACHED

Parts and Components lists pages memorize all data, which were originally fetched 
from the database. Therefore these data are not lost when the list pages are updated, 
and the applied article numbers can not be found in the database.

A list will therefore not become empty when updating lists without having a data-
base attached, or with another database attached.

If you send a project to a customer, who does not have the database attached, the 
lists will still be complete, if the costomer chooses Lists => Update all lists.
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LIST SETTINGS

In PCschematic ELautomation you can specify which types of information you 
want to include on project lists.

By adjusting the settings for a list, you can for instance make separate parts lists for 
the various component vendors, or choose to include articles from the unit draw-
ings in your component list.

In order to specify list settings, you first have to have a list in the project. Read 
“Insert drawing headers/formulas” on page 525 if you need to know more about 
how to insert lists in a project.

If you, on the other hand, want to create list files, you can read more about this in 
“Exporting List Files” on page 625.

THIS CHAPTER DESCRIBES

— CHOOSING THE LIST IN THE PROJECT..................................................................(P. 535)

— UPDATING LISTS .................................................................................................(P. 535)

— WHICH PART OF THE PROJECT TO COLLECT DATA FROM ...................................(P. 536)

— SORTING LISTS ACCORDING TO DATABASE FIELDS.............................................(P. 539)

— SPECIFY CRITERIA FOR WHICH DATA TO INCLUDE .............................................(P. 541)

— HOW TO HANDLE REPETITIONS IN THE LIST.......................................................(P. 544)

— HOW TO REPLACE MISSING INFORMATION .........................................................(P. 545)

— SPECIAL SETTINGS FOR CABLES, TERMINALS AND PLC LISTS...........................(P. 546)

— LIST SETTINGS FOR TABLES OF CONTENTS.........................................................(P. 548)

LIST SETTINGS FOR TEMPLATES

LIST SETTINGS CAN ALSO BE SPECIFIED ON PAGE TEMPLATES, SO THAT YOU 
CAN CREATE LIST TEMPLATES CONTAINING DIFFERENT LIST SETTINGS, FOR 
DIFFERENT PURPOSES.
— READ MORE ABOUT THIS IN “CREATING TEMPLATES” ON PAGE 748, SPE-
CIALLY “CREATING PAGE TEMPLATES — VIA THE TEMPLATE EDITOR” ON 
PAGE 749.
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CHOOSING THE LIST IN THE PROJECT

Enter the page you want to change the settings for, and choose Lists => List set-
tings. Here you specify how you want to fill out the list you are presently working 
on.

Depending on which type of list you are working on, you will have different 
options at hand to specify the list setup.

If the components in for instance a parts list requires more than one page, the pro-
gram will notify you about this, and — if you answer Yes — add one or more addi-
tional parts list pages immediately following the first page in the parts list.

If a list results in less pages following an update, you will also be informed about 
this.

UPDATING LISTS

When you are in the dialog box List setup, and you want to update a list, click on 
Update in the right-hand side of the dialog box. This update only applies for the list 
you are working on for the moment.

If you are contempt with the settings, but would like to wait until later before you 
update the list, you click OK. The update will be carried out next time you choose 
Lists => Update lists.

If you are not pleased with the new settings, you click on Cancel.

Please note, that information about list settings are saved in the project file itself.

Errors displayed in result window during list update
If an error occurs during a List update or during List to file operations, these errors 
will be displayed in a result window. These errors could for instance be unknown 
from/to specification in the list settings.

The window functions as for the Design check function — see “Design Check” on 
page 328.
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SPECIFYING FROM WHERE TO COLLECT COMPONENTS

If you have not already done this, choose Lists => List settings.

Working with lists you have the option to determine precisely which components 
you want on the lists, and according to which of their symbol texts you want the 
lists sorted.

Which data to include
If you select Articles from Unit Lists and Drawings, articles from unit drawings 
are included. The component name from the unit drawing is hereby specified as a 
subname for the component in the list.

DIFFERENT TABS FOR CABLES, TERMINALS AND PLC LISTS

PLEASE NOTE THAT CONTENTS OF THE GENERAL TAB IS DIFFERENT FOR 
CABLES, TERMINALS AND PLC LISTS — AS DESCRIBED IN “LIST SETUP FOR 
TERMINALS- CABLES- AND PLC LISTS” ON PAGE 546.

Only possible for
components lists

The component S2 in the unit drawing and in the list
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When you select Include Lines with article data, article data from lines will be 
included as well, and the lengths of the lines will be calculated.

If you select Include Additionals from Database, the program will examine each 
component, and see whether they need any additionals, that shall be included on the 
list.

Simple parts- and components lists
If you select Each Symbol is a Component, each symbol will be understood as an 
individual component — even though other symbols with the same name exists.

Therefore, if three symbols with the name -X1 exists, these symbols will be under-
stood as three individual components on both parts- and components lists.

This is also the case when documenting electrical house installations, where names 
are not necessarily assigned to the symbols.

See a practical example on the use of simple parts lists in "Electrical installation 
project Tutorial" in the PCschematic Tutorial manual.

Choose Pages and Layers
In Pages and layers you specify from which project pages the parts list receive 
information, and from which layers information will be collected on these pages. If 
it says 0 in the fields, this signifies that all layers/pages are included in the parts list.

When you click the Browse button next to From page or To page, you enter the 
Page menu, where you select the desired page(s), and click OK.

Pages with reference designations
When you need to discern between two pages having the same page numbers, but 
different reference designations, you do this by placing the character "/" between 
the page name and the reference designation for the page.

If page 17 has the reference designation =G1+A1, you therefore write 17/=G1+A1.

When the page number is selected using the Browse button, the reference designa-
tion is inserted automatically.

Layers
When you click the Browse button next to the Layer field, you enter the Layer 
menu, where you select the desired layer, and click OK.

Sorting the list
Using the fields Primary and Secondary on the tab General, you determine which 
symbol texts the list is to be sorted according to.

Only for Components lists: Labels for component marking
When you under Lists => List settings for Components lists on the tab General 
select List only one of each name, each name is only printed once. Hereby you can 
for instance print labels for component marking.
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For Components lists only: Labels for component marking
If you under Lists => List settings for a Components list on the General tab 
choose List only one of each name, each name is only included once. Hereby you 
can for instance create labels for component marking.

Include all pages in Table of Contents
If you select Include all pages in Table of Contents, each page in the list is 
included in the Table of Contents. If not, only the first page is mentioned.

Display first and last object in the Page title for lists
When you choose Insert name in page title, the name of the first and the last object 
on the list page is displayed after the page title in each list page.

Lists in Columns
In PCschematic ELautomation you can create lists in columns. This setting is 
specified on the tab General in the dialog box List settings.

Updated from external list file
If you select Updated from external list file, the list will be updated / filled out via 
data from an external Excel or .csv file. When you click the Update button, you 
will then be asked to point out the external file, which is then loaded on the list 
page.

The checkbox can also be applied for excluding a list file from being updated.

THIS FUNCTION IS NOT FOR CORRECTING PARTS LISTS

THIS FUNCTION CAN FOR INSTANCE BE APPLIED WHEN YOU HAVE A CABLING 
LIST BETWEEN PANELBOARDS, AND DO NOT WISH TO DRAW THE CABLING.
— OR IF YOU GENERALLY DO NOT WISH TO INCLUDE LISTS IN THE PROJECT, 
WHICH YOU CAN NOT FILL OUT VIA THE DRAWINGS.
THE FUNCTION IS NOT DESIGNED FOR CORRECTING EXISTING PARTS LISTS!
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SORTING LISTS ACCORDING TO DATABASE FIELDS

This tab only exists for parts and components lists.

On the Sort by tab you can specify that the list must be sorted based on a field in 
the database. This can for instance be applied for sorting the list by source or by 
manufacturer. Which datafield to sort according to, is specified in the Major sort 
field in the top of the dialog box.

Separation between e.g. manufacturers
You can furthermore specify how the different manufacturers — the selected 
datafield in the dialog box above — shall be separated in the list.

Here you can choose between No separation between MANUFACTUR and Page 
shift between MANUFACTUR — or you can select Empty lines between MANU-
FACTUR, and specify the number of blank lines between the manufacturers in the 
list.

When you select Change page in not enough lines for MANUFACTUR, the com-
ponents for a new manufacturer starts on top of a new page, when there are not 
enough room for all components from the manufacturer on the page. — This option 
can not be selected when you have selected Page shift between MANUFACTUR 
above.

Minor sort
At the bottom of the tab you can furthermore specify how the components shall be 
sorted within each individual manufacturer.

In the above dialog box, the components will therefore primarily be grouped by 
manufacturer. For each manufacturer, the components will then be sorted by name, 
and below this by article number. — See also “Sorting on all parts of the symbol 
name” on page 540.
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Sorting on all parts of the symbol name
Components lists can also be sorted 
according to all parts of the symbol 
name; the function aspect (=), the 
location aspect (+) and the product 
aspect / name (-). — See “Reference 
designations” on page 339, in partic-
ular “On reference designations” on 
page 339.

If for instance you want all compo-
nents with the same location aspect 
(e.g. +A1) to be listed together in the 
same components list, you just need 
to move LOCATION to the top of 
the list.

You can either do this by clicking on LOCATION and then drag it to the top of the 
list, or by clicking on LOCATION and then use the arrow buttons next to the list.

If you place NAME at the top of the list, for instance all -K1 symbols will be placed 
succeedingly, regardles of their function and location aspects.

This makes it possible to create a list where e.g. all panels appears separately.

If you do not make any changes, the order will by default be FUNCTION, LOCA-
TION and NAME.



PCschematic ELautomation 10.0 PAGE 541

LIST SETTINGS

SPECIFYING CRITERIA FOR THE COMPONENTS TO INCLUDE

On the tab Criteria you set up the conditions for which content you want on the list 
you are working on.

You can fill out seven lines, each containing one criterion.

Only one criterion needs to be fulfilled
When you select Only one Criterion needs to be 
fulfilled (logical OR), the text and changes to or 
in the dialog box.

In the dialog box above this would mean that you 
get all components from AEG Industry, as well as all components having a K in the 
symbol name.

If Only one Criterion needs to be fulfilled is not selected, the text and is displayed 
between the criteria lines. This means all the criteria have to be fulfilled at the same 
time. In the dialog box above, this means you only get components from AEG 
Industry, having a K in their symbol names.

Setting up a criterion
By clicking in the text fields below Field, you state which datafield the criterion is 
set for. These datafields can be any datafield from the database, or from one of the 
symbol texts.

If you set Operator to =, you can type in what the contents of the field should be 
identical to in the Text field.

If you want the contents to differ from what you type into the Text field, you choose 
the Operator <>.
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Accordingly, you can set the operator to determine that the contents must be larger 
than (>) or smaller than (<) what you specify in the Text field. Please note, that 
these operators examine whether the texts are placed before or after the text alpha-
betically.

If you select A<>a, you tell the program to distinguish between upper- and lower-
case letters.

Data for which Criteria can be set
The data, for which you can set criteria, are:

- Datafields from the database (written in capitals)

- Component data (Name, Type, Article no and Function)

- Reference designations (the datafield =+design.) — see the figure below

- Symbol type — see “Symbol types” on page 680

- Symbol datafields — see “Creating symbol datafields” on page 705

Wildcards/jokers
If for instance you need all components on a list having the letter K in their name, 
you need a way to tell this to the program.

For this purpose, you can apply the so-called jokers/wildcards, which are also used 
in Windows.

The special characters used for this purpose are ? and *.

When you place a question mark (?) somewhere in a text, this signifies, that on the 
place in the text where the question mark is located, there have to be exactly one 
character. And this character could be any character.

If you place an asterisk (*), any number of characters could be located on the place 
where the asterisk is located.

If you, for instance, have to find something on exactly three letters with the letter Q 
as the second character, you type in ?Q?. Thus you state that there has to be one — 
and just one — character in front of Q, and exactly one character after as well.

If you will find a text having an A anywhere in the text, you type in *A*.

— Please note, that if you use ? there have to be a character, but if you use * this 
also covers cases with no characters on the location of the asterisk.

Example
If you want a list of contactors from AEG Industry, you set up as a first criteria, that 
MANUFACTU have to be equal to AEG Industry.
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As the second criteria, you state that Name shall be equal to *K*. This gives you all 
component names with a K. — You can see these settings on page 541.

By creating several different parts lists, you can create a parts list for each compo-
nent vendor you order components from.
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HOW TO HANDLE REPETITIONS IN LISTS

This tab only exists for parts and components lists.

On the Repetitions tab, you can specify how repetitions in the list shall be handled.

If you choose the datafield and type in a text, the program inserts the text for each 
repetition of the given datafield.

If you fill out the tab as displayed above, the list will look like this:

To empty a line on the tab, choose the blank field in the drop down box for the line.

Data for which repetitions can be specified
The data, for which repetitions can be specified, are the same as the data which can 
be applied for Criteria. — See “Data for which Criteria can be set” on page 542.
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HOW TO REPLACE MISSING INFORMATION

This tab only exists for parts and components lists.

If the program can not find a piece of information about a component in the 
datafield you have specified, you can specify another datafield where the informa-
tion can be collected from.

Please note, that data is only collected from the replace field if the original datafield 
is empty for a component.

When the program can not find information about a components description in the 
database (DESCRIPT), you can tell the program to collect the information from the 
Type field in the Component data dialog box for the component on the diagram.

Please remember, that datafields written in upper-case letters represent information 
coming from the database.

Data for which replacements can be specified
The data, for which replacements can be specified, are the same as the data which 
can be applied for Criteria. — See “Data for which Criteria can be set” on 
page 542.
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LIST SETUP FOR TERMINALS- CABLES- AND PLC LISTS

For terminals, cables and PLC lists you have some special options on the General 
tab, and you also have the option of using symbol datafields on the Criteria tab. 
This is described in the following:

The tab General for terminals, cables and PLC lists
If you are working on a terminals, cables or PLC lists and choose Lists => List set-
tings, the General tab looks like this:

Separation
Here you specify how to separate the terminals, cables or PLC’s on the list.

Here you can choose only to have one terminal row on each page by choosing Page 
shift between Terminal Rows, or to insert empty lines between the terminal rows 
by choosing Empty lines between Terminal Rows. If you choose the latter, it is also 
possible to specify how many empty lines to insert between the terminals/cables/
PLCs in the list.

Components starts on new page in Cables, Terminals and PLClists
When you select Change page if not enough lines for Terminal Row, a component 
starts on a new page, when there is not enough space for it on the remains of the 
current list page.

Survey of cable connections
For cable- and terminals lists, it is possible to create a survey of what the cables 
connects. This is done by enabling List only one of each name, and can be applied 
for lists in the project as well as lists for files.

In terminals lists the first terminal in the terminal row is displayed (the lowest 
group number). In cable lists the first conductor in the cable is displayed.

Specify no.
of blank lines
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Special for cables
For cable lists, there are two more settings:

SORTING IN CABLES LISTS

For cables lists, you can under Sort by specify whether to 
sort by Cable wire, Terminal at To-end or Terminal at 
From-end.

SORTING SO THAT CABLE WIRES FOR THE SAME CABLE SYMBOL ARE KEPT TOGETHER

When you select Sort within symbol, cable wires which are 
drawn next to each other in the same cable — for instance 
because they are under the same screen in a cable or a twisted 
pair — are also placed next to each other in the list.

Sort by name on PLC lists
For PLC lists you also specify according to which datafield 
the list is sorted.

The remaining settings
Pages and layers and Include all pages in the Table of 
Contents are described in “Specifying from where to col-
lect components” on page 536. The Criteria tab is described in “Specifying Crite-
ria for the components to include” on page 541.

Symbol datafields as Criteria for terminals, cables and PLC lists
On the Criteria tab for terminals, cables and PLC lists, you can use userdefined 
datafields as criteria. — See “Creating symbol datafields” on page 705 and 
“Symbol datafields with predefined values” on page 708.

If you therefore have created a symbol datafield Cable route for cables, this can be 
used as a criterion in cables lists, so that cables where Cable route has different val-
ues — such as In ceiling and In wall — can be listed side by side, or in separate 
lists.
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LIST SETTINGS FOR TABLES OF CONTENTS

To specify the settings for a table of contents, you must activate the table of con-
tents page and choose Lists => List Settings. You then enter this dialog box:

Here you specify what to include in the table of contents

Normally, a table of contents will only contain information from project pages 
placed after the table of contents in the project. If you therefore place a table of 
contents as the last page in the project, it will not contain any information — unless 
you select Include all project pages.

In the dialog box you have the following options:

Because some of the above options mutually excludes each other, some options will 
be dimmed as you make selections in the dialog box.

OPTION EFFECT

INCLUDE ONLY DIVID-
ERS

THE TABLE OF CONTENTS WILL ONLY CONTAIN THE DIVIDER PAGES 
OF THE PROJECT.

INCLUDE ONLY PAGES 
FROM CHAPTER

THE TABLE OF CONTENTS WILL CONTAIN THE SUCCEEDING PROJECT 
PAGES IN THE CHAPTER.

INCLUDE ALL PROJECT 
PAGES

WHEN YOU SELECT THIS OPTION, THE TABLE OF CONTENTS WILL CON-
TAIN INFORMATION FROM ALL PAGES IN THE PROJECT.
IF YOU DO NOT SELECT THIS OPTION, THE TABLE OF CONTENTS WILL 
ONLY CONTAIN INFORMATION FROM PROJECT PAGES SUBSEQUENT TO 
THE TABLE OF CONTENTS.

INDENT PAGES IN 
CHAPTER

THE COMMON PROJECT PAGES (DIAGRAMS, LISTS ETC.) WILL BE 
INDENTED 15MM. COMPARED TO THE DIVIDERS.

SHOW ONLY PAGE 
TITLES AT DIVIDERS

FOR CHAPTER DIVIDER PAGES, IT OFTEN SAYS THE SAME IN THE FIELD 
SETTINGS => PAGE DATA => PAGE TITLE AND ON THE TAB.
WHEN YOU SELECT THIS OPTION, ONLY THE PAGE TITLE IS DISPLAYED 
FOR THE DIVIDER PAGES IN THE TABLE OF CONTENTS.

IN COLUMNS — SEE “LISTS IN COLUMNS” ON PAGE 538.

LIST SETTINGS FOR TABLES OF CONTENTS
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COMPONENT GROUPING

To get the correct information transferred from the project diagrams to the lists, you 
sometimes need to apply the Component grouping function.

WHEN IS COMPONENT GROUPING NECESSARY

Normally you regard all symbols with the same symbol name as the very same 
component. However, this component can be built up from several physical compo-
nents.

Therefore, when you want to print out the parts lists, there are cases where the pro-
gram cannot determine how many components of a specific type are used in the 
project.

This could also be the case if for instance you use three terminals, each having the 
same symbol name and the same article number. In this case, the program cannot 
tell whether they are three individual terminals, or it is a triple terminal. — Unless 
you have fetched the terminals directly from the database, as described in “Fetching 
symbols from the database” on page 172.

In this case, the program can not tell whether just one or three components with the 
given article number are needed on the parts list.

Therefore, the program will have to make a qualified guess, but if you are not sure 
that the program will guess correctly, you will have to state what is the case your-
self.

To be specific about this, you have to perform a so-called component grouping.

Here you divide symbols having the same names into groups, by assigning the 
same group number to the symbols for each individual component.

When two symbols have the same name, article number and component group 
number, the program knows they are part of the same physical component. If their 
group number differ, the program knows they belong to different components.

THIS CHAPTER DESCRIBES

— WHEN COMPONENT GROUPING IS NECESSARY ...................................................(P. 549)

— THE COMPONENT GROUPING MENU ...................................................................(P. 550)

— FINDING A COMPONENT IN THE MENU ................................................................(P. 550)

— THE SORTING ORDER OF THE COMPONENTS .......................................................(P. 551)

— SPECIFYING THE COMPONENT GROUPING ...........................................................(P. 551)

— THE ORDER OF THE COMPONENTS IN LISTS.......................................................(P. 553)

— SPECIFYING THE ORDER IN PARTS LISTS.............................................................(P. 553)

— SPECIFYING THE ORDER IN TERMINALS LISTS ....................................................(P. 553)

— ENDING A COMPONENT GROUPING.....................................................................(P. 554)

— COMPONENT GROUPING AND COPYING...............................................................(P. 554)
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Because the component groups are printed out in numerical order (starting from the 
lowest group number), the group numbers have the further advantage, that you can 
determine the order in which components are printed out on the components list, as 
well as in which order terminals are printed out on terminals lists. — Read more 
about this in “The Order of the Components in lists” on page 553.

THE COMPONENT GROUPING MENU

When you have clicked on Symbols, and choose Functions => Component 
Grouping (short-cut [Ctrl+F7]), you enter this dialog box:

You can also select a symbol and choose Functions => Component Grouping, 
which makes you enter the Component Grouping menu for all symbols with the 
chosen symbol name.

Click on Print when you need to print out the component grouping of a component.

FINDING COMPONENTS

If you have not chosen the component you want to group, you can type in the name 
of the component in the lower-left corner of the dialog box.

Clicking on the Used components button gives you a list of the used symbol names 
in the project. Here you click on the symbol name you are interested in, and click 
on OK.

Also, you can scroll back and forth in the list of components by clicking on the Pre-
vious component and Next component buttons. Please note that the arrow-keys 
can be used as short-cut keys for these buttons.

Clicking on the First component button gives you the first component in the list, 
while clicking on the Last component button gives you the last.
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When you click the Show where the component is placed button (or click on the 
symbol in the list and press <Enter>), the cross hairs points out the symbol in the 
project — and the Component grouping menu remains on screen.

THE SORTING ORDER OF THE COMPONENTS

By clicking on the column headers in the table, you determine by which criterion 
the components will be sorted in the dialog box. If you click on Symbol, they will 
be sorted by symbol name, if you click on Path they will be sorted by current path 
numbers — and so on.

SPECIFYING THE COMPONENT GROUPING

You can either let PCschematic ELautomation guess the component grouping, or 
specify how it shall be yourselves:

Letting the program do the component grouping
When you need to zero all the group numbers for the chosen symbol name, do the 
following:

1) Click on the first line in the dialog box

2) Press down <Shift> and click on the last line in the dialog box: All lines are 
now selected

3) Click on the Reset group numbers button

When all group numbers for a component is set to zero, this signifies that you have 
not taken the grouping of the component into consideration. When you print out 
lists, the system will then have to guess in which order the possible parts of the 
component shall be printed, as well as whether they belong to the same component 
or not.

Specifying component grouping by assigning group numbers automatically
If you wish to state that you have specify that all three terminals with the same sym-
bol name are part of the same component, you therefore have to assign group 
number one to all of them.

For instance you have six terminal symbols with the same symbol name, and want 
to state that they represent two components each containing three terminals. You 
therefore give three of the terminals group number 1, while the remaining three gets 
group number 2. Do the following:

1) Set Position pr. terminal to 3 (short-cut [Alt+p]). — This tells the program 
that three terminals are required for one part component (for instance for 
multi layered terminals).

2) Set Groupnumber to 1 (short-cut [Alt+g]).
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3) Click for instance on the column Conns. — to sort the terminals by connec-
tion name.

4) Select the three terminals, and click on Preset Group Numbers, and the three 
selected terminals are assigned group number 1 and the positions 1, 2 and 3 
respectively.

5) Set Group Number to 2.

6) Select the three remaining terminals, and click on Preset Group Numbers, 
and the three selected terminals are assigned group number 2 and the posi-
tions 1, 2 and 3 respectively.

Assigning group numbers manually
If you want to transfer a group number to a symbol, you click the up- and down-
arrows in the field below Group Number until the desired number is in the box.

Then select the symbols, which are part of the component, and click on the Trans-
fer Group Number button, which transfers the group number to the selected sym-
bol.

ASSIGNING GROUP- AND POSITION NUMBERS IN A SINGLE OPERATION

WHEN THE TERMINALS APPEARS IN THE DESIRED ORDER IN THE MENU, AND 
YOU HAVE SET GROUP NUMBER AND POSITION PR. TERMINAL CORRECTLY, 
YOU CAN ASSIGN ALL OF THE TERMINALS IN THE MENU CORRECT GROUP AND 
POSITION NUMBERS IN ONE SINGLE OPERATION, BY CLICKING THE PRESET 
GROUP NUMBERS BUTTON.

COUNTING UP AND DOWN BY DOUBLE-CLICKING

DOUBLE-CLICKING ON A COMPONENT ON THE LIST, WILL INCREASE ITS GROUP 
NUMBER BY ONE.
PRESSING DOWN <SHIFT> WHILE DOUBLE-CLICKING WILL DECREASE ITS 
GROUP NUMBER BY ONE.
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THE ORDER OF THE COMPONENTS IN LISTS

When PCschematic ELautomation fills out a list, the components are listed 
according to the following criteria:

1) Component name

2) Group number

3) Position number

4) Article number

This means, that for each symbol name, the components are printed out primarily 
ordered by group number, then ordered according to position number, and finally 
according to article number.

SPECIFYING THE ORDER IN PARTS LISTS

If you have constructed your own component, for instance a contactor with add-on 
contacts, you can therefore determine in which order the component parts should 
appear on the parts list.

Because the lowest group numbers for the component appears first on lists, you do 
this by assigning the lowest group numbers to the parts that shall appear first.

In this way you can get the contactor first, followed by the auxiliary contacts.

SPECIFYING THE ORDER IN TERMINALS LISTS

The group numbers for the component also determines in which order the terminals 
are printed out in terminals lists.

For individual terminals you can therefore determine their order in the lists using 
the group numbers, so that they are printed out as they should be mounted.
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END COMPONENT GROUPING

When you have completed the component grouping for a component, and change to 
another component name in the lower-left corner, you will be asked whether you 
want to transfer the changed group numbers to the component.

Click on Yes.

When you have finished grouping components, you click on OK, whereby you 
approve the component grouping you have carried out.

COMPONENT GROUPING AND COPYING

For everything which is being placed via the database, the component grouping is 
handled automatically by the program.

For all copying, the used component grouping is examined, and the component 
grouping is continued following the same directions for the inserted copies.
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INSERTING UNIT DRAWINGS

In your projects you can insert the so-called unit drawings, specifying what an indi-
vidual component consist of. It is then possible to attach the unit drawing to a sym-
bol in the project. When you right-click on this symbol, you will then get the option 
to jump to the page where the unit drawing for the symbol is located.

When you use extended parts lists in your project, articles from the unit drawings 
are included in the parts lists. Read more about this in “Specifying from where to 
collect components” on page 536.

— See how to create a unit drawing in “Creating Unit Drawings” on page 744.

INSERT EXISTING UNIT DRAWING / PARTS LIST INTO A PROJECT

When you want to insert an already created unit drawing into a project, you enter 
the Page menu to create a new page, and then state that this page shall contain a 
unit drawing:

Click on the Page menu button, and then click on Insert or Add. In the emerging 
window you click on Unit drawing and click OK.

A new dialog box appears, and you click your way to the folder with the unit draw-
ing, and click on the unit drawing. If you are not sure how to locate files, you can 
read more about this in “Windows” on page 35.

Click OK when you have found the unit drawing. You have now inserted the unit 
drawing into your project.

ATTACH A SYMBOL ON A DIAGRAM TO THE UNIT DRAWING

When you have placed the unit drawing in your project, you can enter one of your 
diagram pages and right-click on a symbol. Then choose Component data => 
Unit.

In the appearing list of unit drawings in the project, you select the relevant unit 
drawing, and click on OK. You then return to the Component data dialog box, and 
click OK again.

The program now knows which unit drawing is attached to the symbol.

When you then right-click on the symbol and choose Open, you automatically go 
to the page with the unit drawing for the symbol.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO INSERT A UNIT DRAWING IN A PROJECT.
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In this section you can see how to use the data-

base in PCschematic ELautomation.

You can read about:

- Using the database ...............................(p. 559)

- Creating components in the database...(p. 572)

- Database settings..................................(p. 591)

- Choosing a database.............................(p. 604)

- Programmable Barcode Scanners ........(p. 608)

- Applying mechanical symbols.............(p. 609)

- From Mechanical to Electrical drawing
via the Database .................................(p. 620)

READ SURVEY ARTICLE

READ THE SURVEY ARTICLE ABOUT WORKING 
WITH DATABASES AND LISTS IN “LISTS” ON 
PAGE 521.

D
atabases
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USING THE DATABASE

PCschematic ELautomation has an attached database from which you can collect 
information about the components you use in your projects.

In PCschematic ELautomation you can either use one of the component vendor 
databases for the program, or use the demo database demo which is installed auto-
matically along with the program.

You can also create your own databases, by entering records in the databases by 
yourself, or by selecting the components you are interested in from the component 
vendor databases.

You can also read about the database in the PCschematic Database manual, and in 
the following chapters.

Using the database for Lines
This chapter focus on using the database while working with symbols.

If you wish to attach article data to a line, this is also possibls. To do this, activate 
the Lines button, deactivate the Pencil (press <Esc>), right-click on the line and 
choose Line article data. Then follow the same procedure as described in this 
chapter.

Please note that you can also apply article data to cable symbols, as described in 
“Working with cable symbols” on page 231.

THIS CHAPTER DESCRIBES

— HOW THE DATABASE WORKS (BASIC PRINCIPLES) .............................................(P. 560)

— ATTACHING COMPONENT DATA FROM THE DATABASE TO A SYMBOL..............(P. 561)

— ABOUT THE DATABASE MENU............................................................................(P. 563)

— SEARCHING FOR COMPONENTS IN THE DATABASE MENU ..................................(P. 564)

— EDITING RECORDS IN THE DATABASE.................................................................(P. 570)

’

SEE ALSO THE SURVEY ARTICLE ABOUT WORKING WITH DATABASES

IN THE SURVEY ARTICLE IN THE BEGINNING OF THE SECTION “LISTS” ON 
PAGE 521, YOU CAN READ MORE ABOUT WORKING WITH LISTS AND DATA-
BASES IN PCschematic ELautomation.

http://www.dps.dk/english/Video/Product_videos.htm
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HOW DOES THE DATABASE WORK?
In the component vendor databases for PCschematic ELautomation, the compo-
nent vendors have included ordering data, as well as electrical and mechanical sym-
bols for each component.

When you click on the component in the database, you automatically get a pick-
menu containing all the electrical symbols for the component. These symbols each 
represent one of the functions in the component.

When you subsequently place the symbols on your diagrams, the program remem-
bers which components these symbols represent.

When you have completed your electrical diagrams, the program can therefore 
automatically fill out components lists and parts lists etc. — without you having to 
type in any component information.
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Originating from the electrical symbols on the diagrams, the program can also fetch 
the mechanical symbols for the components automatically. These symbols can for 
instance be used for mechanical layouts.

ATTACHING INFORMATION FROM THE DATABASE TO A SYMBOL

In “Fetching symbols” on page 160 you will find 
a description of the many ways you can place 
symbols with and without information from the 
database.

If you want to attach information from the data-
base to a symbol which is already placed on a 
diagram, you do like this: Click on Symbols, 
deactivate the Pencil (press <Esc>), right-click on 
the symbol, and choose Component data.

In the dialog box Component data: Click on 
Database, and you enter the database.

If an article number is already specified for the 
symbol in the Component data dialog box, the 
program locates the component when you enter the database.

If only a type text has been specified in the dialog box, all components having the 
same type text will be displayed in the database.

If no type text is specified, a list of components containing matching symbols will 
be displayed.

In the database you find the record for on the component you want to apply, and 
click OK.

You then return to the dialog box Component data, where you can see that the 
information have been transferred.

Click OK.

How to find the right component is described in the following.
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Displaying database information for a symbol
When you want to see which information the database contains for a symbol, right-
click on one of the symbols for the component in the project, and choose Open. 
You then enter the Record Viewer:

Please note that you can not change database information from here. — See how to 
change information in the database in “Editing records in the database” on 
page 570.

Click on Close.
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ABOUT THE DATABASE MENU

When you wish to enter the Database menu, you can for instance press the short-
cut key [d], as described in “Fetching symbols from the database” on page 172.

The Database menu contains folders, each containing different groups of compo-
nents.

The contents of these folders are grouped by component functions.

If you are using the PCschematic Database program you can create your own data-
base menu. — Please refer to the PCschematic Database manual for further details.

If you are using your own database program, you can also create your own menu 
table there. However, it is recommended to create it in the PCschematic Database 
program first, and then transfer it to your own database system. This ensures you 
that the menu has the right format.

If you wish to change which database fields/information is displayed in the Data-
base menu, please refer to “Database settings” on page 591.

Menu for the database Records in database

Scroll/search among
the records displayed

Specify which records
to display
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SEARCHING FOR COMPONENTS IN THE DATABASE MENU

When you are in the Database menu (short-cut key [d]), you can find the compo-
nent, that you are looking for, in various ways.

Please note that the following methods can be combined:

1. Choosing a folder in the article menu
For instance you can click on the folder in the article menu — in the upper-left cor-
ner of the dialog box — which contains the type of components you are looking for. 
The contents of the folder is then displayed, and you click on the desired compo-
nent. However, if the folder contains many components, this will not be sufficient.

Display Fabricates with components from selected Article group only
If you have selected Settings => Database => Component search and have 
selected Show only tablemenu points containing the selected fabricates compo-
nents, the Fabricate menu in the right-hand side only displays fabricates having 
components in the selected article group.

2. Selecting a Fabricate / Vendor
In the upper right-hand corner of the Database menu you 
can find a menu, from which you can choose which fabri-
cate to display components for. — See how to activate this 
option in “Product choice or Fabricate choice in the Data-
base menu” on page 596.

This fabricate menu works in combination with the com-
mon database menu (in which the components are grouped 
by function).

When clicking on a fabricate, all components being of this fabricate and being 
placed in the selected folder in the database menu, are displayed.

When for instance you click on Automatic switches / connection material in the 
menu, and on AEG in the fabricate menu, all components in the menu point Auto-
matic switches / connection material of the fabricate AEG are displayed.

When you click on FABRICATE (Show all), all fabricates in the selected compo-
nentgrouping menupoint are displayed.

3. Activate search
In the lower-right corner of the dialog box, you have the option of searching in sev-
eral ways.

If you activate the Case sensitive query button, the query will discern between 
upper- and lower case letters when you search for a component. (When the applied 
database format supports this).

If you activate the Autorun query button, the program will start searching each 
time you type in a new character in one of the search fields. If this button is not acti-
vated, the searching is not activated until you click the Run query button.
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Specifying the EAN number or the type of the component
When you know the EAN 
number — or just the 
beginning of the number 
— you can click on the tab 
Item No / Type in the 
lower-right side of the dia-
log box. Here you type in 
the number in the field 
EANNUMBER begins 
with. The program then finds every component in the entire database, that matches 
the number. When you only wish to search in the selected folder, select and only in 
Branch equipment at the bottom of the dialog box (The menu point changes name 
according to the folder selected).

When working in the Database menu, the short-cut key [Ctrl+a] gives you direct 
access to this search field.

— Please note, that if you have specified the datafield ITEMNO as Article number 
in Settings => Database => Database settings => Component data, the field will 
be named ITEMNO begins with in stead.

Searching for component or type
When you know the type of the component, you can type it into the TYPE begins 
with field. When working in the Database menu, the short-cut key [Ctrl+t] gives 
you direct access to this search field.

Applying 1.Searchkey
When you wish to search 
on other fields in the 
database, you click on the 
tab 1. Searchkey, or press 
the short-cut key 
[Ctrl+1].

Here you choose which 
datafield you want to 
search on, an operator, and a text to compare the contents of the datafield with.

SPECIFYING AN ALTERNATIVE SEARCH KEY

WHEN YOU CHOOSE SETTINGS => DATABASE => DATABASE SETTINGS => 
COMPONENT DATA, YOU CAN SPECIFY AN ALTERNATIVE SEARCH KEY — FOR 
INSTANCE THE FIELD ORDERNO. THE PROGRAM WILL THEN SEARCH FOR 
THE ALTERNATIVE SEARCH KEY, IF NONE OF THE CHOSEN RECORDS HAVE AN 
EAN NUMBER BEGINNING WITH THE NUMBER YOU TYPE IN.

Click here only to search
in the selected folder

Datafield in the database TextOperator
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In the figure above the following is chosen:

- The datafield PCSTYPE

- The operator begins with

- The text 07-02-01

This tells the program to find all records having a PCSTYPE 
that begins with the text 07-02-01.

It is possible to choose from many different types of operators, 
which are chosen by clicking on the down-arrow in the operator field.

If the Autorun query button is activated, the program will find matching records, 
as you type in the text.

Applying 1. and 2. Searchkey
When you want to search 
on two datafields at the 
same time, you can 
choose to apply the first 
and the second search key 
simultaneously.

Specification of datafield, 
operator and text is simi-
lar to 1. Search key. If 
you enable and 
PCSTYPE begins with “07-02-01”, the program finds the records which fulfils 
both specified criteria. The text in this field will therefore differ, depending on the 
chosen search criterion on the tab 1. Searchkey.

When you want to search in the folder chosen in the upper part of the menu, you 
enable and only in Automatic switches. (Accordingly, the name of the folder will 
vary). If this function is not enabled, the search will be carried out in the entire data-
base.

The short-cut key for the tab 2. Searchkey is [Ctrl+2].

Searching and editing among the found records
By applying the buttons in the lower-left corner, 
you can leaf through the found records, edit 
component information, or search among the 
found records.

If you enable Count records, the program will automatically display how many 
records/components have been found, each time you have performed a new query. 
However, if you do not need this information, it is recommended that you disable 
this function, due to increased search rates.

Leafing through the found records
When you click the First button, you will be placed on the first component in the 
list.

Operators

Search in the selected
folder only

Apply both
search keys
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The Previous button gives you the component just above the actual chosen compo-
nent.

The Next button gives you the component just below the actual chosen component.

The Last button gives you the last component in the list.

Update the database
The Refresh button refreshes the records from the database, which are displayed on 
your screen. This is important when the database is located in a network, where 
other users can change the contents of the database while you are working with it.

Edit records
When you click the Pencil, you can edit, delete and add records to the database. 
Please read more about this in “Editing records in the database” on page 570.

Search for records
When you click the Find button you will enter the dialog box Search, where you 
can specify what you are searching for. You only search among the records which 
are listed in the Database dialog box for the moment — or in the selected folder.

The dialog box Search is elaborated in “Finding symbol texts” on page 324.

Please note that the dialog box here has an extra option: If you choose Search all 
records, the program will search in the entire database. If you do not choose this, 
the program will only search among the listed records.

Displaying Approved components only
When you select Show approved components only, only approved components are 
displayed in the Database menu.

— Read more about this in “Display only Approved components and hide Obsolete 
components” on page 599.

SETTING UP THE DATABASE MENU FOR APPROVED/OBSOLETE

TO WORK WITH APPROVED/OBSOLETE COMPONENTS, THE DATABASE MENU 
MUST FIRST BE SET UP FOR THIS. READ MORE ABOUT THIS IN “APPROVED AND 
OBSOLETE COMPONENTS IN THE DATABASE” ON PAGE 597.
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Hiding Obsolete components
When you select Hide obsolete components, no obsolete components are displayed 
in the Database menu.

— Read more about this in “Display only Approved components and hide Obsolete 
components” on page 599.

Specifying that a component is Approved or Obsolete
To specify that a component is approved or obsolete, do the following:

1) Enter the Database menu (Press [d]).

2) In the Database menu: Find the component, click on it to select it, and click 
on the Pencil.

3) In the dialog box Edit record: Scroll down to the fields Approved and Obso-
lete and click on them, which sets a check mark in the fields.

4) Click the Post changes button, and click Close.

5) The changes are now displayed in the Database menu:

Please note that it is only possible to set a check mark in the Approved and Obsolete 
fields if these fields are created as boolean fields in the attached database. — See 
“Using non-boolean fields for Approved/Obsolete” on page 598.

Click here to display approved components only
Click here not to see the obsolete components
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Open link for selected record in Database menu
When you in the Database menu 
have selected a record, which con-
tains fields with links, you can acti-
vate these links directly from the 
Database menu — without having 
to open the relevant record in the 
Edit record dialog box. This can 
be done by clicking the Open link 
button in the Database menu.

When you let the mouse cursor rest 
over this button, it is displayed 
which link field that will be 
opened, when you click on the button.

Specify preferred link field in the database
When a record for a component has more than one field containing links, the pro-
gram will open the first field in the record containing a link, when you click the 
Open link button.

However, you can specify a Preferred Link Field, as described in “Link Alias” on 
page 602. The link from this specified field will then be opened, when you click the 
Open link button.

Choosing between several fields with links
When you click the down-button to the right of the Open link 
button, you get a survey of the fields in the selected record, that 
contains links. When you click on a field in the list, the link in 
the selected field is opened.

Click here to open link
for the selected record

The link is displayed here
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EDITING RECORDS IN THE DATABASE

When you click on the Pencil in the Database menu — see “About the Database 
menu” on page 563 — you enter the dialog box Record Editor, where you can edit 
the records/components, that are listed in the Database dialog box the moment.

If the Pencil is not visible, you do not have permission to alter the contents of the 
database.

The dialog box Record Editor looks like this:

When you click the Find button you enter the Find dialog box, where you specify 
what you are looking for. You only search among the records that are listed in the 
Database dialog box. If you click the Find again button, the next record fulfilling 
the search criteria is found. This also happens when you press [F3].

When you click the Replace button, you enter the dialog box Find & Replace. The 
information is not transferred to the database until you click the Post button.

— Please read more about the dialog boxes Find and Find & Replace in “Find and 
Replace” on page 324.

Copy / Insert full records in the dialog box Edit Record
To copy a full record in the dialog box Edit Record, you must press the <Ctrl> key 
when clicking the Copy button.

Cut and edit
functions

Functions for
Find and Replace

Insert record
Delete record

Refresh

Cancel
Post
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To then insert the full record you must press the <Ctrl> key again when clicking the 
Insert button.

Drop-down lists in the dialog box Edit Record
In the dialog box Edit Record there are drop-down lists for all editable textfields, 
which enables you to select the existing values in the database.

Click here

... and select in the list
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CREATING COMPONENTS IN THE DATABASE

In PCschematic ELautomation you can create components in the database with 
attached electrical and mechanical symbols.

In the manual for the included database program PCschematic Database you can 
read more about the options for structuring your database — and much more.

GRAPHICAL CREATION OF NEW COMPONENTS IN THE DATABASE

If you want to create a new component in the database with attached electrical sym-
bols, and a mechanical symbol, you first have to place all of the symbols for the 
component in the same project.

Placing all of the symbols for the component in the same project
If you are not already working in a project where all of the symbols for the compo-
nent exists, do the following:

1) Create the electrical symbols and the mechanical symbol — if these does not 
exist in one of the existing libraries — see “Creating Symbols” on page 670

2) Open or create a project containing both a page of the type Diagram and a 
page of the type Ground plan — see “Creating a new page” on page 491

3) Click on the Symbols button

4) Place all of the electrical symbols for the component on the Diagram page, 
and the mechanical symbol on the Ground plan page. Assign the same name 
to all of the symbols

5) Right-click on one of the symbols, choose Select Name, and click on the 
Object data button

THIS CHAPTER DESCRIBES

— GRAPHICAL CREATION OF NEW COMPONENTS ..................................................(P. 572)

— INFORMATION ABOUT THE COMPONENT IN THE DATABASE ...............................(P. 574)

— WHEN THE COMPONENT ALREADY EXISTS.........................................................(P. 575)

— THE ELECTRICAL AND MECHANICAL SYMBOLS FOR THE COMPONENT .............(P. 576)

— ACCESSORIES IN THE DATABASE........................................................................ (P. 586)

— SPECIFYING THE SYMBOL REFERENCE LETTER FROM THE DATABASE ..............(P. 588)

— SPECIFYING SYMBOL SUB NAMES FROM THE DATABASE ...................................(P. 588)

— CREATING PLC COMPONENTS IN THE DATABASE ..............................................(P. 589)
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6) In the dialog box Component data: Type in Article no and Type for the sym-
bols

You are now prepared to create the component in the database, as described below.

Creating a component in the database using an existing project
When you want to add a new component to the database from an existing project, 
do the following (please refer to “Placing all of the symbols for the component in 
the same project” on page 572 to see how to add Article no and Type information to 
the component):

1) Click on the Symbols button

2) Right-click on one of the symbols for the component

3) Choose Select Component

4) Press down <Shift+Ctrl> and click on the Object data button

5) You now enter the dialog box Edit Record, from where you create the com-
ponent as a record in the database — see “Information about the component 
in the database” on page 574

IN THE DATABASE THE SYMBOLS ARE ASSIGNED THE CONNECTION NAMES 
USED IN THE PROJECT. IT CAN THEREFORE BE NECESSARY TO CHANGE THESE 
BEFORE THE COMPONENT IS ADDED TO THE DATABASE.
THE SYMBOLS ARE ARRANGED AS THEY ARE PLACED IN THE PROJECT — IN 
THE SAME ORDER AS YOU READ A BOOK; THIS MEANING SYMBOLS IN THE TOP 
LEFT CORNER ARE PLACED FIRST, WHILE SYMBOLS IN THE LOW RIGHT CORNER 
ARE PLACED LAST.

Electrical symbols on
the Diagram page

Mechanical symbol on
the Ground plan page
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If a component with the specified article number already exists, you will be 
informed about this, as described in “When the component already exists in the 
database” on page 575.

You have now created a new component in the database.

All electrical and mechanical symbols in the project with the same symbol name 
and article number, will be attached to the component in the database.

INFORMATION ABOUT THE COMPONENT IN THE DATABASE

When you enter the Edit Record dialog box, you can create new components as 
records in the database, as well as edit already existing records. — You can read 
more about editing records in “Editing records in the database” on page 570.

If you have entered the dialog box via a graphical creation of new records — as 
described in “Graphical creation of New Components in the Database” on page 572 
— some of the datafields of the record have already been filled out.

Fill out the relevant datafields with text information by clicking in the text fields, 
and typing in the information. Click on the Post button when you have completed 
typing in information. Then click on Close.

In some of the fields you have the option of specifying connection names, reference 
letter for the symbols and much more. — These options are described in “Electrical 
and Mechanical symbols for components” on page 576.

SUBNAMES, ALTERNATIVE SYMBOLS, # AND SYMBOL TYPE

PCschematic ELautomation ALSO DETECTS IF YOU APPLY SUBNAMES, 
ALTERNATIVE SYMBOLS, # FOR SPECIFYING MULTIPLE SYMBOLS WITH IDENTI-
CAL NAMES, AND CHANGES IN SYMBOL TYPE COMPARED TO THE SPECIFIED 
TYPE IN THE DATABASE.

Click and drag
here to see more
of the record
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Here the use of the following datafields are elaborated:

WHEN THE COMPONENT ALREADY EXISTS IN THE DATABASE

If you are trying to create a component with an article number, which already exists 
in the database, you are informed about this:

You are also told which changes this will cause in the database, if you enter the new 
information about the component in the database.

If you here click OK the component is created with the new contents, but if you 
click Cancel the previous component remains in the database.

— Please note that the program does not check whether the new component con-
tains the same symbols as the old, arranged in a different order. The main purpose 
of this check is just to inform you that a component with the same article number 
already exists in the database.

DATAFIELD IS DESCRIBED IN

PCSTYPE “ELECTRICAL SYMBOLS” ON PAGE 576.

PINDATA “CONNECTION NAMES/PINDATA” ON PAGE 581.

MECTYPE “MECHANICAL SYMBOLS” ON PAGE 586.

ADDITIONALS “ACCESSORIES IN THE DATABASE” ON PAGE 586.

REFID “SPECIFYING REF. LETTER FOR THE SYMBOL IN THE DATABASE” ON 
PAGE 588.

DESCRIPTION OF THE FIELDS IN THE DATABASE
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ELECTRICAL AND MECHANICAL SYMBOLS FOR COMPONENTS

When you attach symbols to components in the database, you concentrate on three 
different datafields. These are the datafields PCSTYPE, PINDATA and MEC-
TYPE. (However, it is possible to add extra fields for different types of mechanical 
symbols). These datafields contains information on the electrical symbol(s), the 
connection names, and the mechanical symbol (optional) for the component.

Electrical symbols
In the database field PCSTYPE you specify 
the electrical symbol(s) that represents the 
component on diagrams in the PCschematic 
program.

In this datafield you type in the name of the 
file, in which the electrical symbol is saved. 
The program then searches for these files in the directory specified in Settings => 
Directories => Symbols. — Read more about this in “Directories” on page 819.

Components with more than one electrical symbol
If the component consists of several electrical symbols, you apply a semicolon to 
separate the symbols. If a component contains more symbols of the same kind, you 
can type in a number sign (#) followed by the number of symbols, immediately fol-
lowing the file name.

In the example above, 07-02-01#3 means that the component contains three electri-
cal symbols of the type 07-02-01. — If you need to create components with alterna-
tive electrical symbols for the functions of the component, please refer to 
“Specifying alternative electrical symbols via the database” on page 577.

THIS CHAPTER DESCRIBES

— ELECTRICAL SYMBOLS IN THE DATABASE..........................................................(P. 576)

— CONNECTION NAMES / PINDATA IN THE DATABASE ........................................(P. 581)

— ADDRESSING PLC SYMBOLS VIA THE DATABASE ..............................................(P. 584)

— MECHANICAL SYMBOLS IN THE DATABASE........................................................(P. 586)

OPTIONS FOR ELECTRICAL SYMBOLS IN THE DATABASE

— COMPONENTS WITH MORE THAN ONE ELECTRICAL SYMBOL .............................(P. 576)

— SPECIFYING THE SYMBOL STATUS ......................................................................(P. 577)

— ALTERNATIVE ELECTRICAL SYMBOLS ................................................................(P. 577)

— SPECIFYING SYMBOL STATES ............................................................................. (P. 579)

— ACTIVATING REFERENCES ..................................................................................(P. 579)

— SUPPORT SYMBOLS IN THE PCSTYPE FIELD .....................................................(P. 580)
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When you are working on a Diagram page in PCschematic ELautomation, enter 
the database, and select this component, you will get these electrical symbols to 
choose from:

Specifying the symbol status
If you want to specify the symbol status of a symbol, you can also do this in the 
symbol name in the PCSTYPE datafield. All you have to do, is to place a sign of 
equation and a letter following the symbol name.

Thus, if the symbol 07-01-03 should have status as for instance Main reference, you 
then write 07-01-03=M. — However, you cannot apply this facility on multi sym-
bols — see “Creating a symbol as a Multi symbol” on page 688 — or for symbols 
using # to specify that the symbol is used several times for the component.

Below you see which letters results in which symbol status.

SPECIFYING SYMBOL TYPE FOR TERMINALS WITH ADDITIONAL STATUS

When a terminal symbol shall be assigned more than one status — such as Termi-
nal and Relay or/and Terminal and Open — you specify it like this: 07-15-
01=T,R;07-02-01=T,O

— Read more about terminal symbols with more than one status in “Creating termi-
nal symbols with an additional status” on page 693.

Specifying alternative electrical symbols via the database
When you fetch a component via the database — for instance from the pickmenu 
— it is possible to specify alternative electrical symbols for the functions of the 
component.

If for instance a component has relay coil and two switch functions, the switch 
functions can be used as both a switch, a make contact and a break contact.

LETTER SYMBOL STATUS LETTER SYMBOL STATUS

C CLOSE R RELAY

M MAIN REFERENCE S SWITCH

N NORMAL T TERMINAL

O OPEN W WITH REFERENCE

P PLC

CODES FOR SYMBOL STATUS

The symbol 07-02-01.sym The symbol 07-02-03.sym
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When you get the pickmenu for a such component, it could appear like this:

When you fetch one of these alternative electrical symbols, the other alternative 
symbols for the function disappears. — Read more about alternative electrical sym-
bols in “Alternative electrical symbols” on page 163.

SPECIFYING ALTERNATIVE SYMBOLS

When you specify that you can choose between more than one symbol for one of a 
components functions, you write the options for the function in square brackets 
with a vertical line between the options.

The fact that you can choose between the options 07-02-04, 07-02-01 and 07-02-03 
is therefore specified by writing [07-02-04|07-02-01|07-02-03]. When one of these 
symbols is selected, the other two disappears from the pickmenu for the compo-
nent.

You can also specify repetitions of "or"-sections, by typing #n after the last square 
bracket in the section —where n represents the number of repetitions. In the figure 
above, the section [07-02-04|07-02-01|07-02-03] appears twice. That could there-
fore be specified like this: [07-02-04|07-02-01|07-02-03]#2

ALTERNATIVE SYMBOLS FOR PLC´S

For PLC´s you can thus choose whether to draw using one PLC module, or using 
single I/O symbols.

In the figure above you can choose between one PLC symbol with eight inputs, or 
eight symbols with one input each.

If you choose one of the symbols with one input, the symbol with the eight inputs 
disappears from the pickmenu. Also, the eight other symbols disappear if you 
choose the symbol with the eight outputs.

Alternative electrical symbols Alternative electrical symbols
(1-2-3) (1-2-3)
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ALTERNATIVE SYMBOLS AND PINDATA
When you have specified the alternative PCSTYPE´s, you specify their connection 
names in the PINDATA field — in the same order as the symbols are listed in the 
PCSTYPE field.

— Please note that you shall not mention anything about alternative PCSTYPE´s 
in the PINDATA field.

Specifying symbol state for electrical symbols via the database
For electrical symbols created with states — see “Creating symbols with states” on 
page 686 — you can specify which state the symbol shall be in, when it is placed in 
the project. You specify this in the PINDATA field using the § character succeeded 
by the state number.

If the symbol XXXXX is to be placed in state 2, you therefore write XXXXX§2 in 
the PCSTYPE field.

Activating references on electrical symbols via the database
When you do not specify information about references for a symbol in the database, 
the symbol references are activated/deactivated as specified in the symbols defini-
tion, when the symbol is placed in a project.

To control the activation/deactivation of references on a symbol via the database, 
the symbol filename in the PCSTYPE field must be followed by a *, followed by 
either N, W or M.

This has the following meaning:

The function has no effect on symbols, which through their symbol type already 
have references (e.g. Relay, Open, Close or WithReference), unless the symbol 
type have first been changed using the = function — see “Specifying symbol state 
for electrical symbols via the database” on page 579.

06-05-04*N When the symbol is created with the reference, the reference is 
deactivated.

06-05-04*W The reference will be activated, no matter what the symbol defi-
nition says.

06-05-04*M The reference will be activated and be set to master reference, no 
matter what the symbol definition says.
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REFERENCE CONTROL COMBINED WITH OTHER OPTIONS

The control of the symbol references via the database, can be combined with the 
other parameters for controlling symbol properties via the database. Example:

Supportsymbols in the PCSTYPE field
In the field PCSTYPE it is also possible to specify that there shall be placed one or 
more extra components along with the selected component — components which 
are not known prior to the moment of placing the component. So-called support 
symbols.

For a lamp this could be a blue, yellow or red glass, where you prior to the placing 
of the component do not know which color of the glass is needed — and, conse-
quently, which article number to apply.

If you specify a symbol of the type Support in the PCSTYPE field, this symbol 
will be displayed when you select Show available for the component — see “The 
function Show available” on page 245 —, so that you will remember to place the 
support symbol.

If the symbol is not of the type Support, it will be conceived as a part of the compo-
nent.

When placing the support symbol, you enter the dialog box Component data, from 
which you can specify name and other component data.

Please note that you can also specify additionals to components in the field ADDI-
TIONALS — as described in “Accessories in the database” on page 586. When 
you specify (part)components here, these will not be displayed when you select 
Show available.

— Please also see “Creating Symbols” on page 670, specially “Symbol types” on 
page 680.

07-02-03=T,P§3*W The symbol gets the symbol type Terminal and PLC 
(=T,P), is set to state 3 (§3) and the reference is activated 
(*W).
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Connection names/Pindata

What is connection names /pindata
When you create electrical symbols in 
PCschematic ELautomation, you assign 
connection names to each of the connec-
tion points of the symbol. — See “Creat-
ing Symbols” on page 670.

In the database you have to specify which 
connection names the connection points 
have, when you place the symbol in a dia-
gram.

You do that in the datafield PINDATA. 
Here you type in the connection names 
separated by a comma.

The connection point having the smallest 
number in the symbol definition, is 
assigned the first number on the list — 
and so on.

If the component contains several electri-
cal symbols, these are separated by a sem-
icolon.

In the example above, where the first 
three symbols are of the same kind (07-
02-01#3), you have to type in the connec-
tion name for each of the three symbols, 
separated by a semicolon. — See the 
PINDATA datafield on page 576.

When you place the symbol on a diagram, 
it will be assigned the connection names, 
you have specified in the datafield PIN-
DATA.

Connection names for single line symbols
Connection names for symbols for single line drawings are specified with a ’ sign 
around the list of connection names for a connection point.

CONNECTION NAMES / PINDATA IN THE DATABASE

— WHAT IS CONNECTION NAMES / PINDATA ..........................................................(P. 581)

— CONNECTION NAMES FOR SINGLE LINE SYMBOLS ..............................................(P. 581)

— SYMBOLS WITH VARIABLE CONNECTION NAMES................................................(P. 582)

— CONNECTION NAMES IN FILES ............................................................................(P. 582)

— ALREADY DESIGNED SYMBOLS AND CONNECTION NAMES .................................(P. 582)

— SPECIFYING I/O STATUS FOR CONNECTION POINTS VIA THE PINDATA FIELD ..(P. 583)

Connection name: 1

Connection name: 2

Names when designing a symbol

Names when the symbol is
placed using the database

Connection name (1)

Connection name (2)
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If for instance you write 1,2,3,4,5,6;’1,3,5’;’2,4,6’ this means that the first symbol 
has six connection points, while the other has two connection points with three 
names each.

Symbols with variable connection names
If you write ? or * in a connection name, an extra text field appears in the dialog 
box Component data, when you place the symbol. Here you can type in a variable 
part of the connection name, which is the same for all of the connection points for 
the symbol. This is for instance handy for make, break and switch symbols, where 
the position is not known prior to placing the symbol in the project.

— See “Connection names with variable part in the Symbol definition” on 
page 182, “Connection data with a variable part in the name” on page 675 and 
“Wildcards/jokers” on page 542.

Connection names in files
For symbols having many connections, such as PLC’s, you can choose to place the 
pindata information in a separate file.

This file must be a text file, where you only have information on one component on 
each line.

If you write FILE= followed by the name of the file, the program will look for the 
file in the library you have specified under Settings => Directories => Database. 
Alternatively, you can type in the path leading to the file, along with the file name.

— See “Creating PLC components in the database” on page 589.

Already designed symbols and connection names
In the symbol libraries of PCschematic ELautomation, all symbols are designed 
with invisible connection names (pindata). To display in which order the connec-
tion names are specified, they are set to be visible on the figure below.

Type in the pindata

OR

Type in a filename

The contents of the
file 40MT-DSS.pin

Naming of connection names in PCschematic
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In the already designed symbols, the connection names start with the number one 
and is incremented following the reading direction.

When the symbols are selected using the PCschematic ELautomation program, the 
connection names specified in the database, automatically become visible.

Specifying IO status for connection points via the PINDATA field
IO status for connection points can be specified via the PINDATA field in the data-
base. The status is inserted in square brackets — as for IO addresses on PLCs (see 
“Addressing PLC symbols via the database” on page 584).

Syntax for specifying IO status
IO status is specified by /I: followed by two characters. The following options 
exists:

/I:ET  External terminal connection.

/I:IT   Internal terminal connection.

/I:OP  Output PLC connection.

/I:IP   Input PLC connection.

/I:EI  External terminal connection with PLC input.

/I:EO External terminal connection with PLC output.

/I:II  Internal terminal connection with PLC input.

/I:IO Internal terminal connection with PLC output.

EXAMPLE: TWO PLC SYMBOLS WITH ADDRESS AND IO STATUS SPECIFICATION:
PCSTYPE = PLCO1;PLCI1

PINDATA = 1[100.00/I:OP]; 1[100.01/I:IP]

EXAMPLE: AN OPEN SYMBOL WITH IO STATUS SPECIFICATION:
PCSTYPE = 07-02-01

PINDATA = 13[/I:ET],14[/I:IT]

Naming levels for multi-level terminals via the database
In the PINDATA field in the database you can for multi-level 
terminals specify a digit or a letter for the layer. If for instance 
you write *A;*B;*C, you can, when subsequently placing the 
first terminal symbol, specify a value for the aterisk, which is 
automatically transferred to the other symbols for the terminal:

This way you can e.g. name the first multi-level terminal 1A, 1B and 1C respec-
tively, while the other multi-level terminal is named 2A, 2B and 2C respectively.

In the dialog box Symbol article data: Type in a level number
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Addressing PLC symbols via the database

— Please also see “Connection names/Pindata” on page 581 and “Connection 
names in files” on page 582.

Addressing PLC symbols via the PINDATA field
PLC symbols can be addressed via the database. The address (the function text) is 
specified in square brackets [] after the connection name in the PINDATA field in 
the database.

Example: 1[1000.00],2[1000.01], ...

Enumerated names for symbols with one or more connection point
In the PINDATA field in the database, you can specify enumerated names for sym-
bols with one connection point.

Example: A1;..;A8;B1,..,B8

This specifies connection names for eight one-legged symbols with the connection 
names A1 - A8, and one symbol with eight connection points B1 - B8. (Symbols 
are separated by a semicolon, connection points by a comma).

Enumerated PLC addresses in the PINDATA field
The PINDATA field in the database can handle enumerated PLC addresses (func-
tion texts).

Example: A1[1000.00];..;A8;B1[2000.00];..;B8

The address in the example is automatically incremented from 1000.00 to 1000.07, 
and from 2000.00 to 2000.07 for the individual connection points.

Counting functions for PLC addresses in the PINDATA field
The PINDATA field can contain counting functions.

Example: 
1[1000.00],1G2,1V2,2[1000.01],2G2,2V2,3[1000.02],3G2,3V2,4[1000.03],4G2,4
V2

Can be written using the following notation:

{++(1)[++(1000.00)],++(1)G2,++(1)V2,}#4

OPTIONS FOR ADDRESSING PLC SYMBOLS IN THE DATABASE

— "ADDRESSING PLC SYMBOLS VIA THE PINDATA FIELD" .................................(P. 584)

— "ENUMERATED NAMES FOR SYMBOLS WITH ONE OR MORE CONNECTION POINT"(P. 584)

— "ENUMERATED PLC ADDRESSES IN THE PINDATA FIELD"...............................(P. 584)

— "COUNTING FUNCTIONS FOR PLC ADDRESSES IN THE PINDATA FIELD".......... (P. 584)

— "SPECIFYING A NUMBERING SYSTEM" ................................................................(P. 585)

— "INCREMENTING BY MORE THAN ONE" ..............................................................(P. 585)

— "FIXED NUMBER OF DIGITS ON COUNTING FIELD"..............................................(P. 585)
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Here the contents of the curled brackets is repeated four times ( {...}#4 ).

Please note that the character just before the last curled bracket ( } ) — in the exam-
ple above a comma ( , ) — specifies whether the text inside the curled brackets 
describes one or more symbols.

If this character is a comma ( , ), this means that the text contains a list of pindata 
for one single symbol.

If the character is a semicolon ( ; ), each repetition contains data for a new symbol.

Specifying a numbering system
Which system of notation / numbering system to count according to, can be speci-
fied after ++(. This is specified with the characters B, D, H or O — Binary, Deci-
mal, Hex or Octal, respectively. When no system of notation is specified, the 
decimal numbering system is used.

Example: {++(1)[++(O1000.00)],++(1)G2,++(1)V2,}#4

In the example above, the PLC is addressed according to the octal numbering sys-
tem, while the others are addressed according to the decimal numbering system.

Incrementing by more than one
When you wish to increment by more than one, this can be specified after ++. E.g. 
++2(1).

Example: {A++(0)[++2(00.00)],COM;B++(0)[++2(00.01)],COM;}#8

A0[00.00],COM;B0[00.01],COM; A1[00.02],COM;B1[00.03],COM; ...

When you wish to decrement, ++ is replaced by --. 

Fixed number of digits on counting field
When you want a fixed number of digits on a counting field, you must write : after 
the number, followed by a number between 1 and 9.

Example: {A++(0)[ 00.--2(07:2)],COM;B++(0)[00.--2(01:2)],COM;}#8
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MECHANICAL SYMBOLS

You can also attach a mechanical symbol 
to a component. The name of the file in 
which the symbol is saved, should be 
placed in the database field MECTYPE.

Please note that you can also specify that 
other fields in the database contains 
mechanical symbols — see “Mechanical 
symbols” on page 595. Hereby you can 
have different mechanical symbols for the 
same component. The component can 
therefore be illustrated differently, on dif-
ferent machanical pages in the project.

It is therefore possible on one page to 
show an operating cabinet with the front closed, so that you only see the compo-
nents visible with the front closed. Another page could then show the bottom plate. 
You can therefore have database fields, each containing mechanical symbols for 
different purposes — for instance PNEUTYPE, FRONTTYPE and MECTYPE.

Creating mechanical symbols automatically
When you want to program to automatically create a mechanical symbol of 30x50 
mm, write #x30mmy50mm in the field MECTYPE. If you write #r40mm, the pro-
gram creates a circle with a radius of 40 mm as the mechanical symbol.

These mechanical symbols has no connection points.

Specifying symbol state for mechanical symbols
For mechanical symbols created with states — see “Creating symbols with states” 
on page 686 — you can specify which state the symbol shall be in, when it is placed 
in the project. You specify this in the MECTYPE field using the § character suc-
ceeded by the state number.

If the symbol XXXXX is to be placed in state 2, you therefore write XXXXX§2 in 
the MECTYPE field.

— Read more about mechanical symbols in “Mechanical Load from the Database” 
on page 609, “From Mechanical to Electrical drawing” on page 620 and “Loading 
components from a Ground plan page” on page 653.

ACCESSORIES IN THE DATABASE

To connect accessories to a component in the database, you first have to create a 
record for each accessory component, and place these records in the relevant 
folder(s) in the database menu. These records must all contain an article number 
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they can be identified by in the database — for instance in the EANNUMBER 
field.

Specifying that a component has accessories
To specify, that a component has accessory parts, you type in the article number in 
the ACCESSORY field for the component in the database. In case a component 
has more than one accessory part, their article numbers must be separated by a sem-
icolon (;) in the ACCESSORY field.

If you need more than one of a specific 
accessory part, you type # followed by the 
number needed, after the EANNUMBER 
of the accessory part in the ACCESSORY 
field.

If you for instance need two of the accessory part 1234567890123, you type in 
1234567890123#2 in the ACCESSORY field.

In PCschematic ELautomation you can specify whether to include the accessories 
in your project lists. — Please refer to “Specifying from where to collect compo-
nents” on page 536 for further details about this.

— See “Supportsymbols in the PCSTYPE field” on page 580 also.

Specifying the contents of the ACCESSORY field in a file
As for connection names — see “Connection names/Pindata” on page 581 — you 
can specify the contents of the field ACCESSORY in a file. This is done by writing 
FILE= followed by the name of the file.

In this file one article number can be written on each line — such as:

3240900056666

5908326935039

1236374000001

There is no special requirements for the file name, but if you do not specify a path, 
the program searches for the file where the database catalog is pointing.

— Read more in “Connection names in files” on page 582.

Unit parts list can be specified in the field ACCESSORY
If you write UNIT= in the ACCESSORY field, this specifies that the article num-
bers in the ACCESSORY field is a unit parts list. This field therefore does not con-

SPECIFYING ACCESSORIES IN THE DATABASE

— "SPECIFYING THAT A COMPONENT HAS ACCESSORIES" ......................................(P. 587)

— "SPECIFYING THE CONTENTS OF THE ACCESSORY FIELD IN A FILE"...............(P. 587)

— "UNIT PARTS LIST CAN BE SPECIFIED IN THE FIELD ACCESSORY"..................(P. 587)

Two of this part
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tain accessories to the components, but is a specification of what the component 
consists of.

If for instance you write UNIT=112345566;504509345;123871312 this means that 
the component consists of the three listed article numbers.

If you in the list setting for a parts list or a components list select Articles from Unit 
Lists and Drawings — see “Specifying from where to collect components” on 
page 536 — these three article numbers will be included in the list in stead of the 
specified article number for the component.

Typing in unit list information in the database, functions just as inserting a unit 
parts list in the project for the component. — Read more about this in “Inserting 
Unit Drawings” on page 555.

If the list of article numbers is long, you can place the article numbers in a file, and 
write UNIT=FILE= followed by the name of the file.

The article numbers must be placed on separate lines — as described in “Specifying 
the contents of the ACCESSORY field in a file” on page 587.

SPECIFYING REF. LETTER FOR THE SYMBOL IN THE DATABASE

When you type in a letter in the field REFID, symbols for the component will be 
assigned a name starting with this letter, when placing the symbols in a project.

If for instance you write K, the letter K will be suggested as default reference letter 
when you place the symbol in a diagram.

However, to make this work you first have to choose Settings => Database => 
Database => Database setup => Component data, and there choose REFID in 
the field Reference letter. If the field has no contents in the database for the chosen 
symbol, the reference letter (the symbol name) from the symbol definition is 
applied. — See “Creating Symbols” on page 670.

SPECIFYING SYMBOL SUB NAMES FROM THE DATABASE

PCschematic ELautomation can handle sub names on symbols intelligently, as 
described in “Sub names on symbols” on page 185. To specify sub names on sym-
bols via the database, write the following in the field PCSTYPE:

Hereby the component will contain the sub names F, Q1 and Q2.

INSERT "-" IN FRONT OF SYMBOL NAMES AUTOMATICALLY

YOU CAN MAKE THE PROGRAM INSERT A MINUS IN FRONT OF ALL SYMBOLS 
BEING PLACED IN THE PROJECT, BY CHOOSING SETTINGS => POINTER/
SCREEN AND SELECT INSERT - IN FRONT OF SYMBOL NAMES. — SEE 
“POINTER/SCREEN” ON PAGE 815.
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Specifying pindata in the database for components with sub names
When you specify connection names / pindata in the database for components with 
sub names, you specify these in the order in which the symbols appears in the 
PCSTYPE field:

As you can see, the fact that sub names are being applied for the component, makes 
no difference for how to fill out the PINDATA field.

— See an example on this in the pickmenu:

CREATING PLC COMPONENTS IN THE DATABASE

To create a PLC component in the database, do this:

1) Create the necessary PLC I/O symbols for the PLC, if you wish to use other 
PLC symbols than the ones already created in PCschematic ELautomation. 
— See “Creating PLC I/O symbols” on page 697.

2) Create PLC reference symbol(s) for the PLC, if you wish to use other PLC 
reference symbols than the ones already created in PCschematic ELautoma-
tion. — See “Creating PLC reference symbols” on page 700.

3) Press [d] to enter the Database menu, where you click on the Pencil, to edit 
records.

4) In the dialog box Edit Record: You can now either click the Insert button 
and create a new record with the PLC, or choose an existing PLC component 
in the database and update it. — See “Editing records in the database” on 
page 570.

Click on this symbol (with sub names)

... and you get this
pickmenu

Sub names are shown here
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5) In the field PCSTYPE you now specify the PLC reference symbol(s) for the 
PLC, followed by its PLC I/O symbols. — See “Electrical symbols” on 
page 576, and e.g. “Alternative symbols for PLC´s” on page 578.

6) In the PINDATA field you now specify the connection names for the PLC 
reference symbol(s) followed by the connection names for the PLC I/O sym-
bols — see “Connection names/Pindata” on page 581.
This information most likely becomes quite comprehensive, so you will have 
to place it in a file, as described in “Connection names in files” on page 582:

It is recommended to address the PLC’s in the database as displayed in the 
example above. — See “Addressing PLC symbols via the database” on 
page 584.

7) Add the remaining relevant data for the component — such as the EANnum-
ber — and click on Post and then on Close.

8) The PLC component is now created/updated, and you return to the Database 
menu.

— See also “Graphical creation of New Components in the Database” on page 572, 
“Information about the component in the database” on page 574 and “Electrical and 
Mechanical symbols for components” on page 576.

SIMPLE NOTATION FOR ADDRESSES IN PLCS

YOU DO NOT NEED TO APPLY THE COMPACT NOTATION DISPLAYED IN 
THE FIGURE ABOVE. YOU CAN JUST SPECIFY EACH INDIVIDUAL ADDRESS 
IN SQUARE BRACKETS AFTER THE CONNECTION POINTS. — SEE 
“ADDRESSING PLC SYMBOLS VIA THE PINDATA FIELD” ON PAGE 584.
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DATABASE SETTINGS

This chapter deals with how the information from the attached database is repre-
sented in PCschematic ELautomation.

The work with constructing the database itself, as well as the import of databases 
from component vendors, takes place in an independent database program.

This can either be the PCschematic Database program, or any other open database 
program you use in conjunction with PCschematic ELautomation — see “Choos-
ing a database” on page 604.

If you are using the PCschematic Database program, you can start it by choosing 
Tools => Database in PCschematic ELautomation. — Please refer to the PCsche-
matic Database manual for further details.

If you want to see how to fetch article data from components in the database, please 
read “Using the database” on page 559.

MAPPING OF THE DATAFIELDS IN THE DATABASE

When you are working with a database in PCschematic ELautomation, you can 
determine which component information from the database will be displayed in 
PCschematic ELautomation, and how the program shall interpret the information 
from the database.

To determine this you choose Settings => Database, and then click on Database 
setup.

You then enter the dialog box Database setup. Here you specify the settings you 
need, and click OK to accept the changes, or Cancel not to save the changes.

THIS CHAPTER DESCRIBES

— MAPPING OF THE DATAFIELDS IN THE DATABASE ............................................. (P. 591)

— TRANSFERRING ARTICLE DATA TO SYMBOLS AND LINES................................... (P. 593)

— CHOOSING PRODUCT/FABRICATE IN THE DATABASE........................................ (P. 596)

— APPROVED AND OBSOLETE COMPONENTS......................................................... (P. 597)

— CHOOSING A DATABASE MENU ......................................................................... (P. 600)

— CHOOSING MENUS WHEN USING OTHER DATABASE PROGRAMS....................... (P. 601)

— LINKS TO E.G. PDF FILES OR INTERNET ADDRESSES IN THE DATABASE ........... (P. 603)
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The Field setup tab looks like this:

Which database fields are displayed in PCschematic ELautomation
On the tab Field setup, the datafields in the Show fields column are the datafields 
from the database, which will be displayed in PCschematic ELautomation.

Here they will be displayed under the name specified in the Field title column. Any 
name in this column can be changed if you click on the name, and type in a new 
field name.

The order in which the field names are listed in this dialog box, is also the order in 
which the fields are displayed in the database menu. If for instance you want Price 
to appear first on the list, just click on Price, and drag the field to above the first 
field in the list. This will make these fields exchange places. The fields in between 
the two fields will not change places.

In the Alignment column you determine whether the text is to be left-, right- or cen-
tre-adjusted. If you want to change the alignment, just click on the alignment field, 
and choose the desired alignment in the menu that pops up.

Adding or removing fields
Under Free fields to the left in the dialog box, you can see the fields in the data-
base, which are not being displayed in PCschematic ELautomation at the present.

If for instance you want to display the field TAX, you click on the field and then 
click on the Transfer button.

To remove a field from the Show fields column, just click on the field, and then 
click on the Revert button.
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To have all of the database fields displayed in PCschematic ELautomation, you 
click on the Transfer all button.

Not to display any of the database fields, you click on the Revert all button. Please 
note that the datafields are not deleted, but transferred to the column of Free fields.

TRANSFERRING ARTICLE DATA TO SYMBOLS AND LINES

Click on the tab Component data in the upper part of the dialog box.

When you transfer article data from the database to symbols or lines, it is important 
that you state which database fields will be the Article, Type and Function fields in 
the article data menus.

This is stated in the fields Article, Type and Function in the dialog box.

The database field mentioned in the Article field, will also become the permanent 
search field in the bottom of the Database menu on the tab Article/Type.

In the field Alt. article you specify which field in the database will be used as arti-
cle number, if the datafield you have chosen as Article has no contents for a compo-
nent. This field is for instance useful when you start up using EAN numbers in 
stead of item numbers. If you set Article to EANNUMBER and Alt. Article to 
ITEMNUMBER, the symbols in the project will get the EAN number where a such 
exists. If no EAN number exists, they get an item number instead.



PAGE 594 PCschematic ELautomation 10.0

DATABASE SETTINGS

Thus you make sure that a symbol always has got an article number, without having 
to type in item numbers as EAN numbers in the database.

Parts list prices
When you insert datafields of the type Parts list, you can then choose to insert the 
datafields Price 1 and Price 2.

In the lower-right corner of the dialog box, you specify which of the database fields 
that shall be used as Price 1 and Price 2.

If a discount factor have to be included for the two prices, this is specified in Dis-
count 1 and Discount 2 respectively.

Symbol
In the Symbol field, you specify which field in the database contains the file name 
of the electrical symbol itself. — See “Electrical symbols” on page 576.

To create electrical symbols directly from the database, you type in the dimensions 
of the symbols in the PCSTYPE field for the component. — Read more about the 
syntax in “Syntax for automatic creation of symbols” on page 215.

Reference letter
Here you can specify which reference letter the symbol is assigned when it is 
placed in a project. If this field contains a letter, this letter will be applied. If the 
field has no contents, the symbol will be assigned the reference letter from the sym-
bol definition. — See “Specifying Ref. Letter for the symbol in the Database” on 
page 588.

Pin names
Here you specify which field in the database to use to assign names to the connec-
tion points of the electrical symbols. — See “Connection names/Pindata” on 
page 581.

REPLACE ARTICLE NUMBER WITH ALTERNATIVE ARTICLE NUMBER

IF YOU WANT TO REPLACE THE ARTICLE NUMBER WITH THE ALTERNATIVE 
ARTICLE NUMBER FOR ALL SYMBOLS IN A PROJECT, CHOOSE FUNCTIONS => 
SPECIAL FUNCTIONS => EXCHANGE ARTICLE WITH ALT. ARTICLE ON ALL 
SYMBOLS.
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Mechanical symbols
In the Mechanical sym. field you specify 
which field(s) in the database contains the 
file name of the mechanical symbol(s). 
These symbols displays the physical 
appearance of the component. — Read 
more about this in “Mechanical symbols” 
on page 586 and “Mechanical Load from 
the Database” on page 609.

The first field in the list is understood as the default field (here MECTYPE), and is 
used on all pages of the type Groundplan/Mechanical, where no attached field is 
specified.

Adding fields for Mechanical symbols
To add a field to the list of mechanical 
symbol fields, click the Plus button.

You then enter the dialog box Mechani-
cal symbol (see the figure to the right), 
where you select the fields that contains 
mechanical symbols in the attached data-
base, and click OK.

Deleting fields for Mechanical symbols
To delete a field from the list of fields 
with mechanical symbols, select the field 
in the list (see the figure), and click the 
Minus button.

Moving a field in the list of Mechanical symbols
To move a field with mechanical symbols, click on the field in the list, and then 
click the Up-arrow or the Down-arrow button.

Creating mechanical symbols directly from the database
To create mechanical symbols directly from the database, type in the symbol 
dimensions in the MECTYPE field for the component. — Read more about the 
syntax for automatic creation of symbols in “Syntax for automatic creation of sym-
bols” on page 215.

Additionals
A component can have certain additional parts attached to it, which also must be 
used each time the component is used, but do not have to appear anywhere but in 
the parts lists for the project. This could for instance be a base for a relay.

In the Additionals field you state which field in the database contains this type of 
information. — See “Accessories in the database” on page 586.
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Use DB-Cache
If the applied database is placed on a network, and you use the dBase database for-
mat, you can select Use DB-Cache, which makes the database work faster.

If you are not working on a network, this option makes no difference.

Save settings
Click OK to save the changes you have carried out. If you click Cancel, your 
changes will not be saved.

PRODUCT CHOICE OR FABRICATE CHOICE IN THE DATABASE MENU

In the Database menu you can choose whether it shall be possible to show compo-
nents based on their fabricate — or the like.

To choose which of the database fields to let PCschematic ELautomation sort 
after, do the following:

1) Choose Settings => Database => Database setup:

2) In the dialog box Database setup: Click on the tab Component search, click 
on the Down arrow in the Fabricate field, and choose which database field 
to divide by — for instance Manufactur. (Choose (None) in order not to use 
this Fabricate menu).

3) Click OK to leave the dialog box Database setup, and click OK to leave the 
dialog box Settings.

— See how to apply this option in “Selecting a Fabricate / Vendor” on page 564.

Show only table menu points containing components of the selected fabricate
When you wish the table menu in the right-hand corner of the Database menu only 
to display those table menu points, which contains components of the selected fab-
ricate, do the following:

1) Choose Settings => Database => Database setup => Component search.
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2) Select Show only tablemenu points containing the selected fabricates com-
ponents.

APPROVED AND OBSOLETE COMPONENTS IN THE DATABASE

In PCschematic ELautomation it is possible to discern between approved and non-
approved components, as well as between obsolete and non-obsolete components.

Specify which database fields to use for Approved and/or Obsolete
To specify which of the fields in the selected database that PCschematic ELauto-
mation shall conceive as Approved and Obsolete, do the following:

1) Choose Settings => Database => Database setup.

2) In the dialog box Database setup: Click on the tab Component search, and 
click on the Down arrow in the Approved and the Obsolete field, to choose 
which database field contains this information.

APPROVED AND OBSOLETE FIELDS IN THE COMPONENT DATABASES

IN PCschematic ELautomation TWO SPECIAL FIELDS EXISTS IN THE COMPONENT VEN-
DOR DATABASES FOR THE PROGRAM: AN APPROVED FIELD AND AN OBSOLETE FIELD.

THE DATABASE FIELD APPROVED IS USED TO GET A BETTER SURVEY OF THE DATABASE, BY 
MAKING IT POSSIBLE ONLY TO SHOW THOSE OF THE COMPONENTS THAT YOU TYPICALLY USE 
IN THE PROJECTS. — SEE “DISPLAY ONLY APPROVED COMPONENTS AND HIDE OBSOLETE 
COMPONENTS” ON PAGE 599.

THE DATABASE FIELD OBSOLETE IS USED TO MARK THE OBSOLETE COMPONENTS IN THE 
DATABASE. THIS MAKES IT POSSIBLE TO MAINTAIN OBSOLETE COMPONENTS IN THE DATA-
BASE, WITHOUT THE RISK OF USING THESE COMPONENTS WHEN CREATING NEW PROJECTS.

Click here and choose the field
in the applied database
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3) Click OK to leave the dialog box Database setup, and click OK to leave the 
dialog box Settings.

Using non-boolean fields for Approved/Obsolete
In PCschematic Database it is possible to create boolean datafields. Only when one 
of these boolean datafields is used as Approved/Obsolete, you will get the option to 
set a check mark for Approved and/or Obsolete in the Database menu in PCsche-
matic ELautomation.

If you choose a non-boolean field, you get the option to specify which values in the 
chosen datafield that identifies approved components.

These values must be separated by a semicolon (;).

In the component vendor databases for PCschematic ELautomation, the fields 
Approved and Obsolete are created as boolean fields.

Displaying the fields Approved and Obsolete in the database menu

To display the fields Approved and Obsolete in the Database menu, do this:

1) Choose Settings => Database => Database setup.

2) In the dialog box Database setup: Click on the tab Field setup.

3) On the tab Field setup: Click on the fields Obsolete and Approved in the col-
umn Free fields and drag them over to the column Show fields:

THE FIELDS APPROVED AND OBSOLETE DOES NOT NECESSARILY HAVE TO BE 
DISPLAYED IN THE DATABASE MENU.

Click on the fields and drag them over to the Visible fields
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Display only Approved components and hide Obsolete components
When you have selected the approved components, you can set the Database menu 
to display approved components only. This makes it faster to locate the components 
you typically use. When you need to fetch other components, you can set the Data-
base menu to display all components again.

When you wish to see approved components only, choose Show approved compo-
nents only in the Database menu.

Correspondingly, you can hide obsolete components by selecting Hide obsolete 
components in the Database menu.

Only display table menupoints containing Approved/Obsolete components
When you want the tablemenu in the upper left-hand corner of the Database menu 
only to contain menupoints, which actually contains approved components, do the 
following:

1) Choose Settings => Database setup => Component search.

2) Select Show only tablemenu points containing approved components.

When you wish to do the same for obsolete components, select Show only table-
menu points containing not obsolete components.

Approving all article numbers in a project
To set all the applied article numbers in the active project to Approved in the data-
base, choose Functions => Special functions => Set all articles as approved in 
the database.

No editing of approved/obsolete components
If you will not allow editing of approved and/or obsolete components, do this:

1) Choose Settings => Database settings => Component search.

2) Select No editing of approved components and/or No editing of obsolete 
components.

— See the figure in “Only display table menupoints containing Approved/Obsolete 
components” on page 599.
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CHOOSING A DATABASE MENU

A menu structure can be attached to the database, such as the component structure 
menu (FAFGE), in which you can group the database components according to 
their use. This makes it easier to locate the desired components.

To do this, you click on the Database menu tab.

In the figure above, the menu Dbmenu.dbf is attached to the database Eldemo.dbf.

If you do not wish to have a menu attached, you click the No Menu button in the 
lower-right corner.

If you want to attach an existing menu, you click Open Menu. You then enter the 
dialog box Open, where you choose the desired database menu.

When you choose a database menu, which have been correctly created in PCsche-
matic Database, the fields Table link, Description, Menu index and Menu table 
will then be filled out correctly.

The connection between the menu and the database
The field Table link contains a code, which separates the different groups in the 
menu. When the menu and the database exchange information, it takes place using 
this field.

The field Description contains the names of the groups in the menus.

Name of the menu Name of the database

Under normal circumstances
the contents of these three fields
are not to be changed

Datafield in the database
containing a menu link
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The field Menu index contains information on how the individual groups are 
placed within the menu.

To enable the database and the menu to communicate, there is also a datafield in the 
database, which contains a menu link. On the figure below this field is called 
TABLEGROUP.

If you have a component/record in the database, where it says 2210 in its TABLE-
GROUP field, this connects the component/record to the record, where it says 2210 
in the Menu link field of the menu.

In the menu it says that the group Extra protection relays has got the menu link 
2210. Therefore the program knows, that the component mentioned belongs to the 
group Extra protection relays.

On the figure above, you can therefore see, that Component XX belongs to the 
group Extra protection relays.

For a more detailed explanation, please refer to the PCschematic Database manual.

CHOOSING MENUS WHEN USING OTHER DATABASE PROGRAMS

If you are using another database program than PCschematic Database, you will 
have an extra field on the Database menu tab.

When you click on the down-arrow in the Menu Table field, it is displayed which 
tables are available for the chosen database.

Here you specify which table in the other database program, that contains the menu 
structure.

— Please read more about menus and databases from other systems in “Menu 
structures in other database formats” on page 607.

DatabaseMenu

Component XX
EANno. 4012233029006
HPFI switch
Tablegroup:2210Table link: 2210

Description: Extra protection relays

Choose menu table in
another database program
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LINK ALIAS

On the tab Link Alias you can define a number of link alias’es. The purpose of 
these are that you can specify an alias for a path to e.g. a component catalogue, 
which is placed as a pdf file somewhere on your PC or on the network you are 
attached to. This alias can then be used in the database, when you for instance wish 
to link to the catalogue for a specific component.

(The idea behind using an alias is explained in further detail in “The Alias concept” 
on page 820 — please note that the syntax is different for these two types of 
alias’es).

To edit, create or delete a File Link Alias, right-click in the dialog box, and choose 
either Edit, New or Remove.

Using a File Link Alias
When you are using a File Link Alias in the field for 
a component in the database, you must place a % 
character before and after the name of the alias, as displayed in the figure above.

A File Link Alias can be applied in all links, unless you also use the syntax FILE=. 
(FILE= is for instance used for pindata / cable colors).

Please note: Windows environment variables can also be used in the database fields.

Create a Preferred Link field
At the top of the tab Link Alias, you can specify a Preferred Link field.

When you have selected a record in the Database menu, where some of the fields 
of this record contains links, and you then click the Open link button, the link in 
the field that you have specified as Preferred Link field will be opened. — Read 
more about this in “Open link for selected record in Database menu” on page 569.
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LINKS IN DATABASE FIELDS

Database fields can contain links to for instance PDF files, internet addresses or e-
mail addresses.

PCschematic ELautomation will try to detect these links in the database by itself. 
If this does not succeed, you can write the full link by specifying the applied proto-
col, such as for instance:

- http://www.pcschematic.com/...

- ftp://ftp.pcschematic.com/public/my_file

- mailto:obl@company.com

File names will be recognised when they follow the syntax \\server\path\filename 
or x:\path\filename.

When you are using a field in the database for this purpose, all of the contents of the 
field is conceived as the specification of the address. This meaning that you can not 
write comments or the like in the field.
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CHOOSING A DATABASE

PCschematic ELautomation supports dBase and Access databases directly. When 
PCschematic ELautomation is installed for the first time, the program has got the 
database demo attached. This database has been created in the Access format.

However, PCschematic ELautomation is open for other database programs which 
are supported by either BDE, MDAC or ODBC.

Therefore you can also apply databases, which are created and maintained by other 
database programs. Thus you can apply MS-SQL, Oracle and most of the major 
database programs in conjunction with PCschematic ELautomation.

CHOOSING A DATABASE

When you want to specify which database you want to attach to PCschematic 
ELautomation, you choose Settings => Database => Select database file.

You then enter the following dialog box:

Here you first specify whether you want to apply a database the normal way — see 
“Opening a database without a database alias” on page 605 — or whether you wish 
to use a database via a BDE alias — see “Databases connected via BDE alias” on 
page 606.

THIS CHAPTER DESCRIBES

— CHOOSING A DATABASE .....................................................................................(P. 604)

— DATABASES WITH DATABASE ALIAS .................................................................. (P. 605)

— DATABASES WITHOUT DATABASE ALIAS............................................................ (P. 606)

— MENU STRUCTURES IN OTHER DATABASE FORMATS..........................................(P. 607)
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OPENING A DATABASE WITHOUT A DATABASE ALIAS

When you want to attach a database created in PCschematic Database, dBASE or 
Access, or a database which is opened via a UDL file — see below — you click on 
Database files (*.mdb, *.udl, *.dbf, *.db), and click Next.

You now enter the dialog box Open.

Here you click your way to the desired database, and click Open.

Having chosen the database, you click Next, and the database is attached to 
PCschematic ELautomation.

ON UDL FILES

UDL IS SHORT FOR UNIVERSAL DATA LINK — ALSO CALLED MICROSOFT 
DATA LINK. UDL FILES CAN BE CREATED FROM THE PCschematic Data-
base PROGRAM.
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DATABASES CONNECTED VIA BDE ALIAS

When you want to attach a database via a BDE alias, this is also an option. How-
ever, this requires that you have detailed knowledge of the settings of the other 
database program.

When you have chosen Settings => Database => Select database file, you click 
on Database Alias (BDE alias), and then click Next.

You then enter this dialog box:

Here you have to choose a so-called database alias, which makes it possible to 
fetch data from other database systems.

If an appropriate database alias have not been created, you have to start the program 
BDE Administrator. This is described in the PCschematic Database manual.
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Choosing the table in the database
Now select the table in the database which contains the component data.

Click Next, and the database is attached to PCschematic ELautomation.

MENU STRUCTURES IN OTHER DATABASE FORMATS

If you also have a table representing a database menu in another database system, 
you specify this in Settings => Database => Database settings => Database 
menu. Read more about this in “Choosing Menus when using Other database pro-
grams” on page 601.

When you want to work on the menu structure in another database system, it is rec-
ommended to create the menu in PCschematic Database, and then export the menu 
to the other database format. This ensures you that the menu fulfils the internal 
requirements of PCschematic ELautomation.

You can also choose to apply a menu, created in the PCschematic Database format, 
together with a database from another system. This makes no difference for 
PCschematic ELautomation.

— Please refer to the PCschematic Database manual for further information on 
database menus.
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PROGRAMMABLE BARCODE SCANNERS

If you have a programmable barcode scanner, you can use it to collect symbols 
from the database.

When you have programmed the scanner properly, all you have to do is to scan in 
the barcode from the component vendor catalog. This gives you the symbol for the 
component directly into the cross hairs.

This requires, of course, that the component vendor have included the particular 
component in their database to PCschematic ELautomation.

The reason why this is possible, is that there have been created short-cut keys to the 
search criteria in the Database menu.

Short-cut keys in the database menu
In the Database menu the following short-cuts have been created, for the search 
criteria tabs in the lower-right corner of the dialog box:

Programming the scanner
Exactly how the scanner should be programmed, depends on the applied scanner, as 
well as whether the scanner can send commands while scanning.

As an example, the scanner could be programmed like this: "d"Ctrl-
a<EANNR>Alt-o.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO USE A BARCODE SCANNER IN THE PROGRAM.

SHORT-CUT FIELD SHORT-CUT FIELD

[CTRL+A] ITEM NO [CTRL+1] 1.SEARCHKEY

[CTRL+T] TYPE [CTRL+2] 2.SEARCHKEY

SHORT-CUT KEYS IN THE DATABASE MENU
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MECHANICAL LOAD FROM THE DATABASE

When you have got a database connected to PCschematic ELautomation, it is pos-
sible to perform a so called mechanical load, which gives you the mechanical sym-
bols you need to make a mechanical drawing, displaying how the components 
appear in real life.

INSERTING A PAGE FOR A MECHANICAL DRAWING

To generate a mechanical drawing, you first have to create a page on which to place 
the drawing:

1) Enter the Page Menu, click on Add new and click OK to insert a Normal 
page.

2) In the dialog box New: Click on the template DPSA3MECH and click OK.

3) In the Page menu: Click OK.

THIS CHAPTER DESCRIBES

— INSERTING A PAGE FOR A MECHANICAL DRAWING.............................................(P. 609)

— PERFORMING THE MECHANICAL LOAD...............................................................(P. 610)

— PLACING MECHANICAL SYMBOLS ACC. TO REFERENCE DESIGNATIONS .............(P. 613)

— PLACING MECHANICAL SYMBOLS AS BOXES ......................................................(P. 613)

— PLACE ONLY MECHANICAL SYMBOLS NOT PLACED ON OTHER PAGES ...............(P. 614)

— MESSAGES AND WARNINGS DURING MECHANICAL LOAD ..................................(P. 614)

— SELECTING UNKNOWN MECHANICAL SYMBOLS..................................................(P. 614)

— DISPLAYING CONNECTIONS FOR MECHANICAL SYMBOLS ..................................(P. 615)

— REFERENCES IN LISTS TO THE LOCATION OF A MECHANICAL SYMBOL.............(P. 615)

— REFERENCES FROM MECHANICAL TO ELECTRICAL SYMBOLS............................(P. 616)

— MEASUREMENT OBJECTS ....................................................................................(P. 617)

http://www.dps.dk/english/Video/Product_videos.htm
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PERFORMING THE MECHANICAL LOAD

After this, the mechanical symbols can be placed on the page. These will be loaded 
automatically from the database, in which the electrical symbols, through their 
EAN13 number/article number, are attached to the mechanical symbols.

Now click on the Symbols button, and choose Functions => Mechanical load.

Specify which symbols to place
In the appearing menu you click on Load selected, type in -Q* and click on OK. 
You will now load all mechanical symbols, attached to the components in the dia-
gram, beginning with -Q. — Read more about how to select the symbols in “Wild-
cards/jokers” on page 542.

Specify which Type of mechanical symbols to place
Please note: This is only relevant it your database contains different types of 
mechanical symbols — see “Mechanical symbols” on page 595.

In the field Database symbol field, you can further specify which type of mechani-
cal symbols you wish to place on the page. Please note that you can only place one 
type of mechanical symbols on a project page. When you specify a Database sym-
bol field here, the Database symbol field is automatically changed under Settings 
=> Page setup — see “Database symbol field” on page 824.

Choose how to place the mechanical symbols
You can choose between:

1) Placing mechanical symbols from a list: See “Manual placing via list” on 
page 611

SELECT INCLUDE IN MECHANICAL LOAD

MECHANICAL SYMBOLS ARE ONLY PLACED FOR COMPONENTS HAVING 
INCLUDE IN MECHANICAL LOAD SELECTED IN THE DIALOG BOX SYMBOL 
ARTICLE DATA.
— SEE “INCLUDE IN MECHANICAL LOAD” ON PAGE 181.

Specify which type of
mechanical symbols
you wish to place
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2) Placing the mechanical symbols directly on the page: See “Placing all 
mechanical symbols in a single operation” on page 611

1. Manual placing via list
If you select Manual placement from list, you get a window with a survey of the 
mechanical symbols you can place:

This is handled as described in “Placing symbols via lists” on page 650, “Placing 
the components from the Components List window” on page 651 in particular.

2. Placing all mechanical symbols in a single operation
If you do not select Manual placement from list, the mechanical symbols will be 
placed directly on the page. You have two options for how to do this, depending on 
whether you choose Space symbols and align:

2.1 Space symbols and align
If you select Space symbols and align, you first get a pen-
cil in the cross-hairs, and then click on the position on the page, where you wish to 
place the first symbol. Then click where you wish to place the last symbol. Please 
note that the symbols will either be placed on a vertical or a horisontal line. If there 
is not enough space for the symbols within the specified area, you will be notified 
about this with the following message:

Click OK, and point out a new start position for the remainig symbols.
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2.2 Place the symbols in a pile
If you do not choose Space symbols and align, you get a 
pencil in the cross hairs, and then click somewhere on the page.

The mechanical symbols are then placed in a pile.

REARRANGING THE MECHANICAL SYMBOLS

For a more appropriate arranging of the symbols, mark up a window surrounding 
the symbols.

Then choose Edit => Space. Now click where the first mechanical symbol shall be 
located. In the menu that appears you select Align as well as Sort by name.

Click OK.

Now click so that you only draw a horizontal line, which is shorter than the width 
of a single mechanical symbol. Hereby the mechanical symbols will be placed end 
to end.

By rearranging the symbols, you can then create your own switchboard.

— See "Mechanical load" in the PCschematic Tutorial manual for another exam-
ple.
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Function texts are also transferred during mechanical load
The function text for the components is also transferred to the mechanical symbols 
during mechanical load.

PLACING MECHANICAL SYMBOLS ACC. TO REFERENCE DESIGNATION

When you select Functions => Mechanical Load and click the Used names but-
ton, you enter the dialog box Select name, where you can select which reference 
designation to place mechanical symbols for:

PLACING MECHANICAL SYMBOLS AS BOXES

If you do not wish to use the mechanical symbols included in the component data-
bases for PCschematic ELautomation, select Place symbol as boxes in the dialog 
box Mechanical load.

Hereby the mechanical symbols are placed as boxes with connection points. The 
boxes gets the same measures as the mechanical symbols in the databases. If meas-
ures has been specified in the database, these measures are applied. Connection 
points are only placed if these are specified in the database.

— See “Performing the Mechanical load” on page 610.
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PLACE ONLY MECHANICAL SYMBOLS NOT USED ON OTHER PAGES

If you in select Place only symbols not used on other mechanical pages in the dia-
log box Mechanical Load, PCschematic ELautomation will only place mechani-
cal symbols, that do not appear on other mechanical pages in the project.

MESSAGES AND WARNINGS DURING MECHANICAL LOAD

If something unexpected happens during the mechanical load, you will get mes-
sages and warnings displayed in a window:

The cause can here be:

1) An article number have not been typed in for the electrical symbol in the 
project

2) The component does not have an attached mechanical symbol

3) The mechanical symbol have been removed from the hard disk

This should make it easier to make corrections succeedingly.

SELECT UNKNOWN MECHANICAL SYMBOLS

When electrical symbols are deleted in a project, this might result in mechanical 
pages containing mechanical symbols for components no longer applied in the 



PCschematic ELautomation 10.0 PAGE 615

MECHANICAL LOAD FROM THE DATABASE

project. To select these mechanical symbols, you can right-click on a mechanical 
page and select Select unkonow Components:

Hereby the window Select unknown components is displayed, and all mechanical 
symbols, for which no electrical symbols exists, are selected on the page.

You can now delete the selected symbols, or for instance copy them to another 
page. The window Select unknown components functions like the Select name 
and the Select components windows, as described in “Finding symbols based on 
the Component Name” on page 248.

DISPLAYING CONNECTIONS FOR MECHANICAL SYMBOLS

When you move a mechanical symbol on a 
Groundplan page, it is displayed which of the 
other mechanical symbols are connected to the 
symbol — according to the information about 
the electrical connections on the electrical dia-
gram pages. This makes it easier to find the opti-
mal position for the mechanical symbol.

You get the same result when you right-click on 
a mechanical symbol and choose Mark net.

The function can be activated/deactivated by 
choosing Settings => Pointer/Screen and then 
click on Net router.

REFERENCES IN LISTS TO THE POSITION OF MECHANICAL SYMBOLS

If a reference system have been placed on a project page containing mechanical 
symbols, it is also possible to refer to the position of the symbols on the page 
according to the reference system.
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Placing the reference system
The reference system is placed on the 
page by choosing Settings => Page 
data => Reference, as described in 
the PCschematic ELautomation 
manual. Here the reference system 
can be activated vertically and hori-
zontally at the same time.

Please note, that the reference chosen 
to be Main reference is mentioned 
first in the datafield.

Inserting the datafield
To refer to the position of the 
mechanical symbols, choose Func-
tions => Insert Datafield, as explained in “Datafields” on page 134. Here you 
click on Parts/Components list, and choose the datafield Mechanical position.

Here you can choose between x,y position, which gives the components coordi-
nates in relation to the origo of the page, and Field position, which gives the coor-
dinates in relation to the reference system.

In the components list for the project, you can therefore specify where in the 
switchboard the components are placed.

— Read more about how to create lists in “Creating Lists” on page 727.

REFERENCES FROM MECHANICAL SYMB. TO ELECTRICAL SYMBOLS

By default no references are displayed from mechanical symbols on the Groundp-
lan/Mechanical pages, to the electrical symbols on the Diagram pages.

When you wish to create a reference from a mechanical symbol to one of the elec-
trical symbols for the component, do this:

1) Click on the Symbols button, right-click on the symbol, and choose Compo-
nent data — or double-click on the symbol.

2) In the dialog box Component data: Click on the tab Reference, select With 
reference and then With reference (in the right-hand side), and click OK.

You have now created a reference from the mechanical symbol. When you have 
selected Symbols and double-click on the reference for the mechanical symbol, 
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you jump to the electrical symbol for the component, which is set to Main refer-
ence. If none of the electrical symbols for the component is set to this, you jump to 
the first found symbol for the component, which exists on a diagram page in 
project.

MEASUREMENT OBJECTS

Read about measurement objects in “Measurement objects” on page 115.

MECHANICAL SYMBOLS MUST HAVE A SIMPLE REFERENCE TYPE

THIS ONLY APPLIES FOR MECHANICAL SYMBOLS WITH A SIMPLE REFERENCE 
TYPE. SYMBOLS WITH RELAY OR MASTER REFERENCE MUST THEREFORE BE 
SET TO NORMAL — OR TO ANOTHER SYMBOL TYPE WITH SIMPLE REFERENCES 
— TO MAKE IT WORK.
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DRAW ORDER

The draw order specifies which objects are in the front, and which objects are in the 
back on the drawing, in case of overlapping objects.

The draw order is fixed for the different object types, but within the same object 
type — e.g. for symbols —, it is possible to change the draw order, as described 
below.

The draw order is specially important on pages with mechanical drawings.

Draw order for different object types
When placing objects on a page, the objects will be drawn in the following draw 
order. (Please note that the objects at the bottom of the list will be placed at the top 
of the project drawing):

1) Drawing headers and current path numbers

2) Images and OLE objects

3) Datafield placed on the page with images

4) Lines

5) Circles

6) Free texts

7) Datafields placed on the page with text

8) Symbols

As you can see in the list, symbols are placed in the front, and they will therefore 
cover any other object type they might be overlapping.
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Draw order for objects of the same type
To specify the draw order for 
objects of the same type — as for 
the mechanical symbol in the fig-
ure to the right — you must right-
click on the object, and choose 
Draw order.

You can then choose:

- Bring to front: Place the 
object in front of all other 
overlapping objects of the 
same type.

- Send to back: Place the object 
behind all other overlapping 
objects of the same type.

- Step forward: Moves the 
object one position forwards, 
among to the overlapping objects.

- Step backward:  Moves the object one position backwards, among to the over-
lapping objects.
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FROM MECHANICAL TO ELECTRICAL DRAWING

When you choose to start by creating a mechanical drawing, you can do this by for 
instance placing the mechanical symbols for a motor control, such as fuses, motor 
starter and contactors.

When working with an attached database, PCschematic ELautomation can then 
automatically fetch the necessary electrical symbols, when you draw the electrical 
diagrams.

Do for instance like this:

Creating a new project with a diagram page and a mechanical page
1) Choose File => New.

2) In the dialog box New: Select the template DPSA3 and click OK. — You 
have now chosen a project containing a single page for drawing diagrams.

3) In the dialog box Settings: Click OK.

4) Press the [PageDown] key — to add a new project page.

5) In the dialog box Page function: Choose the page type Normal and click OK.

6) In the dialog box New: Choose the template DPSA3MEK and click OK. — 
You have now added a page for a mechanical drawing.

Placing a mechanical symbol on a ground plan/mechanical page
7) While being on the mechanical page: Press [d] to enter the database.

8) Select a mechanical symbol: For instance write LS in the field Type begins 
with, choose the contactor with the type LS 37.22, and click OK.

SEE ALSO “PLACING SYMBOLS VIA LISTS” ON PAGE 650, “LOADING COMPO-
NENTS FROM A GROUND PLAN PAGE” ON PAGE 653.
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9) You now get the mechanical symbol for the component in the cross hairs: 
Click somewhere on the mechanical page to place the symbol, click OK in 
the dialog box Component data and press <Esc> to remove the symbol from 
the cross hairs.

10) If necessary, place more mechanical symbols on the page.

Fetch symbols automatically on the diagram page
11) Shift to the diagram page by clicking on the tab 1 at the bottom of the screen.

12) On the diagram page: Choose Functions => Show available.

13) In the dialog box Show available: Type in the symbol name, and click OK.

14) You now get a pickmenu containing the electrical symbols for the compo-
nent, and can place these symbols as you normally do.

DISPLAY SYMBOLS NOT YET PLACED IN DIAGRAMS

WHEN YOU HAVE PLACED THE MECHANICAL SYMBOLS BEFORE THE ELECTRICAL SYMBOLS, 
AND CLICK ON THE BUTTON USED NAMES WITH AVAILABLE SYMBOLS, YOU GET A LIST OF 
ALL THE SYMBOLS, YOU HAVE NOT PLACED ON THE DIAGRAM PAGES YET.

IN THIS CONNECTION THE BUTTON IS A HELP TO REMEMBER TO DRAW ALL THE CIRCUITS.
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In this part you can see how to import and export 

files.

You can read about:

- Exporting Lists as Files........................(p. 625)

- Exporting/Importing DWG/DXF files.(p. 635)

- Integration with Excel..........................(p. 641)

- OLE objects .........................................(p. 642)

- Placing symbols via Lists ....................(p. 650)

- Opening files from the Tools menu .....(p. 654)

- The PCschematic Viewer.....................(p. 655)
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EXPORTING LIST FILES

In PCschematic ELautomation you can create List Files — such as parts and com-
ponents list files, cable lists, PLC lists, terminal lists and connection lists.

Different types of List Files
This chapter describes how to create files with parts 
lists, components lists, terminals lists, cables lists, 
PLC lists and connections lists.

These types of files are created according to the same 
directions, and are created from the same type of dia-
log boxes.

It is possible to create comma separated files, as well 
as column files.

These files can subsequently be loaded into other pro-
grams.

Components list files can for instance be used for 
labels to mechanical assemblys.

Furthermore, it is possible to create wire number files. 
— Please refer to “Wire number Files” on page 407 
for further details.

THIS CHAPTER DESCRIBES

— HOW TO CREATE A LIST FILE ............................................................................ (P. 626)

— THE FORMAT FILE.............................................................................................. (P. 626)

— LISTS AND EXCEL .............................................................................................. (P. 627)

— LISTS IN XML FORMAT ..................................................................................... (P. 628)

— THE BUTTONS IN THE DIALOG BOX ................................................................... (P. 629)

— SPECIFYING THE FILE NAME.............................................................................. (P. 630)

— SPECIFYING THE CONTENTS OF THE FILE........................................................... (P. 630)

— HOW TO MATCH THE SYSTEM YOU EXPORT TO ................................................ (P. 631)

— REFERENCE DESIGNATIONS IN LISTS TO FILES ................................................... (P. 632)

— AN EXAMPLE ..................................................................................................... (P. 633)

— THE LIST FILES AND THEIR EXTENSIONS........................................................... (P. 634)
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CREATING A LIST FILE

In the following it is shown how to create a parts list file, but the other types of lists 
can be created correspondingly.

To create a file containing parts list information, you choose Lists => Parts List 
File. You then enter this dialog box:

THE FORMAT FILE

Along with the list file, a so-called format file is created, containing the information 
you specify in this dialog box.

It contains information on how the file is constructed, but no information about the 
individual components in the list.

Thus the format file contains information on which datafields are included in the 
parts list file, the order in which they appear, whether the file is comma separated ... 
and so on.

THE PROGRAM MEMORIZES FROM WHERE THE FORMAT FILE IS LOADED

PCschematic ELautomation MEMORIZES FROM WHERE YOU LAST LOADED 
"LIST FILE" FORMAT FILES. WHEN YOU WORK ON A NETWORK, THESE FILES 
CAN THEREFORE BE MOVED TO A FOLDER ON THE NETWORK.

Type in the name
of the parts list
file

Chosen file
information

Extra information
on the chosen
datafield

Setup/format
of the file
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Transfer list settings for existing Project lists to List files
When you wish to create a list file with the same list settings as an existing list page 
in the project, do the following:

1) Select the page in the project.

2) Choose Lists => Parts List file — if you wish to create a parts list file.

3) Click on the button As Page. This fetches the list settings and datafields from 
the project list page, and the similar settings are created for the list file.

4) Make corrections if necessary — to save the list in e.g. Excel or XML format 
— and click OK.

Please note that the button As Page only appears in the dialog box when you have 
selected a list page in the project.

LISTS AND EXCEL

In PCschematic ELautomation lists can be created directly in Excel.

— See also “Lists in XML format” on page 628.

All lists can be loaded/written as Excel files
PCschematic ELautomation can create all list files as Excel files — just like the 
program can load Excel files.

EXCEL MUST BE INSTALLED

IT IS ONLY POSSIBLE TO SAVE IN EXCEL FORMAT — OR OPEN LISTS IN EXCEL 
FORMAT — IF EXCEL IN INSTALLED ON THE PC. READ MORE ABOUT THIS IN 
“EXCEL MUST BE INSTALLED TO PERFORM EXCEL IMPORT/EXPORT” ON 
PAGE 641.

Click here to create
an Excel file

Click here to start
Excel automatically
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Starting Excel from PCschematic
When you create a list file, you can start Excel from PCschematic ELautomation 
at the same time by selecting Open list file.

It is a good idea also to select Field Header to get a survey of which information is 
placed in which columns in the Excel file.

Placing symbols from an Excel components list
Furthermore, you can place symbols in PCschematic ELautomation based on an 
Excel components list, as described in “Placing symbols via lists” on page 650.

LISTS IN XML FORMAT

When you, at the bottom of the dialog box List File, select the file format XML, the 
list is saved in the XML format.

Among other options, this opens the possibility to include several lists in the same 
file, and to load the created lists in database programs, that handles the XML for-
mat. The created XML file can for instance be displayed in the Internet Explorer.

— See “Lists and Excel” on page 627 also.
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THE BUTTONS IN THE RIGHT-HAND SIDE OF THE DIALOG BOX

In the right-hand side of the dialog box, you find the following buttons:

OK and Close
When you click OK the list file is created, and you will be asked whether to save 
the changes in the format file.

If you click Close, the list is not created, but you get the option of saving the 
changes in the format file.

New
Click here to create a new format file. You then enter the dialog box Save as, and 
do not risk overwriting the previously applied format file.

— See “The format file” on page 626 if necessary.

Open
The next time you want to create a parts list file, which shall be constructed in a 
similar way, you load this format file by clicking Open, and therefore do not have 
to specify the file settings again.

Create list file
(+ save format file)

Specify list criteria,
sorting order etc.

Save the format file

Do not save the list file
(+ save the format file)

Open an existing
format file

Create a new format file

Copy the format from
the selected list page
in the project

These buttons deals
with the format file
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Save and Save as
The buttons Save and Save as are used for saving the format file.

As Page
Click here to fetch the settings from an existing project list page, as described in 
“Transfer list settings for existing Project lists to List files” on page 627.

This button only appears when you have selected a list page in the project.

Settings/Criteria
If you want to specify further criteria for how to select the components, you click 
on Setup. Hereby you enter the dialog box List setup, which you can read more 
about in “List settings” on page 534.

SPECIFYING THE FILE NAME

Under List File in the upper part of the dialog box — see page 626 — you specify 
under which name the parts list shall be saved. If the selected folder is not appropri-
ate, you click on Browse, and select another folder.

The suggested extension to the file name is .par, because you are dealing with a 
parts list.

SPECIFYING THE CONTENTS OF THE FILE

To specify which datafields shall be included into the file, select the desired 
datafields, and click on the Transfer information button. Please note that you can 
transfer more information at the time by selecting datafields using <Shift> or 
<Ctrl>.

By selecting fields in the Used fields column and clicking on the Revert informa-
tion button, you can correspondingly remove fields from the list of fields to be 
included into the file.

The information is arranged in the order in which they are transferred to the Fields 
in file column. If you therefore want the manufacturer first in the file, start by trans-
ferring the MANUFACTUR field, so that it is placed on top of the Fields in file list.

If you want to transfer all the fields, click on the Transfer all fields button.

If you want to empty the list, click on the Revert all fields button.

Please note, that you are allowed to place the same datafield more than one place in 
the file.

The order of the fields can be changed using drag and drop.

SYMBOL DATAFIELDS IN COMPONENTS LISTS

WHEN YOU CREATE COMPONENTS LIST FILES, YOU CAN INCLUDE SYMBOL 
DATAFIELDS IN THE COMPONENTS LIST FILE. — SEE “CREATING DATA SYM-
BOLS” ON PAGE 704.
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Extra information
For some datafields — such as Name in the figure on page 626 — you can deter-
mine whether extra information shall be included into the datafield. Choose the 
extra information you want by clicking on it.

MATCHING THE SYSTEM YOU EXPORT TO

In order to match the file format of the system you export the file to, you can also 
include field headings and specify the file format.

Field headings
When you want the first record in the file to contain the names of the applied 
datafields, select Field header.

Whether to select Field header or not, depends on the program you wish to transfer 
the file to.

Keep line break
When you want a text to contain a line 
break, do the following:

1) Place the line break character (^) 
in all project texts that needs a 
line break — as described in 
“Texts in more than one line” on 
page 139

2) In the dialog box Format file 
click on the relevant field type, 
and select Keep line break (^)

If for instance you want the Type field in the file to contain a line break in the file, 
first click on Type, then click on Keep line break (^).

File header
When you click on the tab File 
Header, you can specify which 
data to include in the file header — 
if you wish to include a file header.

You transfer the datafields to the 
file as described in “Specifying the 
contents of the file” on page 630.

File format
The settings you specify here, depends on the system you are going to export the 
file to. You can choose between different file formats: Comma separated files, Col-
umn files, Excel files and XML files.

Click here

... and here
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If you choose Comma separated, the fields will be separated by a comma. If you 
need another sign to separate the datafields, you type it in the Separator field.

If you choose Column, the 
datafields will be placed in 
columns. The width of the 
columns are then displayed 
in brackets for the individual 
datafields on the list. If you 
want to change the width of 
the column for e.g. the 
datafield Type, click on the Type field in the list of used fields, and type in the 
desired width in the Column width field. If you want to optimize the column 
widths, select Optimize column width.

Thus the width of each 
column is set to the width 
of the longest datafield of 
the type plus one. For the 
field Type the column 
width is here set to 10, 
because the longest field 
in the Type column is 
nine characters long.

Please note, that if you have selected Field header, this can determine the width of 
the columns. On the figure above, this is the case for the Quantity column.

If you choose Microsoft Excel(R), please refer to “Lists and Excel” on page 627.

REFERENCE DESIGNATIONS IN LIST FILES

For list files it is possible to 
insert the field =+design. and 
then choose Page designation, 
Function aspect or Location 
aspect respectively.

This makes it possible to place 
this information in independ-
ent columns in the file, without 
the component name appears in 
the column.

Please note that you must specify whether to place a Designation or a Description.

If you wish to include the component name, use the field Name, to which the refer-
ence designations can also be added.
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EXAMPLE

Choose Lists => Parts List File, and type in the name you want to assign to the 
parts list file in the Fields in file field.

In the field Datafields choose the datafields displayed in the dialog box below 
under Fields in the file one by one, and click on the Transfer information button.

If you accidentally transfer a wrong datafield, click the Revert information button. 
The datafield is then removed from the list.

You can change the order of appearance in the Fields in file column using drag and 
drop.

Click OK to create the file.

You will now be asked whether you want to save the changes in the setup of the 
parts list file. If you want to create a similar file another time, click Yes, otherwise 
click No.

The parts list file have now been created.

DATAFIELDS IN UPPERCASE ARE FETCHED FROM THE DATABASE

DATAFIELDS WRITTEN IN UPPERCASE ARE FETCHED FROM THE DATABASE. 
THE OTHER DATAFIELDS ARE FETCHED FROM THE PROJECT DIAGRAMS.
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THE LIST FILES AND THEIR EXTENSIONS

When you want to create the other types of list files, this is done just like you create 
a parts list file.

Below you can see which extension the format files are assigned for the different 
file types.

For further information about the datafields for the different list types, please refer 
to “Creating Lists” on page 727.

Wirenumber files
It is also possible to create wire number files.

— See “Wire number Files” on page 407.

LIST TYPE FORMAT FILE

PARTS LIST .PFF

COMPONENTS LIST .CFF

TERMINALS LIST .TFF

CABLE LIST .CBF

PLC I/O LIST .PLC

CONNECT POINTS LIST .COF

CONNECTION LIST .CNF

EXTENSIONS FOR LIST FILES
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DWG AND DXF FILES

In PCschematic ELautomation it is possible to import DWG and DXF files, and 
continue working from these files in the program. It is also possible to export DWG 
and DXF files.

If you are working in layers, the layer structure will be maintained during import as 
well as export. — Read more about layers in “Layers, Elevation and Scaling” on 
page 471.

If you wish to change the parameters for the DXF import or export, please refer to 
the PCschematic Tools manual.

THE ZOOM ALL FUNCTION DURING DWG/DXF IMPORT

When working with imported DWG/DXF files, it might happen that objects are 
placed outside the normal drawing area.

During the import to PCschematic ELautomation, all imported objects are placed 
inside the project pages in PCschematic ELautomation, and the page sizes and 
page scales are adapted to make this possible.

If there, in the DWG/DXF file, are placed objects outside the normal drawing area, 
this can therefore result in, that the drawing is placed in e.g. the lower-left corner of 
the page. Consequently, it will not fill out much of the page in the created PCsche-
matic ELautomation project. If you subsequently change the size of the page and/
or the scale of the page — in order to be able to see the drawing — this might result 
in that objects are placed outside the page in PCschematic ELautomation.

When you wish to print such a page, this gives problems because the printing 
presses all objects in the work area to be placed on the page. The drawing can 
hereby e.g. end up in the lower-left corner of the page.

To avoid this, choose View => Zoom All, which displays all objects in the work 
area. Hereby hidden objects with negative or huge positive coordinates can be dis-
played — and subsequently deleted. — See “The Zoom All function” on page 64.

THIS CHAPTER DESCRIBES

— THE ZOOM ALL FUNCTION .................................................................................(P. 635)

— IMPORTING DWG/DXF FILES.............................................................................(P. 636)

— IMPORTING A DWG/DXF FILE AS A PAGE IN A PROJECT...................................(P. 636)

— STARTING A NEW PROJECT BY IMPORTING A DWG/DXF FILE..........................(P. 637)

— IMPORTING A DWG/DXF FILE AS A SYMBOL....................................................(P. 637)

— EXPORTING DWG/DXF FILES ............................................................................(P. 638)

— EXPORTING A PROJECT AS A DWG/DXF FILE ...................................................(P. 638)

— EXPORTING A SYMBOL AS A DWG/DXF FILE ...................................................(P. 640)

— WHICH FUNCTIONS ARE TRANSFERRED?............................................................(P. 640)
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IMPORTING DWG/DXF FILES

There are three different ways of importing a DWG/DXF file into PCschematic 
ELautomation:

a) You can import a DWG/DXF file in an active project by importing it from the 
Page menu — see “Importing a DWG/DXF file as a page in a project” on 
page 636.

b) You can start up a new project by importing a DWG/DXF file — see “Starting 
new projects by importing DWG/DXF files” on page 637.

c) You can import a DWG/DXF file as a symbol, and then continue working 
with the symbol like any ordinary symbol in PCschematic ELautomation — 
see “Importing DWG/DXF files as symbols” on page 637.

The following sections in this chapter elaborates on these options.

IMPORTING A DWG/DXF FILE AS A PAGE IN A PROJECT

If you are working in a project, and want to insert a DWG/DXF file, you first click 
on the Page menu button.

In the Page menu you then click where you want the page to be inserted as a new 
page, and click on Insert new. Or click on Add new to have it inserted as the last 
page in the project. — Read more about the Page menu in “The Page menu” on 
page 489.

ADAPT DWG/DXF FILES BEFORE IMPORTING

PLEASE NOTE, THAT IT IS A GOOD IDEA TO REDUCE THE DWG/DXF FILE 
BEFORE IMPORTING IT, SO THAT IT ONLY CONTAINS EXACTLY WHAT YOU NEED 
IN YOUR PROJECT.
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Then specify which type of page you want to insert:

Click on Standard/Project file, and then on OK.

Opening DWG/DXF files
In the dialog box Open Standard which now appear, you click your way to the 
folder where the DWG/DXF file is located, choose Acad files (*.dwg) or DXF files 
(*.dxf) as file type, click on the DWG/DXF file, and then on Open.

If you are not sure how to change folder or file type, please read “Opening files/
projects” on page 41.

Opening more DWG/DXF files
You have now inserted the DWG/DXF file, but are still in the Page menu. If you 
want to insert more DWG/DXF files, you repeat this procedure for each DWG/
DXF file.

When you have finished inserting DWG/DXF files, click OK to leave the Page 
menu.

STARTING NEW PROJECTS BY IMPORTING DWG/DXF FILES

Clicking on the Open button you enter the dialog box Open, from which you can 
import a DWG/DXF file as described in "Opening DWG/DXF files" above.

Hereby you create a project consisting of one page, on which the DWG/DXF file is 
located. Using this as a basis, you can now build up a new project.

IMPORTING DWG/DXF FILES AS SYMBOLS

It is also an option to import a DWG/DXF file as a symbol. This has the advantage 
that you can move the symbol in the project as you like, and at the same time you 
can not change the symbol by accident.

If you want to import a DWG/DXF file as a symbol, you do like this:

Click on the Symbols button, and then on the Symbol menu button, which brings 
you into the Symbol menu.
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Here you click on the Create new symbol button, which brings you into the Sym-
bol editor. Here you click on the Open symbol button, which leads you to the dia-
log box Open, where you choose Acad files (*.dwg) or DXF files (*.dxf) as file 
type.

Find the next DWG/DXF file, and click OK.

Returning to the Symbol menu, you see the DWG/DXF file displayed in the lower-
right corner of the menu.

Click on OK, which gives you the DWG/DXF symbol in the cross hairs as a sym-
bol. Click where you want to place the symbol.

The program automatically place the reference point for the symbol in the lower-
left corner, where all symbol texts are placed as well. The symbol is a normal sym-
bol, with selection in the reference point. — Read more about this in “Symbol 
types” on page 680.

If you wish to change the imported symbol — or save it in a symbol folder — you 
can click on the Edit symbol button when you are in the Symbol menu. Here you 
can edit and save as for a normal symbol.

— Read more about working with symbols in “Symbols” on page 158, and about 
how to edit symbols in “Creating Symbols” on page 670.

EXPORTING DWG/DXF FILES

Both projects and symbols can be exported as DWG/DXF files.

EXPORTING PROJECTS AS DWG/DXF FILES

If you wish to export a project as a DWG/DXF file, just enter File => Save as (see 
“Saving Projects/Files” on page 47), set the file type to Acad files (*.dwg) or DXF 
files (*.dxf), specify a file name, and click on Save.
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When you save the project as a DWG/DXF file, you enter the following menu:

Apart from choosing which version to export to, you have the following options:

APPLY THE AUTOCAD VERSION 13
BECAUSE PCschematic ELautomation DOES NOT USE AUTOCAD FUNC-
TIONS FROM LATER VERSIONS THAN AUTOCAD VERSION 13, IT IS RECOM-
MENDED TO EXPORT TO AUTOCAD VERSION 13.
THIS ALSO MAKES IT POSSIBLE TO OPEN THE FILE ON MORE PCS.

OPTION RESULTS IN

CODEPAGE THE PROGRAM WILL AUTOMATICALLY APPLY THE CODEPAGE, WHICH THE 
PC IS SET TO USE. IF YOU WISH TO APPLY ANOTHER CODEPAGE FOR THE 
EXPORT, SELECT THIS CODEPAGE IN THE CODEPAGE FIELD IN THE DIALOG 
BOX.

1 PAGE PR. FILE EACH PAGE IN THE PROJECT IS EXPORTED AS A SEPARATE FILE.

1 PAGE PR. LAYER EACH PAGE IN THE PROJECT IS SAVED IN A SEPARATE LAYER. THIS WAY 
THE ENTIRE PROJECT CAN BE SAVED IN THE SAME FILE.
IF THE PCschematic ELautomation PROJECT CONTAINS LAYERS, 
THE DIVISION IN LAYERS NO LONGER EXISTS.

ONLY PAGE F1 ONLY THE ACTIVE PAGE IN THE PROJECT IS EXPORTED.

PAGE 1. LAYER 
LAY 1

ONLY THE SELECTED LAYER ON THE ACTIVE PAGE IN THE PROJECT IS 
EXPORTED.

LAYER (LAY 1) ON 
PAGE F1 
EXPLODED

WHEN YOU CHOOSE THIS OPTION, YOU CHOOSE WHICH LAYER TO 
EXPLODE, AND THEN EXPORT.
OUTPUT CAN FOR INSTANCE BE APPLIED FOR A NUMERICALLY CONTROL-
LED MACHINE.

DWG/DXF EXPORT

Choose which version
to export to



PAGE 640 PCschematic ELautomation 10.0

DWG AND DXF FILES

EXPORTING A SYMBOL AS A DWG/DXF FILE

Saving a symbol as a DWG/DXF file is also possible. You do this by first clicking 
on the Symbols button and then on the Symbol menu button, which brings you 
into the Symbol menu. — Or press the short-cut [F8] to enter the menu.

Here you find the symbol you want to save as a DWG/DXF file, click on it and 
click on the Edit symbol button. You are now in the Edit symbol mode.

Then you choose File => Save as, click on OK in the first dialog box, set the file 
type to Acad files (*.dwg) or DXF files (*.dxf) and type in the name in the follow-
ing dialog box, and click OK.

Then choose File => Close to exit the Edit symbol mode. You now return to the 
Symbol menu, where you click on Cancel in order to return to the project.

Read more about editing and saving symbols in “Creating Symbols” on page 670.

WHICH FUNCTIONS ARE TRANSFERRED FOR DWG AND DXF FILES

Functions which are common for the program, you are importing from, and 
PCschematic ELautomation will be transferred.

When importing objects which PCschematic ELautomation cannot handle, it is 
recommended to “explode” the drawing before importing it. PCschematic ELauto-
mation cannot handle coordinates — for instance line lengths — on more than two 
kilometer.

During export of objects which the DWG/DXF format can not handle, PCsche-
matic ELautomation tries to use object types known to the DWG/DXF format.

Electrical properties cannot be transferred using the DWG/DXF format.

— Please refer to the PCschematic Tools manual.

If you are having difficulties importing DWG/DXF files, please contact your local 
hot-line.
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INTEGRATION WITH MICROSOFT EXCEL

In PCschematic ELautomation you can work together with Microsoft Excel in the 
following ways:

1) Automatic project generation via Excel - see “Generating and Updating 
projects via Excel” on page 614.

2) All lists to files can be saved in Excel format. This means all reports can be 
saved in Excel format — see “Lists and Excel” on page 627.

3) PLC I/O data imported in Excel, where changes can be made, after which 
these changes can be imported in PCschematic ELautomation — see “PLC 
I/O addressing via Excel” on page 463.

4) You can save data from the Object Lister in Excel format — see “The Object 
Lister” on page 314.

5) You can draw projects based on Parts/components lists from Excel, whereby 
PCschematic ELautomation automatically fetches the applied components 
from the attached database — see “Placing symbols via lists” on page 650.

6) Furthermore, you can merge PCschematic ELautomation projects via Excel 
— see “Merging projects via Excel” on page 625.

THIS CHAPTER DESCRIBES

THIS CHAPTER IS A SURVEY OF THE VARIOUS WAYS YOU CAN USE MICROSOFT 
EXCEL TOGETHER WITH PCschematic ELautomation.

EXCEL MUST BE INSTALLED TO PERFORM EXCEL IMPORT/EXPORT

IT IS ONLY POSSIBLE TO SAVE AND OPEN FILES IN EXCEL FORMAT IF MICRO-
SOFT EXCEL IS INSTALLED ON THE PC.

THIS IS BECAUSE PCschematic ELautomation LETS EXCEL HANDLE THESE 
PROCEDURES. YOU ARE THEREFORE NOT DEPENDANT ON WHETHER PCsche-
matic ELautomation CAN HANDLE WHICHEVER VERSION OF EXCEL YOU 
HAVE INSTALLED.
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INSERTING FILES FROM OTHER PROGRAMS / OLE

In PCschematic ELautomation you can insert so-called OLE objects directly on 
the project pages. This means that you can work with files from other computer 
programs inside PCschematic ELautomation.

WHAT IS AN OLE OBJECT?
OLE is a standard for communication between computer programs, which makes it 
possible to be in one computer program, and from there work on a document in 
another computer program. (OLE is an abbreviation of "Object Linking and 
Embedding").

To make this possible, both computer programs have to be installed on the compu-
ter, and both computer programs have to support OLE objects.

Because PCschematic ELautomation supports OLE objects, you can therefore:

1) Create new objects in other computer programs directly from a PCschematic 
ELautomation project, and keep on working with the documents from 
PCschematic ELautomation

2) Insert existing documents from other computer programs in PCschematic 
ELautomation, and work on the documents from PCschematic ELautoma-
tion

Thus you can insert Word or Excel 
documents directly on the pages in 
PCschematic ELautomation, and 
keep working on them from 
PCschematic ELautomation as if 
you were working in Word or 
Excel respectively.

THIS CHAPTER DESCRIBES

— WHAT IS AN OLE OBJECT? ................................................................................(P. 642)

— CREATING NEW OLE OBJECTS ...........................................................................(P. 643)

— INSERTING EXISTING OLE OBJECTS ...................................................................(P. 644)

— COPYING AREAS AND INSERTING AS OLE OBJECTS ........................................... (P. 646)

— EDITING PLACED OLE OBJECTS .........................................................................(P. 646)

— OPENING OTHER COMPUTER PROGRAMS VIA OLE OBJECTS ..............................(P. 647)

— UPDATING PLACED OLE OBJECTS......................................................................(P. 647)

— INSERTING AUTOCAD PROJECTS AS OLE OBJECTS........................................... (P. 647)

— HANDLING OLE OBJECTS IN OTHER COMPUTER PROGRAMS..............................(P. 648)

— PROPERTIES ON OLE OBJECTS ...........................................................................(P. 648)

— UPDATE ALL OLE OBJECTS AND OTHER LINKS..................................................(P. 649)

PCschematic
project

Word document
in PCschematic
as OLE object
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Inserting PCschematic ELautomation projects as OLE objects in other computer 
programs is not possible.

CREATING NEW OLE OBJECTS IN PCschematic ELautomation

To create a new OLE object — for instance a new Word document — choose Func-
tions => Insert object. — If you want to insert an existing document, please refer 
to “Inserting existing objects in PCschematic ELautomation” on page 644.

You now enter the following dialog box:

Here you click on Create new object, and choose which type of OLE object/docu-
ment/file you want to insert in the project. The options you get on the list are those 
of the installed programs on your computer, which supports inserting OLE objects 
in other programs — for instance the Microsoft Office package.

Placing the OLE object
Click on OK when you have chosen which type of document you want to create. 
You are then asked to point out where on the page to place the OLE object.

Having placed the OLE object, you can change its size like this:

1) Place the mouse pointer 
over one of the corners of 
the OLE object, so that 
the cursor changes 
appearance to a two-way 
arrow

2) Press down the left mouse 
button, and drag the cor-
ner to another position

3) Release the mouse button

Click here for
new OLE object

Choose which
type of OLE
object you want

Click here if you want to display an
icon in stead of the document contents

to create

1

2

3
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When an OLE object is placed — for instance a Word document — the toolbars in 
PCschematic ELautomation are replaced with the toolbars from Word.

You can now work with the full functionality on Word inside PCschematic ELau-
tomation.

When you have finished working with the word document, you just click outside 
the area containing the word document. Doing this causes the PCschematic ELau-
tomation toolbars to reappear, and you can continue working in PCschematic 
ELautomation.

The text from the Word document now appears to be an ordinary text in PCsche-
matic ELautomation.

INSERTING EXISTING OBJECTS IN PCschematic ELautomation

When you want to insert existing documents in PCschematic ELautomation — for 
instance an existing Word document — choose Functions => Insert object. — If 
you are interested in creating a new file, please refer to “Creating new OLE objects 
in PCschematic ELautomation” on page 643.
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You now enter the following dialog box:

Here you choose Create from file, and find the document you want to place in the 
project, by either clicking on Browse, or by typing in the file name in the File field 
(including the path — see “Dictionary” on page 850 — leading to the file).

Linking
If you choose Link you will enter the program in which the document is created — 
for instance Word — when you open the document from PCschematic ELautoma-
tion. From there you make changes in the original document, and return to PCsche-
matic ELautomation.

When you do not choose Link, a copy of the document will be created in PCsche-
matic ELautomation. This means that two independent documents now exists. 
Changes in the one document will not be transferred to the other — and vice versa.

Click OK.

Placing the OLE object
You are now asked to place the OLE object, as described in “Placing the OLE 
object” on page 643.

PLEASE NOTE THAT WHEN YOU LINK A WORD DOCUMENT TO PCschematic 
ELautomation, YOU CAN STILL EDIT THE DOCUMENT DIRECTLY FROM WORD 
WITHOUT INVOLVING PCschematic ELautomation.

BECAUSE THE DOCUMENT IS LINKED TO THE PCschematic ELautomation 
PROJECT, THE CHANGES IN THE DOCUMENT WILL ALSO BE DISPLAYED IN 
PCschematic ELautomation.

Click here to insert
an existing object

Specify where the
object/document

Specify whether to create a copy, or
whether you want to make changes
directly in the original

is palced
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COPYING AREAS AND INSERTING THEM AS OLE OBJECTS

When you copy an area — for instance 
from Excel — by selecting the area and 
pressing <Ctrl+c>, you can insert the area 
in PCschematic ELautomation by choos-
ing Edit => Paste special.

You now get the option of choosing 
between Insert and Insert link.

When you choose Insert link changes 
will be transferred automatically between the project and the original file — as 
described in “Linking” on page 645.

When you choose Insert only a copy of the copied area will be inserted, without 
connection to the original file.

EDITING A PLACED OLE OBJECT

When you want to edit a placed OLE object, do like this:

1) Click the Area button

2) Double-click inside the area covered by the OLE object — to select the OLE 
object

3) Right-click on the OLE object and choose Document object => Edit

You have now opened the OLE object, and can edit its contents.

When you click outside the area of the OLE object, you return to working in 
PCschematic ELautomation. The changes in the OLE object are saved automati-
cally.

IT CAN BE DIFFICULT TO SEE HOW MUCH SPACE A NON-SELECTED OLE OBJECT 
TAKES UP IF YOU HAVE DISABLED REFERENCEPOINTS IN SETTINGS => 
POINTER/SCREEN.
— PLEASE REFER TO “POINTER/SCREEN” ON PAGE 815.
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OPENING OTHER PROGRAMS FROM OLE OBJECTS

When you want to open on OLE object in PCschematic ELautomation, so that the 
computer program in which the OLE object is created fills the screen, do like this:

1) Click the Area button

2) Double-click inside the area covered by the OLE object to select the OLE 
object

3) Right-click on the OLE-object and choose Document object => Open

If for instance you have opened an Excel document, the Excel program starts, and 
the size of the document in Excel matches the size in has in PCschematic ELauto-
mation.

Returning to PCschematic ELautomation
To return to PCschematic ELautomation, do like this:

1) Choose File => Close and return to PCschematic project

2) Click on the PCschematic ELautomation button on the process line at the 
bottom of the screen

You have now returned to PCschematic ELautomation.

UPDATING OLE OBJECTS

When the contents of an OLE object have been updated outside the control of 
PCschematic ELautomation, you can transfer the changes to PCschematic ELau-
tomation:

1) Click the Area button

2) Double-click within the area covered by the OLE object to select the OLE 
object

3) Right-click on the OLE-object and choose Document object => Update

You have now updated the OLE object copy in PCschematic ELautomation. — 
However, these changes will for most programs be transferred to PCschematic 
ELautomation automatically.

INSERTING AUTOCAD DOCUMENT AS OLE OBJECT

When inserting OLE objects in PCschematic ELautomation, you have the option 
of drawing on top of the OLE object.

When inserting a groundplan drawing, you can therefore choose to draw for 
instance the electrical installations on top of the AutoCAD file. This way you only 
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have the electrical installations in PCschematic ELautomation, and only have the 
groundplan drawing in AutoCAD — without needing to convert any files.

When the AutoCAD file is placed in PCschematic ELautomation with Link — see 
“Inserting existing objects in PCschematic ELautomation” on page 644 — the 
changes on the groundplan drawing will be transferred automatically from Auto-
CAD to PCschematic ELautomation.

HANDLING OLE OBJECTS IN OTHER COMPUTER PROGRAMS

The handling of OLE objects from other computer programs, can differ from what 
is described above. This is because there can be a difference in how these computer 
programs have chosen to support OLE.

PROPERTIES ON OLE OBJECTS

It is possible to specify properties on OLE objects. This is done like this:

1) Click on the Area button.

2) Double-click on the OLE object.

3) Right-click on the OLE object, and choose 
Document object => Properties.

4) You can now specify properties on the 
OLE object.

When using linked OLE objects you can hereby 
change the link to another file. Furthermore you can change the size of the OLE 
object under Properties.

TO INSERT AUTOCAD FILES AS OLE OBJECTS IN PCschematic ELautoma-
tion YOU MUST HAVE AUTOCAD INSTALLED ON YOUR COMPUTER.

ALTERNATIVELY YOU CAN IMPORT AUTOCAD FILES IN PCschematic 
ELautomation AS EITHER DWG OR DXF FILES. — PLEASE REFER TO “DWG 
AND DXF FILES” ON PAGE 635.
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UPDATE OLE OBJECTS AND OTHER LINKS

When a project contains OLE objects, which have been 
inserted via Functions => Insert object, where at least 
one object have been linked to the project, you can 
choose Edit => Links.

Hereby you enter the dialog box Links:

If the contents of one of these OLE objects have changed, then select the object and 
click on Update Now, so that the object is updated in the project also. Please note 
that the OLE objects in PCschematic ELautomation are only updated when you 
select this manually.

From the dialog box you can aslo open a source file — click on Open Source — or 
select another source for the OLE object — click on Change Source.

From this dialog box you can also handle linked pictures inserted via Functions => 
Insert picture.



PAGE 650 PCschematic ELautomation 10.0

PLACING SYMBOLS VIA LISTS

PLACING SYMBOLS VIA LISTS

ON PLACING SYMBOLS VIA LISTS

In PCschematic ELautomation you can read parts and components list files con-
taining article numbers, and use these files to place symbols in projects.

These lists will typically consist of parts for a machine, and could for instance be a 
components list containing sensors, motors etc.

For hydraulics/pneumatics there will typically be an extra column, where the 
machine responsible informs the electrical constructor which sensors to use, and 
how to use them.

READING COMPONENTS LISTS/PARTS LISTS

1) Choose Lists => Read Components List => Load from file.

2) In the dialog box Select Components List you select the folder where the list 
is placed, specify whether it is an Excel file (file type *.xls) or a comma sepa-
rated file (file type *.csv), and double-click on the file.

THIS CHAPTER DESCRIBES

— ON PLACING SYMBOLS VIA LISTS .......................................................................(P. 650)

— READING COMPONENTS LISTS/PARTS LISTS....................................................... (P. 650)

— LOADING COMPONENTS FROM A GROUND PLAN PAGE ...................................... (P. 653)

— LOADING COMPONENTS / PARTS LISTS FROM MULTIPLE WINDOWS ...................(P. 653)

— UPDATING LOADED COMPONENTS / PARTS LISTS ...............................................(P. 653)

— INTERRUPTED PLACING OF COMPONENTS ..........................................................(P. 653)

POSSIBLE LIST FORMATS

THE INFORMATION IN THE LIST FILE MUST BE THE FOLLOWING: NAME, ARTI-
CLE NO., TYPE AND FUNCTION.
THE LIST CAN BOTH BE AN EXCEL FILE AND A COMMASEPARATED FILE — FOR 
INSTANCE CREATED FROM A DATABASE SYSTEM.
HOWEVER, IT IS ONLY POSSIBLE TO OPEN LISTS IN THE EXCEL FORMAT IF 
EXCEL IS INSTALLED ON THE PC. — SEE “EXCEL MUST BE INSTALLED TO PER-
FORM EXCEL IMPORT/EXPORT” ON PAGE 641.
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Placing the components from the Components List window
3) A survey of the components is now displayed in PCschematic ELautoma-

tion:

4) Double-click on a component in the window, and you get the component in 
the cross hairs. When a component contains more than one function, a sym-
bol toolbar is displayed containing the functions for the component.

5) Place the symbol, and the components list from the file is updated in PCsche-
matic ELautomation.

6) Continue until all components are placed in the project.
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The buttons in the window
When you click on the Show not-placed button, all components, for which all sym-
bols are not placed, are displayed.

When you click on the Show partly-placed button, all components, for which all 
symbols are not placed — or just partly placed —, are displayed.

When you click on the Show all button, all placed as well as not placed compo-
nents are displayed.

When you click on the Show completely-placed button, only the completely 
placed components are displayed.

When you click on the Update list button, the list is updated.

Show where the component is placed
When you wish to see where a component is placed in the project, click on the com-
ponent in the list, and click the Show where the component is placed button.

The Select name window is now displayed for the component. When you click on 
one of the symbols in the window, the program jumps to the page in the project 
where the symbol is placed, and selects the symbol.

THE COMPONENT LIST WINDOW REMAINS VISIBLE

THE COMPONENT LIST WINDOW REMAINS VISIBLE WHILE WORKING WITH THE 
PROJECT, AND CAN BE SET TO BECOME TRANSPARENT, WHILE YOU ARE WORK-
ING ON THE DRAWING AREA — SEE “POINTER/SCREEN” ON PAGE 815.

1) Click on the
component in

2) Click on
the Eye

3) Click on the symbol
in the Select name

4) The symbol is
selected in the

the list window project
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LOADING COMPONENTS FROM A GROUND PLAN PAGE
If you wish to start by drawing the mechanical layout, you can do this, and subse-
quently fetch the electrical symbols for the applied components by choosing Lists 
=> Read Components List => Create from mechanical page:

When you click on the component in the list, you get a pickmenu with the available 
electrical symbols for the component.

LOADING COMPONENTS/PARTS LISTS FROM MULTIPLE WINDOWS

The functions Lists => Read Components List and Lists => Read Parts List can 
open more than one window/list at the same time.

Hereby you can get access to symbols from different lists at the same time, or load 
the same list in different windows, and select components via different views of the 
same list.

UPDATING LOADED COMPONENTS/PARTS LISTS

The functions Lists => Read Components List and Lists => Read Parts List reg-
isters whether the loaded file has been changed, and displays a Reload button, 
which can reload the list file:

The button flashes red/black, and the list file is reloaded when you click the button, 
and subsequently answer OK to reload the file.

INTERRUPTED PLACING OF COMPONENTS FROM THE PARTS LIST

When placing components from the list is interrupted, and for instance continued 
the next day, PCschematic ELautomation examines what has already been placed, 
and you can continue working on this basis.
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OPENING FILES FROM THE TOOLS MENU

Opening files in other programs directly from PCschematic ELautomation is pos-
sible. This can for instance be used as a short-cut when you want to see the lists to 
files, which you create from PCschematic ELautomation.

The #OPENFILE# command
In the dialog box Settings => Tools, the command #OPENFILE# can now be 
applied. It is used when you want to open a file in another Windows program from 
PCschematic ELautomation.

When the command is used along with a file name, the extension of the file deter-
mines which program shall be applied for opening the program. — Please note, that 
it is Windows that handles which program is used for opening the file.

If it therefore says #OPENFILE#C:\tekst.doc under Program name (full path), the 
type doc determines, that the file should be opened in the program Word.

— Please refer to “Tools” on page 825 for further information on the dialog box 
Settings => Tools, and which other commands can be applied there.

Display lists to files
If no file name is specified, or if the file name contains the sign *, you will enter the 
Open dialog box.

This can for instance be used when you are creating 
lists to files. If you place the following line in the dia-
log box, you will be able to open the lists for files you 
create in PCschematic ELautomation quickly:

When you then choose Tools => Show textfile, you 
enter the dialog box Open, with the folder c:\Pcsel-
cad\list opened.

Here you click on the desired file, click OK, and get 
the file opened in the program Notepad.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO OPEN FILES IN OTHER PRO-
GRAMS DIRECTLY FROM PCschematic ELautomation
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PCSCHEMATIC VIEWER

On the PCschematic ELautomation CD there exists a PCschematic Viewer, which 
you can send to your customers for free. The Viewer can furthermore be down-
loaded from www.pcschematic.com in the English, German, Dutch, Polish, Czech, 
Hungarian, Russian, Chinese and Danish version.

Options in the PCschematic Viewer
When you open a project with the PCschematic Viewer, you can do the following:

- See all project pages, and zoom in all parts of the project

- See Page data and Project data

- Search for project texts and find objects via the Object Lister

- Choose which project layers are visible

- Print

You do not have the option to edit projects in the PCschematic Viewer.

Installation of PCschematic Viewer
The PCschematic Viewer is placed in two different ways on the PCschematic 
ELautomation CD:

a) As a file for installing PCschematic Viewer

b) In a folder, from which you can run it directly from the PCschematic ELauto-
mation CD without installing the PCschematic Viewer

Installing the PCschematic Viewer
If you wish to install the English version of the PCschematic Viewer, enter the 
folder \UK\Viewer on the PCschematic ELautomation CD, and double-click on 
the file pcsvieuk.exe. This starts the installation of the viewer. During the installa-
tion process, you will be asked in which folder on your PC to install the program. 
Follow the self-explanatory installation procedure until PCschematic Viewer is 
installed.

The program is subsequently started by opening the folder Pcsview on your PC, 
and then double-click on the file pcsview.exe.

THE INSTALLATION PROGRAM TO PCschematic Viewer CAN BE PLACED ON 
A SINGLE FLOPPY DISK.
WHEN CREATING SECURITY COPIES OF PROJECTS, THE VIEWER CAN FOR 
INSTANCE BE PLACED ON THE CREATED CDS.
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If you wish to install the German version, use the file pcsviede.exe. If you wish to 
install the Danish version, use the file pcsviedk.exe.

Running PCschematic Viewer directly from the CD
If you wish to run the English version of PCschematic Viewer directly from the 
PCschematic ELautomation CD, enter the folder \UK\Viewer\Pcsview and click 
on the file Pcsview.exe.

PCschematic Viewer IN OTHER LANGUAGES

The PCschematic Viewer can be found in other language versions on www.pcsche-
matic.com. Here you can always find the latest versions of the viewer, which can be 
downloaded free of charge.

IN STEAD OF RUNNING THE INSTALLATION PROGRAM, YOU CAN COPY THE 
FOLDER \UK\VIEWER\PCSVIEW, AND PLACE IT ON YOUR PC.
THE VIEWER IS STARTED AS EXPLAINED ON THE PREVIOUS PAGE.



This section deals with how to prepare your 

projects, and how to design the extra symbols 

and lists you need.

You can read about:

- Preparing Projects ................................(p. 659)

- Specifying which Datafields to use .....(p. 663)

- Designing Symbols ..............................(p. 670)

- Designing Signal symbols ...................(p. 710)

- Designing Drawing Headers................(p. 715)

- Designing Lists ....................................(p. 727)

- Designing Unit Drawings ....................(p. 744)

- Creating Page and Project templates ...(p. 748)

Reading this section saves you a lot of time in 

the projects to come.

C
reate Sym

bols, L
ists and Projects





PCschematic ELautomation 10.0 PAGE 659

PLANNING AHEAD

PLANNING AHEAD

When you have become more familiar with the program, it is a good idea to con-
sider how to prepare your future projects in PCschematic ELautomation the best. 
The sooner you do this, the more time you will save — and the more you will ben-
efit from the program facilities.

This chapter gives you a survey of what is worth considering, and contains refer-
ences to the places where the various topics are elaborated.

If you have any difficulties, please contact your local hot-line.

CREATING DRAWING HEADERS

To adapt the program to your company needs, you will need to design your own 
drawing headers. These drawing headers are a kind of formulas you place on the 
pages in your projects, and can be used as front pages, drawing headers for draw-
ings, or formulas for tables of contents as well as several types of lists.

THIS CHAPTER DESCRIBES

— CREATING DRAWING HEADERS ..........................................................................(P. 659)

— CREATING PAGE TEMPLATES..............................................................................(P. 660)

— CREATING PROJECT TEMPLATES.........................................................................(P. 660)

— CREATING SUB DRAWINGS .................................................................................(P. 661)

— PROJECT AND PAGE DATA ..................................................................................(P. 662)

— CREATING SYMBOLS...........................................................................................(P. 662)

— FOLDERS CONTAINING PROJECTS........................................................................(P. 662)

— OPTIONS FOR MULITUSER SYSTEMS....................................................................(P. 662)
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Furthermore, you have got the option to create unit drawings, which are pages on 
which you specify what a specific component consist of.

You can either create your drawing headers from scratch, or you can create them by 
adapting the drawing headers, which comes along with the program, to your own 
needs. Read more about this in “Creating Drawing Headers” on page 715, “Creat-
ing Lists” on page 727 and “Changing an already created list/drawing header” on 
page 740.

If you need to create your own unit drawings, please read “Creating Unit Draw-
ings” on page 744.

CREATING YOUR OWN PAGE TEMPLATES

When you have created these drawing headers, you can succeedingly place them on 
individual page templates, so that you, when creating new project pages, directly 
can select pages, on which these drawing headers are already inserted.

— Read more about this in “Creating Templates” on page 748, specially “Creating 
Page templates — via the Template editor” on page 749.

CREATING YOUR OWN PROJECT TEMPLATES

What really saves time, is if you specify a standard for how your projects shall be 
set up, and then create a project containing everything you need when you start up a 
new project.

Front page Table of Parts-, components-

Terminals list PLC list A4 Drawing header A3 Drawing header

and Cables listContents
Chapter
Front page

Chapter Table
of Contents
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Such a project template could for instance contain a front page, a table of contents, 
some pages for project drawings, a parts list, a components list, a terminals list and 
a cables list — and at the same time it contains the datafields you need.

Furthermore, you could once and for all have created the unit drawings you might 
need in your projects. These could then be loaded into your projects when you need 
them.

When you start up a new project, you start by selecting the project template, and 
continue working from this.

By doing the work once and for all you save time, and avoid doing the same things 
over and over.

Please note that you can create many different standard projects if you need to.

— Read more about this in “Creating Templates” on page 748, specially “Creating 
Project templates” on page 751.

CREATING SUB DRAWINGS

The next step from here is creating your own sub drawings, which you can drag 
directly into the project diagrams. These sub drawings can also be created based on 
existing diagram pages. — Read more about this in “Sub drawings” on page 266.

These sub drawings can also be applied in automatic project generation, which you 
can read more about in the Projekt generator manual.

Front page

Table of Contents

Parts list

Components list

Terminals list

Cables list

Pages for project drawings

Project template

PLC list

Chapter Table of Contents

Chapter tab

Chapter tab
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PROJECT AND PAGE DATA

You can attach different types of information to a project; some is attached to the 
entire project, some is only attached to the individual pages in the project.

This information is typed in on a central place, and can then be inserted as 
datafields on the project pages.

When you start PCschematic ELautomation, it is already determined which 
datafields you can insert on your project pages. But maybe some of these datafields 
are superficial, while you lack other datafields.

When you have determined which information you typically need in your projects, 
you may therefore adapt your standard project, so that it contains exactly the 
datafields you need. — See how to do this in “Page data and Project data 
Datafields” on page 663.

CREATING SYMBOLS

Even though many symbols comes with the program, you still may need to design 
your own symbols, data symbols or signal symbols for your projects.

If this is the case, you may read:

- “Creating Symbols” on page 670 to see how to design symbols,

- “Creating Data symbols” on page 704 for designing data symbols, and

- “Creating Signal Symbols” on page 710 for designing signal symbols

FOLDERS CONTAINING PROJECTS

To maintain a survey of your projects, it is a good idea to create specific folders for 
the various types of projects. If you are an experienced Windows user you are prob-
ably confident with this. However, if this is not the case, you may read more about 
this in “Folders” on page 40.

OPTIONS FOR MULTIUSER SYSTEMS

On multiuser systems, the administrator can furthermore do several things to e.g. 
give every user access to a predefined set of pickmenus, to control database set-
tings, and to ensure every user uses the same version of the program.
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PAGE DATA AND PROJECT DATA DATAFIELDS

As described in “Datafields” on page 134, you can use datafields in PCschematic 
ELautomation. It is a good idea to have a general strategy for which (user-defined) 
datafields you want to use in your projects.

A survey of the datafields in PCschematic ELautomation can be found in 
“Datafields” on page 834.

WHAT IS A DATAFIELD?
All information concerning the entire project is gathered in the dialog box Settings 
=> Project data. Here you for instance type in the project title, as well as the name 
and address of the customer.

THIS CHAPTER DESCRIBES

— WHAT IS A DATAFIELD?......................................................................................(P. 663)

— SPECIFYING WHICH DATAFIELDS SHALL BE AVAILABLE.....................................(P. 666)

— ADDING NEW DATAFIELDS TO PROJECT AND PAGE DATA .................................(P. 666)

— DATALISTS FOR PROJECT DATA AND PAGE DATA ..............................................(P. 667)

— DEFAULT DATAFIELDS ........................................................................................(P. 669)

Project data datafields
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If you need to insert one of these informations in your project — for instance the 
address of the customer — choose Functions => Insert Datafield.

Here you first click on Project Data and then on the datafield Customer name.

This gives you the chosen datafield in the cross hairs, and you place it where you 
want it on the page.

When you update your list, the address of the customer will be read from the 
Project Data tab, and inserted on your list.

Datafield in the drawing header definition

Datafield in the drawing headerThe contents of the datafield specified
in Settings => Project data in the active project
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If the customer change address later on, you only have to change this address once 
in Settings => Project data, which automatically corrects the address on all the 
pages where the datafield Customer Name exists in the project.

Thus datafields makes it possible to have information, that need to be used several 
places within the project, to be located in one central place.

If one or more information need to be changed, you only have to correct it once, 
and the program corrects all the places the datafields appear in the project.

Datafields, which are only attached to the individual pages in the project, are 
located in Settings => Page data.

Datafields in Lists

The figure above displays the following types of datafields in lists:

1) The contents of the datafield Name collected from the diagrams

2) The contents of the datafield DESCRIPT collected from the database

3) The contents of the datafield Title collected from the Page title field in Set-
tings => Page data

Read more about datafields, and how to place these in a project, in “Datafields” on 
page 134.

Drawing header/List

Drawing header/List filled out with project data

1

2

3
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SPECIFYING WHICH DATAFIELDS SHALL BE AVAILABLE

When you insert datafields using Functions => Insert Datafield, the contents of 
some of these datafields, are specified in the dialog box Settings.

You can specifying which of datafields on the Project data and Page data tabs you 
want to use in your projects.

If there is a particular type of datafields you would like to be able to insert, you can 
create these, and if you do not need some of the other datafields, you can delete 
those as well.

ADDING NEW DATAFIELDS TO PROJECT DATA AND PAGE DATA

To add new fields, which can be inserted as Project data datafields in your 
projects, you do like this:

Enter Settings => Project data and right-click on one of the project data datafields, 
and a menu appears:

Click on Add datafield, and you will be asked for a name for the new datafield:

Type it in, and click OK.
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You may now use the new datafield in your project.

Please note that the datafield will be placed where you 
clicked in the first place. Above there was clicked on 
Revision, which caused this field to be moved down, 
and the new field to be placed on its original place.

Accordingly, you can change the name of a datafield, or remove a datafield, by 
clicking on the datafields and then choose either Edit datafield or Remove 
datafield.

Changes in Page data is carried out in a similar way.

If for instance you want to move the datafield Project number down between Cus-
tomer name and Subject name, you click on the Project number field and drag it 
down there. Thus you determine the order in which the datafields appear on the two 
tabs.

Changing the names of used datafields not allowed
You are not allowed to change the names of the datafields which are being currently 
used in the project.

The contents of the datafields you can change any time.

DATALISTS FOR PROJECT DATA AND PAGE DATA

It is possible to create datalists with frequently applied data values for both Project 
data and Page data. To e.g. create a datalist of the designers, do the following:

1) Right-click on the first of the datafields — here the datafield Designer —, 
and select Values:

2) In the dialog box Designer: Type in the names of the designers and click OK:
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3) Click in the textfield next to the datafield, and a down-arrow appears in the 
right-hand side of the textfield. Click on the arrow, and select the desired 
name in the drop-down list:

4) The name is now selected designer is now inserted.

Advanced datalists
When a value in the datalist contains the characters ++ this means that the consecu-
tive datafield(s) in Project data / Page data will also be filled out.

If for instance you create the data value DpS CAD-center ApS++Bygaden 
7++4040++Jyllinge++4678 8244 in the list, you can hereby fill out five consecu-
tive datafields in one operation. Do this:

Create the values in a datalist
1) Right-click on the first of the datafields — here the datafield Customer name 

—, and select Values:

2) In the dialog box Customer name: Type in the text DpS CAD-center 
ApS++Bygaden 7++4040++Jyllinge++4678 8244 and click OK:

3a) Click here 3b) ... click here

3c) ... and select the name in the list
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Select datavalues from the list
3) Click in the textfield next to the datafield, and a down-arrow appears in the 

right-hand side of the textfield. Click on the arrow, and select the line with the 
values in the drop-down list:

4) Hereby the datafield is filled out — as is the four subsequent datafields in the 
dialog box Project data:

DEFAULT DATAFIELDS

To turn your changes into a default setting for datafields, you have to click on the 
Save as default button. This have to be done on the Project data tab as well as on 
the Page data tab.

PROJECT DATA AND PAGE DATA DATAFIELDS ARE SAVED IN THE PROJECT FILE.

3a) Click here 3b) ... click here

3c) ... and select the value in the list
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CREATING SYMBOLS

Working with PCschematic ELautomation, it might happen that the program fold-
ers does not contain the specific symbol you need. Therefore, this chapter is a guide 
on how to create your own symbols.

In the following chapters you can see how to create signal symbols in “Creating 
Signal Symbols” on page 710, and how to create data symbols in “Creating Data 
symbols” on page 704.

— To see how to use the already created symbols, please read “Symbols” on 
page 158.

THIS CHAPTER DESCRIBES

— CREATING A NEW SYMBOL ................................................................................(P. 671)

— THE SYMBOL TYPES ...........................................................................................(P. 680)

— EXTRA SYMBOL DATAFIELDS IN THE SYMBOL ..................................................(P. 685)

— SYMBOLS WITH STATES......................................................................................(P. 686)

— SYMBOLS WITH CONNECTION POINTS IN OTHER LAYERS..................................(P. 687)

— CREATING SYMBOLS AS MULTI SYMBOLS..........................................................(P. 688)

— SPECIFYING DEFAULT TEXT SETTINGS FOR EDIT SYMBOL MODE .......................(P. 689)

— LOADING ANOTHER SYMBOL INTO A SYMBOL....................................................(P. 690)

— COPYING AREAS INTO EDIT SYMBOL.................................................................. (P. 690)

— CREATING TERMINAL SYMBOLS .........................................................................(P. 691)

— CREATING TERMINAL SYMBOLS WITH ADDITIONAL STATUS..............................(P. 693)

— CREATING CABLE SYMBOLS...............................................................................(P. 695)

— CREATING PLC I/O SYMBOLS ............................................................................(P. 697)

— CREATING PLC REFERENCE SYMBOLS ...............................................................(P. 700)

— CREATING LINE CONNECTION SYMBOLS ............................................................ (P. 702)

— OTHER OPTIONS..................................................................................................(P. 703)
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CREATING A NEW SYMBOL

In the example you can create a simple symbol, consisting of a rectangle with a cir-
cle inside. Furthermore, the symbol will contain a free text as well as two connec-
tion points. The precise meaning of this is follows later.

To create a symbol, you have to be working in a project. If this is not the case you 
have to open a new project: 

Click on the New document button, and leave the dialog box Settings by pressing 
<Esc> or by clicking on Cancel.

You are now ready to create a new symbol:

Click on the Symbols button, or use the short-cut [s]. Then click on the Symbol 
menu button. Also, you can press [F8] to enter the Symbol menu directly.

You have now entered the Symbol menu:

Click on the Select Library from Folders button or on the Select Library from 
Alias button, and select the folder/alias you wish to save the symbol under — e.g. 
the folder MISC.

Then click on the Create new symbol button, to create a new symbol.

— Read more about the Symbol menu in “Fetching symbols using the Symbol 
menu” on page 165.

You now enter the Edit symbol mode, in which you can see SYMB flashing on a 
red background in the lower part of the left tool bar.

Make an appropriate Zoom [z] around the red marks in the middle of the screen. — 
If you are not sure to zoom, please see “Zoom” on page 63.

Click here
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On the middle of the screen, you will see the following drawn with the color red:

The symbol reference point
The asterisk (*) is the reference point for the new symbol. This reference point indi-
cates the position of the symbol, and that it is this point you rotate the symbol 
around, if you rotate it. A symbol has only got one reference point.

Reference points for symbol texts
The red pluses (+) are the reference points for the symbol texts. — Read more 
about these texts in “Texts connected to symbols” on page 131.

Position for references to other symbols
When creating new symbols, you can furthermore specify the position for refer-
ences to other symbols. The position of this reference point is pointed out in the 
lower-left corner in the figure above.

The red plus for this reference text is always present in the Edit symbol mode, but 
does not become active for placed symbols before the symbol reference is activated 
— for symbols of the type Open, Close etc.

When you place a symbol of a type, for which references are not displayed — e.g. 
symbols of the type Normal —, the reference is not displayed until you have 
selected With reference on the tab References in the dialog box Component data.

AUTOMATIC CREATION OF SYMBOLS

WHEN YOU ARE IN THE EDIT SYMBOL MODE (WHICH YOU ARE NOW), YOU 
CAN ALSO USE THE SYMBOL GENERATOR TO CREATE A "RAW-SYMBOL", 
WHICH YOU CAN THEN CONTINUE WORKING ON HERE.

TO DO THIS, CHOOSE SYMBOLS, CLICK THE SYMBOL MENU BUTTON, AND 
CLICK ON THE SYMBOL GENERATOR BUTTON. — READ MORE IN “AUTO-
MATIC GENERATION OF SYMBOLS — USING THE SYMBOL GENERATOR” ON 
PAGE 212.

Symbol reference point

Symbol type

Symbol name

Symbol function

Symbol article no.

Reference points for
the symbol texts

(hidden under the
reference point)

Position for references
to other symbols
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Moving the reference point
To make room to draw the symbol itself, you can now move the reference point a 
bit to the left. Therefore, click on the Reference point button. Click on the refer-
ence point, and drag it to where you want it placed. — In this case you move it 
15mm to the left. See the coordinates in the lower-left corner of the screen.

Lines in symbols
Click on the Lines button (short-cut [l]), and click on the Draw button (in order to 
make it highlighted).

You can determine that lines in the symbol must follow the width and the color of 
the conducting lines, which gets connected to the symbol, when you are using it on 
a diagram later on. If the Follow connected button is not activated (highlighted), 
then click on it. Read more about this in “Follow connected lines” on page 111.

Drawing lines as a rectangle
To draw the rectangle in the symbol, you now click on the Rectangle button.

Point out the lower-left corner of the rectangle by clicking on a point 10mm below 
and 10 mm to the left of the reference point. Then point out the upper-right corner 
of the rectangle by clicking on a point 10mm above and 10mm to the right of the 
reference point.

You have now drawn a rectangle of 20x20mm around the reference point.

Coordinates and distances are displayed in the lower-left corner of the screen.

Place connection points
To be able to use the symbol electrically later on, there have to be some points on 
the symbol, to which electrical lines can be connected, when you place the symbol 
in a diagram. These points are called connection points, and you place them by 
clicking on the Symbols button, the Connection point button and the Pencil.
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You then get a connection point in the cross hairs, and click where you want the two 
connection points located — see the illustration below.

When you then place the connection points, you will be asked about their connec-
tion point data.

Symbol name Symbol article number

Connection point Connection point

Symbol reference point

Symbol function

Symbol type

Frame displaying how much
space the symbol needs



PCschematic ELautomation 10.0 PAGE 675

CREATING SYMBOLS

In this case, you can for instance give them the names 1 and 2 respectively, and 
make the names invisible on diagram pages, by deselecting the Visible check box 

for the Name field.

MORE OPTIONS IN THE DIALOG BOX CONNECTION DATA

Connection data with a variable part in the name
If you write ?1 and ?2, you can — 
directly from the dialog box Com-
ponent data — type in what shall 
be at the place of the question mark 
in the connection name, when you 
place the symbol in the project.

This can for instance be useful when 
placing make and break symbols, 
where the mechanical position is not 
known prior to the placing of the 
symbol. Correspondingly, for terminals it can be useful just to write *, which 
gives you the option of typing in all of the connection name when placing the 
terminal in the project.

— See “Connection names with variable part in the Symbol definition” on 
page 182, “Wildcards/jokers” on page 542 and “Symbols with variable con-
nection names” on page 582.

With reference
If you click here, an independent reference text is created for the connection 
point, which refers to connection points on symbols with the same name and 
connection name. This is particularly applied for PLC symbols — see “Cre-
ating PLC I/O symbols” on page 697 and “Creating PLC reference symbols” 
on page 700.

INACTIVE REFERENCE

When you have selected With reference, you then get the option of choosing 
Inactive reference. When you do so, the reference is not activated when the 
symbol is placed. But it makes it possible for you to pre-define the position 
of the references, if these should be activated after the symbol has been 
placed in a project.

No dot generation
— Regarding No dot generation, see “No dot generation” on page 675.
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You have now placed the connection points for the symbol.

Press <Esc> to get rid of the connection point symbol in the cross hairs.

Drawing a circle
You draw the circle in the symbol by clicking on the Pencil and the Circles button 
(short-cut [c]).

The tool bar for circles/arcs then appear, and you get a circle in the cross hairs.

You may read more about this tool bar in “Arcs/Circles” on page 125.

Set the radius (R:) to 8.0, and place the circle with its center in the symbol refer-
ence point.

Typing in a free text
In the middle of the symbol, the free text Block shall appear. — See “Texts” on 
page 127 for further details about the various text types in PCschematic ELauto-
mation.

Therefore click on the Texts button, or press the short-cut key [t].

No double check
When performing a design check — see “Design Check” on page 328 —, it is 
possible to examine whether the project contains symbols, which has more 
than one connection point with the same name. This is done by selecting 
Used more than once.

However, for some symbols — pneumatic symbols in particular — connec-
tion points with identical names allowed according to the standards.

To disable this check for a connection point in the symbol definition, select 
No double check. Having done this, the program will not examine whether 
this connection point name is used more than once for the component, when 
performing a design check.

NOTE FOR NO DOUBLE CHECK

BEFORE DISABLING THE DOUBLE CHECK IN THE SYMBOL DEFINITION, YOU 
SHOULD MAKE SURE THAT THIS IS ALLOWED FOR THIS SYMBOL TYPE ACCORD-
ING TO DOCUMENTATION STANDARDS.
IT IS NOT POSSIBLE TO DISABLE THIS DOUBLE CHECK FOR A SYMBOL IN ANY 
OTHER WAY THAN VIA THE SYMBOL DEFINITION.

MORE OPTIONS IN THE DIALOG BOX CONNECTION DATA



PCschematic ELautomation 10.0 PAGE 677

CREATING SYMBOLS

Click in the text field in the texts tool bar, and type in the text Block. Press <Enter>.

You now have the text in the cross hairs.

Changing text properties
Click on the Text properties 
button. Give the text a height of 
3.0mm, and set the alignment 
to centre-centre.

Select height and alignment as 
displayed in the Text proper-
ties menu. Click OK.

The text in the cross hairs now 
has the chosen properties.

If you are not sure how to make 
these settings, please read “Specifying text properties / Appearance of text” on 
page 145.

Place the text by clicking in the middle of the symbol.

Press <Esc> or click on the Pencil in order not to place more copies of the text.

— Please note that a free text in a symbol definition can not be changed when you 
later place the symbol in a project. These texts can only be changed here in the pro-
grams Edit symbol mode.

Texts and text properties for symbol texts
Click on the Texts button, if not already selected. Deselect the Pencil by pressing 
<Esc>. Click on the reference point for the text Symbol name, to select it. In the 
command tool bar you can see whether you have selected the right text reference 
point.

Here it should say S.Name.

If you fill out this field with the prefix B, this letter will be suggested as a symbol 
name, when you place the symbol in a project. Press [k], and this dialog box 
appear:

Type in B and press <Enter>. — In stead of pressing on [k] you can click in the text 
field in the command tool bar, type in B and press <Enter>.
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When you have selected one of the symbol texts, you can change back and forth 
between the symbol texts by pressing [F5].

Changing text properties
While the text is selected on the drawing, you click on the Text properties button, 
and choose a height of 2.5mm and a centre-centre adjustment.

Click OK.

The text properties settings which are suggested for the various types of symbol 
texts, are set on the tab Settings => Text/Symbol defaults. You may read more 
about this in “Changing text properties” on page 151.

Moving the symbol texts
To move the Symbol name text on the diagram, you do like this:

Click on the Texts button, and deactivate the Pencil (press <Esc>). Click on the 
Symbol name text, in order to select it. Then click on the Move button.

Usually you work in a snap of 2.5mm. The Snap button is selected (highlighted).

To place the text in a finer snap, you press down <Shift>. The snap is now 0.25mm. 
This you can see on a red background in the lower part of the left tool bar. Now 
click where you want to place the text. Let go of the <Shift> key, and you return to 
the normal snap.

Move the other symbol texts according to the drawing of the symbol above.

DO NOT WRITE "-B" IN THE SYMBOL NAME

IT IS RECOMMENDED THAT YOU DO NOT WRITE "-B" IN THE SYMBOL NAME. IF 
YOU CHOOSE SETTINGS => POINTER/SCREEN AND SELECT INSERT - IN 
FRONT OF SYMBOL NAMES, THE PROGRAM AUTOMATICALLY INSERTS A MINUS 
IN FRONT OF THE SYMBOL NAME WHEN YOU PLACE THE SYMBOL IN A PROJECT 
— SEE “POINTER/SCREEN” ON PAGE 815.
IF YOU WRITE "B?" THE SYMBOL WILL AUTOMATICALLY BE ASSIGNED THE 
NEXT AVAILABLE SYMBOL NAME, WHEN YOU PLACE THE SYMBOL.

CHANGING SYMBOL TEXTS WITH THE SYMBOL BUTTON CHOSEN

When you have activated the Symbols button while designing a symbol, you 
get this tool bar on the screen:

Here you can also fill out the symbol texts by clicking on the various fields, 
and type in the relevant texts.
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Read more about snap and grid in “Screen / Image Functions” on page 63.

Saving the symbol
Click on the Save button. If you have not saved the symbol before, a dialog box for 
Symbol settings will appear. Give the symbol a Title — this means a description of 
the use or appearance of the symbol. This text will be displayed in the upper part of 
the Symbol menu when the symbol is selected there — and you also use it to deter-
mine which symbol to pick when you choose symbols in the pickmenu.

Click inside the field, and type in for instance Block symbol with two connection 
points.

SHOW SYMBOL TEXTS

If you want to see which size the 
different symbol texts will have 
when they are filled out, which 
color they have, or whether they 
will cover the drawing of the 
symbol when they are filled out, 
you can choose View => Show 
texts.

Only texts which have not yet 
been filled out, will be altered.

You can change the appearance 
of the texts using the Text prop-
erties button.

Choose View => Show texts again, to turn the function off again.
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Symbol types
As Symbol type you can choose between the following symbol types:

THE SYMBOL SETTINGS BUTTON

YOU CAN ALSO ENTER THIS DIALOG BOX WHILE DESIGNING THE SYMBOL, IF 
YOU CLICK ON THE SYMBOLS BUTTON, AND THEN ON THE SYMBOL SETTINGS 
BUTTON.

SYMBOL TYPE USE

NORMAL SYMBOLS WITHOUT A SPECIAL STATUS.

RELAY SYMBOLS WHICH WILL HAVE AN ATTACHED REFERENCE CROSS WHEN 
PLACED ON A DIAGRAM PAGE.

OPEN THE SYMBOL WILL BE CONCEIVED AS AN OPEN CONTACT, AND THE LOCATION 
OF THE SYMBOL WILL BE DISPLAYED IN THE REFERENCE CROSS, AS AN OPEN 
CONTACT FOR THE COMPONENT IT IS A PART OF. WILL ALSO BE ASSIGNED A 
REFERENCE TO THE RELAY SYMBOL FOR THE SAME COMPONENT.

CLOSE THE SYMBOL WILL BE CONCEIVED AS A CLOSE CONTACT, AND THE LOCATION 
OF THE SYMBOL WILL BE DISPLAYED IN THE REFERENCE CROSS, AS A CLOSE 
CONTACT FOR THE COMPONENT IT IS A PART OF. WILL ALSO BE ASSIGNED A 
REFERENCE TO THE RELAY SYMBOL FOR THE SAME COMPONENT.

SWITCH THE SYMBOL WILL BE CONCEIVED AS A SWITCH, AND THE LOCATION OF THE 
SYMBOL WILL BE DISPLAYED IN THE REFERENCE CROSS, AS AN OPEN- AS 
WELL AS A CLOSE CONTACT FOR THE COMPONENT IT IS A PART OF. WILL 
ALSO BE ASSIGNED A REFERENCE TO THE RELAY SYMBOL FOR THE SAME 
COMPONENT.

SYMBOL TYPES



PCschematic ELautomation 10.0 PAGE 681

CREATING SYMBOLS

The symbol in this example has no specific directions, so the symbol type is Nor-
mal.

Selection
The Selection shall be set to Whole symbol. This means that the symbol will be 
selected if you click anywhere on the symbol.

MASTER REF-
ERENCE

THE SYMBOL WILL HAVE REFERENCES TO ALL OTHER SYMBOLS HAVING THE 
SAME SYMBOL NAME. FOR INSTANCE MANUALLY CONTROLLED CONTACTS.

WITH REFER-
ENCE

REFERS EITHER TO A SYMBOL WITH MASTER REFERENCE, OR TO THE CLOS-
EST PRECEDING- AS WELL AS SUCCEEDING SYMBOL, WHICH IS PART OF THE 
SAME COMPONENT.

REFERENCE A SYMBOL WHICH IS A REFERENCE CROSS.

SIGNAL A SYMBOL USED AS REFERENCE FOR A SIGNAL FROM ONE ELECTRICAL POINT 
TO ANOTHER. READ MORE ABOUT THIS KIND OF SYMBOLS IN “CREATING SIG-
NAL SYMBOLS” ON PAGE 710, AND IN “SIGNAL SYMBOLS” ON PAGE 218.

MULTISIGNAL RESERVED FOR FUTURE USE.

TERMINAL THE SYMBOL WILL APPEAR IN TERMINALS LISTS.

PLC THE SYMBOL WILL APPEAR IN PLC LISTS.

DATA APPLIED TO ADD INFORMATION TO A COMPONENT WHICH HAVE BEEN PLACED 
ON THE DRAWING. THIS INFORMATION CAN ALSO APPEAR IN LISTS. READ 
MORE IN “CREATING DATA SYMBOLS” ON PAGE 704.

NON CONDUCT-
ING

THE SYMBOL CAN BE CONNECTED TO A NON CONDUCTING LINE. FOR 
INSTANCE A SYMBOL FOR A WINDOW OR A DOOR, WHICH CAN BE PLACED ON 
A NON CONDUCTING LINE (A WALL).

SUPPORT A SYMBOL BELONGING TO A SPECIFIC COMPONENT, AND THAT WILL APPEAR 
IN LISTS.

CABLE THE SYMBOL IS A CABLE, AND WILL APPEAR IN CABLES LISTS

— SEE FOR INSTANCE “WORKING WITH CABLE SYMBOLS” ON PAGE 231, AND 
“CREATING CABLE SYMBOLS” ON PAGE 695.

WIRE NUMBER A SYMBOL WHICH CAN BE APPLIED AS A WIRE NUMBER SYMBOL. IS USED 
DURING AUTOMATIC OR MANUAL WIRE NUMBERING. THE PROGRAM SUG-
GESTS NEXT AVAILABLE WIRE NUMBER, WHEN YOU PLACE A WIRE NUMBER 
MANUALLY.
— SEE “AUTOMATIC WIRE NUMBERING” ON PAGE 395.

INSERTION 
POINT

USED FOR AUTOMATIC INSERTION OF SUB DRAWINGS. — SEE “PLACING SUB 
DRAWINGS WITH DRAG’N DRAW” ON PAGE 273.

PLCREFER-
ENCE

SYMBOL, WHICH SHALL BE USED AS A PLC REFERENCE SYMBOL.
— SEE “CREATING PLC REFERENCE SYMBOLS” ON PAGE 700 AS WELL AS 
“WORKING WITH PLC’S” ON PAGE 446, SPECIALLY “ON PLC REFERENCE 
SYMBOLS” ON PAGE 446.

LINE CONNEC-
TION

SYMBOL APPLIED IN CONNECTION WITH SUB DRAWINGS WITH MODELS. THE 
SYMBOL IS APPLIED FOR SPECIFYING WHERE TO CONNECT A WIRE IN A SUB 
DRAWING, WHEN THE SUB DRAWING IS PLACED IN A PROJECT PAGE. — SEE 
“CREATING LINE CONNECTION SYMBOLS” ON PAGE 702.

HEAD SYMBOL APPLIED FOR DIRECT PLACING OF A LIST ON A PAGE. — SEE “CRE-
ATING A LIST SYMBOL” ON PAGE 739.

SYMBOL TYPE USE

SYMBOL TYPES
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If you set the Selection to Reference point, this means the symbol only will be 
selected when you click directly on its reference point. This facility is used for sym-
bols on which you place other symbols, such as a switchboard symbol.

Click on OK.

IN PROJECTS YOU CAN ALSO CHOOSE THE REFERENCE POINTS FOR SYMBOLS 
WITH SELECTION SET TO REFERENCE POINT.

SYMBOL SETTINGS: ADVANCED

CLICK ON THE ADVANCED TAB FOR EXTRA OPTIONS:

HERE YOU CAN TURN THE NO SCALE ADJUSTMENT FUNCTION ON AND OFF. NORMALLY IT 
WILL BE TURNED OFF, WHICH SIGNIFIES THAT THE SYMBOL HAS GOT SCALE ADJUSTMENT. 
THIS MEANS THAT YOU CAN USE THE SAME SYMBOL ON A PAGE WITH THE SCALE 1:1 AS 
WELL AS ON A PAGE WITH THE SCALE 1:50.

AUTO SCALE IS — JUST LIKE NO SCALE ADJUSTMENT — A FUNCTION YOU DO NOT USE IN 
ORDINARY DIAGRAM OR GROUND PLAN DRAWINGS. THIS IS A SPECIAL FUNCTION, WHICH 
MAKES THE SYMBOL SCALE ITSELF, SO THAT IT CORRESPONDS TO THE LINE TYPE YOU PLACE 
IT ON. YOU CAN ONLY USE THIS FUNCTION FOR SYMBOLS DESIGNED TO FIT 10MM LINES.

WHAT MULTISYMBOL IS USED FOR, IS DESCRIBED IN “CREATING A SYMBOL AS A MULTI 
SYMBOL” ON PAGE 688.

WHEN MECHANICAL IS SELECTED, THE SYMBOL WILL BE INCLUDED IN COMPONENTS AND 
PARTS LISTS. MECHANICAL IS SELECTED BY DEFAULT.

— SEE “SYMBOL DATA IN ELECTRICAL AND MECHANICAL LISTS” ON PAGE 181.

WHEN ELECTRICAL IS SELECTED, THE SYMBOL WILL BE INCLUDED IN ALL ELECTRICAL LISTS 
— SUCH AS TERMINALS, CABLES, CONNECTIONS AND PLC LISTS — WHEN THE SYMBOL CON-
TAINS INFORMATION TO INCLUDE IN THESE LISTS. ELECTRICAL IS SELECTED BY DEFAULT.

— SEE “SYMBOL DATA IN ELECTRICAL AND MECHANICAL LISTS” ON PAGE 181.
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Saving the symbol
First time you save a symbol, you enter the Save as dialog box. Here you select the 
folder you want to save the symbol in, like you normally do in Windows. You may 
read more about this in “Saving Projects/Files” on page 47.

The symbol will automatically get the extension .sym.

Click in the File name field and type in the name Block.

Please refer to “Symbol folders” on page 239 to determine in which folder you will 
save the symbol.

SYMBOL SETTINGS: REFERENCE

IF NECESSARY, CLICK THE REFERENCE TAB:

FOR SYMBOL TYPES CREATED WITHOUT REFERENCES, YOU CAN HERE SPECIFY TO CREATE 
THE SYMBOL WITH WITH REFERENCE ACTIVATED, WHEN PLACED IN A PROJECT PAGE. THE 
OTHER WITH REFERENCE SETTINGS CAN ALSO BE PREDEFINED.

— READ MORE ABOUT THIS IN “REFERENCES ON SYMBOLS” ON PAGE 375, “INSERTING REF-
ERENCES ON SYMBOLS WITHOUT REFERENCE” ON PAGE 375 AND “SYMBOL TYPE AND REF-
ERENCES” ON PAGE 376.
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Click on Save. The symbol has now been saved.

Printing out the symbol
If you want the symbol printed out, you just click on the Print this page button.

Leaving the Symbol menu
Having saved the symbol, you may now leave the Design symbol mode.

Therefore choose File => Close.

You now return to the Symbol menu, where 
you can find the symbol by changing to the 
folder you saved the symbol in.

When you place the cursor above the symbol, 
its Title, Name and Type is displayed as a hint.

If you need the symbol on your drawing, you 
then click on OK.

You then return to the project with the symbol in the cross hairs, and you can now 
place it in the project.

— Read more about what you then can do with the symbol in “Symbols” on 
page 158.

SYMBOL CREATION TIME IN GMT
THE TIME OF CREATION FOR SYMBOLS IS REGISTERED IN GMT. THE CREATION 
TIME OF ANY SYMBOL IS THEREFORE INDEPENDENT OF WHERE IN THE WORLD 
THIS SYMBOL IS CREATED. NO UNNECESSARY GENERATION NAMES WILL 
THEREFORE BE GENERATED DUE TO SYMBOLS CREATED IN DIFFERENT TIME 
ZONES, OR WHEN CHANGING BETWEEN SUMMER/WINTER TIME.
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EXTRA SYMBOL DATAFIELDS IN SYMBOLS

You can also insert extra datafields in the definition of a symbol:

1) Create the necessary datafields — as described in “Creating symbol 
datafields” on page 705

2) Choose Functions => Insert Datafield

3) In the dialog box Datafield: Choose the datafield you want to insert, and 
place it in the symbol definition — read more about datafields in “Datafields” 
on page 134

You can also insert datafields of the type Project data and Symbol data in the sym-
bol definition.

When you have placed the symbol on a project page, you type in the contents of the 
datafield as described in “The tab Symbol Data” on page 184.

Inserting symbol datafields from database in symbol definition
There is also a symbol datafield for all fields in the database. In your projects you 
can therefore place symboldata datafields, that fetches data from the database.

To place a such symboldata datafield you must do as described above, and select 
Symbol Datafields in the dialog box Datafield.

The datafields fetching data from the database, are named DB[xxxxxx], where 
xxxxxxx is the name on the database field. For instance will DB[DESCRIPT] fetch 
the contents from the DESCRIPT field for the component in the database.

Symbol datafields, which you have designed yourself, will be written as ordinary 
text. — See “Creating Data symbols” on page 704.

Typing in data when placing symbols with extra symbol datafields
When you have placed the symbol in a project, you type in the contents of the 
datafields as described in “The tab Symbol Data” on page 184.
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CREATING SYMBOLS WITH STATES

When you wish to create a symbol with states — see “Symbols with states” on 
page 187 — you start by drawing the symbol as described in “Creating Symbols” 
on page 670.

How to specify the states
The only extra thing you must do, is to start by clicking the States to layers button, 
when you enter the Edit symbol mode.

This tells the program that the layers in the symbol now shall be understood as 
states. You can then use the Layer menu for specifying the symbol states:

The common parts are placed in layer 0
In layer 0 you draw what all states for the symbols have in common.

In layer 1 you draw what is to be displayed extra for the symbol in state 1. In layer 
2 you draw what is special for state 2 — and so on.

When clicking the States to layers button again, everything is displayed in layer 0.

Assinging titles to the states
To assign a title to a state for the symbol, click the Symbol settings button. On the 
tab General, click in the field Title of state:1 (displayed when you are in layer/state 
1), and type in the title for this state:

To specify the title for another state, you must first change layer using the Layer 
menu, and then name the state for this layer as described above.

The state titles are displayed in the Symbol menu
When you have saved a symbol with states, you can subsequently see the names of 
the states in the Symbol menu, when you let the mouse rest over the symbol:
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The states and state titles are displayed in the Komponent data dialog box
When you place a symbol in the project — see “Symbols with states” on page 187 
— the states are ordered by state number in the dialog box Component data. When 
you let the mouse cursor rest over one of the states, the title for the state is dis-
played.

States and their titles are also displayed in the Information dialog box for symbols.

Datafields in states
Datafields can also be placed in the individual states for a symbol. For instance you 
can use this to create one state where no symbol datafields are visible, and another 
state where some — or all — symbol datafields are visible.

— Read more about symbol datafields in “Creating symbol datafields” on 
page 705.

Other links
— See how to work with layers in “Layers, Elevation and Scaling” on page 471.

— See also “Symbols with states for single line diagrams” on page 478 and “Plac-
ing symbols with selected states in the pickmenu” on page 200.

— See how you from the database can control which state a symbol shall be in 
when placed in a the project in “Specifying symbol state for electrical symbols via 
the database” on page 579 and “Specifying symbol state for mechanical symbols” 
on page 586.

SYMBOLS WITH CONNECTION POINTS IN OTHER LAYERS

The connection points you place in the symbol definition are placed in layer 0. This 
makes the connection point available in the layer you place the symbol.

If you place connection points in other layers in the symbol definition, the connec-
tion points are placed in these layers — no matter which layer you place the symbol 
in.

— Read more about layers in “Layers, Elevation and Scaling” on page 471.
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CREATING A SYMBOL AS A MULTI SYMBOL

If the electrical symbols for a com-
ponent have to be three independ-
ent symbols of the same kind, you 
can state this by saving the symbol 
as a so-called multi symbol. This 
facility can for instance be used for 
PLC’s.

Enter the Symbol menu (press 
[F8]), click on the symbol you just 
created, and then click on Edit 
symbol.

Zoom in on the symbol, and click 
on the Connection point button.

Right-click on the connection point 
in the left side of the symbol, 
choose Connection data and type in 1,3,5 in the Name field. Click on OK.

Then right-click on the connection point on the right side of the symbol, choose 
Connection data, type in 2,4,6 in the Name field, and click OK.

Hereby you state that the symbol shall consist of three independent symbols of the 
same name, and that the first symbol shall have the connection names 1 and 2, the 
second the names 3 and 4, and the last gets the names 5 and 6.

Saving the multi symbol
Now choose File => Save as. Correct the title of the symbol if you want — please 
note that the Symbol type must remain Normal — and click on the tab Advanced. 

On this tab you select Multisymbol, and click OK.

Then type in the new name of the symbol — or keep the old — and click OK.

You have now saved the symbol as a multi symbol.
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Fetching the multi symbol
When you fetch the symbol as you normally do from the Symbol menu (press [F8] 
and choose the symbol), you get a pickmenu with three symbols in it.

Click on one of the symbols, and place it on a drawing. Right-click on the symbol 
you have placed, and chose Show available to enter the pickmenu again. Read 
more about this in “The function Show available” on page 245.

Symbols with extra connection points
If you want one of the three symbol to have an extra connection point, you place 
this extra connection point on the symbol.

To determine that for instance only the third of the symbols shall have this connec-
tion point, you type in ,,7 in the Name field in its Connection data dialog box. 
Hereby you state that the two first symbols shall not have this connection point, and 
that the connection point in the third symbol shall have the name 7.

If only the first of the symbols shall have the connection point, you just type in 7 in 
the Name field.

SPECIFYING DEFAULT TEXT SETTINGS FOR EDIT SYMBOL MODE

To specify where PCschematic ELautomation shall position the different text ref-
erence points in relation to the symbol reference point, as well as which text proper-
ties to suggest for these texts, do the following:

1) When PCschematic ELautomation is in the Edit symbol mode: Choose Set-
tings => Text/Symbol defaults.

2) On the tab Text/Symbol defaults: Click on Symbol.

3) You can then choose which symbol text to edit default settings for:

Choose symbol text Specify the text position
in relation to the symbol
reference point

Specify text
properties
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4) Specify the text position in relation to the symbol reference point, and click 
the Text properties button, if necessary.

5) In the dialog box Text properties: Specify the desired text properties, as 
described in “Specifying text properties / Appearance of text” on page 145, 
and click OK.

6) On the tab Text/Symbol defaults: Click the Save as default button, if the 
selected text settings also shall apply for other projects.

7) Click OK.

LOADING ANOTHER SYMBOL INTO THE SYMBOL

While you are designing a symbol, you have got the option to load another symbol 
into the symbol you are designing.

To do this, you click on the Symbols button, and then on the Symbol menu button. 
Please note, that when you are designing symbols, the Symbol menu button is 
placed to the right on the command tool bar.

You then enter the Symbol menu, click on the symbol you want to use, and click 
on OK.

You get the symbol in the cross hairs, and click where you want it placed.

When you have placed the symbol, it is no longer conceived as an independent 
symbol. This is because the lines are now conceived as ordinary lines in the symbol 
you are now designing.

The reference points and the symbol texts are not transferred in the inserted sym-
bol, but its connection points are still connection points, and the names of the con-
nection points remain unchanged.

You can also use File => Open, and find the symbol there.

Finally, you can also load a DWG or a DXF file into the symbol — see “DWG and 
DXF files” on page 635.

COPYING AREAS TO EDIT SYMBOL

It is possible to copy an area from a project drawing, and use this copied area when 
creating symbols in the Edit symbol mode.

— Read more about this in “Copying areas into Edit symbol mode” on page 265.
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CREATING TERMINAL SYMBOLS

When you create a terminal symbol, you have 
to state which connection points are Input and 
which are Output. This you can only do after 
having placed the connection points.

When you have placed a connection point, 
you right-click on it, and choose Connection 
data.

By clicking on the down-arrow in the Main 
type field in the Connection data dialog box, 
you can choose whether the connection point 
is of the type Input or Output, which is of 
importance on terminals lists.

If you set a connection to the main type Output, the connection point will be filled 
out with the color red.

The type can also be changed after having placed the terminal in a project drawing. 
Read more about this in “Terminal symbols” on page 228.

Set the Extension to TERM (terminal) — see “Creating terminal symbols with an 
additional status” on page 693 also.

IDENTICAL CONNECTION NAMES FOR TERMINAL SYMBOLS

IF YOU IN THE DEFINITION OF A TERMINAL SYMBOL ASSIGN THE SAME NAME 
TO ALL CONNECTION NAMES, PCschematic ELautomation WILL MAKE 
SURE THAT THESE CONNECTION NAMES REMAINS IDENTICAL, WHEN THE SYM-
BOL IS PLACED IN A PROJECT PAGE, AND ONE OF THE CONNECTION NAMES IS 
CHANGED.
— SEE “TERMINAL SYMBOLS WITH DIFFERENT CONNECTION NAMES” ON 
PAGE 693
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No dot generation
When you use terminal symbols, you can let two lines connect to each of the con-
nection points of the terminal.

Normally, this will result in a connection dot being placed in the connection point. 
If you do not want this to happen, you can select No dot generation in the lower 
part of the menu.

The names of both the connection points shall be set to 0, and the Visible field disa-
bled for one of the two connection names. When the connection names (terminal 
numbers) are inserted on the drawing, both the connection points will get the same 
name, but only the one will be visible.

Click on OK.

Terminal symbols are saved under the symbol type Terminal.

You can read more about terminal lists in “Creating a Terminals list” on page 736.

No dot generation Dot
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CREATING TERMINAL SYMBOLS WITH AN ADDITIONAL STATUS

In order to support intelligent terminals and terminals with build-in functions, sym-
bols with the status Terminal can be assigned an additional status — such as Termi-
nal and Relay. Terminal symbols can have the additional status Relay, Open, Close, 
Switch or PLC.

Specifying additional status for terminal symbols
To specify an additional status for a terminal symbol, do the following when creat-
ing the symbol in the Edit symbol mode:

1) Click the Symbol settings button.

2) In the dialog box Symbol options: Select the symbol type Terminal. You then 
get the option of choosing a Symbol type2, which is the additional status for 
the symbol:

3) Select e.g. Open and click OK.

You have hereby assigned the status Terminal and the additional status Open to the 
symbol. The symbol will therefore function as an open contact in the diagram, with 
references to other symbols, and it will also be included in terminals lists.

Terminal symbols with different connection names
Because terminal symbols can behave as both terminal and relay or PLC, the con-
nection names on all of the connections on the terminal symbols are not automati-
cally the same. This is only the case if the symbol in Edit symbol is created with 
identical names on all connections. — See “Identical connection names for termi-
nal symbols” on page 691.
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Terminal symbols with additional status PLC
For terminals with additional status PLC, the Extension of the connection points 
must be set to TERM/PLC. As Main type you can then choose between ext/output, 
ext/input, int/output and int/input, which are created for this purpose.

Symbols with this status are included in both terminals lists and PLC lists.

— See “Creating PLC I/O symbols” on page 697 also.

Specifying terminal additional status via the database
— See how to specify the additional status of terminals via the database in “Speci-
fying the symbol status” on page 577, “Specifying symbol type for terminals with 
additional status” on page 577 in particular.
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CREATING CABLE SYMBOLS

Cable symbols are created as described above.

However, when you design cable symbols, you only place one connection point, 
even though the cable for instance consist of seven wires.

When you use the cable symbol on a project diagram select which wires are 
included into the cable, the program automatically create new connection points for 
each wire you add.

The connection point you place in the cable definition states the location of the first 
cable wire in the cable. As you add more cable wires to the cable on a diagram, the 
cable symbol expands.

When you design the cable symbol, it is important what you place/draw to the left, 
and what you place/draw to the right of the connection point for the cable wires.

To the left of the connection point you place the reference point for the cable sym-
bol, and draw the lines you need at the start of the cable symbol.

To the right you draw what you need at the end of the cable symbol.

Lines going from the left side of the connection point to the right side of the con-
nection point are expanded as you add new cable wires to the cable on the diagram. 
This means that the dotted line on the figure above will expand as you connect new 
cable wires to the cable on a diagram.

Connection point for cable screen
If you place two connection points for the cable symbol, the right-most connection 
point will be conceived as a connection point for a cable screen.

Remains unchanged Remains unchangedExpands

The connection pointThe reference point for
the cable symbol for cable wires

Connection point
for cable screen
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Indicate a cable wire is connected to the cable
When you connect a cable wire to the cable on a diagram, the lines in the middle 
part of the cable definition expands to include those, but no sign is displayed where 
the cable wire meets the connection point of the cable symbol.

If you want such a sign, you can place the Function text of the connection point on 
top of the connection point. Then type in the Function text "/" and choose the 
alignment centre-centre. — See “Specifying text properties / Appearance of text” 
on page 145 for further details.

Direction of the Cable symbol
In the symbol you design, to direction is facing upwards. If you need a small arrow 
displaying the direction of the cable, you have to draw it yourself. If you use the 
color NP for this arrow, it will be displayed on screen only, and not on print.

Saving the Cable symbol
When you save the symbol, you have to set the symbol type to Cable in the Symbol 
options menu. — See e.g. “Symbol types” on page 680.

— See how to work with cable symbols in “Working with cable symbols” on 
page 231.

Specifying Color codes for Cable symbols
When you are working with cable symbols you can let PCschematic ELautoma-
tion control the color codes for the wires in the cable.

You have to specify these color codes in the record for the cable in the database. 
This is done like you specify connection names for symbols in general. Please refer 
to the PCschematic Database manual for further details.

Most used cable direction
For setting the most used cable direction, please refer to “Default Cable direction” 
on page 238.
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CREATING PLC I/O SYMBOLS

— Read about PLC I/O symbols and their use in “Working with PLC’s” on 
page 446, “Workflow for PLC’s from the database” on page 449 and “PLC data on 
the I/O symbol connection points” on page 453.

PLC I/O symbols are designed as other symbols — see “Creating Symbols” on 
page 670.

When designing PLC I/O symbols, you must furthermore do the following:

Activate With reference for PLC I/O symbol input/output connection points
When you place the connection points representing inputs/outputs on the PLC I/O 
symbols, you must enter the dialog box Connection data (e.g. by double-clicking 
on the connection points) and select With reference.

Hereby an independent reference text Ref is attached to the connection point. This 
text you can subsequently place an appropriate place in the symbol definition — 
see “PLC I/O symbols placed in projects” on page 699.

When you have placed the created PLC I/O symbol in the project, the Ref text will 
contain a reference to this connection point in the PLC reference symbol for the 
PLC in the project. — See “Jumping between PLC ref. symbols and PLC I/O sym-
bols” on page 455.

For I/O connection points

For connection points

Connection points for PLC I/O symbols

for common terminals
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Connection points for common terminals: Do not select With reference
For connection points with common terminals (supply/ground) you shall not select 
With reference.

IO status for connection points on PLC I/O symbols
Set the Main type for input and output connection points to input or output, depend-
ing on whether they shall refer to inputs or outputs. Furthermore, set the Extension 
for these connection points to PLC.

— Please refer to the figure on page 697.

Connection points for common terminals shall not be assigned Main type or Extension
For connection points for common terminals (supply/ground), both Main type and 
Extension shall be set to none.

I/O addr. in the symbol definition can specify pairs of connection points
In the field I/O addr. you specify an address for the connection point. This address 
has two functions:

1) The program understands connection points with the same I/O addr. in the 
symbol definition as belonging together. When you draw a PLC I/O symbol 
with e.g. eight connection points, which are addressed in pairs, you can there-
fore give the pairs the same I/O address.

2) When placing the PLC I/O symbol directly in the project — without first hav-
ing addressed the PLC via a PLC reference symbol —, the connection point 
will be assigned the address which you specify here.

Please note, that the field I/O addr. is called Function for a start, and will not get 
the name I/O addr. until you have set IO status for the connection point, as 
described in “IO status for connection points on PLC I/O symbols” on page 698.

— Please refer to the figure on page 697.

Save the PLC I/O symbol with the symbol type PLC
When you save the PLC I/O symbol — see “Saving the symbol” on page 679 and 
“Symbol types” on page 680 —, you must give it the symbol type PLC.

When you use the symbol in projects, you can therefore apply all of the automatic 
PLC functions in PCschematic ELautomation, and the symbol will furthermore be 
included in PLC lists.



PCschematic ELautomation 10.0 PAGE 699

CREATING SYMBOLS

PLC I/O symbols placed in projects
When you have placed the PLC I/O symbol in the project, it can for instance look 
like this:

— See also “PLC data on the I/O symbol connection points” on page 453 and 
“Jumping between PLC ref. symbols and PLC I/O symbols” on page 455.

Name of the PLC Name of the connection point
(Name of the physical pin on the PLC)

Address (The I/O addr. field for

Reference to the connection point

(The Name field for the symbol)

the connection point)

in the PLC reference symbol

The Description field

(The Ref field)
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CREATING PLC REFERENCE SYMBOLS

— Read about PLC reference symbols and 
their use in “On PLC reference symbols” on 
page 446.

PLC reference symbols are designed as 
described in “Creating Symbols” on 
page 670.

When designing PLC reference symbols, 
you must furthermore do the following:

Activate With reference for the PLC symbol I/O connection points
When you place the PLC connection 
points, you must enter the dialog box 
Connection data (e.g. by double-clicking 
on the connection point) and select With 
reference.
This places a reference text Ref attached 
to the connection point. This reference 
text refers to connection points on PLC I/
O symbols with the same name and con-
nection point in the project. — See “Cre-
ating PLC I/O symbols” on page 697.

When you have placed the created PLC 
reference symbol in the project, and subsequently place the PLC I/O symbol with 
the connection name 1, there will be placed a reference to the position of the PLC I/
O symbol next to connection name 1 in the project. — See “Jumping between PLC 
ref. symbols and PLC I/O symbols” on page 455.

You shall only choose With reference for the I/O connection points.

I/O status for PLC reference symbol I/O connection points
Set the Main type for the connection points to output or input, depending on 
whether the connection points shall refer to an input or an output.

Furthermore, set the Extension for the connection points to PLC.

Connection points

Texts for the connection points

Select Reference
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The PLC reference symbol contains connection data for I/O symbols
Data for the PLC inputs/outputs are attached to the connection points on the PLC I/
O symbols — see “PLC data on the I/O symbol connection points” on page 453. In 
this example, the PLC reference symbol consists of lines with data from these con-
nection points:

Save the PLC reference symbol with the type PLC reference
When saving the PLC reference symbol — see “Saving the symbol” on page 679 
and “Symbol types” on page 680 —, you must save it with the symbol type PLC 
reference.

Connection pointI/O address (C.Function)

Reference to the position of the
PLC I/O symbol in the project (Ref)

Name on a PLC I/O symbol con-
nection point, for which this line
will contain data, when this PLC
reference symbol is used in the
project

description (C.Descr.)
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CREATING LINE CONNECTION SYMBOLS

The symbol type Line connection symbol is applied in connection with placing sub 
drawings using drag’n draw and in connection with sub drawings in the Project 
Generator. — See how to apply the symbol in praxis in “Sub drawings with 
intelligent line connection” on page 297. See the Projekt generator manual also.

The symbol is applied to specify to which wire in the diagram to connect a wire in 
the sub drawing, when the sub drawing is placed in a project page. The individual 
connection points on the symbol can for instance have the connection names 1, 2 
and 3.

Please remember to save the symbol using the symbol type Line connection.

In the MISC folder you can find the line connection symbols LineConnect3.sym 
and LineConnect4.sym.

Line connection symbol
with the connection
names 1, 2 and 3
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OTHER OPTIONS

Deleting symbols from folder/library
To delete a symbol from the Symbol menu, you have to enter the Symbol menu 
(press [F8]), right-click on the symbol you want to delete, and choose Delete sym-
bol in the menu that pops up.

Changing a symbol in a folder/library
To change a symbol, you have to enter the Sym-
bol menu (press [F8]), click on the symbol you 
want to change, and then click on the Edit sym-
bol button.

Or you can right-click on the symbol you want 
to change, and choose Edit symbol.

You can now change the symbol, and change it under the same name, or under a 
new name.

Changing the symbol type
When a symbol is being used in a project, you can change the symbol type by right-
clicking on the symbol. A menu pops up, you click on Component data, and then 
click on the down-arrow in the Symbol type field, which gives you a list of the pos-
sible symbol types. Pick your choice, and click OK.

DWG/DXF files and symbols
It is an option to save a symbol as a DWG/DXF file, as well as to load a DWG/DXF 
file as a symbol in PCschematic ELautomation.

— See how to do this in “DWG and DXF files” on page 635.



PAGE 704 PCschematic ELautomation 10.0

CREATING DATA SYMBOLS

CREATING DATA SYMBOLS

If you want to attach some extra information to a symbol you have placed in a 
project, you can do this by using another symbol, called a data symbol.

This extra information can subsequently be included into lists.

Please refer to “Creating Symbols” on page 670 for general information about how 
to create symbols.

Please note that it is also possible to insert extra datafields in the definition of a 
symbol — see “Extra symbol Datafields in symbols” on page 685.

CREATING YOUR OWN DATA SYMBOL

In a project you use a motor, and for this motor you 
would like to have information about how many 
windings it has, as well as how many kW it is on 
included on your drawing and on your lists.

However, you cannot enter this information in the 
Component data menu, and you therefore have to 
attach them to the symbol otherwise. This is done by 
creating a data symbol. This symbol can for instance 
be drawn as a table you can fill out — as the exam-
ple on page 705.

THIS CHAPTER DESCRIBES

— CREATING YOUR OWN DATA SYMBOL...............................................................(P. 704)

— DESIGNING THE DATA SYMBOL ..........................................................................(P. 705)

— PLACING THE DATA SYMBOL IN A PROJECT........................................................(P. 707)

— SYMBOL DATAFIELDS WITH PREDEFINED VALUES .............................................(P. 708)

— DATA SYMBOLS AND LISTS ................................................................................(P. 708)

— DATA SYMBOLS AND COMPONENTS LISTS FILES................................................(P. 709)
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DESIGNING THE DATA SYMBOL

To design the data symbol click on the Symbols button and on Symbol menu — or 
press [F8] to enter the Symbol menu. Here you click on the Create symbol button.

Drawing the symbol
Click on the Lines and the Rectangle button, as well as the Pencil. Draw a rectan-
gle like the one you can see on page 705, then click on Straight lines and draw the 
horizontal line in the middle of the symbol. — How to draw lines is described in 
detail in “Lines” on page 93.

Creating symbol datafields
Now you have to create two symbol datafields, to contain the information you want 
to insert into the data symbol.

Therefore you choose Settings => Text/Symbol defaults, and click on Symbol 
datafields in the left-hand side of the menu.

Here you click on Add, type in Windings in the appearing menu, and click on OK. 
Click on Add again, type in kW: and click on OK. You have now created the two 
symbol datafields Windings and kW.

You can also create a list of predefined values for the datafields, as described in 
“Symbol datafields with predefined values” on page 708.

Click OK to exit the dialog box.

— Please note you do not have to be designing a symbol to create the symbol 
datafields.

Placing the symbol datafields in the data symbol
To place the symbol datafields in the data symbol, choose Functions => Insert 
datafield.
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In the Datafield dialog box you click on Symbol Datafield, choose Windings and 
click on the red down-arrow in the lower part of the menu. Place a colon (:) and a 
space character after the transferred text in the Text field, and set the Width to 20.

You can also adapt the text size by clicking on the Text properties button. Read 
more about this in “Specifying text properties / Appearance of text” on page 145.

Place the text in the upper part of the rectangle, as displayed on the drawing.

Insert the datafield kW correspondingly.

Moving the symbol name
Click on the reference point for the text Symbol name, and place it above the data 
symbol by dragging.

Saving the symbol
You have now completed the creation of the data symbol, and are ready to save it. 
Click on Save, and fill out the dialog box as shown below:

It is important that the Symbol type is set to Data.

Click on OK, assign a name to the symbol in the following menu, and click OK 
again.

Now leave the Design symbol mode by choosing File => Close, and leave the 
Symbol menu by clicking on Cancel.



PCschematic ELautomation 10.0 PAGE 707

CREATING DATA SYMBOLS

PLACING THE DATA SYMBOL IN THE PROJECT

Press on [F8] to enter the Symbol menu, where you click on the data symbol and 
click OK. Returning to the project drawing, with the data symbol in the cross hairs, 
you place the symbol next to the motor symbol.

When you click to place the data symbol, you automatically enter this dialog box:

By assigning the name +W1-M1 to the data symbol, you tell the program that the 
information in this data symbol, is attached to the symbol with the name +W1-M1.

Fill out the data symbol fields, click on OK, and place the symbol.

If the data symbol does not have an appropriate size compared to the motor symbol, 
you can scale it using the symbol scale field in the symbol tool bar. Read more 
about this in “Scaling symbols” on page 194.
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SYMBOL DATAFIELDS WITH PREDEFINED VALUES

Symbol datafields can have a list of predefined values, consisting of typed in values 
for the datafield.

To create such a list of predefined values, choose Settings => Text/Symbol 
defaults and click on Symbol datafields. Then select the relevant symbol datafield, 
and click on Values.

You then enter a dialog box, where you type in the values, and click OK.

Placing symbols containing symbol datafields
When you place a symbol containing a symbol datafield, the tab Symbol data is 
added to the dialog box Component data.

Here you click in the text field for the relevant datafield (1, below), and a down-
arrow is displayed. When you click on the down-arrow (2), a list of the symboldata 
values is displayed (3).

SYMBOL DATAFIELDS AND LISTS

To include the information from the symbol datafields in your lists, you must — 
when you design the list — choose Functions => Insert Datafield, click on Sym-
bol Datafields, and insert the symbol datafields you need. Read more about design-
ing lists in “Creating Lists” on page 727.

This way you can for instance create a components list for the motors in the project, 
containing information about their windings and effect. Read more about sorting 
and list criteria in “List settings” on page 534.

Choose symbol datafield

... and click here to type
in the values

1) Click in the field

2) Click here, and the
list is displayed

3) Choose the desired
value



PCschematic ELautomation 10.0 PAGE 709

CREATING DATA SYMBOLS

DATA SYMBOLS AND COMPONENTS LIST FILES

When you create components lists files, symbol datafields for the applied data sym-
bols — and symbol datafields from any other symbols — can be included in these 
lists.

— Read more about components list files in “Exporting List Files” on page 625, 
specially “Specifying the contents of the file” on page 630.

SYMBOL DATAFIELDS IN ALL SYMBOLS

YOU CAN INSERT SYMBOL DATAFIELDS IN ANY TYPE OF SYMBOLS IN PCsche-
matic ELautomation.



PAGE 710 PCschematic ELautomation 10.0

CREATING SIGNAL SYMBOLS

CREATING SIGNAL SYMBOLS

A special type of symbols are called signal symbols. They are used when you start 
or end a conducting line in a non-electrical point on the drawing.

Read more about signal symbols and how to use them in your projects in “Signal 
symbols” on page 218.

This chapter is only a brief introduction on how to design your own signal symbols. 
If you find it too brief, please read “Creating Symbols” on page 670, where you get 
a more thorough example on how to design symbols.

CREATING YOUR OWN SIGNAL SYMBOL

Click on the Symbols button and then on the Symbol menu button. In the Symbol 
menu you click on the Create new symbol button.

You now enter the Design symbol mode, and see these reference points on the mid-
dle of the screen.

DESIGNING THE SIGNAL SYMBOL

You can now design a signal symbol with the following appearance:

THIS CHAPTER DESCRIBES

— CREATING YOUR OWN SIGNAL SYMBOL ............................................................ (P. 710)

— DESIGNING THE SIGNAL SYMBOL ......................................................................(P. 710)

— FREQUENTLY USED SIGNAL SYMBOLS................................................................(P. 712)

— FREQUENTLY USED SIGNAL SYMBOL NAMES.....................................................(P. 713)

— CREATING JOIN SYMBOLS ..................................................................................(P. 714)

Reference point for
the symbol you are
designing

Reference points
for the symbol texts
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A right-arrow on a total of 7.5mm.

The arrowhead itself is on 45 degrees, and 
5mm high.

In the name field, it could for instance say 
Signal, but you do not have to type in any-
thing in this field, because the signal name 
will be filled out when you place the signal 
symbol on a diagram.

Drawing the signal symbol
Make an appropriate Zoom [z] around the symbol reference point. Click on the 
Reference point button as well as the Pencil, and click where you want the refer-
ence point located (1).

Click on the Lines button as well as the Follow connected button. Draw a horizon-
tal line on 5mm (2) starting from the reference point. If you are using the 2.5mm 
standard snap, you do this by pressing two times on the right-arrow key. Click on 
the mouse and press <Esc>.

— Read more about snap in “Snap” on page 68.

Click on the Filled areas button, click 2.5mm above the terminal point of the line 
(3), click 2.5mm in extension of the horizontal line, then 2.5mm down to the left 
(5), in order to get a filled triangle. (The program automatically choose a slanted 
line of 45 degrees — if that is not so, please read more about Ortho 45 in “Pointer/
Screen” on page 815).

Click on the Texts button, click on the text reference point for S.Name, click on the 
Move button, press down <Shift> to get a finer snap, and place the text field.

Click in the white Text field in the texts tool bar on the top of the screen — or press 
[k] — and type in Signal and press <Enter> (6).

Text fields in signal symbols
When you save a symbol as a signal symbol, the symbol will only contain the sym-
bol texts Symbol Name and Symbol Type.

You can see this by clicking on the Symbols button, and then on the Symbol set-
tings button. Click on the down-arrow in the Symbol type field, choose Signal in 
the drop down list, and click on OK.

This makes the other symbol texts disappear, which also happens when you save 
the symbol as a signal symbol.

You should not type in anything in the Symbol Type field, because this field is used 
to contain the page reference for the signal symbol. Therefore place the symbol 
type field where you want the reference text to be located.

You will typically not specify a symbol name when you create a signal symbol, 
because you normally do not determine the name of a signal symbol until you place 
it in a project. — Read more about which names will be suggested in “Frequently 
used signal symbol Names” on page 713.

(6)

(4)
(5)

(1)

(2)

(3)
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However, if you do not specify a name when you place a signal symbol in a project, 
the signal symbol will get the name specified in the Symbol name field.

Saving the symbol
Choose File => Save as, and assign a title to the symbol. If you have not already 
done this, you choose the symbol type Signal and click on OK.

Then save the symbol, as described in “Saving the symbol” on page 683. Remem-
ber — in the Save as dialog box — to determine which folder you want to save the 
symbol in. — Read more about folders in “Folders” on page 40.

All PCschematic ELautomation signal symbols are saved in the MISC folder, hav-
ing names starting with SG.

FREQUENTLY USED SIGNAL SYMBOLS

Signal symbols you use often, can be added to the list of signal symbols, that appear 
when you click on the up- and down-arrows below Signal symbol in the dialog box 
Signals, which you can see below.

You enter this dialog box automatically when you start or end a conducting line in a 
non electrical point in a diagram.
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To add signal symbols to this list, you choose Settings => Text/Symbol defaults.

Here you click on Signal symbols in the lower-left corner of the dialog box, and 
click on Add.

You now enter the Symbol menu, where you find and select the desired signal 
symbol, and click on OK.

Please remember to exit Settings by clicking OK.

The signal symbol is now added to the list.

If you click on Remove instead of Add, you can remove signal symbols from the 
list.

FREQUENTLY USED SIGNAL SYMBOL NAMES

To add a signal name to the list of predefined signal names, you choose Settings => 
Text/Symbol defaults.

Here you click on Signal names and click on Add.

In the appearing dialog box you type in the new name, and click on OK.

If you want to remove a signal name, you click on the down-arrow in the field 
below Signal name, and click on the signal name you want to remove. Click on 
Remove, and the signal name is removed.
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CREATING JOIN SYMBOLS

When you create join symbols, this follows the same philosophy as for creating 
cable symbols — see “Creating Cable symbols” on page 695.

In join symbols you have to place the reference point to the left, and draw the sym-
bol to the right.

When you place the join symbol on a diagram page, only the horizontal lines in the 
symbol definition are expanded. Furthermore these lines need to be on the same 
line as the connection point in order to be expanded.

Other lines in the symbol definition are moved according to the expansion of the 
horizontal line, but remain unchanged.

When you save the join symbol, choose the Symbol type Signal.

Expands

Remains unchanged
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CREATING DRAWING HEADERS

In this chapter you can see how to create your own drawing header.

Please refer to “Changing an already created list/drawing header” on page 740 to 
see how to change one of the predefined drawing headers for your own use.

See how to place a drawing header on a project page in “Insert drawing headers/for-
mulas” on page 525.

THIS CHAPTER DESCRIBES

— WHAT IS A DRAWING HEADER...........................................................................(P. 716)

— INITIAL PREPARATIONS BEFORE CREATING A DRAWING HEADER.......................(P. 716)

— DESIGNING THE DRAWING HEADER ....................................................................(P. 718)

— ADDING THE DRAWING HEADER TO THE LIST OF DRAWING HEADERS .............(P. 723)

— REMOVING DRAWING HEADERS FROM THE LIST OF DRAWING HEADERS .........(P. 724)

— PREDEFINED DRAWING HEADERS........................................................................(P. 724)

— PLACING YOUR COMPANY LOGO ON A DRAWING HEADER ................................(P. 725)

— CHANGING DATAFIELDS IN PAGE DATA AND PROJECT DATA.............................(P. 726)

INSERTING DRAWING HEADERS ON TEMPLATES

WHEN YOU HAVE CREATED A DRAWING HEADER, YOU CAN INSERT IT ON A 
TEMPLATE PAGE, AS DESCRIBED IN “CREATING TEMPLATES” ON PAGE 748, 
SPECIALLY “CREATING PAGE TEMPLATES — VIA THE TEMPLATE EDITOR” ON 
PAGE 749.
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WHAT IS A DRAWING HEADER?
A drawing header is a kind of formula contain-
ing text and graphics, which you can choose to 
place on your project pages. For instance can a 
drawing header consist of a frame around the 
entire page, with your company name and logo 
placed in the lower-right corner. Apart from 
this the drawing header can contain informa-
tion about the name and number of the individ-
ual page, which customer the project is carried 
out for — and much more.

Once you have created a drawing header, you 
can make the program fill out this information 
for you automatically.

This chapter contains an example on how to 
design your own drawing header.

INITIAL PREPARATIONS BEFORE CREATING A DRAWING HEADER

Creating a new symbol
When you create a drawing header you have to be working in a project, so if that is 
not the case you have to open a new project: Click on the New document button, 
and then leave the Settings dialog box by pressing <Esc>.

Click on the Symbols button and on Symbol menu — or press [F8] to enter the 
Symbol menu, where you click on Create new symbol button.

The program is now in the Design symbols mode. As long as you are here, SYMB 
will flash on a red background in the lower part of the left tool bar.

Setting up the page to vertical A4 format
The next thing you do is to make sure that the program is set to the correct page for-
mat — in this case a vertical A4 page. The page type shall also be correct, and 
because you are going to create a drawing header, the type must be Diagram:

1) Choose Settings => Page setup. — As a short-cut to enter this dialog box, 
you can click on the field in the lower part of the left tool bar, where the page 
size is displayed.

2) On the tab Page setup: Click on Standard size, choose the A4 format, and 
select Vertical format. Set Grid to 5.00mm. — Read more about this tab in 



PCschematic ELautomation 10.0 PAGE 717

CREATING DRAWING HEADERS

“Page setup” on page 823, and about grid and snap in “Screen / Image Func-
tions” on page 63.

3) Click OK.

Help frame displayed on the page
Choose Settings => Pointer/Screen.

Click on Help frame in the right hand side of the dialog 
box.

The help frame displays the margin which is specified as the most common used 
standard, and is therefore only meant as a guideline for where to draw on the page. 
The frame is displayed with a dashed red line.

However, it is not sure that the standard corresponds to 
the settings on your printer. If you therefore want to see 
on the area on which you printer is able to print, you click 
on Printer help frame. This way you can assure yourself that your printer will be 
able to print out in the scale 1:1, when you print out the entire page. This help frame 
is displayed by a grey dash line. Deselect the printer help frame in this example.

If you only use the help frame, the program will automatically scale the drawing 
header to fit to your printer, before you print the page.

Click on OK.

You now see an A4 page with help frames and a grid on 5.00mm. The reference 
point for the drawing header as well as the text reference points, are placed on the 
middle of the page. These reference points shall now be moved to a more appropri-
ate location.
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Moving the reference points
The reference point of a drawing header must be placed precisely on one of the four 
corners of the help frame. In this example you must place it in the lower-left corner 
of the frame.

When you later place the drawing header on a page in a project, the reference point 
of the drawing header will position itself in the corresponding corner of the help 
frame on the page. In this case in the lower-left corner.

Therefore, click on the Symbol button, and click on the Reference point button. 
Click on the reference point you see on the middle of the screen, and drag it until it 
precisely on the lower-left corner of the help frame. In this case the coordinates 
should be x=20.00 y= 5.00mm.

Make a Zoom including the four text reference points and the lower-left corner of 
the page. Then click on the Texts button and right-click on the upper-most of the 
four text reference points. A rubber band starting from the symbol reference point 
in the lower-left corner of the screen, and ending in the text reference point, 
together with a menu. Choose Move in the menu, and then click on the symbol ref-
erence point in the lower-left corner of the screen.

You have now placed the text reference point on the symbol reference point.

Now move the three remaining text reference points correspondingly, because you 
do not need any of these in a drawing header.

Click on the Refresh button if the page need to be 
refreshed.

You are now ready to design the drawing header 
itself.

DESIGNING THE DRAWING HEADER

Drawing the frame
Click on the Zoom to page button, the Pencil, the 
Lines button as well as the Rectangle button. Set the 
line width to 0.5mm. Draw the frame so that it covers 
the entire help frame. — If you are not sure how to 
do this, please read “Lines” on page 93.

The fields in the drawing header is enlarged here:
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Placing the text fields
Click on the Straight lines button. Draw the upper-most horizontal line (See the 
figure above). The x- and y-coordinates are displayed in the lower-left corner of the 
screen. Start 30mm above the bottom of the frame (x=20, y=35) and draw the hori-
zontal line. Let go of the line by double-clicking on the frame to the right — or 
click once and press <Esc>. The vertical line is drawn 70mm from the left of the 
frame (x=90).

Now set the line width to 0.25 and draw the rest of the lines. The small vertical line 
is placed in x=132.50mm.

General information on inserting datafields
When you insert datafields in a drawing header, you can make the program fill out 
the datafields for you. There are nine different types of datafields:

So when you need to insert a datafield in a drawing header, you first choose which 
type of datafield you want to insert, and then which specific datafield of the chosen 
type.

Please note, that datafields written in upper case letters, contains information from 
the database.

To see how to fill out project- or page data, please read “Project and Page data” on 
page 138.

If you need to create new project- or page datafields, you can see how to do this in 
“Page data and Project data Datafields” on page 663.

DATAFIELD TYPE DESCRIPTION

SYSTEM DATA GENERAL INFORMATION ABOUT USER NAME, COMPANY NAME, TIME 
AND DATE.

PROJECT DATA INFORMATION REGARDING THE ENTIRE PROJECT — FOR INSTANCE 
THE ADDRESS OF THE CUSTOMER, CASE NUMBER, THE NAME OF THE 
CONSTRUCTOR AND SO ON.

PAGE DATA RELEVANT INFORMATION FOR THE INDIVIDUAL PAGE IN THE 
PROJECT — SUCH AS PAGE NUMBER, THE SCALE OF THE PAGE, AND 
THE TIME FOR LAST CORRECTION OF THE PAGE.

SYMBOL DATAFIELD DATAFIELDS YOU CAN DEFINE — READ MORE IN “CREATING DATA 
SYMBOLS” ON PAGE 704.

TABLE OF CONTENTS SPECIAL INFORMATION NEEDED FOR A TABLE OF CONTENTS — 
SUCH AS A HEADING FOR THE TABLE OF CONTENTS OR SPECIFICA-
TION OF DRAWING TYPES.

PARTS/COMPONENTS 
LIST

SPECIAL INFORMATION NEEDED ON PARTS- OR COMPONENTS LISTS 
— ARTICLE NUMBERS, PRICES, DESCRIPTIONS OF COMPONENTS AND 
SO ON.

TERMINALS LIST SPECIAL INFORMATION FOR TERMINALS LISTS — THE NAME AND 
TYPE OF THE TERMINAL AND MORE.

CABLE LIST SPECIAL INFORMATION FOR CABLE LISTS — THE NAME AND TYPE 
OF THE CABLE AND MORE.

PLC LIST SPECIAL INFORMATION FOR PLC LISTS — THE NAME, TYPE, FUNC-
TION AND I/O DATA OF THE PLC.

DATAFIELD TYPES
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— For a complete survey of the datafields in PCschematic ELautomation, please 
refer to “Datafields” on page 834.

Insert the datafields
In this drawing header you need the following datafields:

Datafields from Project Data:- Title

- Customer name

- Designer

Datafields from Page Data:- Page number

- Last used page

To determine the appearance of the datafields, you click on the Texts button, and 
then on the Text properties button. Here you set Height to 2.5mm, Width to AUTO 
and Alignment to left-down. Click OK.

To insert a datafield, you choose Functions => Insert Datafield.

The dialog box Datafield is then displayed:

See an elaboration of the functions in this dialog box in “Datafields” on page 134.

Choose Project Data. In the field to the right of Project Data you click on the 
down-arrow. In the appearing drop-down menu you choose the datafield Title.

When you have chosen Title you can transfer the word Title to the Text field by 
clicking on the red arrow. The cursor is then placed inside the text field. Type in a 
colon (:) after Title. If you want space between the colon and the following title, 
please press the [spacebar] key.

In the Width field in the lower-left corner of the menu you can type in the allowed 
number of characters in the filed. In this case, let it be 80.
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Click on OK. Place the datafield in the upper-right corner on the enlarged part on 
the drawing header.

Press <Esc> not to place the datafield again.

Continue by placing the datafield Customer name, which is also of the type Project 
Data.

The next field is Designer. It is also of the type Project Data, and in the Text field 
you type in Design. Set the width to 10. — The already transferred text is also 
included in this maximum number of characters.

Now click on Page Data, because the two last datafields Page number and Last 
used page are of this type.

Choose Page number, type in Page in the Text field, and set the width to 10. Click 
on OK. Click on the Text properties button and set the alignment to right-down 
(See “Specifying text properties / Appearance of text” on page 145). Click on OK 
and place the text.

Choose Last used page, type in the text of, set the Width to 10, and click on OK. 
Click on the Text properties button, set the Alignment to left-down, and click on 
OK. Place the text.

Free text in drawing headers
Now click in the text field in the texts tool bar, and type in the text Hans Chr Ander-
son^Maschinery Inc. Click on the Text properties button, and set the text to the 
Height 4.0mm, Width AUTO, Alignment left-down, and choose Bold text.

The ^ character signifies line break, and will not be displayed on the screen until 
you have typed in a succeeding character.

Place the text like you see it on the figure above. — See more about how to type in 
a free text in “Type in and place a free text” on page 128.

Now change the Text properties settings to the Height 2.0mm, Width AUTO, 
Alignment centre-centre. Deselect Bold text.

Then place the remaining texts, as you see them on the figure above.

You have now created a drawing header, and can save the final result.

DRAWING HEADER FOR DIAGRAM PAGES - INCLUDING A LIST

IT IS ALSO POSSIBLE TO CREATE DRAWING HEADERS FOR DIAGRAM PAGES, 
WHICH INCLUDES A LIST ON THE PAGE. — SEE “DIAGRAM PAGES - CONTAIN-
ING A PARTS OR COMPONENTS LIST” ON PAGE 738.
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Saving the symbol / the drawing header
Choose File => Save as.

Fill out the dialog box as you see below.

Please note, that you can also enter this dialog box while designing the drawing 
header, if you click on the Symbols button, and then on the Symbol settings but-
ton.

Now click on OK, and save the drawing header in the MISC folder with the file 
name A4Vertic:

If you are not sure how to change folder, please read “Folders” on page 40.

You can also create your own folder for drawing headers.

Click on OK.

Leaving the Edit symbol mode
You have now saved the drawing header, and shall now make the program leave the 
Design/Edit symbol mode. Do this by choosing File => Close.

You now return to the Symbol menu, where you click on Cancel or press <Esc>.
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ADDING DRAWING HEADERS TO THE LIST OF DRAWING HEADERS

The next thing you need to do, is to add the drawing header to the list, which con-
tains all the drawing headers you can use in your projects.

Therefore choose Settings => Text/Symbol defaults.

Click on Drawing headers in the left side of the dialog box.

Then click on Add, which brings you into the Symbol menu.

Here you click on the image of the drawing header you want to add, and the draw-
ing header now change to the color grey.

Click on OK.

You have now returned to the tab Text/Symbol Standards, and can here see the 
name of the drawing header in the field Drawing headers. Click on OK.

The drawing header is now ready to be used in a project.

Inserting the drawing header in a project
After having added the drawing header to the list of drawing headers, you can use it 
in your project.

— See how to insert a drawing header on a project page in “Insert drawing headers/
formulas” on page 525.



PAGE 724 PCschematic ELautomation 10.0

CREATING DRAWING HEADERS

REMOVING DRAWING HEADERS FROM LIST OF DRAWING HEADERS

If you want to remove a drawing header from the list of drawing headers, you 
choose Settings => Text/Symbol defaults. Here you click on the down-arrow in 
the field below Drawing headers. In the appearing drop-down menu, you click on 
the drawing header you want to remove from the list, click on Remove, and answer 
Yes to remove the drawing header from the list. Click on OK.

The drawing header is now removed from the list of drawing headers.

PREDEFINED DRAWING HEADERS

To make things a little easier, some predefined drawing headers already exist. They 
Are located in the folder c:\Pcselcad\Symbol\Misc. To make use of these drawing 
headers in your projects, you can open them and adapt them to your needs — as 
described in “Changing an already created list/drawing header” on page 740.

The predefined drawing headers are:

Please also see “Predefined lists” on page 739.

DRAWING HEADER DESCRIPTION

A3DPSA3 A3 DRAWING HEADER TO BE PRINTED OUT ON A3 PAPER.

A3DPSA4 A3 DRAWING HEADER TO BE PRINTED OUT ON A4 PAPER. (HAS A DIFFER-
ENT MARGIN DUE TO THE POSITION OF THE HOLES IN THE PAPER).

A4DPS A4 DRAWING HEADER FOR HORIZONTAL DRAWING.

A4VDPS A4 DRAWING HEADER FOR VERTICAL DRAWING.

FRONTPAG A4 DRAWING HEADER FOR PROJECT FRONT PAGE.

CHAPTER A4 DRAWING HEADER FOR CHAPTER FRONT PAGE.

PREDEFINED DRAWING HEADERS
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PLACING A COMPANY LOGO ON A DRAWING HEADER

Placing a fixed logo on a drawing header
If you wish to place a company logo on the 
drawing header, which is different from the 
project logo, this is also an option.

To do this, you first have to have the logo 
created as either a symbol or a DWG/DXF 
file.

— See how to create symbols in “Creating 
Symbols” on page 670.

You can now see how to place a company 
logo on the drawing header.

Fetching the logo
To load the logo onto the drawing header, 
you choose File => Open — while you are 
in the Edit symbol mode — and choose the 
file for the company logo. — Read more 
about opening files in “Opening files/
projects” on page 41.

In this case you open the folder Misc and 
click on the file Dpscat.sym.

You now get the symbol for the cat in the 
cross hairs, and click somewhere with 
some space open on the page, where you 
can place the logo temporarily. This is 
important if you need to adapt the size of 
the logo later on.

When you have placed the cat, it is no longer conceived as a symbol, but only as the 
lines which the symbol was made up of. When you scale the logo, it is therefore 
important that no other line from the drawing header is part of the area you scale. If 
they are, they will be scaled as well.

ALTERNATIVE PROCEDURE RECOMMENDED

IF YOU WISH TO PLACE A LOGO ON A DRAWING HEADER, IT RECOMMENDED TO 
DO SO VIA CREATING A PROJECT LOGO, AS DESCRIBED IN “INSERTING LOGOS 
IN PROJECTS” ON PAGE 518.
THIS ALSO MAKES IT POSSIBLE TO REPLACE THE LOGO EASILY IN PROJECTS 
FOR OTHER CUSTOMERS.
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Scaling the logo
Now check out whether the symbol has got 
the right size to be placed where you want 
it located.

If this is not the case, please mark up an 
Area around the logo, choose Edit => 
Scale and type in a scaling factor.

In this case a scaling factor of 0.5 will be 
needed.

— Read more about scaling in “Scaling 
areas” on page 476.

Placing the logo
Mark up an Area around the cat, click on 
the Move button, and click where you want 
the logo placed.

Remember to make use of the Undo button, 
if you by accident place the logo so that it 
covers some of the other lines in the draw-
ing header.

You have now placed the logo on the draw-
ing header.

CHANGING DATAFIELDS IN PAGE DATA AND PROJECT DATA

If you want to change the name of a datafield in Project data or Page data, please 
right-click on the datafield. Hereby a menu appear, in which you can edit, delete or 
add datafields. Read more about this in “Page data and Project data Datafields” on 
page 663.
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CREATING LISTS

In this chapter you can see how to create your own project lists.

If you want to create list files you do not need to design a list the way it is described 
here. Please refer to “Exporting List Files” on page 625 for further details.

In “Insert drawing headers/formulas” on page 525 you can see how to insert lists in 
projects.

THIS CHAPTER DESCRIBES

— WHAT IS A LIST ..................................................................................................(P. 728)

— LISTS/DRAWING HEADERS..................................................................................(P. 728)

— HOW TO CREATE A LIST......................................................................................(P. 729)

— ADDING THE LIST TO THE LIST OF DRAWING HEADERS....................................(P. 734)

— USING DATAFIELDS.............................................................................................(P. 735)

— CREATING A TABLE OF CONTENTS .....................................................................(P. 735)

— CREATING A COMPONENTS LIST ........................................................................(P. 735)

— CREATING A TERMINALS LIST ............................................................................(P. 736)

— CREATING A CABLE LIST....................................................................................(P. 736)

— CREATING A PLC LIST........................................................................................(P. 737)

— CREATING A DIAGRAM PAGE CONTAINING A PARTS OR COMPONENTS LIST.....(P. 738)

— CREATING A LIST SYMBOL .................................................................................(P. 739)

— PREDEFINED LISTS ..............................................................................................(P. 739)

— CHANGING AN ALREADY CREATED LIST/DRAWING HEADER ..............................(P. 740)

— OTHER OPTIONS .................................................................................................(P. 743)

INSERTING DRAWING HEADERS / LISTS IN TEMPLATES

WHEN YOU HAVE CREATED A LIST DRAWING HEADER, YOU CAN INSERT IT ON 
A TEMPLATE PAGE, AS DESCRIBED IN “CREATING TEMPLATES” ON PAGE 748, 
SPECIALLY “CREATING PAGE TEMPLATES — VIA THE TEMPLATE EDITOR” ON 
PAGE 749.
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WHAT IS A LIST?
In your projects you may need to create various 
types of lists, such as parts lists, components lists, 
terminals lists, cable lists, PLC lists or tables of con-
tents.

This chapter is a thorough example on how to create 
a parts list, followed by brief descriptions of how to 
create the other types of lists.

The procedure how to create lists, are basically the 
same for all types of lists; the only difference is 
which datafields you insert on the various types.

Basically it is all about placing text fields and 
datafields, which collects information from the other 
project pages, onto a drawing header page. You determine how to place the texts 
and datafields, and you can also draw lines and place a company logo on the page.

When you have created a list and inserted it in your project, you can make the pro-
gram fill out the list with project information automatically.

This way you can for instance create a table of contents, with information about 
which drawings and lists are placed on the project pages, as well as a parts list con-
taining information about all the components you need to carry out the project in 
praxis.

LISTS/DRAWING HEADERS

It is important to note, that in PCschematic ELautomation, lists are conceived as 
drawing headers. As a consequence of this, you create lists the same way as you 
create drawing headers. Also, the functions in the program which can be used for 
drawing headers, can be used for lists as well.

However, when working with lists, you have to update the lists to have them filled 
out with project information. This will be elaborated later.

If a filled out list needs more than just one project page, the program will automati-
cally insert the required extra amount of pages.

You are now ready to start creating a parts list.
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HOW TO CREATE A LIST

The following is an example on how the create a parts list.

Initial preparations
Because a list is also a drawing header, all initial prepa-
rations are the same for lists as for drawing headers.

Now perform the initial preparations as described in 
“Initial preparations before creating a drawing header” 
on page 716.

You Are now ready to design the parts list.

The upper part of the list you are about to design in this 
example looks like this:

Column headings
You Are now ready to make the column headings for the parts list. The texts you 
shall place in this example are:

- Article number

- Function

- Quantity

Click on the Texts button, and then on the Text properties button.

The Text properties menu appear. Here you set Height to 3.0, Width to AUTO, and 
Alignment to left-down. If you are not sure how to do this, please read “Specifying 
text properties / Appearance of text” on page 145.

Click on OK. You have now determined the appearance of the text, and have 
returned to the page.

Click inside the field to the right of the Text properties button, type in Article 
number and press <Enter>.

SELECT DATAFIELDS AND PLACE TEXTS AS YOU WISH

YOU ARE FREE TO PLACE THE TEXTS DIFFERENTLY, TO ASSIGN OTHER NAMES 
TO THE COLUMNS OR TO USE OTHER DATAFIELDS THAN THE ONES CHOSEN 
HERE.
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You now get the text in the cross hairs, and place it by pointing on the point 
x=20.00mm y=265.00mm and then click once. (See the coordinates in the lower-
left corner of the screen).

The text Article number have now been placed on the page.

Press <Esc> not to place the text again.

Now place these texts following the same procedure:

- The text Function in x=75.00 y=265.00mm and

- The text Quantity in x=177.50 y=265.00mm

Corrections
If you by accident place a text in the wrong place, then deactivate the Pencil (press 
<Esc>), select the text by clicking on its reference point, and then move it using the 
Move button, or delete it using the Delete button. Then Refresh the page. Also, 
you can choose Undo to undo your latest action. Read more about these options in 
“Working with selected objects” on page 79.

Inserting the datafields
Now the column headings have been properly placed, and it is time to place some 
datafields, in which information from the drawings can be inserted.

Choosing a datafield
Start by choosing Functions => Insert Datafield.

Click on Parts/Components list and then click on the down-arrow in the field 
immediately to the right of Parts/Components list.

In the appearing drop-down menu, you click on Article no. — Please note not to 
select ARTICLE NO written in upper case, because this will fetch its contents from 
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the database instead. — Read more about the database in “Using the database” on 
page 559.

Click in the field Width in the lower-right corner of the dialog box, and type in 20.

Then select Activate next. What this means will be elaborated in “Activate next” on 
page 732.

(As opposed to creating the drawing header, please do not click on the red arrow, 
because you do not need a fixed text in this datafield).

— You can read more about the Datafield dialog box in “Datafields” on page 134.

Click on OK.

Placing the datafield
You now have the datafield in the cross hairs, and place it in the point x=25.00 
y=245.00mm.

Press <Esc> not to place it more than once.

You have now placed the first datafield.

Placing the remaining datafields
Choose Functions => Insert Datafield, deactivate Activate next, and insert the 
following datafields following the same procedure as above:

- The field Function (width 80) in x=75.00 y=245.00mm and

- The field Quantity (width 20) in x=177.50 y=245.00 mm

Press <Esc> not to place the last datafield again.

Aligning the datafields
As a precaution, you can now align the datafields. Therefore mark up a window 
around the three datafields by clicking and dragging.

Then choose Edit => Align, and click on the reference point for the left-most of the 
texts. — Read more about this function in “The Align function” on page 87.

DATAFIELDS FOR EAN13 BARCODES

FOR PARTS/COMPONENTS LISTS YOU CAN ALSO INSERT THE DATAFIELD 
EAN13 BARCODE FOR AUTOMATIC GENERATION AND INSERTION OF EAN13 
BARCODES. YOU CAN HERE CHOOSE BETWEEN THE THREE STANDARD SIZES 
FOR BARCODES.
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More rows of datafields
You have now placed the first row of datafields in the parts list. However, the parts 
list should consist of many rows of datafields, why you should now copy the three 
datafields and place them below the other datafields several times.

First make a Zoom including the three datafields (Article no, Function and Quan-
tity) and which contains room for twelve more rows of datafields.

Then mark up an area around the three datafields (not including the column head-
ings), so that all the datafields are selected when you release the mouse button. — If 
you are not sure how to mark up an area, please see “Selecting objects” on page 77.

Then click on the Copy button, and place the lines below each other, with a dis-
tance of for instance 10mm. This is most easily done by pressing four times on the 
down-arrow of the keyboard, then press <Enter>, and repeat these actions until all 
the rows of datafields have been placed.

Press <Esc> not to place more copies.

If you have not aligned the rows of datafields properly, then select the rows individ-
ually, and place them using the Move button, as described above.

Activate next
The first time the program meets a check mark in Activate next, you tell the pro-
gram to collect information about the first component in the project, which shall be 
included in the parts list. The following datafields — such as Function and Quan-
tity — will then contain the function and quantity of this first component.

The next time the program meets Activate next, it collects information about the 
next component on the project drawings. The datafields Description and Amount 
now contains information about the second component in the project — and so 
forth.

DATAFIELDS FOLLOWING ACTIVATE NEXT MUST BE ALIGNED

IT IS IMPORTANT TO NOTE, THAT IF YOU PLACE A DATAFIELD JUST A BIT 
HIGHER THAN THE DATAFIELD IN WHICH YOU HAD SELECTED ACTIVATE NEXT, 
THIS DATAFIELD WILL COLLECT ITS INFORMATION FROM THE COMPONENT 
ABOVE.
THEREFORE IT IS RECOMMENDED TO LET DATAFIELDS, WHICH FOLLOWS ACTI-
VATE NEXT, BE ALIGNED BEFORE YOU START COPYING.
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Creating a fancier parts list
Now the parts list is completed, and ready to be 
saved, but you can still choose to do a few things 
to make it look better:

a) You can draw lines on the parts list — see 
“Lines” on page 93.

b) You can insert the datafields and lines, which 
were inserted in “Creating Drawing Head-
ers” on page 715. In that case follow the 
directions given in “Designing the drawing 
header” on page 718.

c) You can insert a heading for the entire parts 
list. (The datafield on the figure is Page 
Data, Title).

d) Place a company logo on the page — see “Placing a Company Logo on a 
drawing header” on page 725.

Saving the parts list
To save the parts list, you do like this:

Choose File => Save as.

Fill out the dialog box like this:

Please note, that you should set the symbol type to Normal, and the selection to 
Reference point. Read more about this in “Symbol types” on page 680.

The symbol Title is the description of the symbol, which will be displayed in the 
Symbol menu.

Click on OK.
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A new dialog box appear, which you fill out like this:

Please note that the parts list will now be saved in the folder c:\Pcselcad\Sym-
bol\Misc. It is recommended to save lists in this folder, but you can save the lists in 
any folder you like. If you are not sure how to change folder, please read “Folders” 
on page 40.

Click on Save when all the settings are correct.

The parts list have now been saved.

Leaving the Create/Edit symbol mode
To make the program leave the Edit/Create symbol mode, you choose File => 
Close.

You now return to the Symbol menu, where you click on Cancel or press <Esc>.

Please note, that the text SYMB, which was flashing on a red background in the 
lower part of the left tool bar, now has disappeared.

ADDING THE PARTS LIST TO THE LIST OF DRAWING HEADERS

The next thing you have to do, is to add the parts list to the list of drawing headers. 
This is done as described in “Adding drawing headers to the List Of Drawing Head-
ers” on page 723.

You will not be able to use the parts list in your project until you have done this.

See “Insert drawing headers/formulas” on page 525 to see how to insert the parts 
list on a page in a project, as well as how you get the list updated.
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USING DATAFIELDS

Which datafields you can use, depends on which type of list you are creating.

You can always use datafields of the type System Data, Project Data and Page 
Data. But apart from these types of datafields, you can only use datafields corre-
sponding to the type of list you are creating.

If you are creating a table of contents, you can make use of datafields of the type 
Table of Contents, but not of the type Parts/Components List.

CREATING A TABLE OF CONTENTS

When you serrate a table of contents, you follow exactly the same guidelines as for 
designing a parts list.

The only differences — apart from the way you want to set up the lists yourself — 
is that you will need datafields of the type Table of Contents, and that you in the 
Page menu — as mentioned in “Insert drawing headers/formulas” on page 525 — 
will have to set the page function to Table of Contents when you insert the page in 
the project.

In a table of contents you can also insert a data filed displaying the reference desig-
nation of the page.

To see an example of a table of contents, take a look at A4INDEX, mentioned in 
“Predefined lists” on page 739.

CREATING A COMPONENTS LIST

You can also create a components list, containing all the components in the project. 
For each component you can place its name and its exact location on the project 
drawings, so that you can use this list to locate any component in the project.
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For components lists, you set the page function to Components list, and use 
datafields of the type Parts/Components list. Components lists are created like you 
create parts lists.

CREATING A TERMINALS LIST

You can also create a terminals list, containing a survey of all terminals in the 
project, their names, and which wires enter and exit the terminals. At the same time 
you can let the list contain information about which cables the wires are a part of.

This way you get a survey of which wires shall be connected to which terminals.

To get transferred special information for terminals lists, you have to set the page 
function to Terminals list, and use datafields of the type Terminals list. Apart from 
this, terminals lists are designed following the same guidelines as for parts lists.

When you place datafields for terminals lists, you have to be sure whether to click 
on External or Internal in the lower part of the dialog box Datafield. — See 
“Datafields” on page 134.

Correspondingly, when you place terminal symbols on a project drawing, you have 
to be conscious about which connection point of the terminal is the Input and 
which is the Output. Read more about this in “Terminal symbols” on page 228.

CREATING A CABLES LIST

Furthermore you can create a cable list containing a survey of the project cables, 
and from where- and to where they are to be connected.

Set the page function to Cable list, use datafields of the type Cable list, and create 
the list as described for parts lists in the beginning of this chapter.
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CREATING A PLC LIST

Finally, you can create a PLC list containing a survey of the inputs and outputs on 
the PLC. At the same time it can contain a description of which functions are 
attached to the various terminals on the PLC. The list can also contain connection 
points labels.

Set the page function to PLC list, use datafields of the type PLC list, and design the 
list as described above.

Datafields and PLC lists
When you are working with PLC’s, you 
can place the information about the PLC 
labels and descriptions in two different 
places.

You can click on the Symbols button and 
right-click on the connection point on the 
PLC itself, and fill out the fields Descrip-
tion and Label.

Or you can right-click on the connection 
point on the symbol connected to the ter-
minal in the PLC, and fill out the fields 
Description and Label here.

When you design a PLC list, you there-
fore have to be aware that you have to 
use different datafields depending on which of the procedures you use.

If you want to collect the information from the connection point of the PLC, you 
must use the datafields C.descr and C.Label. But if you want to collect the informa-
tion from the connection point of the connected symbol, you have to use the 
datafields Cc.C.descr and Cc.C.label.

The two options
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DIAGRAM PAGES - CONTAINING A PARTS OR COMPONENTS LIST

It is possible to create a drawing header for normal diagram pages, which also con-
tains either a parts or a components list. However, these lists can only contain infor-
mation from the page they are placed on.

When you create the list as a part of the drawing header, the list will therefore only 
contain data about the components placed on the page. Furthermore, it is your 
responseability to ensure that the list is long enough for the components, that are 
going to be placed on the page. This is because new pages will not be inserted, if 
this list is to short.

To create such a drawing header, you must do as described in “How to create a 
List” on page 729 — with the only difference that you make room for diagram 
drawings in the drawing header.

Specify that the diagram page contains a list
When you, at a later stage, insert a such drawing 
header on a project page, you must succeedingly 
choose Settings => Page setup, and select Con-
tains a list, and then specify whether it is a Com-
ponents List or a Parts List.

Access to List Settings
On diagram pages containing lists, you can also right-click on the page and choose 
List settings, and then specify the list settings, as described in “List settings” on 
page 534. For this type of lists, there will be some limitations on the settings you 
can specify.



PCschematic ELautomation 10.0 PAGE 739

CREATING LISTS

CREATING A LIST SYMBOL

You can also create a symbol containing either a parts or a components list. When 
you place this symbol on a diagram page, it will subsequently function as a parts or 
components list for the page — according to the same directions as described in 
“Diagram pages - containing a Parts or Components list” on page 738.

When you create a symbol of this kind, datafields etc. must be placed as described 
in “How to create a List” on page 729. When saving the symbol, you must set the 
Symbol type to Head — see “Saving the parts list” on page 733.

When you have created the symbol, you can place it on diagram pages, just like you 
normally place symbols. Then specify that the page contains a parts or components 
list, as described in “Specify that the diagram page contains a list” on page 738. 
The symbol will then function as a list for the page.

You can find an example on such a symbol with the name Listsymbol.sym in the 
MISC folder.

— See “Access to List Settings” on page 738 also.

PREDEFINED LISTS

To make things a little easier, some lists have already been defined, which you can 
use in your projects. They are located in the folder c:\Pcselcad\symbol\misc. To 
use them in your project, you can open them and change them, until they fulfil your 
demands — as described in "Changing an already created list/drawing header" 
below.

The predefined lists are:

LIST DESCRIPTION

A4INDEX A4 DRAWING HEADER FOR TABLE OF CONTENTS.

A3INDEX A3 DRAWING HEADER IN COLUMNS FOR TABLE OF CONTENTS.

CHAPTOC A4 DRAWING HEADER FOR CHAPTER TABLE OF CONTENTS.

CHAPTER A4 DRAWING HEADER FOR CHAPTER DIVIDER.

PREDEFINED LISTS
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— Please see “Predefined drawing headers” on page 724 as well.

CHANGING AN ALREADY CREATED LIST/DRAWING HEADER

If you want to adapt an already created list/drawing header, you click on the Sym-
bols button, and then on the Symbol menu button.

You have now entered the Symbol menu. Here you find the folder in which the 
drawing header is placed, and then click on the drawing of the drawing header you 
wish to change.

This makes the Edit symbol button appear in the lower-left part of the Symbol 
menu, and you click on it. You now have the option of adapting the chosen drawing 
header to meet your demands.

As an example of a drawing header, you can choose the parts list A4PARTDE.

Saving the drawing header under a new name
In order not to overwrite the already existing drawing header, you start by choosing 
File => Save as and save the drawing header under a new name. For instance you 
can give it the name Newlist.sym. — See how to do this in “Saving the parts list” on 
page 733.

Changing free texts and removing the company logo
Make a Zoom covering the lower-left corner of the list.

Click on the Area button, mark up an area around the cat, and press <Del>. The 
company logo has now disappeared.

Click on Refresh.

PROJECTINFO A4 DRAWING HEADER FOR TECHNICAL INFORMATION.

A4PART1 A4 DRAWING HEADER FOR PARTS LIST (WITH DESCRIPTION).

A4PART2 A4 DRAWING HEADER FOR PARTS LIST (WITH FUNCTION TEXT).

A4PRICE A4 DRAWING HEADER FOR PARTS LIST (WITH PRICES).

A4CABLE1 A4 DRAWING HEADER FOR CABLE LISTS (WITH DESCRIPTION).

A4TERM1 A4 DRAWING HEADER FOR TERMINALS LIST (WITH DESCRIPTION - INTER-
NAL/EXTERNAL).

A4TERM2 A4 DRAWING HEADER FOR TERMINALS LIST (WITH DESCRIPTION - EXTER-
NAL).

A4COMP1 A4 DRAWING HEADER FOR COMPONENTS LIST (WITH DESCRIPTION).

A4COMP2 A4 DRAWING HEADER FOR COMPONENTS LIST (WITH FUNCTION TEXT).

A4COMP3 A4 DRAWING HEADER FOR COMPONENTS LIST (WITH SUPPLIER)

A4PLC1 A4 DRAWING HEADER FOR PLC I/O LISTS.

A4NAME1 A4 DRAWING HEADER FOR COMPONENT NAME LIST.

A4DPSREF A4 DRAWING HEADER FOR SURVEY OF REFERENCE DESIGNATIONS.

A4UNITLI A4 DRAWING HEADER FOR UNIT DRAWINGS.

LIST DESCRIPTION

PREDEFINED LISTS
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To change the company name 
you now click on Texts, and 
then click on the reference 
point for the text DpS CAD-
center ApS, which selects the 
text.

Now press [k] or click inside 
the text field in the texts tool 
bar. Correct the company name to your own company name — or to for instance H 
C Andersen Inc — and press <Enter>.

As you will see, the text has now been changed.

Correct the remaining free texts correspondingly.

Please note that you can delete and move texts as you normally do. — Read more 
about this in “Working with selected objects” on page 79.

The appearance of a selected text, can be changed by clicking on the Text proper-
ties button. This is elaborated in “Specifying text properties / Appearance of text” 
on page 145.

Changing a datafield
Also, you can change the 
inserted datafields on the draw-
ing header.

Click on the Texts button, and 
click on the reference point for 
the datafield Printed. Now 
click on the Data button on the 
upper part of the screen, which 
makes you enter the Datafield 
dialog box for the datafield 
Printed.

Another way to enter the dialog 
box Datafield, is to right-click 
on the text/datafield, and 
choose Text properties in the pop-up menu.

Here you choose the desired datafield — for instance Designer of the type Project 
data — and type in Designed by: in the Text field in the lower part of the dialog 
box. Click on OK.

As you can see, the datafield Printed has now been replaced by the datafield 
Designer.
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Changing a column of datafields of the same kind
When adapting a list to meet your demands, 
you will also need to change an entire col-
umn of datafields of the same type, into a 
row of datafields of another type.

To do this, you activate the Texts button, and 
select the datafields you want to change — 
as described in “Working with selected 
objects” on page 79.

For instance you can click on the Zoom to 
page button, and mark up a window around 
all the datafields in the right-most column. 
Please be careful not to include the column 
header.

— You can tell that a text field is a datafield 
by the red dash line which is displayed 
around datafields.

Click on the Data button — or right-click on the selected datafields — to enter the 
dialog box Datafield for the datafield. Now choose for instance the datafield 
Price1 and click OK.

As you can see, all the datafields in the column have been changed to Price1.

When you have completed your corrections, save the list by clicking on the Save 
button.
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OTHER OPTIONS

Company logo on list
If you have created your company logo as a symbol or as a DWG or a DXF file, 
you can place it on your list/drawing header. — See how to do this in “Inserting 
logos in projects” on page 518.

— See also “Placing a Company Logo on a drawing header” on page 725.

Delete a page with a list on
If you want to remove a page with a list on completely from a project, you have to 
delete the page, on which the list is placed. Therefore, click on the Page menu but-
ton.

In the Page menu you click on the page you want to delete, and choose Delete => 
OK. Click OK once again to close the Page menu dialog box.

The page has now been deleted from the project.

Remove a list from a page
If you want to remove a list, but keep the page on which the list is placed, you first 
click on the tab for the page. Then choose Settings => Page data — or click 
directly on the Page data button in the program tool bar.

In the Page data dialog box you deselect With drawing header, and click on OK.

The list has now been removed form the page.

Please note that the Page function of the page remains unchanged. If the page had 
the page function Parts list, it will still have this page function after the drawing 
header/list has been removed from the page.

Once a page has been created, its page function can not be changed. — Read more 
about this in “Creating a new page” on page 491.
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CREATING UNIT DRAWINGS

If a component consists of several different parts, you can specify which parts it 
consists of in a unit parts list. This unit parts list can also contain a unit drawing, 
displaying the parts of the component, but this is not mandatory.

When you use an extended parts list (please refer to “Specifying from where to col-
lect components” on page 536), the program examines for which components a unit 
drawing have been created. In the parts list, the component will then be represented 
by what you specified in the unit parts list.

Unit drawings can consist of more than one page.

CREATING A UNIT PARTS LIST

The procedure for designing the unit parts list, is the same as for designing an ordi-
nary parts list. So, if you want to design your own unit parts list, you should do this 
now, as specified in “Creating Lists” on page 727. Alternatively you can use an 
already created parts list.

However, you have to do a little more before you can use it as a unit parts list.

INITIAL PREPARATIONS

The first thing you have to do, is to click on the New document button.

Here you must first make sure that the page is a vertical A4 page, as described in 
“Setting up the page to vertical A4 format” on page 716. — Also make sure that the 
page function is set to Normal.

To place the unit parts list on the page, you now choose Settings => Page data and 
right-click on the field below Add drawing header. In the pop-up menu, you then 
click on Add drawing header.

THIS CHAPTER DESCRIBES

— CREATING A UNIT PARTS LIST...........................................................................(P. 744)

— INITIAL PREPARATIONS.......................................................................................(P. 744)

— ASSIGNING AN ARTICLE NUMBER TO THE UNIT PARTS LIST..............................(P. 745)

— CREATING A UNIT DRAWING ............................................................................. (P. 745)

— UNIT DRAWING FROM ALREADY CREATED SYMBOL.........................................(P. 746)

— UNIT PARTS LISTS WITHOUT UNIT DRAWINGS ...................................................(P. 747)

— CREATING UNIT PARTS LISTS FROM A DRAWING OF AN ENTIRE COMPONENT.... (P. 747)

— CORRECTING A UNIT DRAWING/UNIT PARTS LIST...............................................(P. 747)

— INSERTING UNIT DRAWINGS IN PROJECTS...........................................................(P. 747)
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You now enter the Symbol menu, where you can select one of the symbols men-
tioned below in the folder MISC. If you are not sure how to find the right folder, 
please refer to “Folders” on page 40.

Click on your own parts list, or choose the symbol UNITLI, and click OK.

You have now placed the unit parts list on the page.

ASSIGNING AN ARTICLE NUMBER TO THE UNIT PARTS LIST

To be able to use the page as a unit parts list, you have to assign an article number 
to the page.

Therefore, right-click somewhere on the page, and choose Page article data. 
Assign a Name and an Article no to the page, and fill out the Type and Function 
fields as well. Click on OK.

You determine the article number of the page yourself, and in the following this is 
the number you use, when you connect a symbol to the unit drawing.

CREATING A UNIT DRAWING

You are now ready to create the unit drawing. In this example you could for 
instance draw three rectangles, which illustrates the parts the component is made 
of. Also, you could place the page title on the top of the page.

If you are not sure how to do these things, please refer to “Lines” on page 93 as 
well as “Project and Page data” on page 138.

Now place the symbols (position numbers), in which you in the Component data 
specify the information, which is necessary for the parts on the unit drawing.

To do this, click on the Symbols button and then on the Symbol menu button.

Find the symbol Posno1, which is created as a circle, in the folder MISC, and dou-
ble-click on the symbol.
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You then get the symbol in the cross hairs, and place a symbol close to each of the 
three rectangles.

When you place a symbol, you enter the Component data menu, where you type in 
1 in the Name field for the first symbol, and 2 and 3 in the Name field for the two 
following symbols. Type in the remaining component data yourself, or fetch them 
by clicking on the Database button. Click on OK when the information have been 
filled out correctly.

If you are not asked about the component data automatically, just right-click on the 
symbols one by one, and fill out the information as described. — Read more about 
this in “Pointer/Screen” on page 815.

If you do not want a circle around the position numbers, you can use the symbol 
Posno2 in stead of Posno1.

Saving the unit drawing
You have now finished designing your unit drawing/parts list.

To save it, you choose File => Save unit as.

In the appearing dialog box, you for instance type in the file name test.std and click 
on OK.

The program now knows that the page is a unit drawing/parts list.

Therefore you can transfer the information from the symbols to the unit parts list by 
choosing Lists => Update Unit Drawing.

Save the unit drawing again.

Then choose File => Close.

The unit drawing is now ready to be used.

UNIT DRAWING FROM ALREADY CREATED SYMBOLS

If you already had created the parts on the unit drawing as symbols, you can place 
them on the unit drawing as well. — Please refer to “Creating Symbols” on 
page 670 to see how to create symbols.

Now place the symbols for the parts on the unit drawing.

Then right-click on the symbols — one by one — on the drawings of the parts and 
choose Component data. In stead of the symbol name, you then type in the 
number you want the part to have on the drawing and in the unit parts list.

In you have not assigned component information to the symbols, you can now type 
in this information, or find them clicking on Database.

Save the unit drawing as described in “Saving the unit drawing” on page 746.
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UNIT PARTS LISTS WITHOUT UNIT DRAWINGS

If you do not want any drawings on your unit parts list, this is also an option. Still, 
you have to create a symbol for each part, in order to specify which parts the com-
ponent is made of.

Here you may use the symbols Posno1 or Posno2, as described above, or you can 
design a symbol for this very purpose yourself.

To these symbols you add the necessary component data, as described above.

In stead of the symbol name, you type in the number you want the part to have on 
the unit parts list.

CREATING UNIT DRAWINGS USING A COMPONENT DRAWING

If you have a drawing of the entire component, you can load it as a symbol from the 
Symbol menu.

If the drawing is in the DWG/DXF format, please refer to “Importing DWG/DXF 
files as symbols” on page 637 to see how to import the drawing via the Symbol 
menu.

In stead of drawing each individual part, you now place some new symbols 
(Posno1 or Posno2), each pointing at an individual part on the drawing.

For each of these symbols you add the relevant article data, as described above.

The crucial part for how the unit parts list is filled out, is exclusively which infor-
mation is attached to the symbols placed on the page. The drawing itself is no more 
than an illustration.

If you want to place other relevant information on the page — for instance about 
expenses — you just place additional symbols on the page containing this informa-
tion.

CORRECTING A UNIT DRAWING/PARTS LIST

In order to change a unit drawing, you choose File => Open Unit.

Then you get the possibility to choose between the available unit drawings.

Pick one of them, perform the changes, and save the unit drawing as mentioned ear-
lier.

INSERTING UNIT DRAWINGS IN PROJECTS

Please read “Inserting Unit Drawings” on page 555 to see how to insert a unit draw-
ing in a project.
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CREATING TEMPLATES

ON TEMPLATES

In PCschematic ELautomation you can create templates for all types of project 
pages, as well as for full projects.

Each time you create a new project, or a new project page, you can therefore start 
out on the basis of an already created template.

Using templates on networks
Using templates enables you to let one person create the company templates, and 
make these templates available for all users via the network. This complete set of 
company templates therefore only needs to be placed at one location, and can be 
maintained by one — or more — persons.

The other users of PCschematic ELautomation therefore does not have to be 
familiar with creating drawing headers (including lists, tables of contents and chap-
ter tabs), or how to specify list settings.

It is therefore easy to achieve a standard appearance of PCschematic ELautoma-
tion projects. It is also simple to make changes in the complete set of template 
projects and pages, because these only have to be changed at one place.

THIS CHAPTER DESCRIBES

— ON TEMPLATES...................................................................................................(P. 748)

— CREATING PAGE TEMPLATES - VIA THE TEMPLATE EDITOR...............................(P. 749)

— CREATING PAGE TEMPLATES - VIA THE SUBDRAWINGS TAB ............................(P. 750)

— CREATING PROJECT TEMPLATES ........................................................................ (P. 751)

— CREATING TEMPLATES BASED ON EXISTING PROJECTS ...................................... (P. 753)

— CONVERTING STANDARD PROJECTS TO PROJECT TEMPLATES ...........................(P. 753)

— EDITING EXISTING TEMPLATES...........................................................................(P. 754)

— DELETING A TEMPLATE ......................................................................................(P. 754)

— TEMPLATE FOR CLICKING THE NEW DOCUMENT BUTTON..................................(P. 755)

— SURVEY OF TEMPLATES IN PCschematic ELautomation ........................(P. 755)
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CREATING PAGE TEMPLATES — VIA THE TEMPLATE EDITOR

In PCschematic ELautomation you can create template pages for all types of 
project pages. The following describes how to create a template page for a normal 
diagram page via the Template editor. — See also “Creating Page templates — via 
the SubDrawings tab” on page 750.

To create a template for a diagram page, do the following:

1) Choose File => New, and you enter the dialog box New:

2) Click on the tab Normal Pages, click on Template in the right-hand side — to 
create a new template page —, click for instance on Blank Page, and click 
OK.

3) You now enter the Template editor, from where you create new templates: 
Click on the Page data button, if you wish to place a drawing header on the 
page.

4) The tab Page data from the dialog box Settings is displayed: Choose a draw-
ing header at the lower part of the tab, type in page data if necessary, and 
click OK.

5) If you wish to draw/place objects on the page, do this now — exactly like 
when you normally work in PCschematic ELautomation.

NEW TEMPLATES FOR LISTS AND CHAPTER DIVIDERS

IF YOU WISH TO CREATE A NEW TEMPLATE FOR E.G. A TERMINAL LIST PAGE, 
SELECT THE TAB TERMINALS LISTS IN STEAD.
IF YOU ARE CREATING A NEW CHAPTER DIVIDER, CLICK ON THE TAB DIVIDER.

2a) Click on the tab Normal Pages 2b) Click on Template

2c) Click on Blank Page 2d) Click OK
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Here you can for instance draw the phases on the upper part of the page.

You can also place existing sub drawings on the page, as described in “Sub 
drawings” on page 266.

6) Click on the Save button, and you enter the dialog box Save as, where you 
type in a name of the template, and click Save.

7) Choose File => Close, and you leave the Template editor, and return to nor-
mal PCschematic ELautomation mode.

CREATING PAGE TEMPLATES — VIA THE SUBDRAWINGS TAB

When you are working in a single-page project, 
you can save it as a template by right-clicking on 
one of the folders in the Template folder, and 
choose Save as.

You then enter the Save as dialog box, where you 
select which folder to save the template in, assign 
a name to the template, and click Save.

Please note that the program automatically assigns 
the extension .std to the template.

If there is a drawing header on the page, the tem-
plate will be understood as a full page. If not, it 
will behave as a normal sub drawing — see “Sub 
drawings” on page 266.

IN PAGE TEMPLATES THE FOLLOWING IS MEMORISED

— ALL CREATED PAGE DATA DATAFIELDS, AS WELL AS THEIR CONTENTS (IF 
ANY)

— THE REFERENCE SYSTEM FOR THE PAGE

— FOR LISTS: THE SPECIFIED LIST SETTINGS — SUCH AS VENDOR AND REPETI-
TIONS

— ALL OTHER PAGE SETTINGS
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CREATING PROJECT TEMPLATES

When you wish to create templates for full projects, enter the Template editor, and 
create a full project as described in “Creating Page templates — via the Template 
editor” on page 749.

In template projects you can place anything you need in a project:

When creating project templates, you are free to insert the already created page 
templates in the project template.

When you are working for different customers, you can create different project 
templates for each individual customer. You can also create project templates con-
taining lists for different component vendors.

— Please read “Creating a template based on an existing project” on page 753 to 
see how to create a template based on an existing project.

— PLEASE NOTE THAT THE TEMPLATE PROJECT MUST BE CREATED FROM THE 
TAB PROJECTS IN THE DIALOG BOX NEW.

Front page

Table of Contents

Parts list

Components list

Terminals list

Cables list

Pages for project drawings

Project template example

PLC list

Chapter Table of Contents

Chapter tab

Chapter tab
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— Please refer to “Converting Standard projects to Project templates” on page 753 
to see how to use standard projects from previous versions of PCschematic ELau-
tomation as templates in this version.

IN PROJECT TEMPLATES THE FOLLOWING IS MEMORISED

— ALL PAGE SETTINGS FOR EACH INDIVIDUAL PROJECT PAGE, AS DESCRIBED 
IN “IN PAGE TEMPLATES THE FOLLOWING IS MEMORISED” ON PAGE 750

— ALL CREATED PROJECT DATA DATAFIELDS, AS WELL AS THEIR CONTENTS 
(IF ANY)

—THE DEFINED REFERENCE DESIGNATIONS

— THE APPLIED COMPANY LOGO

— SETTINGS FOR TEXT PROPERTIES

— SETTINGS FOR TEXT VISIBILITY

— LAYER SETTINGS

— ALL OTHER PROJECT SETTINGS
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CREATING A TEMPLATE BASED ON AN EXISTING PROJECT

To create a template based on an existing project, do the 
following:

1) In the Windows Explorer: Right-click on the project 
file, and click on Cut — or click on Copy if you 
wish to keep the original project.

2) Open the folder Pcselcad\Standard\Template: In 
this folder exists a folder for each type of templates.

3) Open the folder for the type of template you wish to 
create — in this case the Project folder —, by dou-
ble-clicking on the folder.

4) Right-click inside the folder, and choose Paste.

5) The copied project is now inserted in the folder: Right-click on the project 
file, and choose Rename.

6) You can now edit the name of the file: Replace the extension .pro with the 
text .std, and press <Enter>.

You have now created a template based on an existing project. If you wish to edit 
the template, you can do this as described in “Editing templates” on page 754.

Correspondingly, you can save existing projects, containing one page only, as page 
templates. Please be careful to save the project page templates in the correct fold-
ers.

CONVERTING STANDARD PROJECTS TO PROJECT TEMPLATES

The projects called standard projects in version 4.0 (and previous versions) of 
PCschematic ELautomation can be used as templates in this version.

To do so, you must follow the procedure described in “Creating a template based on 
an existing project” on page 753.

Here you find
the templates
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EDITING TEMPLATES

1) Choose File => New.

2) In the dialog box New: Click on the tab on which the template is placed.

3) Click on Template in the right-hand side of the dialog box.

4) Right-click on the template, and click on Open.

5) You now enter the Template editor, where you edit the template, and save it 
by clicking Save.

6) Choose File => Close to leave the Template editor.

DELETING A TEMPLATE

1) Choose File => New.

2) In the dialog box New: Click on the tab on which the 
template is placed.

3) Right-click on the template, and click on Delete.

4) Click OK to leave the dialog box.

THE PAGE TYPE FIELD BLINKS BLUE IN THE 
TEMPLATE EDITOR

WHEN YOU ARE IN THE TEMPLATE EDITOR, 
THIS IS INDICATED BY THE PAGE TYPE FIELD, 
WHICH BECOMES BLUE AND STARTS BLINK-
ING, IN THE LOWER-LEFT CORNER OF THE 
SCREEN.

Blinks blue in
the Template
editor
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TEMPLATE FOR CLICKING ON THE NEW DOCUMENT BUTTON

When you click on the New document button, you enter a project consisting of a 
single blank page.

However, you can create your own template project, which is used as template, 
when you click this button:

1) Create the project that you wish to use as project template.

2) Save the project in the folder Pcselcad\Standard\Template.

3) In the Windows Explorer: Right-click on the project file, select Rename, cor-
rect the file name to filenew.std and press <Enter>.

Then project is now applied as template when clicking the New document button.

SURVEY OF TEMPLATES IN PCschematic ELautomation

The following templates have been created in PCschematic ELautomation:

TYPE TEMPLATE NAME DESCRIPTION

PROJECTS DEMOSTART MULTIPAGE TEMPLATE FOR STEP BY STEP INTRO-
DUCTION.

DPSA3 A3 HORIZONTAL SINGLE PAGE PROJECT TEMPLATE.

DPSA4 A4 HORIZONTAL SINGLE PAGE PROJECT TEMPLATE.

NORMAL PAGES DPSA3MECH A3 SINGLE PAGE PROJECT TEMPLATE FOR MECHANI-
CAL DRAWING (SCALE 1:2).

DPSA3H A3 HORIZONTAL SINGLE PAGE TEMPLATE.

DPSFRONTPAGE A4 VERTICAL FRONT PAGE TEMPLATE.

DPSA4V A4 VERTICAL SINGLE PAGE TEMPLATE.

A4_L1-L3 A4 HORIZONTAL DIAGRAM PAGE TEMPLATE WITH 
POTENTIALS L1, L2 AND L3.

DPSA4H A4 HORIZONTAL SINGLE PAGE TEMPLATE.

PROJECTINFO A4 TEMPLATE FOR TECHNICAL INFORMATION.

DPSA4REF A4 HORIZONTAL SINGLE PAGE TEMPLATE FOR SUR-
VEY OF REFERENCE DESIGNATIONS.

TABLE OF CON-
TENTS

DPSA4-C A4 SINGLE PAGE TEMPLATE.
LIST SETTING — INCLUDES ONLY DIVIDERS.

DPSA4-T A4 SINGLE PAGE TEMPLATE.
LIST SETTING — TOTAL INDEX.

DPSA4-CT A4 SINGLE PAGE TEMPLATE.
LIST SETTING — INCLUDES ONLY DIVIDERS.

DPSA4-I A4 SINGLE PAGE TEMPLATE.
LIST SETTINGS, INDENTED PAGES IN CHAPTERS.
DISPLAYS ONLY PAGE TITLES FOR DIVIDERS.

DPSA4-PC A4 SINGLE PAGE TEMPLATE.
LIST SETTING — ONLY PAGES IN CHAPTER.

TEMPLATES IN PCschematic ELautomation
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DPSA3-T A3 SINGLE PAGE TEMPLATE.
LIST SETTING — IN COLUMNS.

PARTS LISTS DPSA4 A4 SINGLE PAGE TEMPLATE.

COMPONENTS 
LISTS

DPSA4 A4 SINGLE PAGE TEMPLATE.

DPSLABEL TEMPLATE FOR CREATING LABELS.

TERMINAL LISTS DPSA4-EI A4 SINGLE PAGE TEMPLATE, EXTERNAL AND INTER-
NAL CONNECTIONS ARE DISPLAYED.

DPSA4-E A4 SINGLE PAGE TEMPLATE, EXTERNAL CONNEC-
TIONS ARE DISPLAYED.

CABLES LISTS DPSA4 A4 SINGLE PAGE TEMPLATE.

PLC LISTS DPSA4 A4 SINGLE PAGE TEMPLATE.

DIVIDERS DPSA4 A4 SINGLE PAGE TEMPLATE.

TYPE TEMPLATE NAME DESCRIPTION

TEMPLATES IN PCschematic ELautomation
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If your version of PCschematic ELautomation allows you to work with modules, 
you have the following options:

WHAT CAN YOU INSTALL

As extra modules you can for instance install:

- Automatic symbol documentation

- Graphical terminal plans

- Graphical cable plan

- Graphical connection plans

- The program DWG/DXF map settings for setting up parameters for DWG/
DXF import/export

- Translation program for translation of project texts

- Mouse Chasing System for reducing Repetitive Strain Injuries — see “Prevent-
ing Repetitive Strain Injuries” on page 779

These extra modules are covered in a separate tools manual.

THIS CHAPTER DESCRIBES

— WHAT YOU CAN INSTALL................................................................................... (P. 759)

— HOW TO INSTALL AND UNINSTALL.................................................................... (P. 760)

— RE-INSTALLING OR UPDATING MODULES .......................................................... (P. 760)

— STARTING A MODULE ......................................................................................... (P. 761)
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HOW TO INSTALL AND UNINSTALL

Installing and uninstalling can be done by choosing File => Modules, whereby you 
enter this dialog box:

Here you get a survey of which modules can be installed, as well as which modules 
are installed in your case.

In a net installation you can therefore see which modules can be installed on all of 
the PC’s on the net, and which are installed on your machine. Opposed to this, the 
settings you see under Settings => Tools are individual settings for your PC only.

By clicking on a module on the list, you can install or uninstall the module by click-
ing on Install or Uninstall respectively.

If you have no need for converting PCschematic ELautomation DOS files to 
PCschematic ELautomation Windows files, you can click on Symbol conversion, 
TYP to SYM, and then click Uninstall.

Clicking on Install all will install all modules on your PC.

RE-INSTALLING OR UPDATING MODULES

If you have uninstalled a module, you can install it again at any time, with no harm 
done.

If you need to update a module, you do not have to uninstall the module first. Just 
click on the module name, and click Install.
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STARTING A MODULE

When a module is installed, a line is inserted in 
the dialog box Settings => Tools, and maybe 
also an extra button in the toolbar.

The module can succeedingly be started by 
clicking on Tools, and then on the name of the 
module.
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UPDATE AND AUTOMATIC INFORMATION

This chapter describes how you can update PCschematic ELautomation via the 
internet, when new updates are created for the program version you are using. It is 
also described how you, via the internet, can receive information automatically 
from DpS CAD-center ApS about PCschematic ELautomation.

UPDATING VIA THE INTERNET

When you have access to the internet from your PC, you can get PCschematic 
ELautomation to examine automatically whether new updates exist for the version 
of the program, that you are working on. To do this, you must first choose Settings 
=> Setup.

In the lower-left corner of the dialog box you 
can then choose:

•9.XX update: Hereby you automatically 
receive information when updates exist 
for the version you are using.

•Newer version: Hereby you automatically 
receive information when a new version 
is released.

• Information: Hereby you automatically 
get new information from DpS CAD-
center — see “Information from DpS CAD-center via the internet” on 
page 763. When this automatic check is selected and new information is 
released, an information window will appear when you start the program. This 
will only take place the first time a new piece of information is released.

•Scan for releases: Hereby you can manually activate a search for new updates 
and new versions.

When new updates exist, this is displayed below the relevant checkbox. A button 
will also be displayed to the right of the checkbox. When you click this button, you 
enter DpS CAD-center’s homepage, from which you can download the update.

Icon for updates
When you have activated the automatic check, an icon is displayed in the lower-
right corner of the screen. When you click the icon, you enter the dialog box Set-
tings => System, as which is described above.

THIS CHAPTER DESCRIBES

— UPDATING VIA THE INTERNET ............................................................................(P. 762)

— INFORMATION FROM DPS CAD-CENTER VIA THE INTERNET .............................(P. 763)
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If you do not wish to see this message again, you can select  Do not show this mes-
sage again. — When a new patch is available, the message will pop up again.

When you right-click on the icon, a menu is displayed, which gives access to DpS 
CAD-centers homepage, from which you can download the update.

INFORMATION FROM DPS CAD-CENTER VIA THE INTERNET

If you have access to the internet on your PC, you can make PCschematic ELauto-
mation examine automatically whether important information about the program 
have been released. This information could e.g. be:

• If a critical error have been reported, which can cause loss of data. This way you 
can get this information the same moment the error is detected, along with a 
work-around on how to avoid the problem until the error is corrected.

• Information on changed release dates.

... as well as other information of this character.

Activating automatic information
The function can be set in the dialog box Settings 
=> System, by selecting Information in the 
lower-right corner of the dialog box, as displayed 
in “Updating via the internet” on page 762.

If you click the button to the right of the checkbox, a list of the latest pieces of 
information are displayed.

You will only receive information from the program version you are working in.

Icon for Information
When the function is activated, an icon is displayed in the 
lower-right corner of the screen. When you click the icon, a 
list of the latest pieces of information are displayed.

Automatic status popup
When you right-click on the icon and choose 
Automatic status popup, a pop-up window is dis-
played, when new information exist. If this func-
tion is not activated, the icon will start blinking 
when new information exist.
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ADAPTING THE SYSTEM TO YOUR NEEDS

In PCschematic ELautomation you can do quite a few things to adapt the system 
to your needs, in order to work faster and in a more appropriate way for you.

DESCRIBED IN OTHER CHAPTERS

You will find a summary of some of these options below:

ADDITIONAL POSSIBILITIES

Apart from the possibilities mentioned above, you will find the following options:

Favorites
When you right-click anywhere in a project, it is now possible to choose Favorites.

THIS CHAPTER DESCRIBES

— WHERE YOU FIND THESE OPTIONS DESCRIBED...................................................(P. 764)

— ADDITIONAL OPTIONS.........................................................................................(P. 764)

OPTION PAGE

DOCKING THE PROGRAM WINDOWS 35

INSTALLING EXTRA MODULES 759

DEFINE YOUR OWN SHORT-CUT KEYS 766

CHANGE THE SYSTEM COLORS 770

OTHER PROGRAM SETTINGS 809

ADAPTING THE PROGRAM TO YOUR NEEDS
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This gives you the option to specify some favorite functions:

These functions are activated when you press down <Shift>, <Ctrl> or <Alt> and 
right-click on an object.

Specify character set
Under Settings => System, you can specify which character set shall be applied on 
the project pages.

The options are here Standard, Latin2, Russian, Baltic and Polish.

The information of the chosen character set is included in each project file sepa-
rately.

More character sets will be created on request.
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SHORT-CUT KEYS

In PCschematic ELautomation you will find most commands accessible through 
short-cut keys. It is also possible to define your own short-cut keys in the program 
— as described in “User defined short-cut keys” on page 768.

FUNCTION SHORT-CUT KEY FUNCTION SHORT-CUT KEY

AREAS [A] RECTANGLE [CTRL+F]

ARTICLE [V] REDRAW [CTRL+G]

CIRCLES / ARCS [C] REPLACE [CTRL+H]

COMPONENT 
GROUPING

[CTRL+F7] REPLACE SYMBOL [F4]

COORDINATES [CTRL+ I] ROTATE 90O [SPACEBAR]

COPY [CTRL+C] SAVE PROJECT [CTRL+S]

DATABASE [D] SELECT ALL [CTRL+A]

DELETE <DEL> SHOW AVAILABLE [F9]

DRAW ON/OFF <INSERT> SHOW AVAILABLE AGAIN [CTRL+F9]

ELEVATION ON/OFF [F11] SLANTED LINES [CTRL+K]

FIND [CTRL+F] SNAP, FINE <SHIFT>

FIND ARTICLE [V] STRAIGHT LINES [CTRL+R]

FIND NEXT [F3] SURVEY WINDOW ON/OFF [F12]

FIND TYPE [B] SYMBOL MENU [F8]

INSERT POTENTIAL [P] SYMBOLS [S]

KEYBOARD ENTRY [K] TEXTS [T]

LINES [L] TYPE [B]

NEXT [F5] UNDO [CTRL+Z]

NEXT PAGE <PAGEDOWN> VIEW ARTICLE DATA [CTRL+F2]

NEW DOCUMENT [CTRL+N] VIEW CONDUCTING [SHIFT+F2]

OBJECT LISTER [F7] WRITE TEXT [K]

ON-LINE MANUAL [F1] ZOOM [Z]

OPEN [CTRL+O] ZOOM IN [CTRL+HOME]

PRECEDING [F6] ZOOM, MOVE / PAN <CTRL>+ARROW KEYS

PREVIOUS PAGE <PAGEUP> ZOOM OUT [CTRL+END]

PREVIOUS 
SELECTED PAGE

[F10] ZOOM TO PAGE <HOME>

PRINT [CTRL+P]

THE SHORT-CUT KEYS
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Please note that using lower or upper case letters effects the short-cut function. 
Thus [Shift+c] will not activate the Circles command. Whether CapsLock is active 
makes no difference.

Right-clicking
To get further functions/options when working with the program, use right-click. 
For example you can right-click on a symbol, the pickmenu or on the entire page. 
Right-clicking in many cases causes a menu to appear, a menu containing functions 
and/or data dealing with whatever you are clicking on.

When in doubt, you can always try right-clicking.

Buttons with double functions
If you — without clicking — let the mouse rest for a moment on a button, a hint 
displaying the function of the button will be displayed in a tiny yellow rectangle 
below the button. If there is a plus (+) in front of the hint, this tells you that the but-
ton contains another function as well. This other function will be activated by 
pressing down <Ctrl> while clicking on the button.

For instance click on the Symbols button on the top part of the screen, and then let 
the mouse rest on the Symbol menu button on the left hand side of the screen. A 
yellow rectangle appear in which it says +Symbol menu, indicating you have got 
two options: You either just click the button, which brings you into the symbol 
menu, or if you press down <Ctrl> while clicking the button, you go directly into 
the database.

Or, experiment with the other buttons, and find out for yourself which other func-
tions are included in the program buttons.

Faster short-cuts for activating the Pencil
— See “Short-cuts for activating the Pencil” on page 55.
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USER DEFINED SHORT-CUT KEYS

In PCschematic ELautomation you can design your own short-cuts. This is done 
by entering Settings => Pointer/Screen => Shortcuts.

You then see the following dialog box:

In this dialog box you can create short-cut keys for all commands in PCschematic 
ELautomation. The predefined short-cut keys can also be changed.

In order to change or create a short-cut key, you do like this:

1) Choose the menu where the command is located

2) Choose the command

3) Click in the Press new shortcut key field and type in the new short-cut key

4) Click on Assign

The short-cut key is not assigned to the command before you click Assign.

If a short-cut key is already defined for a command, the short-cut key is displayed 
in the Current key field.

If you want to remove a short-cut key, you choose the command and click Remove.

Click on Close when you have finished your changes.

Choose Menu (1) Choose Command (2)

Type in New short-cut key (3) The Current short-cut key
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Reset all
When you click Reset all in the lower-right corner of the dialog box, all short-cut 
keys are reset to their default values, which they were assigned when the program 
was installed. — See “Short-cut Keys” on page 766.

Displaying and printing short-cuts
When you click Show all, all short-cut keys are displayed in a list, which you can 
print by clicking on Print, or save it by clicking Save.
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In PCschematic ELautomation you can set the system colors as you like.

To specify which colors shall be applied in PCschematic ELautomation, you click 
on Settings => Cursor/Screen => Colors.

You then enter the following dialog box:

Here you determine which elements you want to change the color settings for. You 
get the following options:

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO SET THE SYSTEM COLORS.

OPTION REMARKS

BACKGROUND THE BACKGROUND COLOR OF THE SCREEN. IF BLACK BACKGROUND IS 
CHOSEN UNDER SETTINGS => POINTER/SCREEN, THE BACKGROUND 
COLOR CANNOT BE DETERMINED HERE.

DOTTED GRID THE COLOR OF THE DOTS IN DOTTED GRID.

SQUARED GRID THE COLOR OF THE LINES IN SQUARED GRID.

SQUARED GRID-10 HERE YOU CAN DETERMINE THE COLOR OF EACH TENTH LINE IN THE 
SQUARED GRID, FOR INSTANCE TO HIGHLIGHT THESE LINES.

OPTIONS IN COLORS
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Click on Colors when you have chosen which color settings you want to change.

Here you either click on a basic color, or define a color in the right-hand side of the 
dialog box. If you have defined a color by yourself, and click on Add to custom 
colors, the color is placed under Custom colors in the left-hand side of the dialog 
box.

Color for Object selection
When you choose a color for 
Object selection, you have to 
choose the color complimentary 
to the color you want to see when 
you select objects.

If you are using a basic color, it is 
therefore recommended to 
choose a color in the triangle on 
the figure to the right.

The darker a color you choose, 
the better appearance on the 
screen. Especially the four colors 
in the box inside the triangle are recommended.

HELP OBJECTS THE COLOR OF REFERENCE POINTS, THE CENTRE OF CIRCLES, THE CUR-
RENT PATH NUMBERS, THE DISPLAYING OF PAGE MARGINS, THE APPEAR-
ANCE OF THE ORIGO ETC. IN SHORT: EVERYTHING WHICH IS HELP 
INFORMATION ON THE PAGES, BUT ARE NOT DISPLAYED WHEN YOU PRINT 
OUT PROJECT PAGES.

OBJECT SELECTION WHEN YOU CHOOSE AN OBJECT IN PCschematic ELautomation, 
THIS IS INDICATED BY A COLORED BOX COVERING THE OBJECT. IT IS THE 
COLOR OF THIS BOX YOU DETERMINE HERE. PLEASE NOTE, THAT YOU 
HAVE TO CHOOSE THE COLOR COMPLIMENTARY TO THE COLOR YOU WANT 
TO SEE WHEN YOU SELECT OBJECTS.

CROSS HAIRS HERE YOU DETERMINE THE COLOR OF THE CROSS HAIRS. PLEASE NOTE, 
THAT YOU HERE HAVE TO CHOOSE THE COLOR COMPLIMENTARY TO THE 
COLOR YOU WANT TO SEE ON THE SCREEN.

GRADIENT BARS IF YOU HAVE SELECTED GRADIENT TOOLBARS UNDER SETTINGS => 
POINTER/SCREEN (SEE “POINTER/SCREEN” ON PAGE 815), YOU CAN 
HERE SPECIFY THE COLORS FOR THIS. THE THREE MOST APPLIED COLORS 
(FROM WINDOWS 2000, WINDOWS XP AND WINDOWS VISTA) ARE PRE-
DEFINED UNDER USERDEFINED COLORS IN THE DIALOG BOX COLOR.

OPTION REMARKS

OPTIONS IN COLORS

Choose a color for Objekt selection
inside the triangle
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TANKING LICENSES

WHAT IS LICENSE TANKING

When you are using a net license key on PCschematic ELautomation, you have 
the option of tanking licenses. This meaning, that you have the option of giving 
away a license from the PC on which the key is mounted, to a PC which has no 
license key. This can be done for a period of time between 10 minutes and 30 days.

This gives this PC the possibility of working independent from the net, which the 
PC with the license key is attached to.

Licenses can be tanked in two ways:

1) By tanking a license to a PC which is on the net for the moment — see 
“Transferring licenses by License tanking” on page 773.

2) By transferring a license file to a PC which is not on the net — see “Transfer-
ring licenses via license tanking” on page 774.

LIMITING HOW MANY LICENCES TO TANK

It is possible to limit how many licenses, that can be tanked from a license key, so 
that e.g. only 3 out of 5 licenses can be tanked. The function makes sure that there 
is always a predefined amount of licenses available in the company. The license 
keys can only be programmed by DpS CAD-center ApS.

It is also possible to log the license tanking, so that the administrator can see who is 
tanking the licenses.

Please contact your local hotline for further information about this.

THIS CHAPTER DESCRIBES

— WHAT IS LICENSE TANKING................................................................................(P. 772)

— LIMITING HOW MANY LICENCES TO TANK..........................................................(P. 772)

— TRANSFERRING LICENSES BY LICENSE TANK......................................................(P. 773)

— TRANSFERRING LICENSES BY LICENSEFILE.........................................................(P. 774)

— STATUS BUTTON FOR TANK STATUS...................................................................(P. 777)

— SUPERPRO MONITOR ..........................................................................................(P. 778)

NET LICENSE KEY REQUIRED (FLOATING VERSION)
TO MAKE USE OF TANKING LICENSES, THE SYSTEM, WHICH GIVES AWAY THE 
LICENSE, MUST HAVE A NET LICENSE KEY.
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TRANSFERRING LICENSES BY LICENSE TANKING

To tank a licence to the PC which you are working on for the moment — from a net 
license key placed on another PC —, do the following:

1) Choose Settings => System, and the license key settings are displayed on the 
lower-left corner of the tab:

2) Click on License Tank:

3) In the dialog box License Tank: Select a Time or a Date and click on Tank 
license.

4) You are now informed whether you are allowed to tank the license: Click OK.

5) In the dialog box License tank: Click Close.

The net license key herby loose a license for the specified period of time. When the 
tanking period expires, the licence automatically returns to the net license key.

Releasing a tanked license
If you wish to release a license, which has been tanked as described above, choose 
Settings => System => License Tank, and click on Release the tanked license.
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TRANSFERRING LICENSES VIA LICENSE TANKING

When you wish to transfer a license from a PC, which you can not access via a net-
work, do this:

1) Create a license file in PCschematic ELautomation with information about 
your home PC (the PC that needs the license), for use when transferring the 
license. — See “Creating a license file” on page 774.

2) Send the file via e-mail/floppy disc to the person administrating PCschematic 
ELautomation licenses on the system, from which you wish to tank a license.

3) The administrator opens a special program for transferring licenses via file/e-
mail, transfers a license to the file you sent, and returns the file to you. — See 
“Giving away licenses via license files” on page 776.

4) You receive a file, load it in PCschematic ELautomation, and use the license 
for the assigned period of time. — See “Loading a license file containing a 
license” on page 775.

Creating a license file
1) Choose Settings => System: The license key settings are displayed in the 

lower-left corner — as displayed in “Transferring licenses by License tank-
ing” on page 773.

2) Click on License Tank.

3) In the dialog box License Tank: Click on Create file.

4) In the dialog box Save license file: Specify where to save the license file (the 
Pcselcad folder is suggested), and click OK.

5) In the dialog box License file: Click on Close.

Now send an e-mail to the administrator for the system, from which you wish to 
receive a license. In this e-mail you mention for how long you want the license 
(max. 30 days), and attach the license file to the e-mail.

ASSIGNED LICENSE FILES CAN NOT BE RETURNED

WHEN YOU ARE ASSIGNED A LICENSE VIA A LICENSE FILE, IT IS NOT POSSIBLE 
TO RETURN THIS LICENSE.
IF FOR INSTANCE YOU HAVE BEEN ASSIGNED THE LICENSE FOR A PERIOD OF 20 
DAYS, YOU CAN NOT RETURN THIS LICENSE IN THESE 20 DAYS.
THE SYSTEM, FROM WHICH YOU RECEIVED THIS LICENSE, WILL THEREFORE 
NOT BE ABLE TO GET THIS LICENSE BACK, BEFORE THE 20 DAYS ARE OVER.
THE LICENSE CAN ONLY BE USED ON YOUR PC.
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Loading a license file containing a license
When you receive a license file containing a license from the administrator, you can 
load the license in PCschematic ELautomation like this:

1) Place the license file on your harddisk — for instance in the folder Pcselcad.

2) Start PCschematic ELautomation. You now get the following message:

3) Click on License file.

4) In the dialog box Open: Click on the license file, and click on Open.

5) PCschematic ELautomation is now started, and you can work with the pro-
gram in the specified period of time.

See for how long you will keep the license
When you have tanked a license, and choose Settings => System => License 
Tank, you can see for how much longer you have the license:

When the tanked license expires
If the PC is connected to a network when the tanked license expires, PCschematic 
ELautomation automatically looks for an available license, and continues nor-
mally, if an available license is found.
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GIVING AWAY LICENSES VIA LICENSE FILES

If you are the administrator of the licenses on a system with a net license key, and 
receive a license file, you can give away a license like this:

1) In Windows Explorer: Start the program PCsTank.exe — which for instance 
is placed on the server in the Pcselcad folder, or on your own PC.

2) In the program PCschematic ELautomation License Tank: Click on Open 
license file.

3) In the dialog box Open: Click on the license file, which you received, and 
click on Open.

4) In the program PCschematic ELautomation License Tank: Click on Find 
available license.

5) When an available license is found: Click on Tank license.

6) In the dialog box License Tank: Specify for how long to tank the license, and 
click on Tank license.

7) You now get a message telling for how long the license is tanked: Click OK.

8) In the program PCschematic ELautomation License Tank: Click on Close.

The received license file has now got a license assigned for the specified period of 
time, and you return the license file via e-mail/floppy disk.
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Please note, that it is the same file you send back. No new file is created for this pur-
pose.

STATUS BUTTON FOR TANK STATUS

In the right-hand side of the status bar a Status /Info func-
tion button for tank status is displayed, when a license 
have been tanked.

When you click on the button, the remaining tanked time 
is displayed. The function is activated automatically when 
the program is started, and when half of the remaining tanked time has been used. 
The next time it is activated is when half of the now remaining time has been used 
(i.e. 3/4 of the total time) — etc.

When you right-click on the button, a menu is displayed from which the automatic 
pop-up information can be disabled.

ASSIGNED TANKED LICENSE FILES CAN NOT BE RETURNED

WHEN YOU GIVE AWAY A LICENSE VIA A LICENSE FILE, YOU CAN IN NO WAY 
RETURN THIS LICENSE BEFORE THE SPECIFIED PERIOD OF TIME EXPIRES.
IF FOR INSTANCE YOU HAVE GIVEN AWAY THE LICENSE FOR A PERIOD OF 20 
DAYS, THE SYSTEM CAN NOT GET THIS LICENSE BACK BEFORE THE 20 DAYS 
ARE OVER.
THE LICENSE CAN ONLY BE USED ON THE PC, ON WHICH THE LICENSE FILE 
WAS ORIGINALLY CREATED.
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SUPERPRO MONITOR

If you choose Settings => System => SuperPro monitor, you enter a net license 
key monitor, where the available net license keys are displayed.

Here you can select the license server(s), on which the program shall look for 
PCschematic ELautomation license keys.

When you select a PC in the left-hand side of the dialog box, its license keys are 
displayed in the right-hand side of the dialog box.

When you double-click on one of these license keys in the right-hand side, you get 
further information.

Set a check mark here to look for license keys

Double-click on a license key for further information
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PREVENTING REPETITIVE STRAIN INJURIES

In order to prevent repetitive strain injuries — and at the same time save working 
hours — PCschematic ELautomation includes the special developed program 
Mouse Chasing System, which registers which menu functions and buttons you 
click on during your daily work. From the basis of this information, you can then 
block for clicking on specific functions, and thereby learn the short-cuts to the 
functions gradually.

STARTING THE Mouse Chasing System

To start the Mouse Chasing System choose Tools => Mouse Chasing System.

You have now started the Mouse Chasing System, and the following dialog box is 
displayed:

When you click anywhere in the PCschematic ELautomation program, the dialog 
box disappears. Click the Mouse Chasing System button at the bottom of the 
screen when you want to see the dialog box again.

HOW TO INSTALL Mouse Chasing System

IF Mouse Chasing System IS NOT AN OPTION IN THE TOOLS MENU, YOU INSTALL 
IT LIKE THIS:

1) CHOOSE FILE => MODULES

2) YOU NOW ENTER THE DIALOG BOX MODULES: CLICK ON Mouse Chasing Sys-
tem, AND CLICK ON INSTALL

3) CLICK CLOSE TO LEAVE THE DIALOG BOX
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The system registers what you click on
The Mouse Chasing System now registers all the menu selections you make and all 
the buttons you click on, and makes statistics about how many times you click in a 
menu or at a button.

When you click on a function in the dialog box, and then click on Block, the func-
tion is blocked when you click on it in PCschematic ELautomation.

Clicking on a blocked function in PCschematic ELautomation
When you click on a blocked function in PCschematic ELautomation you get the 
following message:

This way the program informs you about the short-cut key to the function. When 
you press this key, the dialog box disappears automatically, and the function is acti-
vated.

If no short-cut key is defined, you can create a short-cut key as described in “User 
defined short-cut keys” on page 768.

Blocks the selected
function

Remove blocking
of selected function

Clear chosen
function

Clear alle
functions

Save the informa-
tion in a file

Statistical
information
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Automatic blocking
When you click on Auto Block you can specify 
that the program shall automatically block all 
functions which have been clicked on more 
than for instance 100 times.

When you click on Show all, all menu choices 
in PCschematic ELautomation are shown. You can then choose which functions to 
block.

Learning the short-cut keys by need
Because the mouse chaser tells you which functions you click on the most, you can 
concentrate on learning these functions. If for instance you block the three most 
used functions, you can learn these without using any special effort.

When you have learned the short-cut keys for these three functions, you can then 
block the three functions you now click on the most — and keep on doing so until 
you have learned the short-cut keys you need to know.

Disabling the Mouse Chasing System
You can at any time disable the blocking of the clicking on a function, by first click-
ing on the function in the Mouse Chasing System and then clicking on Unblock.

When you want to close the Mouse Chasing System, just choose Tools => Mouse 
Chasing System so that the check mark in front of Mouse Chasing System disap-
pears.

Starts automatically along with PCschematic ELautomation
When you do not close Mouse Chasing System before closing PCschematic ELau-
tomation, the Mouse Chasing System closes when you exit PCschematic ELauto-
mation. It will then start automatically the next time you start PCschematic 
ELautomation. This way you can perform statistics on which functions you click 
on for a longer period of time.

THE MOUSE CHASING SYSTEM CAN BE CLOSED DOWN

When the Mouse Chasing System is closed down, PCschematic ELautomation is 
informed about this, so that it knows that the Mouse Chasing System has been 
closed down.
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In this section you get information about net-

work security checks, revision control, registra-

tion of file types etc.

You can read about:

- Access codes on projects .....................(p. 785)

- Locking project files ............................(p. 786)

- Revision control ...................................(p. 788)

- Registering PCschematic file types .....(p. 793)

- Indexing ...............................................(p. 796)

- Starting functions and DDE.................(p. 801)

- Compressed saving / Zipping ..............(p. 804)
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PASSWORDS ON PROJECTS

In PCschematic ELautomation you can create a password for your project files, in 
order to prevent others from opening or saving them.

When you choose Settings => Project data, you can click on 
one of the password buttons.

You then enter this dialog box:

If a password already exists for the project, you first have to enter the previous 
password in the field Previous password.

Then type in the new password in New password, and type in the new password 
once more in Confirm new password.

Click OK.

The next time the project is opened or saved — depending on the password type 
used — you must type in the password and click OK.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO USE PASSWORDS IN PCschematic ELautomation.



PAGE 786 PCschematic ELautomation 10.0

LOCKING PROJECT FILES

LOCKING PROJECT FILES

Due to the security on net installations, the program control which program files are 
opened for the moment.

LOCKING OF A PROJECT IN USE

If you open a project file, which is being used by another user for the moment, you 
get a message informing you that another user is already working on the project, 
and gives you the name of the other user.

However, you are allowed to open a copy of the project. But when you want to save 
your copy of the project, you are only allowed to save it under another name. This 
takes place to prevent you from overwriting the changes made by the other user — 
and to prevent the other user from overwriting your changes as well.

When the original project is no longer occupied, you are can open it and make addi-
tional changes to the project.

THIS CHAPTER DESCRIBES

— LOCKING OF A PROJECT IN USE ..........................................................................(P. 786)

— LOCKING AFTER SYSTEM BREAK DOWN .............................................................(P. 787)

— SHARING LICENSES ON A NETWORK ...................................................................(P. 787)
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LOCKING AFTER SYSTEM BREAK DOWN

When a project is not closed down in the authorized way — for instance due to 
power failure — PCschematic ELautomation does not release the project.

If a new user then tries to open the project, he will be informed that the old user is 
still working on the project, even though this is not the case. The new user will 
therefore not be allowed to save the project under the original project name.

When this is the case, the old user just have to enter the project. The following mes-
sage will then be displayed:

Answer Yes to re-open the project, and close it again. It is not required to save the 
project at this occasion.

Deleting the %pr file manually
If this procedure fails, the problem can be solved using the Windows Explorer.

PCschematic ELautomation have placed a security file in the same folder as the 
project. The file has the same name as the project, but has the extension .%pr. If 
the name of the project is example.pro, the name of the security file will therefore 
be example.%pr.

By entering the Explorer and deleting this file, the project is again accessible for 
other users.

Please note, that PCschematic ELautomation deletes this file under normal cir-
cumstances, when the project is closed down.

SHARING LICENSES ON A NETWORK

On network installations, your license 
can be taken by others, if you have not 
worked on your PC for ten minutes. 
When you start working again you get 
the following message:

If you click Yes, PCschematic ELau-
tomation finds an available license for you, if possible. If no license is available, 
you will have to restart the program to start working again.
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REVISION CONTROL

WHAT IS REVISION CONTROL

When you start the revision control in PCschematic ELautomation, the program 
keeps track of on which pages in the project, changes has been made.

However, there are not kept track of which changes have been made.

It is subsequently possible to see where changes have been made — see “Page 
menu and Object Lister during Revision control” on page 789.

It is also possible to print the edited pages — see “Printing during revision control” 
on page 789.

STARTING A REVISION

1) Choose Settings => Project data => Revision

2) Select Use Revision check

3) Click on Start New Revision

The system now memorizes on which pages changes are being made subsequently.

THIS CHAPTER DESCRIBES

— WHAT IS REVISION CONTROL ............................................................................. (P. 788)

— STARTING A REVISION ........................................................................................(P. 788)

— THE PAGE MENU AND THE OBJECT LISTER DURING REVISION CONTROL...........(P. 789)

— PRINTING DURING REVISION CONTROL...............................................................(P. 789)

— ENDING A REVISION............................................................................................(P. 790)

— DELETING REVISION INFORMATION....................................................................(P. 791)

— DATAFIELD FOR DISPLAYING LAST REVISION.....................................................(P. 791)

Click here
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PAGE MENU AND OBJECT LISTER DURING REVISION CONTROL

When you have started a revision — see “Starting a revision” on page 788 — it is 
possible in the Page menu and the Object Lister to see on which pages changes 
have been made.

The Page menu during revision control
When you have started a 
revision, an extra column is 
displayed in the Page menu, 
named R. In this column an 
R is displayed for the pages, 
which have been changed 
since the start of the revi-
sion.

— Read more about the 
Page menu in “The Page 
menu” on page 489.

The Object Lister during revision control
When you have started a revision, the 
Object Lister for pages can contain an 
extra column, named R. In this column 
an R is displayed for the pages, which 
have been changed since the start of the 
revision.

You enter the Object Lister for pages 
by choosing Object Lister => Pages.

If the R column is not displayed, choose 
Show => Pages => Revision. (Please 
note that the contents of the column Revision comes from the user defined Page 
data datafield of the same name). — Read more about pages in the Object Lister in 
“Editing Page data in the Object Lister” on page 322.

PRINTING DURING REVISION CONTROL

To print the pages, which have been changed since starting the revision control:

1) Click on the Print pages button

2) Select All pages

3) In the dialog box Print: Click on the tab 
Settings

4) Select From date and then select From 
revision date
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5) Click on OK

The edited pages are now printed. — Read more about the dialog box Print in 
“Printing” on page 332.

ENDING A REVISION

1) Choose Settings => Project data => Revision

2) Choose End Revision

The revision is now ended. The next time you enter the dialog box Revision, the 
revision period is displayed.

If you subsequently try to edit pages in the project, you are informed that the revi-
sion has ended. However, you will get this message each time you try to make 
changes.

The Object Lister and the Page menu after ending a revision
When the revision has been ended, the R-column in the Object Lister and the Page 
menu change function: The R-column now displays the pages, which have been 
changed since the revision ended. — See “Page menu and Object Lister during 
Revision control” on page 789.

Creating a password after ending a revision
If you wish to make sure that no changes are made after ending a revision, you can 
subsequently enter a password for the project. — Read more about this in “Pass-
words on Projects” on page 785.

ENDING A REVISION AND DELETING REV. DATA IS NOT THE SAME

ENDING A REVISION AND DELETING REVISION DATA IS NOT THE SAME THING. 
— SEE “DELETING REVISION INFORMATION” ON PAGE 791.
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DELETING REVISION INFORMATION

1) Choose Settings => Project data => Revision

2) Deselect Use Revision check

3) You are now informed that all revision settings are deleted: Click OK

4) In the dialog box Revision: Click OK

5) In the dialog box Settings: Click OK

DATAFIELD FOR SHOWING LAST REVISION

To include a history in the revision information in PCschematic ELautomation, 
you can create consecutively numbered revision datafields in the menus Page data 
and Project data. These datafields can the be filled out as the revisions are made.

When information about the last revision shall be placed on a project page, you 
place the datafield Page revision, which fetches the contents from the last filled out 
of these datafields.

Do for instance the following:

1) Create the datafields Rev1, Rev2, ... , Rev9 under Settings => Project data 
— see “Page data and Project data Datafields” on page 663, specially “Add-
ing New datafields to Project data and Page data” on page 666.

ALL REVISION INFORMATION IS DELETED

PLEASE NOTE THAT ALL REVISION INFORMATION IS HEREBY DELETED 
FROM THE PROJECT. — SEE “ENDING A REVISION” ON PAGE 790 
ALSO.
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2) At the position where you need information about the last revision, you then 
insert the Project data datafield Last revision, and select one of the datafields 
Rev1 ... Rev9 below Linked to datafield in the dialog box Datafield:

3) Fill out the datafields with revision information as the revisions are per-
formed:

4) At the position where you placed the Last revision datafield in the project, the 
contents of the last filled out revision datafield is now displayed (In this 
example the contents of the datafield Rev4):

CAN ALSO ATTACH HISTORY TO OTHER DATAFIELDS

YOU CAN ALSO USE THE DATAFIELD LAST REVISION WITH A SEQUENCE OF 
OTHER DATAFIELDS WITH IDENTICAL NAMES, WHEN YOU NEED TO ATTACH 
HISTORY INFORMATION TO THESE DATAFIELDS.
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REGISTRATION OF PCSCHEMATIC FILE TYPES

REGISTRATION OF FILE TYPES

In order to for instance start PCschematic ELautomation projects directly from 
Windows Explorer, you must register the program file type (*.pro) in Windows. 
Hereby you tell Windows which program to use for starting *.pro files.

When you have done this, you furthermore get the option to apply the Windows 
indexing services for searching for project texts and properties — see “Indexing” 
on page 796.

To register the program file type in Windows, do this:

1) Choose Settings => System and click on File type registration:

2) You then enter the dialog box File type registration:

3) To register .pro files, first click on .PRO Project Files and then on Register. 
The file type is now registered. (.sym files are registered correspondingly).

When a file type is already registered by another program, this will be displayed in 
the dialog box.

When a file type is already set as Registered (this meaning registered by PCsche-
matic ELautomation), no harm will be done by clicking Register again.

THIS CHAPTER DESCRIBES

— REGISTRATION OF PCSCHEMATIC FILE TYPES ....................................................(P. 793)

— REGISTRATION OF .PRO FILES............................................................................(P. 794)

— REGISTRATION OF .SYM FILES...........................................................................(P. 794)

Click here
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Unregistering
To unregister a file type, select the file type and click on Unregister.

THE EFFECT OF REGISTERING .PRO FILES

When *.pro files are registered, this has the following effect:

- Existing PCschematic ELautomation projects can be started directly from the 
Windows Explorer. Right-click on the PCschematic ELautomation project in 
the Windows Explorer, and choose Open.

- New PCschematic ELautomation projects can be created directly from the 
Windows Explorer. Right-click on the PCschematic ELautomation project in 
the Windows Explorer, and choose New.

- Projects can be printed from the Windows Explorer. Right-click on the PCsche-
matic ELautomation project in the Windows Explorer, and choose Print.

- When you right-click on a project in the Windows Explorer and choose Proper-
ties => Project data, the project data are displayed for the selected project.

- The first five Project data datafields are displayed as a hint in the Windows 
Explorer, when the mouse cursor rests over the project file.

- A cat icon (the DpS logo) is displayed in front of PCschematic ELautomation 
files in the Windows Explorer.

- It becomes possible to apply the Windows Indexing services to search for 
project texts and properties, as described in “Indexing” on page 796.

Creating new projects from the menu in the Windows Explorer
If you wish to start creating a new project from the Windows Explorer, do this:

1) In the Windows Explorer: Click on the folder in which you want to create the 
new project

2) Choose File => New => PCschematic project file

3) In the selected folder you now type in the name of the project, and press 
<Enter>

4) Double-click on the file, and the project is opened in PCschematic ELauto-
mation.

THE EFFECT OF REGISTERING .SYM FILES

To register .sym files, see “Registration of file types” on page 793.

When *.sym files are registered, this has the following effect:

- PCschematic ELautomation symbols can be opened in the Symbol editor 
directly from the Windows Explorer. Right-click on the PCschematic ELauto-
mation symbol in the Windows Explorer, and choose Open.
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- New symbols can be created directly from Windows Explorer. Right-click on 
the PCschematic ELautomation symbol in the Windows Explorer, and choose 
New.

- A cat icon (the DpS logo) is displayed in front of PCschematic ELautomation 
symbols in the Windows Explorer.

- It becomes possible to apply the Windows Indexing services to search for sym-
bol texts, as described in “Indexing” on page 796.
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When you use PCschematic ELautomation, it is possible to search on the texts in 
your project and symbol files directly from Windows, via Windows indexing serv-
ice — or from a html page in a web browser.

WHAT IS WINDOWS INDEXING SERVICE?
Windows indexing service makes it possible to search on project/document infor-
mation directly from Windows — without PCschematic ELautomation have to be 
started.

The information, that can be searched on, includes both texts in documents/projects 
(document contents) and the document properties — such as who has created the 
document.

Windows indexing service can only be used for programs, which are prepared for it 
— such as e.g. Microsoft Office, Adobe Acrobat and PCschematic ELautomation.

When the indexing service is activated, Windows use some time to run through all 
documents on your PC, to create the index, which succeedingly makes the back-
ground for the search. This might take some time — as described in “Starting Win-
dows indexing service on Windows XP” on page 796.

STARTING WINDOWS INDEXING SERVICE ON WINDOWS XP

To start Windows indexing service, do the following in Windows:

1) Click on the Start button at the lower-left corner of the screen

THIS CHAPTER DESCRIBES

— WHAT IS WINDOWS INDEXING SERVICE .............................................................(P. 796)

— STARTING WINDOWS INDEXING SERVICE ON YOUR PC .....................................(P. 796)

— SEARCHING VIA WINDOWS INDEXING SERVICE..................................................(P. 798)

— SYNTAX FOR USING WINDOWS INDEXING SERVICE............................................(P. 799)

THE PCSCHEMATIC FILE TYPES MUST BE REGISTERED

TO USE THE WINDOWS INDEXING SERVICE FOR PROJECT FILES, THE FILE TYPE 
.PRO MUST BE REGISTERED. CORRESPONDINGLY THE FILE TYPE .SYM MUST BE 
REGISTERED BEFORE YOU CAN APPLY THE WINDOWS INDEXING SERVICE FOR 
SYMBOLS.
— READ MORE ABOUT THIS IN “REGISTRATION OF PCSCHEMATIC FILE TYPES” 
ON PAGE 793.
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2) Choose Search

3) Click on Change preferences in the lower-left corner

4) Click on With Indexing Service, and then click on Yes, enable Indexing 
Service and click OK

The indexing service is now activated, and Windows now spend some time to run 
through all documents on your PC, to create the index which is the basis for the 
succeeding search — as described in “Searching for project texts via Windows 
indexing services” on page 798.

The creation of this index takes place in the background, so you can continue work-
ing on your PC while the index is created.

Please note, that if you have many files on your PC, it can be a good idea not to turn 
off the PC for one night while Windows creates the index.
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SEARCHING FOR PROJECT TEXTS VIA WINDOWS INDEXING SERVICES

When you have activated Windows indexing service — as 
described in “Starting Windows indexing service on Win-
dows XP” on page 796 —, you can search like this:

1) Click on the Start button in the lower-left corner of 
the screen

2) Choose Search

3) Click on All files and folders in the lower-left cor-
ner

4) You can now type in what you are searching for in 
the file A word or phrase in the file:

The syntax for how you can search is described in “Syntax for using Win-
dows indexing service” on page 799.

5) Type in the search text, and click on Search.

6) The result of the search is now displayed in the right-hand side of the window.
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SYNTAX FOR USING WINDOWS INDEXING SERVICE

When you use Windows indexing service — as described in “Searching for project 
texts via Windows indexing services” on page 798 — you type in a search text in 
the field A word or phrase in the file:

In this file you type in a property (e.g. @DocAuthor) followed by a search value 
(e.g. Peter Hansen). Hereby there are searched for whether the property e.g. con-
tains the text Peter Hansen.

If more than one criterion must be fulfilled at the same time, just write AND 
between the criteria — as in the figure above.

If the one or the other criterion must be fulfilled, write OR between the criteria: 
@DocTitle Eldocumentation OR @DocCompany Machinefactory. — For further 
options, please refer to the Windows on-line help.

If you are only searching for the beginning of a text, or for parts of a text, you can 
use wildcards (e.g. @DocTitle *document*) — as described in “Wildcards/jokers” 
on page 542.

You have the following options:

PROPERTY FUNCTION

@DOCTITLE HERE YOU CAN SEARCH FOR PROJECT TITLES — I.E. THE CONTENTS OF 
THE FIELD TITLE IN THE DIALOG BOX SYSTEM => PROJECT DATA — 
AND SYMBOL TITLES — I.E. THE TITLE SPECIFIED IN THE SYMBOL EDI-
TOR WHEN YOU CLICK ON THE SYMBOL SETTINGS BUTTON.

@DOCCOMMENTS HERE YOU CAN SEARCH FOR PROJECT REMARKS — I.E. THE CONTENTS 
OF THE FIELD REMARKS IN THE DIALOG BOX SETTINGS => PROJECT 
DATA.

@DOCAUTHOR HERE YOU CAN SEARCH FOR WHO HAS DESIGNED/CREATED THE 
PROJECT. HERE ARE ONLY SEARCHED FOR PROJECT DATA DATAFIELDS 
WITH THE NAMES CONSTRUCTOR, AUTHOR, CREATOR AND DESIGNER. 
IF YOU HAVE PLACED THIS INFORMATION IN A PROJECT DATA 
DATAFIELD WITH ANOTHER NAME, YOU WILL NOT BE ABLE TO FIND IT 
THIS WAY.

@DOCREVISION HERE YOU CAN SEARCH FOR THE REVISION NUMBER OF THE PROJECT. 
THERE ARE ONLY SEARCHED FOR PROJECT DATA DATAFIELDS WITH THE 
NAMES REVNUMBER, REVISION AND REV. IF YOU HAVE PLACED THIS 
INFORMATION IN A PROJECT DATA DATAFIELD WITH ANOTHER NAME, 
YOU WILL NOT BE ABLE TO FIND IT THIS WAY.

SYNTAX FOR USING WINDOWS INDEXING SERVICES
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@DOCCOMPANY HERE YOU CAN SEARCH FOR CUSTOMERS/COMPANIES. THERE ARE 
ONLY SEARCHED FOR PROJECT DATA DATAFIELDS WITH THE NAMES 
CUSTOMER AND COMPANY. IF YOU HAVE PLACED THIS INFORMATION 
IN A PROJECT DATA DATAFIELD WITH ANOTHER NAME, YOU WILL NOT 
BE ABLE TO FIND IT THIS WAY.

@DOCCATEGORY HERE YOU CAN SEARCH ON SYMBOL TYPE. YOU CAN SEARCH FOR THE 
TYPES NORMAL, RELAY, OPEN, CLOSE, SWITCH, MASTER REFERENCE, 
WITH REFERENCE, TERMINAL, PLC, NON CONDUCTING OR SUPPORT.

@CONTENTS HERE YOU CAN SEARCH FOR ALL TYPES OF TEXTS IN THE PROJECT — 
E.G. SYMBOL TYPES, FREE TEXTS, PAGE TITLES AND THE CONTENTS OF 
DATAFIELDS.
IF YOU JUST WRITE A TEXT WITH NO PRECEDING PROPERTY (I.E. JUST 
WRITE PETER HANSEN), THERE WILL ALSO BE SEARCHED AMONG ALL 
KINDS OF TEXTS IN THE PROJECT.

PROPERTY FUNCTION

SYNTAX FOR USING WINDOWS INDEXING SERVICES
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STARTING FUNCTIONS, BATCH PRINTING AND DDE

It is both possible to open a PCschematic ELautomation file on a specified page, 
and to start PCschematic ELautomation files directly from the Explorer in Win-
dows. It is also possible to start PCschematic ELautomation from expert systems.

Furthermore it is possible to batch print PCschematic ELautomation projects.

These options are described in the following.

STARTING FUNCTIONS

PCschematic ELautomation contains the following starting functions, which can 
all be activated from the command line:

1. Loading a project with a specified page open
It is possible to open a PCschematic ELautomation file on a specified project 
page. This is done using the commandline parameter /P.

If you want to load the project edemo.pro and display page 7, you type:

C:\PCSECAD\PCSECAD.EXE EDEMO.PRO /P7

2. Loading a project with a specified symbol selected
It is possible to open a PCschematic ELautomation file with a specified symbol 
selected. This is done using the commandline parameter /S.

If you want to load the project edemo.pro with the symbol K1 selected, you type:

C:\PCSECAD\PCSECAD.EXE EDEMO.PRO /SK1

The first project page containing a K1 symbol will be displayed, and all K1 sym-
bols in the project will be selected.

Correspondingly you can type C:\PCSECAD\PCSECAD.EXE EDEMO.PRO /
SK1:13, which causes all K1 symbols to be selected, and the project to be opened 
on the project page where K1:13 is placed.

3. Opening only a few project pages
It is also possible only to load individual project pages.  This is done using the com-
mandline parameter /L.

If for instance you only want to open page 3 from the edemo.pro project, you type:

THIS CHAPTER DESCRIBES

— STARTING FUNCTIONS.........................................................................................(P. 801)

— BATCH PRINTING.................................................................................................(P. 802)

— DDE FUNCTIONS.................................................................................................(P. 802)



PAGE 802 PCschematic ELautomation 10.0

STARTING FUNCTIONS, BATCH PRINTING AND DDE

C:\PCSECAD\PCSECAD.EXE /L[3] EDEMO.PRO

If for instance you want to open the pages 3, 5 and 7 from edemo.pro, you type:

C:\PCSECAD\PCSECAD.EXE /L[3][5][7] EDEMO.PRO

The name of the opened pages becomes part of the project name in the limited 
project which is opened. Therefore you do not risk to save the limited version of the 
project which replaces the original project. In the example mentioned above, the 
limited project will be named edemo.[3][5][7].pro.

BATCH PRINTING

The following function for batch printing in PCschematic ELautomation exists, 
which can be activated from the command line, or e.g. from a schedule program:

Batch printing from stand-alone installation
To print the file C:\batch.pro (where PCschematic ELautomation is installed in 
the folder C:\Pcselcad), write this:

C:\PCSELCAD\PCSELCAD.EXE -xp C:\batch.pro

— When you need to print more than one file, write the names of these after 
C:\batch.pro, only separated by a space character:

C:\PCSELCAD\PCSELCAD.EXE -xp C:\batch.pro C:\batch2.pro

Batch printing from net installation
To print the file C:\batch.pro (where PCschematic ELautomation is installed in 
the folder F:\Pcselcad), write this:

F:\PCSELCAD\PCSELCAD.EXE /n:C:\PCSELNET -xp C:\batch.pro

Here F:\PCSELCAD is the system catalog, while /n:C:\PCSELNET is the work-
station catalog.

— When you need to print more than one file, write the names of these after 
C:\batch.pro, only separated by a space character:

F:\PCSELCAD\PCSELCAD.EXE /n:C:\PCSELNET -xp C:\batch.pro C:\bat2.pro

DDE FUNCTIONS

In PCschematic ELautomation exists DDE functions, which makes it possible to 
right-click on a .pro file in the Windows Explorer, and then getting the options 
Open, New, and Print.

Thus it is possible to open a file by double-clicking on it — or by right-clicking and 
choosing Open. Also a new project can be opened by right-click New, and a project 
can be printed by right-click Print.

Registration of PCschematic ELautomation
From the command line .pro files for PCschematic ELautomation are registered 
using the parameter /REGISTER — for instance type:
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C:\PCSECAD\PCSECAD.EXE /REGISTER

The program only have to be started once this way.

The registration is removed by C:\PCSECAD\PCSECAD.EXE /UNREGISTER.

DDE registration also has the consequence that once you have started PCschematic 
ELautomation, and opens a file from the Windows Explorer, this file is opened in 
the running program.
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COMPRESSED SAVING / ZIPPING PROJECTS

WHAT IS ZIPPING?
The Zip program is so commonly used for compressing files, that it is close to 
becoming an international standard for file compression.

Therefore automatic zipping of project documents have become an integrated 
option in PCschematic ELautomation.

SET THE PROGRAM TO AUTOMATIC ZIPPING

When you wish to set PCschematic ELautomation to save project files in the zip 
format automatically, you can choose Settings => System and activate Com-
pressed saving:

The projects still gets the extension *.pro, though they are zipped.

Opening zipped project files
When a project is opened, PCschematic ELautomation automatically analyses 
whether the project is zipped or not. When a project is saved in the zip format — 
from PCschematic ELautomation — it is opened like any other project.

It therefore has no consequence for your working process with the program, if you 
choose compressed saving.

ADVANTAGES BY ZIPPING IN PCschematic ELautomation

When you set PCschematic ELautomation to automatic zipping, the size of the 
projects are reduced to about 8-12% of the original size, and both loading and sav-
ing are faster for projects on networks. For projects on local disks, there will be no 
time difference.

THIS CHAPTER DESCRIBES

— WHAT IS ZIPPING................................................................................................(P. 804)

— SET THE PROGRAM TO AUTOMATIC ZIPPING....................................................... (P. 804)

— GAINS BY ZIPPING IN PCschematic ELautomation .................................(P. 804)

Click here
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The compression follows the zip standard completely. Therefore you can choose to 
change the extension of a zipped project document to .zip, after which you can let 
the document be unzipped by a common unzipping program.
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CHOICES IN THE DIALOG BOX SETTINGS

The dialog box Settings is a menu in PCschematic ELautomation. If you wish to 
be able to select all tabs in the dialog box, choose Settings => Settings. (If the tab 
you are looking for is not displayed in the dialog box for the moment, you can click 
the right- and left-arrows in the upper right-hand corner of the dialog box).

When you wish just to choose one of the menu points, you can choose this directly 
from the menu: When for instance you wish to access the tab Tools directly, you 
therefore choose Settings => Tools. Hereby the dialog box Settings is opened, and 
the tab Tools is selected. Please note that the tab Tools then becomes the only tab in 
the dialog box.

Entering Settings without an active project
It is possible to enter the Settings dialog box when no projects are open. Tabs in 
Settings, which are not project related, are not displayed when there are no active 
projects.

THE TABS IN THE SETTINGS MENU

The tabs in the dialog box Settings includes:

THIS CHAPTER DESCRIBES

IN THIS CHAPTER YOU CAN READ ABOUT WHICH TABS YOU CAN SELECT IN THE DIALOG BOX 
SETTINGS, AND GET FURTHER INFORMATION ON THE VARIOUS SETTINGS IN THE DIALOG BOX.

A SURVEY OF THE CONTENTS OF THE TABS, EXISTS IN “THE TABS IN THE SETTINGS MENU” ON 
PAGE 809.

TAB CONTENTS

PROJECT DATA

(P. 811)
SPECIFICATION OF DATAFIELDS CONCERNING THE ENTIRE PROJECT. PASS-
WORDS, PROJECT REMARKS, REFERENCE DESIGNATIONS, MOUNTING COR-
RECT DRAWING, PROJECT LOGO, REVISION CONTROL AND RELAY 
REFERENCE TYPE.

PAGE DATA

(P. 813)
SPECIFICATION OF DATAFIELDS CONCERNING THE PAGE YOU ARE WORK-
ING ON IN THE PROJECT. PLACING A DRAWING HEADER ON THE PAGE. 
REFERENCE SETTINGS E.G. FOR CURRENT PATHS, ARTICLE DATA FOR THE 
PAGE, AND REFERENCE DESIGNATIONS FOR THE PAGE.

POINTER/SCREEN

(P. 815)
SETTINGS DEALING WITH WHAT IS DISPLAYED ON THE SCREEN, AND HOW 
IT IS DISPLAYED.
CHOOSE SYSTEM COLORS, AND USER-DEFINED SHORT-CUT KEYS.

FUNCTIONS ON THE SETTINGS TABS
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DIRECTORIES

(P. 819)
SPECIFICATION OF WHERE DIFFERENT TYPES OF FILES WILL BE SUG-
GESTED SAVED/LOADED FROM, AS WELL AS FOR WHICH TYPES OF FILES A 
BACKUP WILL BE MADE. SPECIFICATION OF THE ORDER IN WHICH THE 
SYMBOL FOLDERS WILL BE EXAMINED, WHEN THE PATH TO A SYMBOL IS 
NOT SPECIFIED (ALIAS).

PAGE SETUP

(P. 823)
SPECIFICATION OF PAPER SIZE, PAGE TYPE, PAGE SCALING, AS WELL AS 
GRID AND SNAP FOR THE PAGE YOU ARE WORKING ON.

TOOLS

(P. 825)
HERE YOU SPECIFY WHICH OTHER PROGRAMS CAN BE STARTED FROM 
PCschematic ELautomation.

DATABASE

(P. 827)
CHOOSE DATABASE FILE AND SETTINGS. ACTIVATING AND DEACTIVAT-
ING THE DATABASE.

SYSTEM

(P. 829)
COMPANY AND USER NAME. LICENSE KEY SETTINGS. FILE TYPE REGIS-
TRATION. SPECIFICATION FOR INTERVAL BETWEEN SAVING AUTO 
RECOVER INFORMATION.
CHOOSING CHARACTER SETS FOR OTHER LANGUAGES, AND CHOOSE LAN-
GUAGE.

TEXT/SYMBOL 
DEFAULTS

(P. 832)

SPECIFICATION OF THE STANDARD APPEARANCE OF VARIOUS TYPES OF 
TEXTS IN THE PROGRAM. SPECIFICATION OF WHICH DRAWING HEADERS 
CAN BE USED, AS WELL AS WHICH SIGNAL SYMBOLS AND SIGNAL SYMBOL 
NAMES THAT WILL BE SUGGESTED IN THE DIALOG BOX SIGNALS.
CREATION OF DATAFIELDS FOR DATA SYMBOLS.
DEFAULT CABLE DIRECTIONS.

TAB CONTENTS

FUNCTIONS ON THE SETTINGS TABS
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PROJECT DATA

On the tab Project data you specify general settings for the project. You can add 
and fill out the Project data datafields, specify passwords for the active project, 
choose a project logo, choose reference designations, set up mounting correct draw-
ing, start/stop a revision control and choose the reference type for relays.

Clicking on the Project data button brings you directly into this dialog box.

Passwords
For further details about passwords on projects, please refer to “Passwords on 
Projects” on page 785.

Project data and Project title
In Project data you type in information regarding the entire project, which you can 
read more about in “Project and Page data” on page 138.

By right-clicking on a datafield name (the grey fields to the left), you can delete, 
add or change the datafield names in the menu. Read more about this in “Adding 
New datafields to Project data and Page data” on page 666.

The field names you specify here, can be inserted into your project, when you 
choose Functions => Insert Datafield and click on Project data. The program 
then collects the information you have typed in here, and place it in the project. If 
you need to change an information, you therefore only have to do it here once and 
for all. Read more about datafields in “Datafields” on page 134.
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Clicking on the Save as default button, saves the datafields you have specified as 
default datafields of the type Project data. When you start up a new project, these 
datafields will be suggested.

Remarks in projects
In the Remarks field, you can type in remarks for the entire project. There is no 
limitation for the size of the remarks in the Remarks field.

When you have typed in a remark, you can right-click in the Remarks field. This 
gives you the opportunity to print out the remark, or to save it as an independent 
text file.

Logo
— See “Inserting logos in projects” on page 518.

Relay reference type
Here you specify whether you wish to use reference crosses or contact mirrors for 
relay references. — See “Contact mirrors and Reference crosses” on page 380.

Revision
— See “Revision control” on page 788.

Reference designations for the project
When you click on Reference designations, you can specify the reference designa-
tions you want to use in the project. Please refer to “Reference designations” on 
page 339 for further details.

Mounting correct drawing
When you select Mounting correct drawing, the program supports you in creating 
mounting correct drawings. Please refer to “Mounting correct drawing” on 
page 120 for further details.

Do not display Project data when starting a new project
If you do not wish to see the tab Project data when creating new projects, choose 
Settings => Project data, and deselect Show this dialog when creating a new 
project. This checkbox is displayed at the bottom of the tab.

Click here
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PAGE DATA

In this dialog box you specify various kinds of settings regarding the project page 
you are working on right now.

Clicking the Page data button brings you directly into this dialog box.

Include page in Table of Contents
If you select Include this page in Table of Contents, the page is included in the 
table of contents.

Page data and Page title
In these text fields you type in information regarding the page you are working on 
in the project right now.

Read more about this in “Project and Page data” on page 138.

The field names specified here, are the datafield names you can insert into your 
project, when you choose Functions => Insert Datafield, and select Page data. 
When you insert a datafield, the program collects the information you have typed in 
here, and insert it where you have placed the datafield. Read more about datafields 
in “Datafields” on page 134.

When you right-click on a datafield name (the grey fields to the left), you can 
delete, add or change the datafield names in the dialog box. Read more about this in 
“Adding New datafields to Project data and Page data” on page 666.
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Clicking on the Save as default button, saves the datafields you have specified as 
default datafields of the type Page data. When you start up a new project, these 
datafields will be suggested.

Reference designations for the page
In PCschematic ELautomation you can attach reference designations to all sym-
bols placed on the same page.

If reference designations are already attached to the page, they are displayed, as you 
can see on the figure. When you wish to specify new reference designations for the 
page, click on Select.

— Please refer to “Reference designations” on page 339 for further details.

Reference designations is only visible on this tab if reference designations have 
been chosen for the project on the Project data tab. — See “Reference designa-
tions for the project” on page 812.

Drawing headers
In this part of the dialog box you specify which drawing header you want to place 
on the page. This is described in “Inserting a drawing header on a page in a project” 
on page 526.

References
When you click on the References button, you enter the dialog box Reference sys-
tem setup, where you specify the settings for the reference system/current path 
numbers on the page. — Read more about this in “Current path numbers / Refer-
ence System” on page 385.

Article data
Clicking on the Article data button brings you into the dialog box Page article 
data.

Here you type in article data for the page if you need to.

When you right-click on the page itself, and then choose Page article data, you 
also enter this dialog box.
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POINTER/SCREEN

This tab consists of a number of check boxes, in which you specify how you want 
the screen and pointer settings.

Change system colors
If you want to change the system colors, you click on Colors. Please refer to 
“Colors” on page 770 for further details.

Change system Short-cut keys
If you want to change the system short-cut keys, you click on Short cuts. Please 
refer to “Short-cut Keys” on page 766 for further details.

Grid display: Here you specify the appearance of the grid on the screen. Please 
refer to “Grid” on page 68 for further details.

Align grid to 1. Reference: If you want your grid aligned to the first reference 
number on the page, you select Align grid to 1. Reference. This goes for both verti-
cal and horizontal reference systems.

You then have to adapt the size of the grid/snap in order to make it fit the interval 
between the current path numbers.

Grid on list pages: Select this option if you want grid on list pages.

Cross hairs / Small cross hairs: Here you specify whether you wish to use a cross 
hairs, as well as the appearance of the cross hairs. Read more about cross hairs in 
“Dictionary” on page 850.
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Pointer: Specifies whether a mouse pointer is displayed on the screen. Is automati-
cally selected if Cross hairs is deselected.

Straighten lines: Here you specify whether the connecting lines should be straight-
ened when you move a symbol. Is enabled by default.

Ortho 45: When you draw Lines, and have chosen Straight lines, you are only 
allowed to draw horizontal and vertical lines. However, if you select this function, 
you are also allowed to draw diagonal lines.

Cross hairs line displayed right angled: When you are drawing Straight lines, a 
rubber band always appear, radiating from the last place you clicked towards the 
cross hairs.

If you have selected this function, you will always see the line as it will be drawn if 
you click in this very moment.

If you have deselected this function, you will see a line going from where you 
clicked last to the exact position of the cross hairs.

Depending on which snap you are using, these lines will not always be the same.

Cross hairs figure with snap: When this function is selected, the objects in the 
cross hairs follow the actual snap. This way you will continuously see where the 
object will be placed when you click.

If the function is deselected, the symbols will only follow the exact position cross 
hairs — but will still be placed according to the actual snap if you click. — Read 
more about snap in “Snap” on page 68.

Net router: When you move mechanical symbols, the program can display which 
other mechanical symbols the symbol is connected to — according to the informa-
tion on the electrical pages. Read more about this in “Displaying connections for 
mechanical symbols” on page 615.

Unit of measurement: Here you specify according to which unit of measurement 
PCschematic ELautomation interprets the object positions you type in. If the unit 
of measurement is set to mm and you type in 15, this will be interpreted as 15mm.

However, you can still type in another unit of measurement together with the 
number — typing in 15 cm will still be interpreted as 15cm.

Show message in (ms): Specify how long time the hints are displayed in the pro-
gram.

Ask for Names: If this function is selected, you will enter the Component data 
dialog box each time you place a symbol in your project. If the function is dese-
lected, you have to right-click on the symbols later on, choose Component data, 
and then fill out the symbol name and other information.

Insert - in front of symbol names: When there is no minus in front of the symbol 
name in the symbol definition, a minus will be inserted in front of the symbol name, 
when you place the symbol.
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To insert a minus in front of already placed symbols choose Functions => Special 
Functions => Prefix all symbol names with -.

Keep zoom: Imagine you have zoomed in on an area — for instance the upper-right 
corner — of a project page, and change to another page in the project. If Keep zoom 
is selected, you will then also see the upper-right corner of the page you change to. 
If the function is deselected, you will see the entire new page.

Keep page zoom: If Keep zoom is selected, you also get the option to select Keep 
page zoom. If you select this function, the program remembers which zoom you are 
using on each individual page. When you close a project, the applied zoom settings 
are not memorized.

Show scrollbars: When you have zoomed in on an area, you can drag the scrollbars 
to move the zoom — see “The Scroll button and Scrollbars” on page 64.
When you deselect Show scrollbars you get a larger work area on the screen.
— See Auto hide scrollbars below.

Auto hide scrollbars: Is only displayed when Show scrollbars is selected. If you 
activate Auto hide scrollbars, the scrollbars are only displayed when you point the 
mouse pointer to the far right or to the bottom of the screen. This way you do main-
tain the full work area and are still able to use the scrollbars.

Flat buttons: If you want the program to apply the flat Windows 98 buttons, you 
select Flat buttons. If Flat buttons is not selected, the buttons will be displayed in 
Windows 95 style.

Gradient toolbars: If you wish to apply the gradient look, as known from e.g. the 
Microsoft Office programs, select Gradient toolbars. See how to set the colors in 
“Colors” on page 770.
— Please note that dialog boxes aways have gradient look.

Gradient Pickmenu: Is only displayed when you have selected Gradient toolbars. 
Select Gradient Pickmenu if you also want gradient look in pickmenus.

Hints: If you let the mouse pointer rest for a moment, on for instance a program  
button, you will see the name of the button displayed in a small text field. Or, if you 
let the pointer rest on a symbol in the symbol pick menu, the symbol title will be 
displayed. This is called hints, and here is the place you specify whether you want 
hints when working with the program.

Show popup information: When selected and you let the mouse cursor rest over a 
symbol, a window is displayed containing information about the symbol. The win-
dow disappears when you move the mouse again.

Show popup help: When you have started a function, which requires more than one 
action, and you have not moved the mouse for a while, a window is displayed, tell-
ing what the program expects you to do.

Page tabs: On the bottom of each project page, you see some small tabs, displaying 
which project page you are working on. Clicking on these tabs enables you to 
change back and forth between the project pages quickly. This is the place to select 
whether you want tabs on your pages or not.
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If the function is disabled, the drawing area on the screen will become a little larger.

Black background: Selecting this function will make the project pages turn black, 
while lines, symbols and so forth will become white.

Survey window: Here you enable and disable the Survey window. Short-cut [F12].

Elevation window: Here you enable and disable the Elevation window. Short-cut 
[F11]. The window is only displayed on pages of the type Ground plan.

Explorer window: Here you enable and disable the Explorer window. Please refer 
to “The Explorer window: The Projects tab” on page 309 for further details. In 
Show in Edit symbol you specify whether to display the Explorer window when 
editing symbols.

Help frame: Clicking here makes a standard margin appear on the project pages. 
The margin is displayed by a red dash line. The help frame is not included when 
you print out project pages.

Printer help frame: Clicking here will make the printable area of your printer visi-
ble. The printable area is displayed by a grey dash line, and is not displayed when 
you print the project pages.

Reference points: When the function is selected, the reference points of the objects 
are displayed on the screen. Read more about reference points in “Dictionary” on 
page 850. The reference points are not visible when you print out the project.

Pickmenu: Here you turn the pickmenu on and off. Read more about the symbol 
pick menu in “Fetching symbols from the Pickmenu” on page 161.

Transparent windows: Some windows can remain on screen while you are working 
on the drawing area in the project. These windows can be set to become transparent 
by selecting Transparent windows. You can set the degree of transparency by mov-
ing the slider below Transparent windows. This makes it possible to get an idea of 
what is behind the dialog box on the drawing area.

When the window / dialog box is activated — e.g. by clicking on it — the window 
becomes fully visible again. When you click on the drawing area of the screen, the 
window becomes transparent again.

The best way to set the degree of transparacy, is to open e.g. the Object Lister 
(press [F7]), and select Symbols, so that the Object Lister contains data. Then 
select Settings => Pointer/Screen, and drag the slider below Transparent win-
dows to a position, where you get the desired transparency in the Object Lister.

The following windows will also become transparent, when Transparent windows 
is selected: The Show available window, the Insert component list window, the 
Find and Replace window, and the result window from Design check.
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DIRECTORIES

Directories
Here you specify in which folder/directory you want the program automatically to 
suggest you to save the various types of program files. If you want to save a project, 
and have chosen the setting above, the program will automatically suggest you to 
save it in the folder Project.

When you click on the Browse button in front 
of a directory, you get a little Explorer win-
dow, where you can locate the folder you now 
wish to apply as directory:

Click on the desired folder, and click OK.

Displaying System catalog and Workstation catalog
At the bottom of the tab Directories the sys-
tem catalog is displayed, as well as the work-
station catalog on net installations.

Save with backup
In the right-hand side of the dialog box you specify for which kind of files you want 
backups to be made. These backups are made when you save a file, and contains the 
previous version of the file.

Here the System catalog is displayed,
as well as the Workstation catalog
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The backups gets the same names as the files, but the extension of the files are 
changed to the character ~ followed by the first two characters in the extension of 
the original. Thus the backup of the project demo.pro will be called demo.~pr, 
while the backup of the symbol symbol.sym will be called symbol.~sy.

Show directory alias
When you have clicked on Symbols in the left-hand side of the dialog box, you get 
the option of clicking on Show directory alias.

Here you get the option to assign an alias to each symbol folder/directory.

This makes it easy for you to move the symbol directories, if this should become 
necessary.

The Alias concept
As displayed above, the directory C:\PCSELCAD\SYMBOL\MISC has the alias 
MISC. If it at some point is decided to move this directory to for instance I:\SYM-
BOLS\MISC, you only have to correct the path here. In this case, the program will 
automatically find all the project symbols — which used to be located in the old 
directory — in the new directory.

You will not need to type in the alias MISC anywhere in PCschematic ELautoma-
tion; it is merely a name you have given the program, so that it internally can distin-
guish between the various aliases. But off course it is a good idea to give them 
appropriate names, so that you yourself can distinguish between them here in the 
Alias for directories dialog box.

Specify which directories you use the most
When you fetch a symbol from the database, or load a project with no specified 
paths to the symbols, the program will search the symbol folders in the order you 
have specified here, starting from the top. The program then finds the first symbol 
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with the given symbol name. Please note, that the order of the directories therefore 
is important.

To save time, it is therefore a good idea to place the folders, you use the most, on 
the top of the list. You can move the aliases by clicking and dragging.

If for instance you want User to be on top, then click on User, keep the mouse but-
ton pressed down, drag the alias to the top of the list, and let go of the mouse but-
ton. User is now placed on top of the list.

Correcting directories or alias
If you want to correct an alias name or path, you first have to 
make sure that you are working in an empty project, and that no 
other projects are open.

Then right-click on the place in the list where you want to make 
changes. — If you are not working in an empty project, or other projects are open, 
you will get a warning, and will not be allowed to make any changes.

If you want to change an alias name, you then choose Change alias, and if you 
want to remove an alias, you choose Remove alias.

If you choose Modify path, you enter a dialog box, where you click your way to 
the desired directory.

Click OK.

When you want to add a new alias to the list, you choose Add new alias. Then you 
type in the name of the alias, and click your way to the desired directory.

Click on Close when you have completed the corrections.

Example
If you are working inside an empty project — having no other projects open — and 
want to add a new alias, which you want to be placed as number three on the alias 
list, then start by choosing Settings => Directories.

Click on Symbols in the left-hand side of the dialog box, and then click on Show 
directory alias. Right-click on the lower part of the list, and choose Add new alias.
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Now type in the alias name, click OK, click your way to an appropriate directory, 
and click OK again. Move the new alias to the third position on the list by clicking 
and dragging.

Click OK.

Alias when installing databases
When you install a database on PCschematic ELautomation, the program automat-
ically creates an alias to the library containing the symbols of the database.

Administrator control
If Administrator is selected, various system settings can be controlled by the sys-
tem administartor. This function should only be activated after consulting the sys-
tem administrator.
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PAGE SETUP

On the tab Page setup you have the options mentioned below for specifying the 
page setup. — Page settings can also be copied between pages, as described in 
“Page setup - and transferring this to other pages” on page 501.

Paper size
In the upper-left corner of the tab you select the Paper size of the active page, as 
described in “Paper size” on page 503.

Page type and Page function
See how to select the Page type in “Page type” on page 502.

The Page function is also displayed here, but can not be changed. This has been 
specified when the page was created, and can never be changed. Please refer to 
“Creating a new page” on page 491 for further details.

Please note that a Page function can be set to Normal, as described in “Changing 
the page function” on page 493.

Grid and Snap
Grid and Snap is also specified here; read more about this in “Screen / Image Func-
tions” on page 63.



PAGE 824 PCschematic ELautomation 10.0

SETTINGS

Database symbol field
For pages of the type Groundp-
lan/Mechanical, you can further-
more specify a Database symbol 
field. Hereby you specify from 
which field from the database to 
fetch the mechanical symbols, 
when placing mechanical sym-
bols on the page.

To be able to specify this, you must first specify which alternative fields in the data-
base, that can contain mechanical symbols. Read more about this in “Database set-
tings” on page 591, “Mechanical symbols” on page 595 in particular.

It is not possible to use mechanical symbols from different database fields on the 
same project page.

When placing the mechanical symbols — see “Performing the Mechanical load” on 
page 610 — you can specify which of the database fields with mechanical symbols 
to use on the page. If you here select another Database symbol field, the setting on 
the tab Page setup is automatically changed correspondingly.

Scale factor and Reading direction
— Read more about Scale factor in “Setting the scale of the page” on page 476.

— Reading direction is described in “Specify reading direction” on page 152.

Contains a list
If you select Contains a list, diagram pages are 
allowed to contain either a Components List or a 
Parts List for the page.

— Read more about this in “Diagram pages - con-
taining a Parts or Components list” on page 738.

Default settings
If you want to see the current standard settings, you click on the Show defaults but-
ton. To load the default settings, you click on the Load defaults button.

If you, on the other hand, want to save the specified settings as the future default 
settings, you click on the Save as default button.

Click OK when the settings are satisfactory.

Standard settings for List pages and Chapter tabs
If you have selected a list page and choose Settings => Page setup, and choose 
Save as default, the page size of the selected list page becomes the default page 
size for list pages. This works correspondingly for chapter tabs.

— Please also see “Standard page sizes for List and Chapter tabs” on page 503.
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TOOLS

In the program tool bar you can choose a menu called Tools. From this menu you 
can change back and forth between PCschematic ELautomation and other pro-
grams.

Here — in Settings => Tools — you specify which other programs you can start 
directly from the Tools menu.

You do this by typing in the name you want to see in the Tools menu in the MENU 
name column, while you type in the full path and program name in the PROGRAM 
name column on the same line.

You can here use the following parameters:

%SYSDIR% here specifies the directory in which the program is installed.

%SYSDIR8% works as %SYSDIR%, but is used on net systems, which only han-
dles eight characters in file names — or for DOS or Windows 3.11 programs.

%HOMEDIR% is the home directory. This is the same as %SYSDIR% if the pro-
gram is not installed on a network server.

%HOMEDIR8% works as %HOMEDIR%, but is used on net systems, which only 
handles eight characters in file names — or for DOS or Windows 3.11 programs.

%DATABASE% is the name of the database attached to the program.

%NET% is used when an application needs to know whether it is running on a net 
installation. This is a special parameter which only works for PCschematic applica-
tions.
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Insert a button in the program tool bar
To make it easier to change to another program, it is also possible to insert your 
own buttons on the program tool bar.

If you want to add a button with the text DOS on it, in order to be able to change to 
DOS quickly, you just add #B(DOS)# after the program name for DOS.

If you have got a bitmap file which you want displayed on the button, you type in 
the name of the file (including the full path) instead of DOS in the example above: 
#B(bitmap file)#. The size of the bitmap file should be 20x20 pixels.
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DATABASE

Here you specify whether to work in PCschematic ELautomation with- or without 
a connected database, by clicking on On or Off respectively.

Select database file
By clicking on Select database file you enter a dialog box, from which you specify 
which database you want to work with — see “Choosing a database” on page 604.

You may read more about changing to another folder and opening another file in 
“Folders” on page 40.

Database setup
By clicking on Database setup you enter a dialog box, where you specify the data-
base setup, as it will appear when working in PCschematic ELautomation. Read 
more about this in “Database settings” on page 591.

You can read more about the database program in the PCschematic Database man-
ual.
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UPDATE SYMBOLS FROM DATABASE

When selecting Update Components when changing Article No. you can specify 
whether/how PCschematic ELautomation updates the other symbols for the com-
ponent, when the article number is changed for one of the symbols for a compo-
nent.
This update is made when the article number is changed for the symbol in the Com-
ponent data dialog box, having Change all symbols for the component selected.
The function is activated by first selecting Update Components when changing 
Article No.. When you subsequently click on Settings, you enter the dialog box 
Update from Database:

Here you have the following options:

OPTION DESCRIPTION

DO NOT UPDATE TYPE TEXTS FOR THE COMPONENT IS NOT UPDATED.

UPDATE MISSING ONLY TYPE TEXTS ARE ONLY UPDATED FOR THOSE OF THE SYMBOLS FOR 
THE COMPONENT, WITH NO PREVIOUSLY SPECIFIED TYPE TEXT.

UPDATE ALL ALL TYPE TEXTS FOR THE COMPONENT IS UPDATED ACCORDING TO 
THE DATABASE.

UPDATE CONNECTION 
POINTS

ALL CONNECTION NAMES FOR THE COMPONENTS ARE UPDATED 
ACCORDING TO THE SPECIFIED CONNECTION NAMES IN THE DATA-
BASE.

CHECK FOR CORRECT 
SYMBOLS

IT IS CHECKED WHETHER THE SYMBOLS FOR THE COMPONENT HAVE 
THE CORRECT SYMBOL FILENAMES — ACCORDING TO THE DATABASE 
INFORMATION.

CHECK FOR UNKNOWN 
ARTICLE NO.

IT IS CHECKED WHETHER THE NEW ARTICLE NUMBER FOR THE COMPO-
NENT EXISTS IN THE DATABASE.

OPTIONS IN UPDATE FROM DATABASE
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Company and User name
Here you type in your own name, as well as the name of your company. This infor-
mation can automatically be inserted in your projects, when you choose Functions 
=> Insert Datafield, and click on System data. The program then collects the infor-
mation you have typed in here, and inserts it into the project. If you have to change 
this information later on, you only have to do it once right here. — Read more 
about datafields in “Datafields” on page 134.

Automatic recovery information
If you select Select auto recover information every, you will make PCschematic 
ELautomation save automatic recovery information every 30 minutes. By clicking 
on the up and down-arrows you can change the contents of the Interval in minutes 
field. The recovery file is saved in the directory Pcselcad using the same project 
name, but with the extension .$pr.

After an unauthorized closure, PCschematic ELautomation will automatically 
start up from the automatic recovery file.

SAVE YOUR PROJECTS FREQUENTLY

PLEASE REMEMBER TO SAVE YOUR PROJECT OFTEN. THE AUTOMATIC RECOV-
ERY FILE IS ONLY MEANT AS A MEANS OF RE-CREATING THE PROJECT FILE IF 
THE SYSTEM CRASHES — FOR INSTANCE BECAUSE OF A POWER SUPPLY FAIL-
URE.
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Compressed saving
— See “Compressed saving / Zipping projects” on page 804.

Load previous project
When you select Load previous project at program start, PCschematic ELauto-
mation automatically opens the last active project, the next time you start the pro-
gram.

Undo levels
In the Undo levels field you can specify how many levels/actions it shall be possi-
ble to undo. You can here choose between 5 and 30 levels.

— Read more about the Undo function in “Undo” on page 82.

License key and Servers
The License key field is used for license key settings. 
Normally, you will not have to change the license key 
settings, because these are set when the program is 
installed. Read more about this in “License key” on 
page 32.

When a SuperPro license key is applied, the license 
key number is displayed under Settings => System 
=> License key.

— Please see “Tanking licenses” on page 772 also.

Time-out
For the SuperPro NET key you can set a Time-out for 
the license to None, 10 min., 20 min. or 30 min.. If 
there has been no activity on the PC in the specified 
period of time, the license is released for other users. When you continue working 
with the program, PCschematic ELautomation automatically searches for a free 
license, and continue working normally when a free license is found.

Choose language
Under Choose language you can choose in which language to use for the program 
texts in PCschematic ELautomation.

It is possible to choose between English, Czech, Polish, Russian, Chinese, Dutch, 
Hungarian and Danish.

If these options are not available in your installation, you can have them sent to you 
by contacting DpS CAD-center ApS.

When changing language the program must be restarted.
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Select set of characters
When you want to specify which set of characters you want to use in the project, 
the options are Standard (normally used), Latin2, Russian, Baltic and Polish.

The codes for these characters ([Alt]+0xxx) follows the common Windows charac-
ter sets.

The information of the chosen character set is included in each project file sepa-
rately. More character sets will be created on request.

Automatic check for Updates, New versions and Information
In the lower-right corner of the dialog box, 
you can select 9.XX update, Newer version 
and Information. This makes it possible for 
you to receive information — via the internet 
— when updates or new versions are released, 
or to get important information about the pro-
gram automatically.

— Read more about this in “Update and 
Automatic information” on page 762.
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TEXT/SYMBOL DEFAULTS

The dialog box is divided in two parts: Text defaults on the upper part, and Symbol 
defaults on the lower part.

Text defaults
— Read more about this part of the dialog box in “Texts displayed in the project 
(general setting)” on page 150.

— If you want to change the Name format of the symbol names in the project, 
please refer to “Naming symbols due to page and current path number” on 
page 388.

— See also “Default text properties for free texts” on page 130 and “Appearance of 
references” on page 377.

Symbol defaults
The program contains some lists of which symbols can be used as for instance 
drawing headers or signal symbols. In this part of the dialog box you specify which 
symbols shall be included on these lists. (Of course you can not place a symbol on a 
list, before the symbol is created. Read more about creating symbols in “Creating 
Symbols” on page 670).

Inserting symbols in lists
To place a symbol on a list, you first specify — on the left-hand side — which type 
of list you want to place the symbol on. Then click on Add, which makes you enter 
the Symbol menu. Here you click on the symbol you want to add to the list, and 
click OK. — Read more about adding a symbol to a list in “Adding drawing head-
ers to the List Of Drawing Headers” on page 723.
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Removing symbols from lists
Also, you can remove symbols from the lists by clicking on the down-arrow in the 
Drawing headers field, then click on the symbol you wish to remove, click on the 
Remove button, and answer Yes to remove the symbol from the list. — You can 
read more about removing a symbol from a list in “Removing drawing headers 
from List of Drawing Headers” on page 724.

— Read more about drawing headers in “Creating Drawing Headers” on page 715.

— Read more about signal symbols in “Creating Signal Symbols” on page 710.

— Read more about join signal symbols in “Creating Join symbols” on page 714.

— Read more about symbol datafields in “Creating symbol datafields” on 
page 705.

— Read more about reference symbols in “Changing the reference crosses” on 
page 387.

List of signal names
There also exists a list of signal names. When you place a signal symbol on a 
project drawing, and click on the Used button in the Signals dialog box, you will 
get a list of signal names to choose from. By clicking on Signal names in the left-
hand side of the dialog box, you can specify which signal names that will be sug-
gested in this list. Here you can add or remove signal names, as described for sym-
bols above. — Read more about the dialog box Signals in “Signal symbols” on 
page 218, and about adding signal names to the list in “Frequently used signal sym-
bol Names” on page 713.

Cable direction
At the bottom of the tab you can specify the default cable direction for horizontal 
and vertical cables.

Activate Follow connected on symbols
Follow connected can be activated/deactivated as a general setting in the active 
project, by clicking on Activate Follow connected on symbols.

This setting is activated by default.

— Read more about Follow connected in “Follow connected lines” on page 111.
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DATAFIELDS

In the following it is displayed which datafields can be inserted from the dialog box 
Datafield. You can enter this dialog box by choosing Functions => Insert 
datafield.

The datafields are grouped in the same order in which they appear in the dialog 
box.

Datafields demarcated by an asterisk (*), are user defined datafields.

SYSTEM DATA DATAFIELDS

PROJECT DATA DATAFIELDS

DATAFIELD DESCRIPTION

USER NAME USER NAME

DATE DATE

TIME TIME

COMPANY NAME COMPANY NAME

PROGRAM TYPE PROGRAM TYPE

PROGRAM PATH PROGRAM PATH

DATAFIELDS OF THE TYPE SYSTEM DATA

DATAFIELD DESCRIPTION

PROJECT NUMBER (*) PROJECT

REVISION (*) REVISION

CUSTOMER NAME (*) CUSTOMER NAME

SUBJECT NAME (*) SUBJECT NAME

DESIGNER (*) DESIGNER

TITLE TITLE

FILE NAME FILE NAME

FILE DATE/TIME FILE DATE/TIME

REFERENCE DESIGNATION REFERENCE DESIGNATION DEFINED IN THE PROJECT: CHOOSE 
BETWEEN ALL, FUNCTION ASPECT AND LOCATION ASPECT, AND 
SPECIFY WHETHER THE INSERT THE DESIGNATIONS OR THE 
DESCRIPTIONS.

LOGO THE PROJECT LOGO.

CREATION DATE/TIME CREATION DATE/TIME

DATAFIELDS OF THE TYPE PROJECT DATA
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PAGE DATA DATAFIELDS

REMARKS REMARKS FROM THE REMARKS FIELD.

LAST REVISION THE DATAFIELD LAST REVISION IS USED FOR DISPLAYING THE 
MOST RECENT REVISION OF THE PROJECT. THERE CAN BE CRE-
ATED A LIST OF REVISION DATAFIELDS IN THE MENUS, WHICH CAN 
BE FILLED OUT AS THE REVISIONS ARE PERFORMED.
— SEE “DATAFIELD FOR SHOWING LAST REVISION” ON PAGE 791.

DATAFIELD DESCRIPTION

APPROVED BY (*) APPROVED BY

DATE (*) DATE

REVISION (*) REVISION

PAGE INDEX PAGE INDEX

PAGE NUMBER PAGE NUMBER

TITLE TITLE

DATE FOR LAST CHANGE TIME AND DATE FOR LAST CHANGE ON THE PAGE. CHOOSE 
BETWEEN DATE AND TIME, DATE AND TIME.
IF YOU NEED TO SET THE TIME/DATE FOR ALL PAGES IN THE 
PROJECT, CHOOSE FUNCTIONS => SPECIAL FUNCTIONS => SET 
DATE FOR LAST CHANGE ON ALL PAGES AND ANSWER YES TO 
SET THE DATE FOR LAST CHANGE TO NOW.

SCALE FACTOR SCALE FACTOR

PRINT SCALE PRINT SCALE

TEXT CORNER TEXT CORNER

FIRST USED PAGE FIRST USED PAGE

LAST USED PAGE LAST USED PAGE

NEXT USED PAGE NEXT USED PAGE

PREVIOUS USED PAGE PREVIOUS USED PAGE

USED PAGES USED PAGES

PAGE DESIGNATION PAGE DESIGNATION. THIS CAN EITHER BE PAGE DESIGNATION 
(THE FULL REFERENCE DESIGNATION), FUNCTION ASPECT OR 
LOCATION ASPECT.

PICTURE BITMAP PICTURE.

CREATION DATE/TIME CREATION DATE/TIME. CHOOSE BETWEEN DATE AND TIME, 
DATE AND TIME.

LAST REVISION THE DATAFIELD LAST REVISION IS USED FOR DISPLAYING THE 
MOST RECENT REVISION OF THE PROJECT. THERE CAN BE CRE-
ATED A LIST OF REVISION DATAFIELDS IN THE MENUS, WHICH 
CAN BE FILLED OUT AS THE REVISIONS ARE PERFORMED.
— SEE “DATAFIELD FOR SHOWING LAST REVISION” ON 
PAGE 791.

DATAFIELDS OF THE TYPE PAGE DATA

DATAFIELD DESCRIPTION

DATAFIELDS OF THE TYPE PROJECT DATA
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SYMBOL DATAFIELDS

Contains only user-designed symbol datafields. — See “Creating symbol 
datafields” on page 705.

Symbol datafields can also be created with a list of predefined values. — See 
“Symbol datafields with predefined values” on page 708.

TABLE OF CONTENTS DATAFIELDS

FIRST/LAST OBJ THE DATAFIELD FIRST/LAST OBJ CAN DISPLAY THE FIRST AND/
OR THE LAST OBJECT IN THE LIST PAGE.

LAST PRINTED TIME AND DATE FOR WHEN THE PAGE WAS PRINTED LAST. HERE 
YOU CAN CHOOSE BETWEEN DATE AND TIME, DATE AND TIME.

DATAFIELD DESCRIPTION

DATE (*) DATE

REVISION (*) REVISION

PAGE INDEX PAGE INDEX

PAGE NUMBER PAGE NUMBER

TITLE TITLE

DATE FOR LAST 
CHANGE

DATE FOR LAST CHANGE

SCALE FACTOR SCALE FACTOR

PRINT SCALE PRINT SCALE

PAGE DESIGNATION PAGE DESIGNATION. THIS CAN EITHER BE PAGE DESIGNATION, 
FUNCTION ASPECT OR LOCATION ASPECT.

CREATION DATE/TIME CREATION DATE/TIME FOR THE PAGE. CHOOSE BETWEEN DATE AND 
TIME, DATE AND TIME.

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT.
YOU CAN HERE CHOOSE BETWEEN ON ALL LINES AND ON USED 
LINES.

FIRST/LAST OBJ THE DATAFIELD FIRST/LAST OBJ CAN DISPLAY THE FIRST AND/OR 
THE LAST OBJECT IN THE LIST PAGE.
YOU CAN HERE CHOOSE BETWEEN FIRST AND LAST, FIRST AND 
LAST.

LAST REVISION THE DATAFIELD LAST REVISION IS USED FOR DISPLAYING THE MOST 
RECENT REVISION OF THE PROJECT. THERE CAN BE CREATED A LIST 
OF REVISION DATAFIELDS IN THE MENUS, WHICH CAN BE FILLED OUT 
AS THE REVISIONS ARE PERFORMED.
— SEE “DATAFIELD FOR SHOWING LAST REVISION” ON PAGE 791.

DATAFIELDS OF THE TYPE TABLE OF CONTENTS

DATAFIELD DESCRIPTION

DATAFIELDS OF THE TYPE PAGE DATA
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PARTS/COMPONENTS LIST DATAFIELDS

Datafield names written in upper-case letters, are fields from the database. These 
are not displayed in the survey below.

DATAFIELD DESCRIPTION

NAME THE NAME OF THE COMPONENT. YOU CAN HERE ALOS CHOOSE 
WITH QUANTITY, LOCATION ASPECT AND FUNCTION ASPECT.

TYPE THE TYPE OF THE COMPONENT.

ARTICLE NO. THE ARTICLE NUMBER OF THE COMPONENT.

FUNCTION THE FUNCTION OF THE COMPONENT

SYMBOL NAME THE SYMBOL FILE NAME OF THE COMPONENT

SYMBOL FIGURE THE SYMBOL FIGURE OF THE COMPONENT

SYMBOL TITLE THE TITLE OF THE COMPONENT

SYMBOL DATE TIME AND DATE FOR SAVING THE SYMBOL

QUANTITY THE QUANTITY OF THE COMPONENT

UNIT QUANTITY THE NUMBER OF COMPONENTS REFERRING TO THE UNIT PAGE

PRICE1 PRICE1

PRICE2 PRICE2

TOTAL ARTICLE PRICE1 TOTAL ARTICLE PRICE1

TOTAL ARTICLE PRICE2 TOTAL ARTICLE PRICE2

TOTAL PRICE1 TOTAL PRICE1

TOTAL PRICE2 TOTAL PRICE2

UNIT NAME LIST UNIT NAME LIST

NAME LIST LIST OF COMPONENTS HAVING THE SAME ARTICLE NUMBER

REFPOSTITON THE PAGE/CURRENT PATH NUMBER OF THE COMPONENT. HERE CAN 
BE REFERRED TO FUNCTION ASPECT, LOCATION ASPECT, PAGE AND 
CURRENTPATH.

MECHANICAL POSITION THE LOCATION OF THE MECHANICAL SYMBOL. CAN BE EITHER X,Y 
POSITION OR FIELD POSITION. PLEASE REFER TO “REFERENCES IN 
LISTS TO THE POSITION OF MECHANICAL SYMBOLS” ON PAGE 615 
FOR FURTHER INFORMATION.

MECHANICAL PAGE THE PAGE NUMBER FOR THE GROUNDPLAN PAGE, WHERE THE 
MECHANICAL SYMBOL IS PLACED. YOU CAN HERE CHOOSE 
WHETHER TO ADD THE FUNCTION ASPECT AND/OR THE LOCATION 
ASPECT ALONG WITH THE PAGE NUMBER.

=+DESIGN THE FUNCTION AND/OR LOCATION ASPECT FOR THE COMPONENT. 
THIS CAN EITHER BE REFERENCE DESIGNATION, FUNCTION ASPECT 
OR LOCATION ASPECT. YOU ALSO CHOOSE WHETHER TO SHOW THE 
DESIGNATION OR THE DESCRIPTION.

SYMBOL TYPE THE MAIN SYMBOL TYPE FOR THE COMPONENT.

CABLE WIRES CHOOSE BETWEEN WIRE COUNT AND USED WIRE COUNT.

EAN13 BARCODE DATAFIELD WHICH AUTOMATICALLY GENERATES AN EAN13 BAR-
CODE FOR THE COMPONENT. YOU CAN HERE CHOOSE BETWEEN DIF-
FERENT STANDARD SIZES.

DATAFIELDS OF THE TYPE PARTS/COMPONENTS LIST
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TERMINALS LIST DATAFIELDS

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT. CHOOSE BETWEEN ON 
ALL LINES OR ON USED LINES.

SYMBOL FILE NAME THE LIBRARY FILENAME FOR THE SYMBOL.
YOU CAN HERE CHOOSE WITH FILE PATH, FILE NAME AND WITH 
FILE EXTENSION. WHEN THERE ARE MORE THAN ONE SYMBOL FOR 
A COMPONENT, THE DATAFIELD INSERTS THE FILENAME FOR THE 
MOST SIGNIFICANT SYMBOL.

DATAFIELD DESCRIPTION

T.NAME THE NAME OF THE TERMINAL. YOU CAN HERE SELECT WITH SUB 
NAME, WITH CONNECTION NAME, LOCATION ASPECT AND FUNC-
TION ASPECT.

T.TYPE THE TYPE OF THE TERMINAL.

T.ARTICLE THE ARTICLE NUMBER OF THE TERMINAL.

T.FUNCTION THE FUNCTION OF THE TERMINAL.

T.=+DESIGN THE FUNCTION AND LOCATION ASPECT OF THE TERMINAL. THIS CAN 
EITHER BE REFERENCE DESIGNATION, FUNCTION ASPECT OR LOCA-
TION ASPECT. YOU ALSO CHOOSE WHETHER TO SHOW THE DESIGNA-
TION OR THE DESCRIPTION.

C.NAME THE CONNECTION NAME OF THE TERMINAL.

C.FUNCTION THE CONNECTION FUNCTION OF THE TERMINAL. THIS CAN EITHER BE 
OUTPUT SIDE OR INPUT SIDE.

C.LABEL THE CONNECTION LABEL OF THE TERMINAL. THIS CAN EITHER BE 
OUTPUT SIDE OR INPUT SIDE.

C.DESCR. THE CONNECTION DESCRIPTION OF THE TERMINAL. THIS CAN EITHER 
BE OUTPUT SIDE OR INPUT SIDE.

C.REF THE CONNECTION CURRENT PATH OF THE TERMINAL. YOU CAN HERE 
SELECT FUNCTION ASPECT, LOCATION ASPECT, PAGE AND CUR-
RENT PATH.

IE.NAME INTERNAL/EXTERNAL COMPONENT NAME. THIS CAN EITHER BE 
EXTERNAL OR INTERNAL. YOU CAN HERE SELECT WITH SUB NAME, 
WITH CONNECTION NAME, LOCATION ASPECT AND FUNCTION 
ASPECT.

IE.TYPE INTERNAL/EXTERNAL COMPONENT TYPE. THIS CAN EITHER BE 
EXTERNAL OR INTERNAL.

IE.ARTICLE INTERNAL/EXTERNAL COMPONENT ARTICLE NUMBER. THIS CAN 
EITHER BE EXTERNAL OR INTERNAL.

IE.FUNCTION INTERNAL/EXTERNAL COMPONENT FUNCTION. THIS CAN EITHER BE 
EXTERNAL OR INTERNAL.

IE.=+DESIGN INTERNAL/EXTERNAL COMPONENT FUNCTION/LOCATION. THIS CAN 
EITHER BE EXTERNAL OR INTERNAL. CHOOSE BETWEEN REFERENCE 
DESIGNATION, FUNCTION ASPECT OR LOCATION ASPECT.

DATAFIELDS OF THE TYPE TERMINAL LIST

DATAFIELD DESCRIPTION

DATAFIELDS OF THE TYPE PARTS/COMPONENTS LIST
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IE.=+DESCRIPTION THE DESCRIPTION FOR THE INTERNAL/EXTERNAL COMPONENT 
FUNCTION/LOCATION. THIS CAN EITHER BE EXTERNAL OR INTER-
NAL. CHOOSE BETWEEN REFERENCE DESIGNATION, FUNCTION 
ASPECT OR LOCATION ASPECT.

IE.C.NAME INTERNAL/EXTERNAL COMPONENT CONNECTION NAME. THIS CAN 
EITHER BE EXTERNAL OR INTERNAL.

IE.C.FUNCTION INTERNAL/EXTERNAL COMPONENT CONNECTION FUNCTION. THIS 
CAN EITHER BE EXTERNAL OR INTERNAL.

IE.C.LABEL INTERNAL/EXTERNAL COMPONENT CONNECTION LABEL. THIS CAN 
EITHER BE EXTERNAL OR INTERNAL.

IE.C.DESCR. INTERNAL/EXTERNAL COMPONENT CONNECTION DESCRIPTION. THIS 
CAN EITHER BE EXTERNAL OR INTERNAL.

IE.C.REF. INTERNAL/EXTERNAL COMPONENT CONNECTION CURRENT PATH. 
THIS CAN EITHER BE EXTERNAL OR INTERNAL. YOU CAN HERE 
SELECT WITH SUB NAME, WITH CONNECTION NAME, LOCATION 
ASPECT AND FUNCTION ASPECT.

IE.SIGNAL INTERNAL/EXTERNAL SIGNAL NAME. THIS CAN EITHER BE EXTER-
NAL OR INTERNAL. YOU CAN ALSO CHOOSE FUNCTION ASPECT AND 
LOCATION ASPECT.

IE.WIRENO INTERNAL/EXTERNAL WIRE NUMBER. THIS CAN EITHER BE EXTER-
NAL OR INTERNAL.

IE.CB.NAME INTERNAL/EXTERNAL CABLE NAME. THIS CAN EITHER BE EXTERNAL 
OR INTERNAL. YOU CAN HERE SELECT WITH SUB NAME, WITH CON-
NECTION NAME, LOCATION ASPECT AND FUNCTION ASPECT.

IE.CB.TYPE INTERNAL/EXTERNAL CABLE TYPE. THIS CAN EITHER BE EXTERNAL 
OR INTERNAL.

IE.CB.ARTICLE INTERNAL/EXTERNAL CABLE ARTICLE NUMBER. THIS CAN EITHER 
BE EXTERNAL OR INTERNAL.

IE.CB.FUNCTION INTERNAL/EXTERNAL CABLE FUNCTION. THIS CAN EITHER BE 
EXTERNAL OR INTERNAL.

IE.CB.=+DESIGN. INTERNAL/EXTERNAL CABLE FUNCTION/LOCATION. THIS CAN 
EITHER BE EXTERNAL OR INTERNAL. CHOOSE BETWEEN REFERENCE 
DESIGNATION, FUNCTION ASPECT AND LOCATION ASPECT.

IE.CB.=+DESCRIPTION DESCRIPTION FOR THE INTERNAL/EXTERNAL CABLE FUNCTION/
LOCATION. THIS CAN EITHER BE EXTERNAL OR INTERNAL. CHOOSE 
BETWEEN REFERENCE DESIGNATION, FUNCTION ASPECT AND 
LOCATION ASPECT.

IE.CB.W.NAME INTERNAL/EXTERNAL CABLE WIRE NAME. THIS CAN EITHER BE 
EXTERNAL OR INTERNAL.

IE.CB.W.FUNCTION INTERNAL/EXTERNAL CABLE WIRE FUNCTION. THIS CAN EITHER BE 
EXTERNAL OR INTERNAL.

IE.CB.W.LABEL INTERNAL/EXTERNAL CABLE WIRE LABEL. THIS CAN EITHER BE 
EXTERNAL OR INTERNAL.

IE.CB.W.DESCR. INTERNAL/EXTERNAL CABLE WIRE DESCRIPTION. THIS CAN EITHER 
BE EXTERNAL OR INTERNAL.

IE.CB.W.REF. INTERNAL/EXTERNAL CABLE WIRE CURRENT PATH. THIS CAN 
EITHER BE EXTERNAL OR INTERNAL. YOU CAN HERE SELECT WITH 
SUB NAME, WITH CONNECTION NAME, LOCATION ASPECT AND 
FUNCTION ASPECT.

JUMPER LINK JUMPER LINK CONNECTION OF TERMINAL.

DATAFIELD DESCRIPTION

DATAFIELDS OF THE TYPE TERMINAL LIST
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CABLE LIST DATAFIELDS

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT. YOU CAN HERE CHOOSE 
ON ALL LINES OR ON USED LINES.

POS. NO. THE POSITION NUMBER.

DATAFIELD DESCRIPTION

CB.NAME CABLE NAME. THIS CAN EITHER BE WITH CONNECTION NAME, LOCATION 
ASPECT OR FUNCTION ASPECT.

CB.TYPE CABLE TYPE

CB.ARTICLE CABLE ARTICLE NUMBER

CB.FUNCTION CABLE FUNCTION

CB.=+DESIGN. CABLE FUNCTION AND LOCATION ASPECT. THIS CAN EITHER BE REFER-
ENCE DESIGNATION, FUNCTION ASPECT OR LOCATION ASPECT. YOU 
ALSO CHOOSE WHETHER TO SHOW THE DESIGNATION OR THE DESCRIP-
TION.

CB.W.NAME CABLE WIRE NAME

CB.W.FUNCTION CABLE WIRE TYPE

CB.W.LABEL CABLE WIRE ARTICLE NUMBER

CB.W.DESCR. CABLE WIRE FUNCTION

CB.W.REF. CABLE WIRE CURRENT PATH. HERE CAN BE REFERRED TO FUNCTION 
ASPECT, LOCATION ASPECT, PAGE AND CURRENT PATH.

FT.NAME FROM/TO COMPONENT NAME. THIS CAN EITHER BE WITH SUB NAME, 
WITH CONNECTION NAME, LOCATION ASPECT OR FUNCTION ASPECT.

FT.TYPE FROM/TO COMPONENT TYPE

FT.ARTICLE FROM/TO COMPONENT ARTICLE NUMBER

FT.FUNCTION FROM/TO COMPONENT FUNCTION

FT.=+DESIGN. FROM/TO COMPONENT FUNCTION AND LOCATION ASPECT. THIS CAN 
EITHER BE REFERENCE DESIGNATION, FUNCTION ASPECT OR LOCATION 
ASPECT.

FT.=+DESCRIP-
TION

DESCRIPTION FOR THE FROM/TO COMPONENT FUNCTION AND LOCATION 
ASPECT. THIS CAN EITHER BE REFERENCE DESIGNATION, FUNCTION 
ASPECT OR LOCATION ASPECT.

FT.C.NAME FROM/TO COMPONENT CONNECTION NAME

FT.C.FUNCTION FROM/TO COMPONENT CONNECTION TYPE

FT.C.LABEL FROM/TO COMPONENT CONNECTION ARTICLE NUMBER

FT.C.DESCR. FROM/TO COMPONENT CONNECTION FUNCTION

FT.C.REF. FROM/TO COMPONENT CONNECTION CURRENT PATH. HERE CAN BE 
REFERRED TO FUNCTION ASPECT, LOCATION ASPECT, PAGE AND CUR-
RENT PATH.

CB.W.SIGNAL CABLE WIRE SIGNAL NAME. YOU CAN ALSO SELECT LOCATION ASPECT 
AND FUNCTION ASPECT.

CB.W.WIRENO CABLE WIRE WIRE NUMBER

DATAFIELDS OF THE TYPE CABLE LIST

DATAFIELD DESCRIPTION

DATAFIELDS OF THE TYPE TERMINAL LIST
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PLC LIST DATAFIELDS

CABLE WIRES CHOOSE BETWEEN WIRE COUNT AND USED WIRE COUNT.

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT. CHOOSE ON ALL LINES OR 
ON USED LINES.

DATAFIELD DESCRIPTION

PLC NAME PLC NAME. THIS CAN EITHER BE WITH SUB NAME, WITH CONNECTION 
NAME, LOCATION ASPECT OR FUNCTION ASPECT.

PLC TYPE PLC TYPE

PLC ARTICLE PLC ARTICLE

PLC FUNCTION PLC FUNCTION

PLC =+DESIGN. PLC FUNCTION AND LOCATION ASPECT. THIS CAN EITHER BE REFER-
ENCE DESIGNATION, FUNCTION ASPECT OR LOCATION ASPECT. CHOOSE 
EITHER DESIGNATION OR DESCRIPTION.

C.NAME CONNECTION NAME OF PLC

C.FUNCTION CONNECTION FUNCTION OF PLC

C.LABEL CONNECTION LABEL OF PLC

C.DESCR. CONNECTION DESCRIPTION OF PLC

C.REF. CONNECTION CURRENT PATH OF PLC. HERE CAN BE REFERRED TO 
FUNCTION ASPECT, LOCATION ASPECT, PAGE AND CURRENTPATH.

CC.NAME CONNECTED COMPONENT NAME. THIS CAN EITHER BE WITH SUB NAME, 
WITH CONNECTION NAME, LOCATION ASPECT OR FUNCTION ASPECT.

CC.TYPE CONNECTED COMPONENT TYPE

CC.ARTICLE CONNECTED COMPONENT ARTICLE NUMBER

CC.FUNCTION CONNECTED COMPONENT FUNCTION

CC.=+DESIGN. CONNECTED COMPONENT FUNCTION AND LOCATION ASPECT. THIS CAN 
EITHER BE PAGE DESIGNATION, FUNCTION ASPECT OR LOCATION 
ASPECT. CHOOSE BETWEEN DESIGNATION AND DESCRIPTION.

CC.C.NAME CONNECTED COMPONENT CONNECTION NAME.

CC.C.FUNCTION CONNECTED COMPONENT CONNECTION FUNCTION

CC.C.LABEL CONNECTED COMPONENT CONNECTION LABEL

CC.C.DESCR. CONNECTED COMPONENT CONNECTION DESCRIPTION

CC.C.REF. CONNECTED COMPONENT CONNECTION CURRENT PATH. HERE CAN BE 
REFERRED TO FUNCTION ASPECT, LOCATION ASPECT, PAGE AND CUR-
RENT PATH.

C.SIGNAL CONNECTED SIGNAL NAME. YOU CAN ALSO CHOOSE LOCATION ASPECT 
AND FUNCTION ASPECT.

C.WIRENO. CONNECTED WIRE NUMBER

SIGNALPATH PLC SIGNAL PATH THROUGH TERMINALS AND CABLES. THIS CAN EITHER 
BE WITH SUB NAME, WITH CONNECTION NAME, LOCATION ASPECT OR 
FUNCTION ASPECT.

DATAFIELDS OF THE TYPE PLC LIST

DATAFIELD DESCRIPTION

DATAFIELDS OF THE TYPE CABLE LIST



PAGE 842 PCschematic ELautomation 10.0

DATAFIELDS

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT. CHOOSE BETWEEN ON ALL 
LINES AND ON USED LINES.

LINE-NAME NAME OF THE CONNECTED LINE. CHOOSE BETWEEN AT PLC CONNEC-
TION AND AT CONNECTED SYMBOL.

LINE-TYPE TYPE OF THE CONNECTED LINE. CHOOSE BETWEEN AT PLC CONNECTION 
AND AT CONNECTED SYMBOL.

LINE-ARTICLE ARTICLE NUMBER OF THE CONNECTED LINE. CHOOSE BETWEEN AT PLC 
CONNECTION AND AT CONNECTED SYMBOL.

LINE-FUNCTION FUNCTION OF THE CONNECTED LINE. CHOOSE BETWEEN AT PLC CON-
NECTION AND AT CONNECTED SYMBOL.

DATAFIELD DESCRIPTION

DATAFIELDS OF THE TYPE PLC LIST
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THE DATABASE FIELD PCSTYPE

One symbol:
PLC1OUT-UF

Multiple symbols: ;
PLC1OUT-P;PLC1OUT-UF

Multiple symbols of the same kind: #n
PLC1OUT-UF#8

PLCREF8-;PLC1OUT-UF#8

Or-function with multiple drawing options: [A|B|C]
PLCREF8-;[PLC1OUT-UF#8|PLC8OUT]

Sub names: A( )
PLCREF4I4O;O(PCSOUT-UF#4);I(PLCIN-UF#4)

Symboltype: =A or =A,B
PLCREF8-; PLC1OUT-UF=T,P#8

Options:
N Normal T,R Terminal/Relay

R Relay T,O Terminal/Open

O Open T,C Terminal/Close

C Close T,S Terminal/Switch

S Switch T,P Terminal/PLC

M MasterReference

W WithReference

T Terminal

P PLC

X PLC Reference

States: §n
PLCREFOUT4D4A;PLC1OUTAD#4§1; PLC1OUTAD#4§2
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FILE=
If the PCSTYPE field is too short, you can type in FILE=xxxxxx.pcs, where 
xxxxxx.pcs is the file containing the information for the PCSTYPE field, specified 
according to the syntax described above.

The file must be placed in the database folder, which you have selected in Settings 
=> Directories.

Please note! In PCSTYPE files semicolon is the same as a line break:
PLCREF8-;PLC1OUT-UF#8

Is equal to: PLCREF8-

PLC1OUT-UF#8

Or: PLCREF8-;

PLC1OUT-UF#8;
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THE DATABASE FIELD PINDATA

One connection:
10

Multiple connections on the same symbol: ,
1,2,3,4,5,6

Consecutive connection names on the same symbol: ,..,
1,..,6

Separation between the connections of multiple symbols: ;
1,2;3,4;5,6

Consecutive connection names on symbols with a single connection: ;..;
1;..;6

Specification of I/O address: [adr]
1[10.00];2[10.01];3[10.02]

Specification of I/O status: /I:status
1[/I:OP];2[/I:IP]

1[10.00/I:IP];2[10.01/I:IP]

Options:
ET External terminal connection

IT Internal terminal connection

OP Output PLC connection

IP Input PLC connection

EI Eksternal terminal connection with PLC input

EO Eksternal terminal connection with PLC output

II Internal terminal connection with PLC input.

IO Internal terminal connection with PLC output.

N       Changes the status to "no status" 
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THE DATABASE FIELD PINDATA: COUNTING

Counting on the same symbol: {++(A),}#n
Please note: There must be a comma before }

{++(1),}#16 => 1,2,3,4,5,6,……….

{++(1)[10.++(0)],}#16 => 1[10.0],2[10.1],3[10.2],……….

{A++(1)[Y10.++(0)],}#16 => A1[Y10.0],A2[Y10.1],A3[Y10.2],……….

Counting on multiple symbols with one connection each: {++(A);}#n
Please note: There must be a semicolon before }

{++(1);}#16 => 1;2;3;4;5;6;……….

{++(1)[10.++(0)];}#16 => 1[10.0];2[10.1];3[10.2];……….

{A++(1)[Y10.++(0)];}#16 => A1[Y10.0];A2[Y10.1];A3[Y10.2];……….

Counting on multiple symbols with two connections each: {++(A),++(B);}#n
{++(1),++(1)G;}#8 => 1,1G;2,2G;3,3G;………….

{++(1)[10.++(0)],++(1)G;}#8=>1[10.0],1G;2[10.1],2G;……..

Incrementing with more than 1: {++d(A);}#n
{++2(1);}#8 => 1;3;5;7;9;……

{++2(1),++2(2);}#8 => 1,2;3,4;5,6;7,8;9,10;……

Incrementing with specified numbering system: {++(DA);}#n
{++(1)[10.++(D0)];}#8 => {++(1)[10.++(0)];}#8 Decimal

{++(1)[10.++(H0)];}#8 => Hexadecimal

{++(1)[10.++(O0)];}#8 => Octal

{++(1)[10.++(B0)];}#8 => Binary

Neutralize the significance of D,H,O,B: {++(/DA);}#n
Please note: There must be placed a / before D

{++(1)[++(/O0)];}#8 => 1,O0;2,O2;3,O3;……..

Specification of field width (number of digits): {++(A:x);}#n
{++(1)[10.++(00:2)];}#8 => 1[10.00];2[10.01];3[10.02];……

Decrementing: {--(A);}#n
{--(20),++(1);}#4 => 20,1;19,2;18,3;17,4;……….
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Example
A PLC reference symbol with two connections for each PLC output and eight PLC 
symbols with each two connections pr. symbol:

PCSTYPE = PLCREF8-1;PLC1OUT-P#8

PINDATA = {B++(0)[++(10.00)],A++(0),}#8; {B++(0),A++(0);}#8

The incremented value of PINDATA:
B0[10.00],A0,B1[10.01],A1,……..,B7[10.07],A7; B0,A0; B1,A1;……….;B7,A7

FILE=
If the PINDATA field is to short, you can type in FILE=xxxxxx.pin, where 
xxxxxx.pin is the name of the file with the PINDATA contents, specified according 
to the syntax described above.

The file must be placed in the database folder, which you have selected under Set-
tings => Directories.

Please note! In PCSTYPE files semicolon is the same as a line break:
{B++(0)[++(10.00)],A++(0),}#8; {B++(0),A++(0);}#8

Is equal to: {B++(0)[++(10.00)],A++(0),}#8

{B++(0),A++(0);}#8

Or: {B++(0)[++(10.00)],A++(0),}#8;

{B++(0),A++(0);}#8;
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Variable definition: /@n

Normal variable: /@n

Variable with default value:  xxxx/@n

Variable that inserts a value in a text: xxxx</@n>

Insertion with default value: xxxx<yyyy/@n>

/@n n is a number between 1 and 64000. Variables contain-
ing small numbers will be processed faster than varia-
bles containing larger numbers. Therefore smaller 
numbers are recommended in variables.

/@1     Variable 1 /@10     Variable 10

/@1 The variable has no default value. Fields in the project 
definition file, where the variable value will be typed in 
later, are empty.

3389110610000/@1 3389110610000 is displayed in field in the project defi-
nition file, where the variable value will be typed in 
later.

-P1/@3 The variable has the default value –P1.
The value that is typed in later, overwrites the default 
value.

-P</@3> The text (name) has a fixed part (-P) and a variable part 
</@3>

</@4> out
</@4> in Can be applied with benefit where the same value shall 

be inserted into texts, where the fixed part are different 
from text to text. Here the values could for instance be 
’Weighing’ in one case, and ’Casting’ in another.

-P</@3>
-S</@3> Can be applied where all — or some — names in a sub 

drawing always have the same serial number.
E.g. –P1 and –S1

-P<1/@3> The text (name) has a fixed part (-P) and a variable part 
</@3>, which has the default value ’1’.

<Weighing/@4> out The variable has the default value ’Weighing’.
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Indexed variables: /@n[i]    or   /@n[i1,i2,i3,....]
/@4[1] The variable takes the value from the first parameter 

in a comma separated text.
E.g.: BK,BL,BU,GR The variable gets the value BK

/@4[2] E.g.: BK,BL,BU,GR The variable gets the value BL
/@4[2,3] E.g.: BK,BL,BU,GR The variable gets the value  

BL,BU
This function is very useful for cables.
Below this is shown with cable wire colors.

< BK,BL,BU,GR/@4[1]> => BK
< BK,BL,BU,GR/@4[2]> => BL
< BK,BL,BU,GR/@4[3]> => BU
< BK,BL,BU,GR/@4[4]> => GR
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Activate next (in lists): The first time the program meets a check mark in an Acti-
vate next check box, you tell the program to collect information about the first com-
ponent in the list. Subsequent datafields, such as Description and Quantity, will 
then be regarded as the description and quantity of the first component respectively.

The next time the program meets a check mark in the Activate next check box, it 
collects information about the following component on the list. The subsequent 
datafields Description and Quantity, will then be regarded as the description and 
quantity of the next component on the list — and so on.

It is important to note, that if you place a datafield just a bit higher on the page, than 
the datafield for which you enabled Activate next, this datafield will collect it is 
information from the previous component.

Please refer to “Creating Lists” on page 727 to get an example on how to use Acti-
vate next.

Alignment: Specifies where the reference point of a text is located. Read more 
about this in “Specifying text properties / Appearance of text” on page 145. See ref-
erence point.

Click: To press down the left mouse button once. Read more about the actions you 
can perform with the mouse in “The mouse” on page 35.

Command toolbar: Has got a varying appearance on the screen. It holds functions 
and editing-tools for the various drawing facilities. Point number 3 on the figure on 
page 850.
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Connection name: The name of a connection point.

Connection point: The point in which a symbol can be connected to a line. Please 
refer to “Place connection points” on page 673 for more information.

Cross hairs: When you are working on a project drawing, the location of the mouse 
pointer i demarcated by the crossing of a horizontal and a vertical line. This point is 
called the cross hairs.

Datafield: All information concerning the entire project, is gathered in the dialog 
box Settings => Project data. Among others, the project title, and the name and 
address of the customer is specified in this dialog box.

If you need to insert one of these informations on a list in your project — for 
instance the address of the customer — choose Functions => Insert Datafield. 
Here you first click on Project data and then on the datafield Address. When you 
update your list, the address of the customer will be inserted where you placed the 
datafield.

If the customer changes his address later on, you only have to change the address in 
Settings => Project data, which causes the address to be changed automatically 
everywhere the datafield Address exists in the project.

Datafields therefore makes it possible for you to control central information — 
which is being applied several places in the project — in just one dialog box. If an 
information have to be changed, you just have to change it once, and the program 
will correct all the places the datafields are inserted in the project.

Datafields attached to the individual pages in the project, can be found in Settings 
=> Page data.

Dimmed: If an option in a menu is written in grey, you say it is dimmed, and it can-
not be chosen.

Directories: See Folders.

Docking: To move a program window or toolbar to another fixed position on the 
screen. Please refer to “Docking Windows and Toolbars” on page 49.

Double-click: To click two times on the left mouse-button. It is important not to 
move the mouse while clicking. Read more about the actions you can perform with 
the mouse in “The mouse” on page 35.

Drag’n draw: In PCschematic ELautomation it is possible to save parts of dia-
grams as sub drawings, which you can then drag directly into project pages in other 
projects. This is in PCschematic ELautomation called Drag’n Draw. Hereby you 
can also drag project pages or full projects into the active project. — Read more 
about this in “Sub drawings” on page 266.

Drag and drop: Press down the left mouse button, and keep it pressed down while 
moving the mouse pointer across the screen. Is typically applied when you move an 
object or apply the zoom function. You are said to drag the object across the screen. 
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Read more about the actions you can perform with the mouse in “The mouse” on 
page 35.

Drawing header: Apart from being what you normally understand as a drawing 
header — namely a frame containing information which can be placed around a 
project drawing — formulas for lists, tables of contents and unit drawings are also 
conceived as drawing headers in PCschematic ELautomation.

You can say that a drawing header is a template with text and graphics, which you 
can choose to place on the various pages in your project. It can for instance contain 
your company logo. Read more about drawing headers, and how to create your own 
drawing header in “Creating Drawing Headers” on page 715.

Read more about how to create lists in “Creating Lists” on page 727.

Read more about how to create unit drawings in “Creating Unit Drawings” on 
page 744.

And, finally, you can read about how to insert an already created drawing header in 
“Insert drawing headers/formulas” on page 525.

Drawing objects: See objects.

Drive: The place where all your folders and files are gathered is called a drive. If 
you have to load a file from a diskette, you have to contact the disk drive (often 
called A:), and if you have to load something from your hard disk, you for instance 
have to contact the c:\-drive (There can also be other drives on your hard disk).

Elevation: The height in which an object is placed on a ground plan drawing. Read 
more about this in “Drawing with elevation” on page 475.

Elevation window: Is used to type in the height in which you want to place an 
object on a ground plan drawing.

Explorer window: A window in which you can locate pages and symbols in the 
projects. Point number 6 on the figure on page 850. Described in further detail in 
“The Explorer window: The Projects tab” on page 309.

File: Anything you save on a computer, is saved in what you call a file. Each time 
you for instance save a project or a symbol, these are saved in a file. When you 
fetch the project or symbol again, you are said to open the file. Read more about 
files in “Opening files/projects” on page 41.

Folder: In order not to place all files on the computer in the same place, you collect 
files, which belong together, in the same folder. Inside this folder you can create 
subfolders — and so on. In “Folder structure” on page 34 you can see which folders 
the installation of PCschematic ELautomation contains. Read more about folders 
in “Folders” on page 40.

Free text: A text which is not connected to a symbol, a line or the like. Read more 
in “General purpose / Free texts” on page 128.
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Grid: The dots you see placed at fixed intervals on the paper on a drawing, are 
called the grid of the drawing. You specify the distance between the dots in Set-
tings => Page setup. Read more about this in “Grid” on page 68.

Hints: When you let the mouse pointer rest on for instance a program button, you 
will see the name of the button displayed in a small text field. Or, if you let the 
mouse pointer rest for a moment on a symbol in the symbol toolbar, you will get a 
short description of the symbol. This facility is called hints, and can enabled/disa-
bled in Settings => Screen/Pointer.

Left toolbar: Contains various page- and zoom functions, as well as information 
on the page settings. Point number 7 on the figure on page 850.

Maximize: To maximize a window means to make it fill out the entire screen. In the 
upper-right corner of a window, you will find the Maximize button. Click this but-
ton, and you will maximize the window. Read more about this as well as other win-
dows functions in “Maximize a dialog box” on page 37.

Menu: A place where you can choose which command to carry out in the program. 
See “Menus” on page 37 for further details.

Menu bar: Consists of the menus, that contains all the functions in the program. 
Use the mouse or the <Alt> key to choose the functions. For instance choose File 
by pressing [Alt+f]. Point number 1 on the figure on page 850.

Minimize: To minimize a window means to remove it from the screen temporarily, 
so that you cannot work on it. It will then be placed as a small button on the lower 
part of the screen. When you click on this button, the window is enlarged, and you 
will be able to work on it again.

In the upper-right corner of a window, you will find the Minimize button. Click this 
button, and you will minimize the window. Read more about this as well as other 
windows functions in “Minimize a dialog box” on page 37.

MMB Drag’n Draw: Short form of "Module and Model Based Drag’n Draw". — 
See drag’n draw.

Mouse pointer: The arrow/pointer displayed on the screen, which is controlled by 
the mouse. When it is above a field in which you can enter text, it is converted to a 
short vertical line.

Non conducting symbol: A symbol, which cannot be connected to a conducting 
line, without causing a warning to appear. If you connect a normal symbol to a non 
conducting line, you will be warned about it, but will be allowed to do so if you 
insist.

NP: “Non printable.” Texts/lines/circles in this color will be displayed on the 
screen, but not on print. Read more about this in “Specifying text properties / 
Appearance of text” on page 145.
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Objects: A common name for the symbols, lines, texts, and circles that can be 
placed on a project drawing. Also called drawing objects. Read more about this in 
“On Drawing objects” on page 75.

Page tabs: On the lower part of the screen you will see some small tabs, telling you 
which project page you are located on. By clicking on these tabs, you can jump 
back and forth between the project pages. These tabs are called page tabs, and can 
be activated/deactivated in Settings => Pointer/Screen.

Parking: If you have not specified what a conduction line is to be connected to, 
you can temporarily park the line. You can then wait to connect it until later. Read 
more about this in “Conducting (electrical) lines” on page 99 and “Signal symbols” 
on page 218.

Path: If you want to specify the exact location of a file on your PC, you can specify 
the path that leads to the file. This path starts by specifying on which drive the file 
is located, and then specifies which folder or subfolder the file is located. At the 
end, there is the file name itself. The file project.pro which is saved in the Project 
folder, thus has the path: c:\Pcselcad\Project\project.pro.

Pickmenu: A place you can place symbols for easy access while working. Point 
number 4 on the figure on page 850. Described in further detail in “Fetching sym-
bols from the Pickmenu” on page 161.

Program toolbar: Contains the program buttons. Here you can choose the various 
functions. The common file- and print functions are located here, along with the 
more general drawing- and editing tools. Point number 2 on the figure on page 850.

Reference point: All symbols and texts have got a reference point. For symbols, 
the reference point is demarcated by a *, while the reference point for texts is +. 
When you want to move a symbol, it is the reference point you click on to select 
(get in contact with) the symbol, and if you want to rotate the symbol, it is rotated 
around the reference point. — This also goes for texts. Read more in “Creating 
Symbols” on page 670 and in “Specifying text properties / Appearance of text” on 
page 145.

Right-click: To click once on the right mouse-button. Read more about the actions 
you can perform with the mouse in “The mouse” on page 35.

Scroll: If you only see a smaller part of your drawing on the screen for the moment, 
and wish to see something that is placed to the right of the displayed section, you 
can gradually move the displayed section to the right on the drawing, until you see 
what you want on the screen. Moving the displayed section is called scrolling.

You can scroll by clicking on the Scroll button on the left toolbar. You scroll by 
clicking one of the four arrows on the button. Or use the Survey window in the 
lower-right corner of the screen. Click on the black box in the survey window, and 
drag it until it covers the area you want to see on the full screen.

Read more about this in “Screen / Image Functions” on page 63.
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Signal symbol: A symbol, which states an electrical connection, that is not dis-
played otherwise on the drawing. Thus, if a signal symbol with the name L1 is 
placed on two different pages in a project, this means these two places are electri-
cally connected. It is the signal name only, that states the electrical connection.

Therefore, a signal symbol having the name L2, has no connection to a signal sym-
bol having the name L1 — even though the same symbol is used for the two sig-
nals.

Read more about signal symbols in “Creating Signal Symbols” on page 710.

Snap: When you want to place an object on the screen, it is important to be able to 
place it exactly where you want it. To support this, you have got the option to spec-
ify that objects can only be placed at fixed intervals of, say, 2.50mm. — If you then 
want to place a symbol, you will only be able to move it in steps of 2.50mm at the 
time. This enables you to place the symbol accurately in relation to the other sym-
bols.

If the distance between the points in which the symbols can be placed is 2.50mm, 
you say that snap is 2.50mm.

By clicking on the Snap button in the left toolbar, you can change back and forth 
between normal snap (for instance 2.50mm) and fine snap (for instance 0.50mm).

If <Shift> is pressed down while an object is in the cross hairs, you will change to 
the fine snap, and as soon as you let go of the <Shift> key, or place the object, you 
return to normal snap.

In Settings => Page setup you specify the snap settings.

Read more about snap in “Snap” on page 68.

Status bar: Contains coordinates, layer title and help text. Point number 11 on the 
figure on page 850.

Sub drawing: See “Sub drawings” on page 266.

Survey window: Displays the entire page, while the zoom, you are presently work-
ing in, is displayed by a black box. Point number 9 on the figure on page 850. Read 
more in “The Survey window” on page 67.

Tanking: See “Tanking licenses” on page 772.

Untick: To remove a check mark from a check box.

Work area: Reflects the size of paper you have chosen to draw on. Point number 8 
on the figure on page 850.

Zoom: If you need to zoom in on something, this means you have to mark up a sec-
tion of the drawing you have on the screen, and then the section will be enlarged.

Read more about this in “Screen / Image Functions” on page 63.
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The special characters displayed below, is a character set you can use when you 
want to place special characters on your drawings in PCschematic ELautomation. 
To place a special character, you press down the <Alt> button while typing in the 
figures on the numerical keyboard on the right-hand side of the keyboard. When 
you let go of the <Alt> button, the special character is displayed.

On some screens a wrong character will be displayed in the text field on the texts 
tool bar, but the correct character will still be displayed on the project drawing.
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A
Absolute measures . . . . . . . . . . . . . . . . . . . . . 113
Access . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 604
Accessory symbols . . . . . . . . . . . . . . . . . . . . . 238
Acrobat files . . . . . . . . . . . . . . . . . . . . . . . . . 337
Activate next . . . . . . . . . . . . . . . . . 135, 732, 850
Active  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 472
Active, check box  . . . . . . . . . . . . . . . . . . . . . 386
Actual page . . . . . . . . . . . . . . . . . . . . . . . . . . 474
Adaptability

symbol names . . . . . . . . . . . . . . . . . . . . . 391
Adapting the system to your needs  . . . . . . . . . . 764
Add a wire to a cable  . . . . . . . . . . . . . . . . . . . 236
Add new  . . . . . . . . . . . . . . . . . . . . . . . 490, 508
Additionals . . . . . . . . . . . . . . . . . . . . . . . . . . 595
Adjust to printer . . . . . . . . . . . . . . . . . . . . . . . 335
Adobe Acrobat  . . . . . . . . . . . . . . . . . . . . . . . 337
Adobe Acrobat Reader  . . . . . . . . . . . . . . . . . . . 58
ALARM, symbol folder  . . . . . . . . . . . . . . . . . 239
Alias

correct . . . . . . . . . . . . . . . . . . . . . . . . . . 821
Align . . . . . . . . . . . . . . . . . . . . . . . . . . . 87, 612
Align grid to 1. Reference  . . . . . . . . . . . . . . . . 815
Alignment  . . . . . . . . . . . . . . . . . . . . . . . . . . 146
All pages  . . . . . . . . . . . . . . . . . . . . . . . . . . . 333
All visible . . . . . . . . . . . . . . . . . . . . . . . . . . . 472
Already placed objects  . . . . . . . . . . . . . . . . . . . 76
Alternative electrical symbols . . . . . . . . . . . . . . 577
Alternative symbols

and PINDATA  . . . . . . . . . . . . . . . . . . . . 579
for PLC  . . . . . . . . . . . . . . . . . . . . . . . . . 578

Ambiguous drawing . . . . . . . . . . . . . . . . . . . . 398
ANSI

paper size . . . . . . . . . . . . . . . . . . . . . . . . 503
Apply addresses . . . . . . . . . . . . . . . . . . . . . . . 452
Approved components

in Database menu . . . . . . . . . . . . . . . . . . . 597
Arcs/circles . . . . . . . . . . . . . . . . . . . . . . . 75, 125

toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . 125
Area button . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Areas

change symbol names in  . . . . . . . . . . . . . . 202
change symbol names in, naming order  . . . . 203
choosing connection points in . . . . . . . . . . . 206
copy

between projects  . . . . . . . . . . . . . . . . 265
into Edit symbol  . . . . . . . . . . . . . . . . 265
reference designations intelligently  . . . . 257

copy between projects . . . . . . . . . . . . . . . . 512
copy intelligently . . . . . . . . . . . . . . . . . . . 255
counting on texts in areas . . . . . . . . . . . . . . 143
filled  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
invisible . . . . . . . . . . . . . . . . . . . . . . . . . . 92

rotate  . . . . . . . . . . . . . . . . . . . . . . . . . . . 263
scaling texts in . . . . . . . . . . . . . . . . . . . . . 264

Article data . . . . . . . . . . . . . . . . . . . . . . . . . . 814
on lines . . . . . . . . . . . . . . . . . . . . . . . . . . 100
transfer for symbols or lines  . . . . . . . . . . . . . 83

Article number
type in directly . . . . . . . . . . . . . . . . . . . . . 174

Articles from unit drawings  . . . . . . . . . . . . . . . 536
Ask for Names . . . . . . . . . . . . . . . . . . . . 131, 816
Assign article number to unit parts list  . . . . . . . . 745
Asterisk  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 542
Auto hide scrollbars  . . . . . . . . . . . . . . . . . . . . 817
Autocompletion of texts . . . . . . . . . . . . . . . . . . 129
Automatic

blocking of mouse clicks  . . . . . . . . . . . . . . 781
insertion of electrical potentials . . . . . . . . . . 102
line drawing  . . . . . . . . . . . . . . . . . . . . . . 109
recovery information . . . . . . . . . . . . . . . . . 829
wire numbering  . . . . . . . . . . . . . . . . . . . . 395

Automatic information  . . . . . . . . . . . . . . . . . . 762
Automatic switches, database folder . . . . . . . . . . 172

B
Background color . . . . . . . . . . . . . . . . . . . . . . 770
Baltic characters . . . . . . . . . . . . . . . . . . . 765, 831
Barcode scanners  . . . . . . . . . . . . . . . . . . . . . . 608
Base addressing

for PLC’s  . . . . . . . . . . . . . . . . . . . . . . . . 448
Batch printing  . . . . . . . . . . . . . . . . . . . . . . . . 802

on net installation . . . . . . . . . . . . . . . . . . . 802
on stand-alone installation  . . . . . . . . . . . . . 802

BDE  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 604
Bend  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121
Black background . . . . . . . . . . . . . . . . . . . . . . 818
Bold text . . . . . . . . . . . . . . . . . . . . . . . . . . . . 147
Bookmarks

in Symbol menu . . . . . . . . . . . . . . . . . . . . 168
Bottom to top . . . . . . . . . . . . . . . . . . . . . . . . . 466
BUILDING, symbol folder . . . . . . . . . . . . . . . . 239
Busses  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 465

C
Cable list, page function . . . . . . . . . . . . . . . . . . 493
Cable symbols . . . . . . . . . . . . . . . . . . . . . . . . 231

add wire to  . . . . . . . . . . . . . . . . . . . . . . . 236
color codes  . . . . . . . . . . . . . . . . . . . . . . . 234
create . . . . . . . . . . . . . . . . . . . . . . . . . . . 695
implicit references on cable wires  . . . . . . . . 227
invisible  . . . . . . . . . . . . . . . . . . . . . . . . . 238
place in one operation  . . . . . . . . . . . . . . . . 235
remove wire from a cable . . . . . . . . . . . . . . 236
reverse direction . . . . . . . . . . . . . . . . . . . . 238
same cable in more places  . . . . . . . . . . . . . 238

Cables

Index for Part 1 and Part 2
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move
connection points . . . . . . . . . . . . . . . . 235

Cables lists
create . . . . . . . . . . . . . . . . . . . . . . . . . . . 736
data fields . . . . . . . . . . . . . . . . . . . . . . . . 135
list setup . . . . . . . . . . . . . . . . . . . . . . . . . 546

Cancel button  . . . . . . . . . . . . . . . . . . . . . . . . . 39
Capital letters  . . . . . . . . . . . . . . . . . . . . . . . . 150
Cascade . . . . . . . . . . . . . . . . . . . . . . . . . . . . 510
CD

component vendors  . . . . . . . . . . . . . . . . . . . 7
Change

between projects  . . . . . . . . . . . . . . . . . . . 514
between windows . . . . . . . . . . . . . . . . . . . . 37
column of data fields  . . . . . . . . . . . . . . . . 742
created drawing header . . . . . . . . . . . . . . . 740
data field  . . . . . . . . . . . . . . . . . . . . . . . . 741
free texts  . . . . . . . . . . . . . . . . . . . . . . . . 740
name format types  . . . . . . . . . . . . . . . . . . 390
symbol in folder . . . . . . . . . . . . . . . . . . . . 703
symbol names in Area . . . . . . . . . . . . . . . . 202
symbol names in Area, naming order . . . . . . 203
symbol type  . . . . . . . . . . . . . . . . . . . . . . 703
text  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134
text in the cross hair  . . . . . . . . . . . . . . . . . 139

Chapters . . . . . . . . . . . . . . . . . . . . . . . . . . . . 487
chapter tabs collapsed . . . . . . . . . . . . . . . . 487

Character set . . . . . . . . . . . . . . . . . . . . . . . . . 765
choose . . . . . . . . . . . . . . . . . . . . . . . . . . 831

Chinese version
PCschematic Viewer . . . . . . . . . . . . . . . . . 655

Choose language  . . . . . . . . . . . . . . . . . . . . . . 830
Circles . . . . . . . . . . . . . . . . . . . . . . . . . . 75, 125

align  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87
convert to lines  . . . . . . . . . . . . . . . . . . . . 126
full  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125
half . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125
invisible . . . . . . . . . . . . . . . . . . . . . . . . . . 92
quater  . . . . . . . . . . . . . . . . . . . . . . . . . . 125
space . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88
toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . 125

Circles button  . . . . . . . . . . . . . . . . . . . . . . . . 125
Click . . . . . . . . . . . . . . . . . . . . . . . . . . . 35, 850
Clipboard

copy to . . . . . . . . . . . . . . . . . . . . . . . . . . 517
Close a window . . . . . . . . . . . . . . . . . . . . . . . . 37
Close window button  . . . . . . . . . . . . . . . . . . . . 37
Close, symbol status . . . . . . . . . . . . . . . . . . . . 577
Close, symbol type . . . . . . . . . . . . . . . . . . . . . 680
Codepage . . . . . . . . . . . . . . . . . . . . . . . . . . . 639
Color . . . . . . . . . . . . . . . . . . . . . . . . . . 147, 770

background . . . . . . . . . . . . . . . . . . . . . . . 770
dotted grid  . . . . . . . . . . . . . . . . . . . . . . . 770
help objects . . . . . . . . . . . . . . . . . . . . . . . 771
lines  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 97
object selection  . . . . . . . . . . . . . . . . . . . . 771
Squared grid . . . . . . . . . . . . . . . . . . . . . . 770
squared grid-10  . . . . . . . . . . . . . . . . . . . . 770

Color codes for cables . . . . . . . . . . . . . . . . . . . 234
Columns

change column of data fields . . . . . . . . . . . . 742
lists in columns  . . . . . . . . . . . . . . . . . . . . 538

Combined circuit and connection diagram . . . . . . 120
Command bar  . . . . . . . . . . . . . . . . . . . . . . . . . 60
Command toolbar . . . . . . . . . . . . . . . . . . . . . . 850
Company and User name . . . . . . . . . . . . . . . . . 829
Company logo

on drawing header  . . . . . . . . . . . . . . . . . . 725
remove . . . . . . . . . . . . . . . . . . . . . . . . . . 740

Component databases
how does the database work  . . . . . . . . . . . . 560

Component Grouping
and copying . . . . . . . . . . . . . . . . . . . . . . . 554
menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . 550

Component vendors
CD with databases  . . . . . . . . . . . . . . . . . . . . 7

Components
approved and obsolete in Database menu  . . . 597
changing symbol data for Component . . . . . . 252
create in database . . . . . . . . . . . . . . . . . . . 572

from existing project . . . . . . . . . . . . . . 573
fetching component symbols from database . . 243
find in database  . . . . . . . . . . . . . . . . . . . . 564
functions on component level  . . . . . . . . . . . 241
grouping . . . . . . . . . . . . . . . . . . . . . . . . . 549
having several electrical symbols . . . . . . . . . 576
insert new names  . . . . . . . . . . . . . . . . . . . 305
navigation between symbols . . . . . . . . . . . . 188
place available symbols . . . . . . . . . . . . . . . 253
rename selected  . . . . . . . . . . . . . . . . . . . . 299

direction for renaming . . . . . . . . . . . . . 302
start number  . . . . . . . . . . . . . . . . . . . 303
which names are renamed  . . . . . . . . . . 300

rrename
when copying areas . . . . . . . . . . . . . . . 255

sorting order  . . . . . . . . . . . . . . . . . . . . . . 551
survey of symbols with same Symbol Name  . 248

Components list, page function . . . . . . . . . . . . . 493
Components lists  . . . . . . . . . . . . . . . . . . . . . . 135

create . . . . . . . . . . . . . . . . . . . . . . . . . . . 735
files . . . . . . . . . . . . . . . . . . . . . . . . . . . . 625

Conducting (electrical) lines . . . . . . . . . . . . . . . . 99
Conducting lines button . . . . . . . . . . . . . . . . . . . 99
Connection data . . . . . . . . . . . . . . . . . . . . . . . 204
Connection is used in several nets  . . . . . . . . . . . 330
Connection lists  . . . . . . . . . . . . . . . . . . . . . . . 217

wire numbers . . . . . . . . . . . . . . . . . . . . . . 410
Connection names  . . . . . . . . . . . . . . . . . 581, 851

in one line diagrams  . . . . . . . . . . . . . . . . . 478
in single line diagrams . . . . . . . . . . . . . . . . 478
insert new . . . . . . . . . . . . . . . . . . . . . . . . 305

Connection point button . . . . . . . . . . . . . . . . . . 688
Connection point texts . . . . . . . . . . . . . . . . . . . 133
Connection points . . . . . . . . . . . . . . . . . . 204, 851

choosing in areas  . . . . . . . . . . . . . . . . . . . 206
edit next/previous . . . . . . . . . . . . . . . . . . . 205
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place  . . . . . . . . . . . . . . . . . . . . . . . . . . . 673
Contact mirrors

about  . . . . . . . . . . . . . . . . . . . . . . . . . . . 381
and changing article numbers  . . . . . . . . . . . 381
choose  . . . . . . . . . . . . . . . . . . . . . . . . . . 383
created automatically by the program  . . . . . . 383
creating without using database . . . . . . . . . . 384
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